問題点 (Issue) 

Adobe Illustrator で Illustrator 書類(*.ai)を開くと以下のエラーが表示されます。

  • 「イラストレーションを開くことができません。このイラストレーションは実行可能な限界を超えています。不正なオペレータ: 「%%Page Trailer」コンテクスト: (不明な文字)」



 

詳細 (Detail)

- リムーバブルディスクまたはネットワークボリュームからファイルを開いています。

- Illustrator プログラムをインストールする際に入力するユーザ名または会社名に全角 17 文字以上を入力しています。

- 非常に深いフォルダ階層に Illustrator 書類を保存している、または非常に長いファイル名を付けているため、パス名が長くなっています。

 

解決方法 (Solutions) 

この問題を解決するには、以下の A. ~ I. のいずれか、もしくは複数の操作手順を行います。

また、現象が改善されない場合は、H. の手順でファイルを復旧します。

 

A. ファイルをローカルのハードディスクに移動/コピーします

B. ファイル名を含んだパスの文字数が半角英数字で 254 文字(全角で 84 文字)以内にします

C. プリンタドライバの問題を確認します

D. Illustrator 10.0.3 へアップデートします

E. 初期設定ファイルを作り直します

F. ユーザ名または会社名が全角 17 文字以上で入力されていないか確認します

G. Windows の一時ファイルを削除します

H. ファイルの復旧を実行します

I. A. ~ H. を実行しても問題が解決できない場合

 

 A. ファイルをローカルのハードディスクに移動/コピーします

ネットワークボリュームやリムーバブルメディアに保存されているファイルは直接開かず、いったんローカルハードディスクに移動またはコピーをして、ローカルハードディスク上で作業を行います。

Illustrator で直接ネットワーク上にあるファイルの作業を行うと、回線ノイズやパケットの衝突などの要因によってファイルが破損するおそれがあります。また、リムーバブルメディアに保存されているファイルは、ハードディスク上に保存されているファイルに比べ破損が生じやすい傾向があります。

 注意 : ファイルの移動やコピーを行う際、ファイル内にリンク配置されている画像がある場合、その画像も移動してください。

 

Illustrator 10 の場合は「WebDAV サーバを利用したファイルの管理」をお勧めします。 WebDav サーバの導入により、ネットワークの安定性、ファイルの同時使用などの問題が軽減されます。詳しくは、『Adobe Illustrator 10 ユーザガイド』 P. 54 ~ 「WebDAV を使用したファイルの管理」または、下記の文書を参照してください。

文書番号 222438 チュートリアル:ワークグループサーバによるファイル管理

 

 B. ファイル名を含んだパス名の文字数が半角英数字で 254 文字(全角で 84 文字)以内にします

Illustrator では、ファイル名に使用される漢字やひらがな、カタカナなど全角文字の 1 文字は、半角英数字の 3 文字分に相当します。そのため全角文字の場合は、半角文字にくらべてパス名に使用できる文字数が少なくなります。

 

パス名の長さを確認するには、以下の操作手順を行います。

※ Windows 98 の場合は、手順 5. 以降を行ってください。

  1. マイコンピュータを開きます。
  2. [ツール] メニューから [フォルダオプション] を選択します。
  3. [表示] タブをクリックします。
  4. [アドレスバーにファイルのパス名を表示する] にチェックを入れ、[OK] をクリックします。



  5.  パス名を確認するファイルが保存されているフォルダを開きます。
  6. アドレスバーに表示されているパスの文字数とファイル名の文字数を確認します。



     注意 : アドレスバーが表示されていない場合は、[表示] メニューから [ツールバー] - [アドレスバー] を選択してください。



    ※ 例えば以下のパス名の場合、合計文字数は 85 文字になります。半角スペースや拡張子、ドットなども 1 文字として数えます。



    C:¥Documents and Settings¥Administrator¥My Documents¥Work¥Webサイト¥バナー01.ai
  7. パス名が長すぎる場合はフォルダ名やファイル名を短くします。または、上の階層にフォルダを作成し、そこに Illustrator ドキュメントを移動します。

 

 

 C. プリンタドライバの問題を確認します

利用しているプリンタドライバが、お使いの Windows バージョンに対応していないことがあります。使用環境に適した最新のプリンタドライバを、プリンタメーカーの Web ページやサポートセンターから入手してください。プリンタドライバのインストールやアンインストールの方法についての詳細は、プリンタの製造元にお問い合わせください。

 

 

 D. Illustrator 10.0.3 へアップデートします(Illustrator 10 のみ)

使用している Illustrator のバージョンが 10.0.0 の場合は、10.0.3 へアップデートします。10.0.3 アップデータは、以下の弊社 Web サイトより無償でダウンロードすることができます。

URL : http://www.adobe.co.jp/support/downloads/1873.html

 

アップデート完了後、Illustrator の [ヘルプ] メニューから [Illustrator について] を選択し、表示されるスプラッシュウィンドウの画面右上を確認します。

下図の赤枠箇所が 10.0.3 になっていれば、正常にアップデートが行われています。

 

 

 

 E. 初期設定ファイルを作り直します

初期設定ファイルを削除した後に Illustrator を起動すると、初期設定ファイルが新規に作成されます。

以下の場所に保存されている初期設定ファイルを別のドライブやデスクトップなどにバックアップをコピーし、Illustrator を終了している状態で削除を行ってください。

 

下記の環境設定ファイルを削除後、エラーの出るファイルを開き、問題が再現するかどうかを確認します。

 

削除するファイル/フォルダ

- Illustrator 10 の場合 : 「Adobe Illustrator 10」フォルダ

- Illustrator 9 の場合 : 「AIPrefs」ファイル

 

Illustrator

バージョン

削除する

ファイル/フォルダ

保存場所

Illustrator 10

- Windows 2000/XP

Documents and Settings¥<ユーザ名>¥Application Data¥Adobe

 

- Windows Me/98

以下のいずれかのフォルダ

Windows¥Porfiles¥<ユーザ名>¥Application Data¥Adobe

Windows¥Application Data¥Adobe

Illustrator 9

- Windows 2000/XP

Documents and Settings¥<ユーザ名>¥Application Data¥Adobe¥Adobe Illustrator 9 J

 

- Windows Me/98

以下のいずれかのフォルダ

Windows¥Porfiles¥<ユーザ名>¥Application Data¥Adobe¥Adobe Illustrator 9 J

Windows¥Application Data¥Adobe¥Adobe Illustrator 9 J

 

 

 F. ユーザ名または会社名が全角 17 文字以上で入力されていないか確認します

登録されているユーザ名および会社名を確認するには、以下の操作手順を行います。

  1. Illustrator を起動します。
  2. [ヘルプ] メニューから [Illustrator について] を選択します。
  3. 表示されたスプラッシュウィンドウの右上に、登録社名と会社名が表示されます。



    いずれかの文字数が全角 17 文字以上の場合は、Illustrator を削除して再インストールする必要があります。



 

Illustrator を削除して再インストールするには、以下の操作手順を行います。

  1. [スタート] メニューから [コントロールパネル](Windows XP)/[スタート] メニューから [設定] - [コントロールパネル](Windows 2000/Me/98)を選択します。
  2. [プログラムの追加と削除](Windows XP)/[アプリケーションの追加と削除](Windows 2000/Me/98)をダブルクリックします。
  3. [Adobe Illustrator <バージョン>] を選択し、[削除] ボタンをクリックします。
  4. 削除完了後、E. の手順を参照し、初期設定ファイルを削除します。
  5. コンピュータの CD-ROM ドライブに Illustrator アプリケーション CD-ROM を挿入します。
  6. 画面の指示に従って、Illustrator をインストールします。

※ インストール時に、「名前」と「所属」(Illustrator 10.0)/「姓」「名」「会社名」(Illustrator 9.0)の入力欄に必ず全角 16 文字以下で入力します。

 

 

 G. Windows の一時ファイルを削除します

Windows が使用する一時ファイルを最適化します。Windows やアプリケーションは作業中のデータを一時ファイル(.tmp)としてハードディスクに保存します。過剰な一時ファイルや古い一時ファイルは Windows のパフォーマンスに影響し、エラーの原因となることがあります。一時ファイル削除し、少なくとも書き込み可能なハードディスクの空き容量が 50MB 以上であることを確認してください。

 

 注意 : 一時ファイルの削除は定期的に行うことをお勧めします。一時ファイルは、Windows やアプリケーションが正常に終了した場合は自動的に削除されます。しかし、Windows やアプリケーションがクラッシュしたり不正に終了されると、一時ファイルはハードディスクに残ります。

 

一時ファイルを削除するには、以下の操作手順を行います。

  1. 起動しているアプリケーションをすべて終了します。
  2. [スタート] メニューから [検索] - [ファイルとフォルダすべて](Windows XP)/[ファイルやフォルダ](Windows 2000/Me/98)を選択します。
  3. 以下のテキストボックスに " *.tmp " と入力します。



    - Windows XP : [ファイル名のすべてまたは一部]

    - Windows 2000/Me : [ファイルまたはフォルダの名前]

    - Windows 98 : [名前]



  4. [探す場所] でローカルハードドライブを選択し、[検索開始] をクリックします。
  5. 検索結果が表示されたら、[編集] メニューから [すべて選択] を選択します。
  6. [ファイル] メニューから [削除] を選択します。
  7. ファイル削除の確認が表示されたら [はい] をクリックします。
  8. 削除したくないファイルをゴミ箱から移動し、ゴミ箱を空にします。

 

 

 H. ファイルの復旧を実行します

 注意 : 復旧作業の前に、必ず上記の A. ~ G. の解決方法を行ってください。

 

Illustrator 書類の復旧には、以下のいずれかを行います。

 

- Illustrator 書類が開けない場合

オブジェクトを新規書類へ配置します。以下の操作手順を行います。

  1. Illustrator を起動します。
  2. [ファイル] メニューから [新規] を選択します。
  3. 名前(ファイル名)、アートボード設定(アートボードのサイズ)、カラーモードを設定し、[OK] をクリックします。
  4. [ファイル] メニューから [配置] を選択します。
  5. 開けないファイルを選択し、[配置] ボタンをクリックします。

 

- Illustrator 書類が開ける場合

新規 Illustrator ファイルにすべてのオブジェクトをコピーします。以下の操作手順を行います。

  1. Illstrator を起動します。
  2. [ファイル] メニューから [開く] を選択して、エラーが発生するファイルを選択します。
  3. エラーメッセージが表示されたら [OK] をクリックします。
  4. ロックされているオブジェクトやレイヤーがある場合は、ロックを解除します。

    - オブジェクトのロック解除方法 : [オブジェクト] メニューから [すべてをロック解除] を選択します。

    - レイヤーのロック解除方法 : レイヤーパレット上でロックアイコン()をクリックします。
  5. [選択] メニューから [すべて](Illustrator 10.0x)/[すべてを選択](Illustrator 9.0x)を選択します。
  6. [編集] メニューから [コピー] を選択します。
  7. [ファイル] メニューから [新規] を選びます。名前(ファイル名)、アートボード設定(アートボードのサイズ)、カラーモードを設定し、[OK] をクリックします。
  8. [編集] メニューから [ペースト] を選択して、オブジェクトを貼り付けます。

 I. A. ~ H. を実行しても問題が解決できない場合

ファイルを開く際に表示される「イラストレーションを開くことができません。...」等のエラーメッセージは、他にも既知の問題として弊社サポートデータベースで紹介しております。

エラーメッセージを詳しく確認し、下記の文書の内容に該当する現象が起こっている場合は、その文書を参照してください。

 

文書番号 221998 ファイルを開く際に「不正なオペレータ」/「不当なオペランド」が表示される場合のトラブルシューティング

文書番号 220472 Illustrator 9.0 (Mac):エラーメッセージ 「MPS 解析で解析できません。」が表示されてファイルを開くことができない

文書番号 219762 Illustrator 9.0 (Mac/Win):エラーメッセージ:不正なオペレータ:「AdobeNoteAttribute」が表示される

 

追加情報 (Additional Information) 

「%%PageTrailer」エラーを発生する Illustrator 書類は、プレビューが正しく表示されない、印刷領域が乱れるなどの現象が発生することがあります。

「%%PageTrailer」エラーはさまざまな要因から発生しますが、主に以下のような条件のもとで発生します。

- ファイルをサーバやネットワークボリュームから直接開いている。

- ファイルをリムーバブルメディアから直接開いている。

- パス名が非常に長い、ファイルを保存しているフォルダ階層が非常に深い場所にある。

- 登録しているユーザ名や会社名の文字数が長い。

その他、プリンタドライバとのコンフリクトやフォント数の影響など、コンピュータの使用環境によって発生する例もあります。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー