この情報は、米国アドビシステムズ社が提供している情報をもとにローカライズし、作成したものです。

日本語環境での動作保証はしておりませんのでご了承ください。

内容 (What's Covered)

A. トラブルシューティング/初級~中級編

B. トラブルシューティング/上級編

この文書は、破損した Illustrator ファイル(*.ai)によって引き起こされたエラーを解決する際に役立ちます。破損した Illustrator ファイルはアートワークを修正、保存、または印刷などをする際に、クラッシュ、プレビューできないなどのエラー、または予期しない現象などを引き起こす可能性があります。

破損したファイルがエラーの原因になっているかを特定するために、もう一度新規 Illustrator ファイルを作りエラーが発生した元のファイルと同じ作業を行います。もし新規 Illustrator ファイルでエラーが再現できないなら、元のファイルは破損している可能性があります。

Illustrator ファイルはハードディスクの空き容量やシステムリソースが少ない場合、またはアプリケーションのコンフリクトなどが原因で破損する可能性があります。さらにアプリケーションがハードディスクを読み書きしている際にシステムにエラーやフリーズまたはクラッシュなどが発生すると、そのとき開いているファイルが破損する可能性があります。ネットワークやリムーバブルドライブ上にあるファイルでの作業は、読み取り、書き込みプロセスの間にコミュニケーションエラーが発生する可能性を増加させます。

A. トラブルシューティング/初級~中級編

A-1. Illustrator の最新のアップデータをインストールします。

A-2. ハードディスクにファイルをコピーします。

A-3. 新規ファイルにアートワークをコピーします。

A-4. 使用していない、スウォッチ、カスタムカラー、ブラシ、シンボル、スタイルを削除します。

このセクションの作業は、もっとも一般的な破損したファイルの問題を解決する際に役立ちます。これらの作業を行う前に、すべての個人用のファイルのバックアップを取ってください。システムエラーが発生したら、必ずコンピュータを再起動してください。再起動せずに作業を続行すると、問題が複雑になることがあります。

A-1. Illustrator の最新のアップデータをインストールします。

アプリケーションのアップデータはアプリケーションが発売された後に発見された問題を修正します。最新のアップデータは、アプリケーション自体の問題によってエラーが引き起こされる可能性を最小限にします。Illustrator のバージョンを確認するには、Illustrator の [ヘルプ] メニューから [Illustrator について] (Windows/Mac OS 9.x)/[Illustrator] メニューから [Illustrator について](Mac OS X)を選択します。

Illustrator のアップデータは、以下の弊社 Web サイトからダウンロードすることが可能です。

http://www.adobe.co.jp/support/downloads/main.html

A-2. ハードディスクにファイルをコピーします。

ファイルがネットワーク上やリムーバブルディスク(例えは CD-R、MO、メモリーカード など)上にある場合、ローカルのハードディスクにコピーして開いてください。

Illustrator 10/CS 単体でお使いの場合:

Illustrator を単体でお使いの場合は、まずローカル上のハードディスクにファイルを保存し、Illustrator を終了させてからファイルをネットワーク上やリムーバブルディスク上にコピーします。

Creative Suite とともに Illustrator CS をお使いの場合:

Creative Suite を購入して Illustrator CS をお使いの場合は、ネットワーク上にファイルを直接保存するために Creative Suite に付属の Version Cue をインストールして設定してください。Version Cue についてのより詳細な情報は、Creative Suite 製品ページを参照してください。

Creative Suite 製品ページ : http://www.adobe.co.jp/products/creativesuite/main.html

A-3. 新規ファイルにアートワークをコピーします。

破損したファイルから新規ファイルにアートワークをコピーするには、以下の操作を行います。

  1. Illustrator を起動し、破損したファイルを開きます。
  2. [オブジェクト] メニューから [パス] - [パスを削除] を選択し、[パスの削除] ウィンドウからアートワークから不要なものにチェックを入れて [OK] をクリックします。



  3. レイヤーパレットのポップアップメニューから [コピー元のレイヤーにペースト] にチェックを入れます。

    ※ オリジナルファイルに複数のレイヤーがあり、新規ファイルにペーストする際に、確実にアートワークを同じように表示させるために行います。
  4. [選択] ツールをクリックし、アートワークの周囲をドラッグします。
  5. [編集] メニューから [コピー] を選択します。
  6. [ファイル] メニューから [新規] を選択し [OK] をクリックします。
  7. 作成した新規ファイルがアクティブな状態で [編集] メニューから [前面へペースト] を選択し、アートワークを正確な位置にペーストします。
  8. [ファイル] メニューから [保存] を選択して保存します。
  9. 新規ファイルを確認します。



    新規ファイルでも同じ現象が発生する場合:

    破損したオブジェクトを含んでいる可能性があります。オブジェクトが破損しているか特定するためには、新規ファイルからそれを削除してファイルを保存し、再度開き、問題が再現されるか確かめます。ファイル内の各オブジェクトに対して、この操作を行ってください。



    問題が再現されなくなった場合:

    元のファイルの中の破損したオブジェクトを削除して作り直します。

    - Illustrator で描画されたオブジェクトが破損している場合は、Illustrator の描画ツールを使って作り直します。

    - リンクされたイメージが破損している場合は、元のイメージを作り直して置き換えます。

    - テキストオブジェクトが破損している場合は、テキストオブジェクトをアウトラインに変換するか、フォントを変更します。

ドキュメント内のフォントをすばやく変更するには、以下の操作を行います。

  1. Illustrator を起動し、ファイルを開きます。

    ※ ロックされたオブジェクトを含む場合、[オブジェクト] メニューから [すべてをロック解除] を選択します。
  2. [選択] メニューから [すべて] を選択します。
  3. [文字] メニューから [フォント] を選択し、現在ドキュメントで使われていないフォントを選択します。

     注意 : テキストオブジェクトが、今後破損しないように問題のフォントを再インストールしてください。

A-4. 使用していない、スウォッチ、カスタムカラー、ブラシ、シンボル、スタイルを削除します。

使用していない、スウォッチ、カスタムカラー、ブラシ、シンボル、スタイルを削除するには、以下の操作を行います。

  1. Illustrator を起動し、破損したファイルを開きます。
  2. [スウォッチ] 、[ブラシ] 、[シンボル] 、[スタイル(10.x)/グラフィックスタイル(CS)] パレットから、使用していないものを選択します。



  3. [ゴミ箱] ボタンをクリックし、ダイヤログボックスが表示されたら [はい] をクリックして削除します。
  4. 手順 2. ~ 3. を繰り返してすべての使用していない、スウォッチ、カスタムカラー、ブラシ、シンボル、スタイルを削除します。

B. トラブルシューティング/上級編

B-1. 破損したパターン、グラデーション、カスタムカラーを特定します。

B-2. ファイルの拡張子を変更します。

B-3. ファイルを Adobe PDF ファイルに変換します。

B-4. PostScript ファイルとしてファイルをプリントします。

B-5. ファイルを作り直します。

これまでの作業を行ってもエラーを解決できない場合は、ファイルのフォント、グラデーション、パターン、リンク、オブジェクトが破損している可能性があります(例えば、テキストブロック、インポートされたグラフィック、Illustratorで描画されたグラフィックなど)。以下の B-1. ~ B-5. のいずれか、または複数を実行してください。

 注意 : 以下の作業によってファイルを回復した場合、透明部分やレイヤー情報を失います。

B-1. 破損したパターン、グラデーション、カスタムカラーを特定します。

破損したパターン、グラデーション、カスタムカラーを特定するには、以下の操作を行います。

  1. Illustrator を起動し、破損したファイルを開きます。
  2. [選択] メニューから [すべて] を選択し、ツールボックスの塗りと線をプロセスブラック(シアン、マゼンタ、イエローの重ね合わせによるブラック)に変更します。



  3. [スウォッチ] 、[ブラシ] 、[シンボル] 、[スタイル(10.x)/グラフィックスタイル(CS)] パレットから、使用していないものを選択します。
  4. [ゴミ箱] ボタンをクリックし、ダイヤログボックスが表示されたら [はい] をクリックして削除します。
  5. 手順 2. ~ 3. を繰り返し、すべての使用していない、スウォッチ、カスタムカラー、ブラシ、シンボル、スタイルを削除します。
  6. 問題が発生するか特定します。

    問題が発生しない場合

    パターン、グラデーション、あるいはスポットカラーを元のファイル上で作り直します。

B-2. ファイルの拡張子を変更します。

破損したファイルの拡張子を Illustrator ファイル(*.ai)から PDF ファイル(*.pdf)に変更し、新規 Illustrator ファイルにそのファイルを配置します。

 注意 : [Illustrator 形式オプション] ダイアログボックスで [互換性のある PDF ファイルを作成する] が選択されていない場合、この操作手順は機能しません。

破損したファイルの拡張子を変更するには、以下の操作を行います。

  1. エクスプローラ(Windows)/Finder (Macintosh)上でファイルの拡張子を「*.ai」から「*.pdf」に変更します。



  2. Illustrator を起動し、[ファイル] メニューから [新規] を選択します。
  3. 適切なサイズとカラーモードを選択し、[OK]をクリックします。
  4. [ファイル] メニューから [配置] を選択します。
  5. [配置] ダイアログボックスが表示されたら、[ファイルの種類] プルダウンメニューから [すべてのファイル](Windows)/[表示] ポップアップメニューから [すべての読み取り可能な書類] 選択します。
  6. 拡張子を変更した破損したファイルを選択して [配置] をクリックします。
  7. ファイルに名前を付けて保存します。

B-3. ファイルを Adobe PDF ファイルに変換します。

ファイルが EPS フォーマットの場合は、ファイルを Adobe Acrobat Distiller を使用して PDF ファイルに変換し、Illustrator で PDF ファイルを開いてください。

 注意 : Illustrator 10.x および CS は Illustrator ファイル(*.ai)に PDF ファイル(*.pdf)を組み入れるので、Acrobat Distiller は Illustrator 9.x 以前で作成した古いバージョンの Illustrator ファイルを変換することはできません。

B-4. PostScript ファイルとしてファイルをプリントします。

PostScript ファイルとしてファイルをプリントし、Illustrator で PostScript ファイルを開きます。

 注意 : この操作手順を行うには、PostScript プリンタドライバがインストールされている必要があります。PostScript プリンタドライバをインストールする情報については Windows ヘルプメニューを参照してください。

B-5. ファイルを作り直します。

元の Illustrator ファイルで使用したグラフィックス、テンプレート、カスタムカラーを作り直し、再度保存して Illustrator ファイルを作り直します。ほかの Illustrator ファイルからコピーしたすべての要素を作り直してください。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー