この情報は、米国アドビシステムズ社が提供している情報をもとにローカライズし、作成したものです。

日本語環境での動作保証はしておりませんのでご了承ください。

内容 (What's Covered)

A. トラブルシューティング

B. 回避策 

この文書は、Adobe Illustrator CS2/CS3 で、非 PostScript プリンタから印刷を行う際に発生するエラーやトラブルを解決するのに役立ちます。

Adobe Illustrator は PostScript による出力の際に最良の結果が得られるように設計されており、Illustrator の高度な機能の多くはページ記述言語 PostScript のみを使用して記述することができます。非 PostScript プリンタ(例えば、Hewlett-Packard 社 の LaserJet シリーズ、EPSON 社の PM シリーズ、Canon 社の BJ シリーズなど)は PCL や QuickDraw などのプリンタ記述言語を使用しているため、Illustrator アートワークのオブジェクトや属性をすべて表現できるとは限りません。非 PostScript プリンタにおける出力結果の多くは、プリンタドライバからプリンタへ送信するディスプレイの情報、ホストコンピュータのリソースなどの情報に依存します。

Illustrator から非 PostScript プリンタに印刷を行う際に、オブジェクトが出力されない、あるいは出力されても正しく印刷されていないといった問題が発生する場合があります。プリンタおよびプリンタソフトウェアの種類やバージョンによって出力結果は異なりますが、非 PostScript プリンタでの出力の問題は、以下のようにさまざまな形で発生します。

  • テキストやその他のオブジェクトの一部または全体が出力されない。
  • システムエラーが発生したり、フリーズする。

非 PostScript プリンタへの出力の問題は、以下のトラブルシューティングを行うことで解決できる可能性があります。ただし、ドライバをアップデートしていない、あるいは古いプリンタを使用している場合、以下の手順で問題が解決できない場合があります。その際は、この文書の後半に記載されている「回避策」のセクションを参照してください。

 A. トラブルシューティング

A-1. プリンタドライバのアップデートまたは再インストール

A-2. [ビットマッププリント] オプション(Windows)

A-3. エンハンスド PCL(Windows)

A-4. 標準ビデオカードドライバ(Windows)

A-5. テキスト形式の変更

A-6. 隠れたカラーオブジェクトを追加します

A-7. [プリントするレイヤー] オプション

A-8. 通常使うプリンタの設定(Windows)

A-9. ローカルプリンタに出力します

このセクションでは、プリント時の一般的なトラブルに対処する方法について説明します。はじめに、以下のトラブルシューティングを行う前に、新規ファイルを作成し、新しいファイルでも同様の問題が再現するかを確認してください。新しいファイルで問題が再現しない場合、ファイルの破損が原因となっている可能性があります。また、システムエラーが発生した場合は必ずコンピュータを再起動してメモリをリフレッシュしてください。再起動せずに作業を続行すると、問題が複雑になることがあります。

破損した Illustrator ファイルのトラブルシューティングについては、以下の弊社技術文書を参照してください。

文書番号 226199 破損したファイルのトラブルシューティング(Illustrator CS2/CS3/CS4)

 A-1. プリンタドライバのアップデートまたは再インストール

プリンタドライバが原因で問題が生じている場合、プリンタドライバをアップデートするか、もしくは再インストールすることで問題が改善される可能性があります。プリンタドライバのアップデートについては、プリンタの製造元に問い合わせるか、Web サイトから最新バージョンのプリンタドライバを入手してください。最新バージョンのドライバでも問題が発生する場合は、ドライバを削除し、プリンタに付属のインストールディスクから再インストールを行います。

 A-2. [ビットマッププリント] オプション(Windows)

Windows 版 Illustrator の場合、[プリント] ダイアログボックスの [ビットマッププリント] オプションを変更することによって、問題が改善される場合があります。

以下の操作を行います。

  1. Illustrator を起動し、印刷するファイルを開きます。
  2. [ファイル] メニューから [プリント] を選択します。
  3. 画面左側のリストから [詳細設定] を選択します。
  4. [ビットマッププリント] オプションを変更します。選択されている場合はチェックをはずし、選択されていない場合はチェックを入れます。



 注意 : [ビットマッププリント] オプションを無効にした場合、Illustrator は GDI(Graphic Display Interface)の情報とプリンタドライバを使用してベクトル形式のプリントデータを作成します。ベクトル形式のプリントデータを使用することによって印刷速度が向上しますが、デバイスによっては一定の出力結果を得られない場合があります。

 A-3. エンハンスド PCL(Windows)

Windows でプリンタがエンハンスド PCL プリンタドライバをサポートしている場合、エンハンスドドライバをインストールします。ドライバのインストールについての詳細は、プリンタに付属のマニュアルを参照するか製造元にお問い合わせください。

 A-4. 標準ビデオカードドライバ(Windows)

Windows を VGA モードで起動し、Windows 標準ビデオカードドライバに切り替えてから印刷を行います。以下の操作を行います。

Windows Vista

  1. Windows を再起動し、「詳細ブートオプション」画面が表示されるまで F8 キーを押し続けます。
  2. メニューから「低解像度ビデオ(640 x 480) を有効にする」を選択して Enter キーを押します。

    ※ このメニューが表示されない場合、またはすぐに終了してしまう場合、以下の a. ~ g. の操作を行ってから再度上記手順 1. ~ 2. を行ってください。
  • [スタート] メニューから [コントロールパネル] を選択します。
  • [システムとメンテナンス] をクリックします。
  • [システム] をクリックして [設定と変更] をクリックします。
  • [ユーザーアカウント制御] ダイアログボックスが表示されたら [続行] をクリックします。
  • [システムの詳細設定] タブをクリックします。
  • [起動と回復] セクションで [設定] をクリックします。
  • [起動システム] セクションで [オペレーティング システムの一覧を表示する時間] の値を増やします。



Windows XP

  1. Windows を再起動し、「Windows 拡張オプションメニュー」画面が表示されるまで F8 キーを押し続けます。
  2. メニューから「VGA モードを有効にする」を選択します。

    ※ このメニューが表示されない場合、またはすぐに終了してしまう場合、以下の a. ~ f. の操作を行ってから再度上記手順 1. ~ 2. を行ってください。
  • [スタート] メニューから [コントロールパネル] を選択します。
  • [パフォーマンスとメンテナンス] をクリックします。
  • [システム] をクリックします。
  • [詳細設定] タブをクリックします。
  • [起動と回復] セクションで [設定] をクリックします。
  • [起動システム] セクションで [オペレーティング システムの一覧を表示する時間] の値を増やします。



Windows 2000

  1. Windows を再起動し、F8 キーを押し続けます。
  2. メニューから「VGA モードを有効にする」を選択します。

※ このメニューが表示されない場合、またはすぐに終了してしまう場合、以下の a. ~ d. の操作を行ってから再度上記手順 1. ~ 2. を行ってください。

  • [スタート] メニューから [設定] - [コントロールパネル] を選択します。
  • [システム] アイコンをダブルクリックします。
  • [詳細] タブを選択します。
  • [起動/回復] ボタンをクリックし、[オペレーティング システムの一覧を表示する時間] オプションの値を増やします。

SVGA または VGA ドライバを使用して Illustrator から正確に印刷できた場合、ビデオカードドライバが最新ではないか、破損している、あるいはプリンタドライバまたは Illustrator と互換性ない可能性があります。ビデオカードドライバのアップデートについて、ビデオカードもしくはコンピュータの製造元へお問い合わせください。

 A-5. テキスト形式の変更

テキストが正しく出力されない場合は、Illustrator ファイルのバックアップを作成した後に、以下のいずれかを行ってから印刷を行います。

  • 文字に 0 ポイントまたは 0.01 ポイントの白い線を適用します。
  • 文字をアウトラインに変換します。文字が小さい場合(24 ポイント以下)は、0 ポイントまたは 0.01 ポイントの白い線を文字に適用し、アウトラインに変換した文字による線のひずみを防ぎます。この場合、見た目に少し文字が太く印刷される場合があります。
  • [選択ツール] で文字を選択し、[オブジェクト] メニューから [ラスタライズ] を選択して文字をラスタライズします。

 A-6. 隠れたカラーオブジェクトを追加します

黒以外の色で塗りを設定した文字が黒で出力されてしまい、なおかつファイル内で使用している色がその色のみである場合は、以下の手順で文字と同じ色を塗りに設定した隠しオブジェクトを作成し、印刷を行います。

  1. [長方形ツール] を使って長方形を描きます。
  2. 長方形の塗りに、文字に設定した色と同じ色を設定します。



  3. 手順 1. で作成した長方形を完全に覆うことができる程度の大きさで、長方形を描きます。
  4. 新規作成した長方形の塗りを白に設定し、手順 1. で作成した長方形を覆うように配置します。



 A-7. [プリントするレイヤー] オプション

[プリントするレイヤー] オプションを [すべてのレイヤー] に変更し、印刷を行います。

  1. [ファイル] メニューから [プリント] を選択します。
  2. 画面左側のリストから [一般] を選択します。
  3. [プリントするレイヤー] ポップアップメニューから [すべてのレイヤー] を選択します。



 A-8. 通常使うプリンタの設定(Windows)

Windows で PostScript プリンタを通常使うプリンタに設定します。その後、通常使うプリンタ以外のプリンタを使用して Illustrator から印刷を行います。

通常使うプリンタを設定するには、以下の操作を行います。

  1. 以下のいずれかの操作を行います。

    Windows Vista

    [スタート] メニューから [コントロールパネル] を選択し、[ハードウェアとサウンド] セクションの [プリンタ] をクリックします。

    Windows XP

    [スタート] メニューから [プリンタと FAX] を選択します。

    Windows 2000

    [スタート] メニューから [設定] - [プリンタ] を選択します。
  2. PostScript プリンタを右クリックして、[通常使うプリンタに設定] を選択します。

 注意 : PostScript プリンタをお持ちでない場合でも、仮想プリンタとして PostScript プリンタドライバをインストールすることができます。プリンタの追加方法についての詳細は、Windows ヘルプを参照してください。PostScript プリンタをインストールするには、以下の操作を行います。

Windows Vista

  1. [スタート] メニューから [コントロールパネル] を選択します。
  2. [ハードウェアとサウンド] をクリックします。
  3. [プリンタ] セクションで [プリンタの追加] をクリックします。
  4. 「プリンタの追加」画面が表示されたら、画面上の指示に従い PostScript プリンタを追加します。

Windows XP

  1. [スタート] メニューから [プリンタと FAX] を選択します。
  2. 画面左上の [プリンタのタスク] セクションで [プリンタのインストール] をクリックします。
  3. 「プリンタの追加ウィザード」が表示されたら、、画面上の指示に従い PostScript プリンタを追加します。

Windows 2000

  1. [スタート] メニューから [設定] - [プリンタ] を選択します。
  2. [プリンタ] アイコンをクリックし、[プリンタの追加] アイコンをダブルクリックします。
  3. 「プリンタの追加ウィザード」が表示されたら、、画面上の指示に従い PostScript プリンタを追加します。

Illustrator で通常使うプリンタ以外のプリンタを使用してプリントを行うには、以下の操作を行います。

  1. Illustrator を起動します。
  2. [ファイル] メニューから [プリント] を選択します。
  3. [プリンタ] ポップアップメニューから、使用するプリンタを選択します。
  4. [プリント] をクリックし、印刷を行います。

 A-9. ローカルプリンタに出力します

ネットワーク上のプリンタに接続している場合、プリンタをコンピュータに直接接続し、印刷を行います。出力が正常に行われた場合、ネットワークに関連した問題が原因となっています。ネットワークの管理者にお問い合わせください。

 B. 回避策

B-1. ファイルを PDF ファイルとして保存します

B-2. 別のアプリケーションから出力します

B-3. 他のプリンタから出力します

上記の手順で問題が解決できない場合、以下のトラブルシューティングを行います。

 B-1. PDF ファイルとして保存

[別名で保存] ダイアログボックスの [ファイルの種類](Windows)/[フォーマット](Macintosh)ポップアップメニューから [Adobe PDF] を選択し、Illustrator ファイルを Adobe PDF(Portable Document Format)ファイルとして保存します。その後、Adobe Reader または Acrobat で PDF ファイルを開いて印刷します。

 B-2. 別のアプリケーションから出力します

Illustrator ファイルを Adobe Photoshop、Adobe PageMaker、Adobe InDesign などの他のアプリケーションから出力します。

 注意 : 他のアプリケーションでも非 PostScript から出力すると問題が発生する可能性があります。この場合は、Illustrator ファイルを他のフォーマット(例えば、TIFF や EPS)で保存または書き出しをしてから、開くか配置してから印刷を行ってください。

 B-3. 他のプリンタから出力します

PostScript プリンタまたは他の非 PostScript プリンタから出力します。

 注意 : 非 PostScript プリンタの製造元(例えば、Hewlett-Packard 社、EPSON 社)によっては、PostScript ハードウェアまたはソフトウェアを提供している場合があります。PostScript ハードウェアまたはソフトウェアを提供しているかについては、製造元にお問い合わせください。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー