この情報は、米国アドビシステムズ社が提供している情報をもとにローカライズし、作成したものです。 

 注意 : このサポート文書の手順を行うには、一定の専門知識が必要です。パソコン初心者の方は、まず以下の文書をご覧ください。

内容 (What's Covered)

A. トラブルシューティング/初級編~中級編

B. トラブルシューティング/上級編

この文書は、Adobe Illustrator CS2/CS3/CS4 で作成したファイルによって生じる問題の対処方法について説明します。破損した Illustrator ファイルは、エラー「メモリが不足しているため Illustrator は開けません」または「Acrobat PDF ファイル形式は ~ できません」あるいは、アートワークを修正、保存、または印刷などを行う際のクラッシュや、プレビューできないなど、予期しない動作の原因となる可能性があります。

破損したファイルが原因かどうかを特定するには、Illustrator で新規ファイルを作成し、オリジナルファイルで起こった問題の原因となった同じ動作を実行します。新規ファイルで問題が再現されない場合、オリジナルファイルが破損している可能性があります。

ハードディスクの空き容量やシステムリソースの不足、またはアプリケーション間のコンフリクトなどによって、ファイルに破損が生じる場合があります。さらにアプリケーションがハードディスクを読みこんだり書き出す際にシステムにエラーやフリーズまたはクラッシュなどが発生すると、そのとき開いているファイルが破損する可能性があります。またネットワークやリムーバブルドライブ上にあるファイルでの作業は、ローカルハードディスク上の作業に比べて読み取り、書き込みの際にエラーが生じる可能性が高くなります。

A.トラブルシューティング/初級編~中級編

A-1. 最新版の Illustrator をインストール

アプリケーションのアップデータは、アプリケーションが発売された後に発見された問題を修正します。最新のアップデータを適用することによって、アプリケーションの問題によるエラーを改善することができます。使用している Illustrator のバージョンを確認するには、[ヘルプ](Windows)/[Illustrator](Macintosh)メニューから [Illustrator について] を選択します。llustrator の最新アップデータは、弊社 Web サイト http://www.adobe.com/jp/downloads/updates/ から無償でダウンロード可能です。

Illustrator CS4 のアップグレード版は、アドビストアおよび正規代理店から購入することができます。詳細については、以下の弊社 Web サイトを参照してください。

販売パートナーのご紹介

URL : http://partners.adobe.com/public/main.html?force-locale=ja-jp

アドビストア

URL : http://www.adobe.com/go/gntray_store_jp

購入について詳細は、弊社 カスタマーサービス にお問い合わせください。

A-2. ローカルハードディスク上での作業

ファイルがネットワーク上、または CD-R、MO、メモリーカード などのリムーバブルディスク上にある場合、ローカルのハードディスクにコピーしてから作業を行ってください。

Adobe Creative Suite を購入されている場合、ネットワーク上でのファイル管理には、付属の Adobe Version Cue の使用をお勧めします。Version Cue に関する詳細は、以下の弊社 Web サイトを参照してください。

URL : http://www.adobe.com/jp/products/creativesuite/versioncue/

A-3. 新規ファイルへのコピー

 重要 : Illustrator CS2 の場合、オリジナルのファイルを保存する際に、[Illustrator オプション] ダイアログボックスで [PDF 互換ファイルを作成] を選択していないと、この解決方法は使用できません。Macintosh 環境では、破損した Illustrator ファイルは [配置] ダイアログボックス内で灰色に表示されますが、選択および新しい Illustrator ファイルに配置することは可能です。

  1. [ファイル] メニューから [新規] を選択します。
  2. 任意のドキュメントサイズとカラーモードを選択して [OK] をクリックします。

    ※ Illustrator CS3/CS4 の場合、[詳細] 左側の下向き矢印ボタンをクリックすると、カラーモードのオプションが表示されます。



  3. [ファイル] メニューから [配置] を選択します。
  4. [配置] ダイアログボックスが表示されたら、以下のいずれかの操作を行います。

    - Windows

    [ファイルの種類] ポップアップメニューから [すべてのファイル形式] または [すべてのファイル] を選択します。

    - Macintosh

    [使用可能] ポップアップメニュー(Illustrator CS2)/[選択対象] ポップアップメニュー(Illustrator CS3/CS4)から [すべてのドキュメント] を選択します。
  5. [ファイル名] にオリジナルのファイルを指定して [配置] をクリックします。
  6. [PDF を配置] ダイアログボックスが表示された場合は、[トリミング] ポップアップメニューから任意のトリミングオプションを選択し [OK] をクリックします。
  7. [ファイル] メニューから [保存] を選択し、ファイル名と保存先を指定して [保存] をクリックします。

A-4. 新規ファイルへのアートワークのコピー

新規ファイルにオリジナルファイルのアートワークをコピーするには、以下の操作を行います。

  1. 破損したファイルを開き、[オブジェクト] メニューから [パス] - [パスの削除] を選択します。
  2. [削除] セクションの不要な項目にチェックを入れ、[OK] をクリックします。

    ※ パスの削除を行うことによって、ファイル上の余分なポイントや塗りのないオブジェクト、空のテキストパスを削除します。



  3. [レイヤー] パレット(Illustrator CS2)/[レイヤー] パネル(Illustrator CS3/CS4)のメニューから [コピー元のレイヤーにペースト] を選択します。

    ※ オリジナルファイルに複数のレイヤーがある場合、この操作を行うことによって、新規ファイルにペーストする際にレイヤー構造が保持されます。
  4. [選択] メニューから [すべてを選択] をクリックします。
  5. [編集] メニューから [コピー] を選択します。
  6. [ファイル] メニューから [新規] を選択して、新規ファイルを作成します。
  7. 新規ファイルの [編集] メニューから [前面へペースト] を選択して、ページ上の正確な位置にアートワークをペーストします。
  8. [ファイル] メニューから [保存] を選択し、ファイル名と保存先を指定して [保存] をクリックします。



     注意 : オリジナルファイルへの上書きではなく、別のファイルとして新規に保存してください。

問題が再現する場合 :

破損したオブジェクトを含んでいる可能性があります。破損したオブジェクトを特定するには、新規ファイルにペーストしたオブジェクトのうちの 1 つを削除してファイルを保存し、再度開いて問題が再現するかどうか確認します。ファイル内の各オブジェクトに対してこの操作を行い、問題の再現するオブジェクトを特定します。

問題が再現しない場合 :

オリジナルファイルに含まれている破損したオブジェクトを削除し、再作成します。

  • Illustrator で描画されたオブジェクトが破損している場合、Illustrator の描画ツールを使って再作成します。
  • リンクされたイメージが破損している場合、元のイメージを作り直してリンクを置き換えます。
  • テキストオブジェクトが破損している場合、テキストオブジェクトをアウトラインに変換するか、ドキュメントのフォントを変更します。

ドキュメントのフォントを変更するには、以下の操作を行います。

  1. Illustrator を起動し、オリジナルファイルを開きます。

    ※ ロックされたオブジェクトを含む場合、[オブジェクト] メニューから [すべてをロック解除] を選択します。
  2. [選択] メニューから [すべてを選択] を選択します。
  3. [書式] メニューから [フォント] を選択し、現在ドキュメント上で使用されていないフォントを選択します。

 注意 : テキストオブジェクトが今後破損しないために、問題の発生するフォントを再インストールしてください。

A-5. 未使用のスウォッチ、カスタムカラー、ブラシ、シンボル、グラフィックスタイルの削除

使用していないスウォッチ、スポットカラー、カラーグループ(Illustrator CS3/CS4)、ブラシ、シンボル、またはグラフィックスタイルを削除します。

以下の操作を行います。

  1. Illustrator を起動し、破損したファイルを開きます。
  2. [スウォッチ]、[ブラシ]、[シンボル]、[グラフィックスタイル] パレット(Illustrator CS2)/[スウォッチ]、[ブラシ]、[シンボル]、[グラフィックスタイル] パネル(Illustrator CS3/CS4)を表示して、使用していない項目を選択します。
  3. パレット右下のゴミ箱のアイコンをクリックし、確認のメッセージが表示されたら [はい] をクリックします。



  4. 手順 2. ~ 3. の操作を繰り返し行い、すべての使用していないスウォッチ、スポットカラー、カラーグループ、ブラシ、シンボルおよびグラフィックスタイルを削除します。

B. トラブルシューティング/上級編

上記セクションの手順を行った後も問題が継続して発生する場合、ファイルのフォント、グラデーション、パターン、リンク、オブジェクトが破損している可能性があります(例えば、テキストブロック、インポートされたグラフィック、Illustratorで描画されたグラフィックなど)。以下のいずれか、または複数のトラブルシューティングを行います。

 注意 : 以下の作業によってファイルを回復した場合、透明部分やレイヤー情報が失われます。

B-1. 破損したパターン、グラデーション、カスタムカラーの特定

破損したパターン、グラデーション、カスタムカラーを特定するには、以下の操作を行います。

  1. Illustrator を起動し、破損したファイルを開きます。
  2. [選択] メニューから [すべてを選択] をクリックします。
  3. ツールボックス(Illustrator CS2)/ツールパネル(Illustrator CS3/CS4)の [塗り] または [線] をダブルクリックし、カラーピッカーでプロセスブラック(シアン、マゼンタ、イエローの重ね合わせによるブラック)に変更します。



  4. 上記 A-4. 新規ファイルへのアートワークのコピーの手順を行い、パターン、グラデーションおよびスポットカラーを含まない新規ファイルで問題が再現するか確認します。

問題が再現しない場合 :

パターン、グラデーション、あるいはスポットカラーを元のファイル上で再作成します。

B-2. ファイルを PDF 形式に変換

ファイルが EPS 形式で保存されている場合、Adobe Acrobat Distiller を使用して PDF ファイルに変換し、Illustrator で PDF ファイルを開きます。

B-3. PostScript ファイルとしてファイルをプリント

PostScript ファイルとしてファイルをプリントし、Illustrator で PostScript ファイルを開きます。

 注意 : この操作を行うには、PostScript プリンタドライバがインストールされている必要があります。Windows に PostScript プリンタドライバをインストールする詳細については Windows ヘルプを参照してください。

以下の操作を行います。

  1. 使用するプリント、または出力設定を行います。
  2. [ファイル] メニューから [プリント] を選択します。
  3. [プリンタ] ポップアップメニューから [Adobe PostScript ファイル] を選択して、[保存] をクリックします。
  4. [ファイルに出力](Illustrator CS2)/[ファイルへ出力](Illustrator CS3/CS4)ダイアログボックスが表示されたら、ファイル名と保存場所を指定し、[保存] をクリックします。



     注意 : ファイルの拡張子は「.ps」にします。(例 :illustrator.ps など)
  5. 作成した PostScript ファイルを Illustrator で開きます。

B-4. ファイルの再作成

問題が発生するファイルで使用したグラフィック、テンプレート、スポットカラーを再作成し、再度保存して Illustrator ファイルを作成し直します。他の Illustrator ファイルからコピーしたすべての要素を再作成してください。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー