この情報は、米国アドビシステムズ社が提供している情報をもとにローカライズし、作成したものです。

日本語環境での動作保証はしておりませんのでご了承ください。

内容 (What's Covered)

A. Windows の最適化

B. ハードウェア構成の最適化

C. Illustrator 機能の効果的な使用

D. Windows 関連情報

 

この文書は、Windows Vista で Adobe Illustrator CS4/CS5 のパフォーマンスを最適化するためのさまざまな方法を紹介します。Illustrator が遅くなったと感じたときにもお試し下さい。

Illustrator のパフォーマンスは、設定、ワークフロー、オペレーティングシステムやハードウェア構成などのさまざまな要因に左右されます。以下にあげる操作や設定を行うことで、特にサイズの大きいファイルで作業を行う際に効果を得られます。また、オペレーティングシステムやハードウェア構成を最適化することにより、Illustrator 以外の他のアプリケーションのパフォーマンスも向上します。

以下の操作を行う前に、必ず Illustrator を最新バージョンにアップデートしてください。アップデートには、多くの場合パフォーマンス関連の修正や強化が含まれています。最新バージョンの情報およびアップデートについては、弊社 Web サイト http://www.adobe.com/jp/downloads/updates/ を参照してください。

 

A. Windows の最適化

Windows の設定を変更することによって、使用可能なメモリの容量が増え、アプリケーションが快適に起動、動作するようになります。また、使用しないアプリケーションを終了したり、スタートアップ項目やフォントを無効にすることにより、Illustrator のパフォーマンスが更に向上します。

A-1. 仮想メモリ

仮想メモリによって、通常はメモリ(RAM)に保存される情報をハードディスクに保存できます。ハードディスクの情報にアクセスする場合は、メモリにアクセスするよりも時間がかかるため、ハードディスクの一部を仮想メモリとして使用すると、パフォーマンスが低下します。

Windows ではページングファイルを使って仮想メモリを管理し、ユーザーはページングファイルの最小サイズと最大サイズを定義することができます。ページングファイルの最大サイズが搭載メモリ容量の 3 倍以上に設定されていると、Illustrator のパフォーマンスは最適化されます。

Windows のページングファイルサイズを設定するには、以下の操作を行います。

 注意 : コンピューターのページングファイルのサイズを変更するには、管理者権限でログインしている必要があります。

  1. すべてのアプリケーションを終了します。
  2. [スタート] メニューから [コンピュータ] を右クリックして [プロパティ] を選択します。
  3. 画面左側のタスクで [システムの詳細設定] をクリックします。
  4. [ユーザーアカウント制御] ダイアログボックスが表示された場合は [続行] をクリックします。
  5. [システムのプロパティ] ダイアログボックスの、[[詳細設定] タブをクリックします。
  6. [パフォーマンス] セクションで [設定] ボタンをクリックし、[パフォーマンスオプション] ダイアログボックスで [詳細設定] タブをクリックします。
  7. [仮想メモリ] セクションの [変更] ボタンをクリックします。
  8. [詳細設定] タブの [すべてのドライブのページングファイルのサイズを自動的に管理する] のチェックを外します。
  9. 「ドライブ」リストから搭載メモリの 3 倍以上の空き領域のあるハードディスクを選択します。例えばコンピューターに 512 MB のメモリが搭載されている場合は、1536 MB(約 1.5 GB)以上空き領域のあるハードディスクを選択します。Illustrator の仮想記憶ディスクに使用されていないドライブを選択すると、より効果的です。
  10. [選択したドライブのページングファイルサイズ] セクションで、[初期サイズ] フィールドに搭載メモリ容量に 300 MB を加えた値を入力します。
  11. [最大サイズ] フィールドに搭載メモリ容量の 3 倍の値を入力します。
  12. [設定] をクリックします。
  13. [OK] をクリックし、[仮想メモリ] ダイアログボックスを閉じます。
  14. [OK] をクリックし、[パフォーマンスオプション] ダイアログボックスを閉じます。
  15. [OK] をクリックし、[システムのプロパティ] ダイアログボックスを閉じます。
  16. [システム設定の変更] ダイアログボックスが表示されたら、[はい] をクリックし、コンピューターを再起動します。

A-2. ディスプレイドライバー

ディスプレイドライバーの中には、グラフィックの表示を高速化したり変更したりする高度な設定が用意されているものもあります。場合によっては、これらの設定が Illustrator のスクリーン再描画のパフォーマンスに影響をおよぼすこともあります。ドライバー専用の機能を無効にして、Illustrator に最適な設定を決定します。詳細については、使用しているディスプレイカードのマニュアルを参照してください。

A-3. フォント

必要なフォントだけをインストールすることで、システムのパフォーマンスが向上し、フォントにアクセスするアプリケーションのパフォーマンスも向上します。フォントを 1 つインストールすると、その分システムが使用するメモリ容量が増加します。したがって、アプリケーションに割り当てられるメモリが減少し、フォント名をリストしたメニューの表示に時間がかかります。フォント管理ユーティリティを使用すると、多くのフォントを効率的に管理することができます。

A-4. スタートアップ項目

コンピューターの起動時に自動的に読み込まれるアプリケーションは、Illustrator が利用可能な RAM と競合することがあります。以下の操作を行い、自動的に起動するよう設定されたアプリケーションを無効にすることができます。以下の操作を行います。

  1. すべてのアプリケーションを終了します。
  2. [スタート] メニューから [すべてのプログラム] - [Winsows Defender] を開きます。
  3. [ツール] をクリックして、 [ソフトウェアエクスプローラ] をクリックします。
  4. [カテゴリ] ポップアップメニューから [スタートアッププログラム] を選択します。
  5. 自動的に起動するプログラムの一覧から、停止するアプリケーションを選択して [無効にする] ボタンをクリックします。
  6. 「アプリケーションを無効にしますか?」と表示されたら [はい] をクリックします。
  7. 手順 5. ~ 6. の操作を繰り返し行い、不要な項目をすべて無効にします。
  8. コンピューターを再起動します。

- Illustrator のパフォーマンスに変化がない場合、上記手順で無効にしたスタートアップ項目を再度有効にします。

- Illustrator のパフォーマンスが向上した場合、無効にしたスタートアップ項目のいずれかがパフォーマンス低下の原因となっている可能性があります。上記手順で無効にしたスタートアップ項目を 1 つずつ有効にしてコンピューターを再起動し、原因となるアプリケーションを特定します。アプリケーションが特定できた場合は、アプリケーションを再インストールするか、製造元へアップデートまたはアップグレードについてお問い合わせください。

レジストリで自動的に起動するように指定されているアプリケーションを無効にするには、以下の操作を行います。

  1. Windows を再起動します。
  2. Ctrl + Shift + Esc キーを押して、Windows タスクマネージャを起動します。
  3. [アプリケーション] タブをクリックします。
  4. 任意のアプリケーションを 1 つ選択します。
  5. [タスクの終了] ボタンをクリックします。
  6. Illustrator を再起動します。

Illustrator のパフォーマンスが著しく向上した場合は、アプリケーションの製造元に連絡し、そのアプリケーションを常に自動的に起動しないようにする方法についてお問い合わせください。残りのスタートアップ項目についても手順 2. ~ 6. を繰り返します。

 

B. ハードウェア構成の最適化

Illustrator のパフォーマンスは使用するハードウェアによって左右されます。プロセッサーやハードディスクドライブが高速であれば、Illustrator で情報をすばやく処理することができます。メモリの増設、マルチプロセッサーシステムの使用、ドライブの最適化やデフラグなど、その他のハードウェア強化によっても Illustrator のパフォーマンスは向上します。

B-1. プロセッサーの速度

Illustrator は大量のデータを操作し、多くの計算を実行するため、プロセッサー(CPU)の速度が処理速度に大きな影響を与えます。高速なプロセッサーを搭載したコンピューターを使用することで、Illustrator の処理速度も向上します。

B-2. 内蔵メモリ

Illustrator の動作に十分なメモリ(RAM)がない場合は、ハードディスクスペース(仮想メモリ、仮想記憶ディスク、または両方)を使用して情報が処理されます。搭載メモリの容量が大きければ、仮想記憶ディスクを使用する必要がなくなり、Illustrator の動作はより高速になります。

B-3. ハードディスク

システムに十分な連続した空き容量がない状態で、ファイルの追加、削除、移動などを行うとハードディスクの断片化が生じます。断片化したファイルは読み取りに時間がかかります。スキャンディスクやデフラグを使用してファイルの断片化を解消し、ハードディスクの空き容量を最適化できます。「スキャンディスク」と「デフラグ」の詳細については、Windows のマニュアルを参照してください。

Illustrator は、ファイルの作業と同時に読み取りおよび書き込みを行います。したがって、ファイルを保存しているディスクまたは Illustrator の仮想記憶ディスクへのアクセス速度が高速であれば、それだけ高速にファイル情報を処理できます。ファイルの保存場所はネットワークサーバー(ネットワークドライブ)やリムーバブルメディア(Zip 、Jaz 、またはフロッピーディスクなど)のようなアクセスに時間を要するディスクは避け、内蔵ハードディスクドライブなどのアクセス速度が高速なディスクを選択します。リムーバブルメディアは、内蔵ハードディスクドライブと比べるとアクセス速度が遅く、ファイルが破損しやすい傾向があります。

Illustrator ファイルをネットワークまたはリムーバブルメディアに保存する場合、弊社では、一度ファイルを内蔵ハードディスクに保存してから外部メディアへ保存するか、もしくは Adobe Version Cue を使用することをお勧めします。

B-4. PostScript プリンターの使用

Illustrator からプリントする際に最良の結果を得るためには、PostScript プリンターを使用します。多くの非 PostScript プリンターはディスプレイ情報、ホストコンピューターのリソース、および所有権のあるプリンタードライバーに依存して、プリント情報をプリンターに送ります。また、PostScript プリンターと比べてプリントに要する時間が長くなる可能性があります。

 

C. Illustrator 機能の効果的な使用

Illustrator での作業の方法、特にアートワークを表示する動作は、Illustrator のパフォーマンスに大きく影響します。Illustrator の画面表示オプションの変更、画像を埋め込まずにリンク、仮想記憶ディスクとスタートアップオプションの最適化などの方法を用いて、Illustrator の速度とメモリの使用率を向上できます。

C-1. アウトライン表示

Illustrator のアウトライン表示ではペイント属性が隠され、アートワークは塗りのないパスとして表示されます。アートワークをアウトライン表示した状態で作業を行うと、グラデーションまたはパターンを含むオブジェクトなどの、複雑なアートワークを含むオブジェクトの形状をすばやく表示できます。アウトライン表示では塗りが非表示になるため、他の塗りつぶされたオブジェクトの背後に隠れたオブジェクトを編集する際にも便利です。アートワークをアウトラインで表示するには、[表示] メニューから [アウトライン] を選択します。

アートワークの表示に関する詳細は、Illustrator ヘルプを参照してください。

C-2. 画面表示のカスタマイズ

書類の画面モード、拡大率、スクロール位置およびレイヤーオプションをカスタマイズした状態の画面を 1 つの設定として登録しておくことで、[表示] メニューから設定をすばやく呼び出すことができるようになります。

画面表示の設定をカスタマイズするには、以下の操作を行います。

  1. Illustrator を起動し、画面表示をカスタマイズする書類を開きます。
  2. 画面モード、拡大率など、保存する画面属性を設定します。
  3. [表示] メニューから [新規表示] を選択します。
  4. [新規表示] ダイアログボックスで [名前] テキストボックスに任意の名前を入力し、[OK] をクリックします



以上の操作で、[表示] メニューの一番下にカスタマイズした設定の名前が表示されます。

C-3. 表示パフォーマンス(Illustrator CS4 のみ)

[手のひらツール] を使用してアートボードを移動する際の、画質および速度を指定します。表示パフォーマンスの設定を変更するには、以下の操作を行います。

  1. [編集] メニューから [環境設定] - [単位・表示パフォーマンス] を選択します。
  2. [手のひらツール] のスライダを左に動かすと画質、右に動かすと速度のパフォーマンスが向上します。





     
  3. [OK] をクリックします。

C-4. ラスター効果の解像度

Illustrator のパフォーマンスを最適化するために、ラスター効果の解像度を変更します。ラスター効果の解像度を変更するには以下の操作を行います。

  1. [効果] メニューから [ドキュメントのラスタライズ効果設定] を選択します。
  2. [解像度] セクションで以下のいずれかの設定を行い、[OK] をクリックします。
    • ファイルを編集する場合、[スクリーン] をクリックします。Illustrator はラスター効果を 72 ppi の解像度で使用し、表示速度が向上します。
    • ファイルを印刷する場合、[高解像度] をクリックします。Illustrator はラスター効果を 300 ppi の解像度で使用し、印刷の速度は低下しますが、印刷の品質は向上します。

C-5. レイヤーの表示

複雑なアートワークや高解像度のビットマップ画像が配置されているファイルを編集する場合、アートワークやビットマップ画像が配置されたレイヤーを非表示にすることによってスクリーン再描画の速度を向上することができます。レイヤーを非表示にするには、レイヤー名の左側にある目のアイコンをクリックします。選択したレイヤー以外の全てのレイヤーを非表示にするには、Option キーを押しながら目のアイコンをクリックします。

[レイヤー] パネルには、上位レベルのレイヤー、ネスト化されたレイヤー、グループ、およびオブジェクトのサムネールを表示することができます。サムネールの数を減らし、Illustrator の再描画を高速化するには、以下の操作を行います。

  1. [レイヤー] パネルのメニューから、[パネルオプション] を選択します。
  2. いくつかのサムネールを削除します。
    • すべてのサムネールを非表示にするには、[行のサイズ] セクションで [小] を選択し、[OK] をクリックします。
    • 特定のレイヤーのサムネールを非表示にするには、[サムネール] セクションで [レイヤー]、[グループ] または [オブジェクト] からチェックをはずし、[OK] をクリックします。

C-6. オーバープリントプレビュー

オーバープリントプレビューでは、ブレンドや透明が擬似的に「インクプレビュー」として表現され、色分解出力でのオーバープリントが表示されます。オーバープリントプレビューを無効にすることにより、パフォーマンスが向上する可能性があります。オーバープリントプレビューの有効/無効を切り替えるには、[表示] メニューの [オーバープリントプレビュー] を選択します。

C-7. アートボード

アートボードは、印刷可能なアートワークの領域を表しています。パフォーマンス向上のために、不要なアートボードの削除を検討してください。アートボードの管理は、[ウィンドウ] メニューの [アートボード] から行います。

C-8. 仮想記憶ディスク

Illustrator では埋め込まれたビットマップ画像を操作する際にメモリが不足すると、ハードディスクスペースを仮想記憶ディスクとして使用します。ハードディスクの情報へのアクセスは、メモリの情報へのアクセスより時間を要します。したがって、ハードディスクの一部を仮想メモリとして使用すると、パフォーマンスが低下します。Illustrator で作業するための十分なメモリがない場合は、メモリの増設が効果的です。

Illustrator の初期設定では、オペレーティングシステムがインストールされているハードディスクが 1 番目の仮想記憶ディスクとして設定されます。最適なパフォーマンスを得るためには、OS がインストールされておらず、未使用領域が多い、読み書きのスピードが(ネットワークドライブや Zip ドライブなどよりも)速い、デフラグされたハードディスクを 1 番目の仮想記憶ディスクとして設定することを推奨します。複数のハードディスクがある場合は、追加の仮想記憶ディスクを指定することを推奨します。

仮想記憶ディスクの割り当てを変更するには、以下の操作を行います。

  1. [編集] メニューから [環境設定] - [プラグイン・仮想記憶ディスク] を選択します。
  2. [ディスク 1] ポップアップメニューから適切なハードディスクを選択します。
  3. 必要に応じて [ディスク 2] ポップアップメニューから 2 番目のハードディスクを選択します。
  4. [OK] をクリックします。
  5. Illustrator を再起動します。

 注意 : Windows に付属するディスクデフラグなどのディスクユーティリティを使用して、ハードディスクを定期的に最適化し、断片化を解消することをお勧めします。ディスクデフラグの詳細については、Windows ヘルプを参照してください。

C-9. 新規ドキュメントのプロファイル

Illustrator の新規ドキュメントのプロファイルには、デフォルトパターン、グラデーション、グラフのデザイン、カラーおよびカラーライブラリが含まれています。さらに、新規にファイルを開く際のデフォルトのズームレベル、ウィンドウサイズ、画面の環境設定およびスクロール位置も含まれます。新規文書のファイルサイズを最小にするには、不要なスウォッチ、グラデーション、グラフィックスタイル、ブラシを文書プロファイルから削除します。各パレットの操作についての詳細は、Illustrator のヘルプを参照してください。Illustrator では基本 RGB と基本 CMYK の他に、プリント、Web、ビデオとフィルムなどのドキュメントプロファイルが用意されています。

ドキュメントプロファイルの作成に関する詳細は、Adobe Illustrator CS4/CS5 ヘルプ「新しいドキュメントの作成」を参照してください。

C-10. テンプレート

Illustrator テンプレートによって、共通の設定やデザイン要素を共有する新規ドキュメントを作成することができます。たとえば、似たような名刺をデザインしたり、アートボードの大きさ、ガイドなどの表示設定、印刷設定、などのテンプレートを作成します。不要なスウォッチ、シンボル、グラフィックスタイル、ブラシなどをテンプレートから除くことで、ファイルサイズを小さくすることができます。テンプレートは起動ファイルやドキュメントプロファイルを作成するよりも有効な手段です。また、テンプレートはいくつでもを作成することができ、起動ファイルやドキュメントプロファイルのようにファイル名や場所が制限されていないため、任意の場所に保存して使用することができます。

テンプレートファイルを作成するには、以下の操作を行います。

  1. Illustrator を起動します。
  2. テンプレートとして使用するファイルを作成、もしくは開きます。
  3. [ファイル] メニューから [テンプレートとして保存] を選択します。
  4. 任意の場所に保存します。

作成したテンプレートを使用するには、以下の操作を行います。

  1. Illustrator を起動します。
  2. [ファイル] メニューから [テンプレートから新規] を選択します。
  3. 作成したテンプレートを選択します。

テンプレートファイルの作成に関する詳細は、Adobe Illustrator CS4/CS5 ヘルプ「新規テンプレートの作成」を参照してください。

C-11. リンクされたファイル

TIFF 形式(Tagged-Image Files Format)、BMP 形式(BitMap)、Photoshop EPS 形式(Encapusulated PostScript)などの埋め込まれたビットマップ画像がある場合は、Illustrator ファイルのサイズが大きくなり、パフォーマンスが低下します。パフォーマンスを向上するためには、ビットマップ画像を配置する際に [配置] ダイアログボックスから [リンク] を選択します。[リンク] オプションを使用することによって、配置した画像の参照情報をハードディスクに作成することができます。サービスビューローが埋め込まれた画像を必要としている場合には、オリジナルファイルのコピーを保存するようにします。コピーを保存する際に、[Illustrator オプション](Adobe Illustrator 書類)または [EPS オプション](Illustrator EPS)ダイアログボックスで、[配置した画像を含む] にチェックを入れます。

C-12. EPS プレビュー

ファイルが高解像度プレビューの EPS イメージへのリンクを含んでいるとき、アートワークの編集時に画像の描画に時間がかかる場合があります。Illustrator の低解像度 EPS プレビューを使用することで、描画速度が向上します。

低解像度 EPS プレビューを設定するためには以下の操作を行います。

  1. [編集] メニューから [環境設定] - [ファイル管理・クリップボード] を選択します。
  2. [ファイル] セクションで [リンクされた EPS に低解像度の表示用画像(プレビュー)を使用] にチェックを入れます。
  3. [OK] をクリックします。

C-13. [DCS 形式への透明の影響を表示] オプション

[リンク] パネルで [DCS 形式への透明の影響を表示] オプションが設定されている場合、[リンク] パレットに黄色のアイコンが表示され、透明オブジェクトに影響される EPS 画像を示します。このオプションによって、Illustrator がリンクされた EPS ファイルに透明の影響があるかどうかを定期的に判定することになるため、パフォーマンスが低下することがあります。[DCS 形式への透明の影響を表示] オプションを無効にするには、以下の操作を行います。

  1. [リンク] パネルのメニューから [パネルオプション] を選択します。
  2. [パネルオプション] ダイアログボックスで、[DCS 形式への透明の影響を表示] のチェックをはずします。
  3. [OK] をクリックします。

C-14. [ナビゲータ] パネル

[ナビゲータ] パネルには作業中のアートワークのサムネールが表示され、簡単にナビゲートできます。複雑なアートワークを編集している場合、変更を行うたびにサムネールを更新するため、処理に時間がかかることがあります。複雑なアートワークを含む Illustrator ファイルのスクリーン再描画速度とパフォーマンスを向上させるためには、[ナビゲータ] パネルを非表示にする方法が有効です。[ナビゲータ] パネルを非表示にするには、[ウインドウ] メニューから [ナビゲータ](Illustrator CS4)/[ナビゲーター](Illustrator CS5)のチェックをはずします。

※ 画面表示をカスタマイズしておくと、文書の特定の範囲をより効率的にズーム表示できます。詳細については、C-2. 画面表示のカスタマイズを参照してください。

C-15. アートワークのアンチエイリアス

[アートワークのアンチエイリアス] オプションを選択することによって、オブジェクトの端のピクセルと隣接したピクセルのカラーがブレンドされ、テキストやグラフィックが滑らかに表示されますが、画像の再描画に要する時間が長くなります。このオプションを無効にするには、以下の操作を行います。

  1. [編集] メニューから [環境設定] - [一般] を選択します。
  2. [アートワークのアンチエイリアス] のチェックをはずします。
  3. [OK] をクリックします。

C-16. パスの単純化

[パスの単純化] コマンドを使い、パスおよびパスシェイプのアンカーポイントの数を減らすことによって、ファイルサイズを減らし、パフォーマンスを向上させることができます。[パスの単純化] コマンドを適用するには、以下の操作を行います。

  1. 単純化するパスまたはオブジェクトを選択します。
  2. [オブジェクト] メニューから [パス] - [単純化] を選択します。
  3. [単純化] ダイアログボックスで適切な設定を行い、[OK] をクリックします。

[パスの単純化] コマンドに関する詳細は、Adobe Illustrator CS4/CS5 ヘルプ「パスのスムーズ処理と単純化」を参照してください。

C-17. スマートガイド

スマートガイドは、Illustrator オブジェクトを他のオブジェクトとの相対関係で作成、整列、編集、および変形することができます。アートワークに多数のオブジェクトが含まれる場合は、スマートガイドを表示するために時間がかかります。スマートガイドを無効にするには、[表示] メニューを選択し、[スマートガイド] にチェックが表示されている場合はクリックして無効にします。

スマートガイドに関する詳細は、Adobe Illustrator CS4/CS5 ヘルプ「スマートガイド」を参照してください。

C-18. 絵筆ブラシ(Illustrator CS5 のみ)

絵筆ブラシは複数の重なりと、塗りが適用されたパスの透明効果で構成されます。これらのパスは、塗りが適用された一般的なパスと同様に、他のオブジェクトの塗りや絵筆ブラシのパスと相互に影響します。

本格的なアートワークを作成する前に、簡単なアートワークで絵筆ブラシの動作を確認してください。ブラシの属性を変更して適用すると、使用されているすべてのブラシが再描画されます。

絵筆ブラシを使用する際、以下の方法でアートワークを簡素化し、ファイルサイズを軽減することができます。

絵筆ブラシのラスタライズ

アートワークに多数(30 超)の絵筆ブラシが使用されている場合、[オブジェクト] メニューから [ラスタライズ] を選択して、絵筆ブラシのバスをラスタライズし、アートワークを簡素化することを推奨します。

 注意 : コンテンツの一部をラスタライズする前に、オリジナルの複製をあらかじめ保存しておくことをお勧めします。

PDF 機能の無効化

Illustrator の初期設定では、他の Adobe アプリケーションとの互換性を維持するために、ai ファイルを保存する際に PDF データが合わせて保存されます。[ファイル] メニューから [保存] または [別名を保存] を選択し、[PDF 互換ファイルを作成] オプションを無効にしてファイルサイズを軽減します。

 

D. Windows 関連資料

以下に示す Web サイトには、Windows の一般情報やトラブルシューティングに関する情報が掲載されています。

Adobe サポート情報 : http://www.adobe.com/jp/support/

Microsoft 技術情報 :  http://support.microsoft.com

Download.com : http://www.download.com*(英語サイト)

 

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー