Learn the basics of adding interactivity to your Adobe InDesign CC documents, including adding links, buttons, animation, sharing your interactive document, and more.

About interactivity in InDesign

Explore adding and previewing interactivity in your documents, as well as methods for sharing interactive documents

 

What you learned: About InDesign interactivity 

  • You can add interactivity such as buttons, links, forms, animation, video and audio, and more to your InDesign documents. Choosing Window > Workspace > Digital Publishing will open the necessary panels.
  • Interactivity in InDesign can be previewed in the EPUB Interactivity Preview panel (Window > Interactive > EPUB Interactivity Preview).
  • To share your interactive document, export (File > Export) it as ePub (Fixed Layout) or PDF (Interactive), or by choosing File > Publish Online.

Add interactivity

Discover a few of the many types of interactivity you can add to your documents

 

What you learned: Add links, and animation 

  • Hyperlinks (Window > Interactive > Hyperlinks) let viewers click a link to jump to other locations in the same document, to websites, and more.
  • Animation effects (Window > Interactive > Animation) allow you to add different types of animation to content, like adding motion to an object on the page.
  • Buttons (Window > Interactive > Buttons and Forms) perform an action such as linking to a page or showing/hiding content. 
  • Most interactivity cannot be previewed directly in the InDesign pages. Rather, it can be previewed in the EPUB Interactivity Preview panel (Window > Interactive > EPUB Interactivity Preview).

Share interactive documents

Discover how to share your interactive documents using Publish Online

 

What you learned: Share an interactive document via Publish Online

Publish Online outputs a digital version of an InDesign document that works on any device and in any modern web browser, and supports all interactivity included in the InDesign document:

  1. Click the Publish Online button or choose File > Publish Online, set the export options, and click Publish.
  2. Choose File > Publish Online Dashboard to see the Publish Online Dashboard in your default web browser. 
    • You can manage published documents and view analytics in the dashboard.
       
09/10/2018

 

Presenter: Brian Wood

Designer: Erica Larson

このページは役に立ちましたか。