InDesignには、豊富な画像編集の機能が用意されています。画像のサイズ調整やトリミングはもちろんのこと、フレームサイズに合わせて画像サイズを自動的に調整する機能や、さまざまな切り抜き使用の方法が用意されています。さらには、画像の持つメタデータから自動的にキャプションを生成することも可能です。

InDesignには、豊富な画像編集の機能が用意されています。画像のサイズ調整やトリミングはもちろんのこと、フレームサイズに合わせて画像サイズを自動的に調整する機能や、さまざまな切り抜き使用の方法が用意されています。さらには、画像の持つメタデータから自動的にキャプションを生成することも可能です。

画像を配置する

レイアウトソフトであるInDesignでは、PhotoshopやIllustrator等で作成した画像を配置する作業を頻繁に行います。さまざまな形式の画像が配置可能でPSDやAIといったネイティブ形式をはじめ、PDF、TIFF、EPS、JPEGなど、用途や目的に応じて使い分けることができます。とは言っても、どのような形式の画像を使用してもよいというわけではありません。用途に応じた形式の画像を使用する必要があり、印刷用途であればネイティブ形式での運用が推奨されています。ネイティブ形式であれば、レイヤーやアルファチャンネル、不透明度等を保持したままの運用が可能です(以前はEPS形式が使用されることが多かったですが、EPS形式ではアルファチャンネルや透明を保持したまま保存することができず、編集用画像と配置用画像に分けて運用しなければなりませんでした)。

また、画像の配置方法にもさまざまな方法が用意されています。[ファイル]メニューの[配置]コマンドを実行して配置したり、Adobe Bridgeやデスクトップ上から画像をInDesignドキュメント上にドロップしてもかまいません。どの方法でも、一度に複数の画像を配置することができますが、画像をどのように読み込むかをコントロールして配置したい場合には、[配置]コマンドを実行します。

 

[配置]ダイアログで[読み込みオプションを表示]にチェックを入れると、ファイル形式に合わせたオプションダイアログを表示させることが可能です

 

[画像読み込みオプション]ダイアログでは、画像をどのように読み込むかの詳細な指定が可能です。図はPSD形式の画像を配置する際に表示されるオプションダイアログで、画像のレイヤーやレイヤーカンプを指定して読み込むことができます

 

複数の画像やテキストを一度に配置する場合には、マウスポインタに画像のサムネールとファイル数が表示されます。矢印キーを押せば、次に配置するファイルを指定しながら、目的の場所に配置していくことが可能で、この機能をマルチプレースと呼びます

画像のサイズ調整とトリミング

画像のサイズ調整を行う際にまず覚えてほしいのが、選択ツールとダイレクト選択ツールの使い分けです。画像を選択ツールで選択すると、グラフィックフレーム自体が選択され、ダイレクト選択ツールで選択すると中身の画像のみが選択されます。もちろん、[変形]パネルに表示される値も異なります。何らかのコマンドを実行する場合に、画像をどちらのツールで選択しているかで結果が異なる場合がありますので注意してください。

基本的に、配置した画像は100%で使用することが望ましいですが、実際の作業では拡大・縮小して使用することもあります。画像サイズの調整は、[オブジェクトサイズの調整]コマンドから実行できますが、拡大・縮小率を正確にコントロールしたい場合には、[変形]パネル(あるいは[コントロール]パネル)に数値を入力して調整するとよいでしょう。なお、画像をダイレクト選択ツールでプレスすると、トリミングされて非表示になっている部分が半透明で表示されますので、位置の調整を行います。
 

画像を選択ツールで選択した場合(左)とダイレクト選択ツールで選択した場合(右)。それぞれ、[変形]パネルに表示される値が異なるのが分かります

 

画像をダイレクト選択ツールでプレスしたままにすると、トリミングされて非表示になっている部分が半透明で表示されます

 

[オブジェクトサイズの調整]コマンド。画像を選択して目的のコマンドを実行することで、画像のサイズ調整ができます

[オブジェクトサイズの調整]コマンド

元画像(左)に対し、[フレームに均等に流し込む]を実行したもの(右)。グラフィックフレームのサイズに合うよう画像か拡大・縮小されます。同じ縦横比率で拡大・縮小され、画像の一部がトリミングされます

 

左:[内容を縦横比率に応じて合わせる]を実行したもの。グラフィックフレームのサイズに合うよう画像が拡大・縮小されます。同じ縦横比率で拡大・縮小され、グラフィックフレーム内にはすき間ができます

右:[内容をフレームに合わせる]を実行したもの。グラフィックフレームにぴったり合うサイズに画像が拡大・縮小されます。この際、異なる縦横比率で拡大・縮小されます

 

左:[フレームを内容に合わせる]を実行したもの。画像サイズにぴったり合うようグラフィックフレームのサイズが変更されます

右:[内容を中央に合わせる]を実行したもの。グラフィックフレームの中央に画像の中央が揃います

 

拡大・縮小率を正確にコントロールしたい場合には、[変形]パネル(あるいは[コントロール]パネル)の[拡大/縮小X(Y)パーセント]に直接数値を入力します

 

選択ツールを選択している場合でも、マウスポインタを画像の中央部に移動すると、マウスポインタはハンドツールに切り替わり、ダイレクト選択ツールのように中の画像を移動することができます。これをコンテンツグラバーと呼びますが、グラフィックフレーム自体を動かしたい時に、謝って中の画像を動かしてしまうケースもあるため注意が必要です。コンテンツグラバーをオフにしたい場合には、[表示]メニューから[エクストラ]→[コンテンツグラバーを隠す]を実行します

フレーム調整オプション

画像は通常、原寸(100%)で配置されますが、あらかじめ、グラフィックフレームに対し[フレーム調整オプション]を設定しておくと、設定した内容で画像サイズが調整されて配置されます。グラフィックフレームを選択したら、[オブジェクト]メニューから[オブジェクトサイズの調整]→[フレーム調整オプション]を選択します。[フレーム調整オプション]ダイアログが表示されるので、目的に応じて各項目を設定します。

[フレーム調整オプション]ダイアログで[サイズ調整]と[整列の開始位置]を設定しておくと、画像配置時にその設定内容で配置されます。なお[自動調整]にチェックを入れておくと、画像配置後にフレームサイズを変更すると、変更後のフレームサイズに合うよう画像のサイズも再度、調整されます。ちなみに[自動調整]は、CS6までは[自動フィット]という名称になっていました

 

画像サイズを調整するオブジェクトスタイルを作成しておくと、複数の画像を一気にグラフィックフレームに合うサイズに調整でき便利です。新規でオブジェクトスタイルを作成したら、[基本属性]の[フレーム調整オプション]を設定しておきます。あとは、複数の画像を選択して、このオブジェクトスタイルを適用すればOKです。なお、[フレーム調整オプション]以外の[基本属性]は、すべてオフにしておくとよいでしょう

 

画像を切り抜き使用する

InDesignでは、さまざまな方法で画像を切り抜き使用することが可能です。旧来のワークフローでは、クリッピングパスを設定した画像を配置することで切り抜きを実現していましたが、InDesignではアルファチャンネルやPhotoshopパスを利用しての切り抜きや、背景を透明にするなどした画像を使用することでも切り抜きと同等の効果を得ることができます。用途や目的に応じて、切り抜き方法を使い分けると効率的な切り抜き作業が実現できます。

画像のクリッピングパスを利用した切り抜き

Photoshop上でクリッピングパスを設定した画像は、切り抜かれた状態でInDesignドキュメントに配置できます

 

Photoshop上でPhotoshopパスを設定した画像は、InDesignドキュメントに画像を配置後、[クリッピングパス]ダイアログで[タイプ]に[Photoshopパス]、[パス]に目的のパスを指定することで切り抜き処理ができます。クリッピングパスを設定した場合と違い、複数のパスを切り替えて使用することも可能です

 

画像のアルファチャンネルを利用した切り抜き

Photoshop上でアルファチャンネルが設定されている画像は、InDesignドキュメントに画像を配置時する際に、オプションダイアログでアルファチャンネルを指定して読み込みます。アルファチャンネルを基に切り抜かれた状態で配置できます

 

背景を透明にした画像を使用する

Photoshop上で透明機能を使用した画像は、透明を保持したままInDesignドキュメントに配置することができます

元画像の編集とリンクの更新

InDesignドキュメント上に配置されたリンク画像を修正する場合、PhotoshopやIllustratorで目的の画像を直接開いてもかまいませんが、InDesign上から開く指示を行うことが可能です。この場合、PhotoshopやIllustratorで編集を終えてドキュメントを保存すれば、その修正は即座にInDesignに反映されます。

PhotoshopやIllustratorで直接、編集を行った場合には、InDesignドキュメント上の画像や[リンク]パネルに、リンク画像に変更が加えられたことをあらわすアイコンが表示されます。目的に応じてリンクを更新します。
 

リンクされた画像の管理は[リンク]パネルから行います。画像の情報の確認や、リンクの更新など、リンク画像に関するさまざまな操作をこのパネルから実行します

 

InDesignドキュメント上で編集したい画像を選択して、[リンク]パネルから[元データを編集]を実行すれば、PhotoshopやIllustratorでその画像が開かれ、編集可能になります。編集を終えて保存すれば、その修正は即座にInDesignに反映されます。なお、InDesignドキュメント上で、option(Windowsはalt)キーを押しながら画像をダブルクリックすることでも、同様の動作が可能です

 

PhotoshopやIllustratorで画像に変更が加えられていると、InDesignドキュメント上の画像や[リンク]パネルには、図のような警告アイコンが表示されます。画像左上のアイコンを直接クリックするか、画像を選択して[リンク]パネルの[リンクを更新]ボタンをクリックすれば、画像が最新の状態に更新されます

 

ライブキャプション

画像の持つメタデータからキャプションを自動的に作成してくれる機能がライブキャプションです。複数の画像に対して、指定した位置、指定した段落スタイルを適用した状態でキャプションを作成してくれるため、手作業で行うより大幅に作業時間を短縮できます。

ライブキャプションの作成方法

1. まず、どのようなキャプションを作成するかを設定します。[リンク]パネルのパネルメニューから[キャプション]→[キャプション設定]を選択します。

2.[キャプション設定]ダイアログが表示されるので、各項目を設定します。[メタデータ]には、キャプションとして使用する画像のメタデータを選択し、目的に応じて[先行テキスト]や[後続テキスト]を指定します。また、キャプションを作成する位置や、キャプションに適用する段落スタイルも指定しておきます。設定が終わったら[OK]ボタンをクリックしてダイアログを閉じます。なお、キャプションは画像の上下左右に作成できますが、左右を指定した場合、テキストは寝た状態で作成されるので、日本語環境ではうまく運用できません。

3. キャプションを作成したい画像を選択します。

4. [リンク]パネルのパネルメニューから[キャプション]→[ライブキャプションの作成]を選択します。なお、[キャプション]→[キャプションの作成]を選択しても同様の結果が得られますが、画像のメタデータとリンクを保ったまま運用したい場合は[ライブキャプションの作成]、キャプション作成後はメタデータとリンクしない状態で運用したい場合は[キャプションの作成]を選択します。ここでは、[ライブキャプションの作成]を選択して作業を進めます。

5. 画像に対してキャプションが作成されますが、右下の画像のみ < リンクからのデータなし >
と表示されています。実際の作業では、画像にメタデータが設定されていないケースが多いと思いますが、この機能はメタデータがなくてもキャプションを作成してくれます。あとからテキストのみ配置すれば良いので、さまざまな場面で活用できる機能となっています。

6. では、右下の画像にBride上でメタデータを設定してみましょう。Brideで画像を表示したら、[メタデータ]パネルでメタデータを指定します。

7. InDesignに戻るとリンクの更新を促すアラートが表示されるので、[リンクを更新]を実行します。すると、右下の画像のキャプションが更新されます。

このページは役に立ちましたか。