InDesignには、他のデザインツールにはない表作成機能を備えており、高品質な表組みを簡単に作成、編集できます。ここでは、Microsoft Excelで作成した既存の表を組み込んで、デザイン性の⾼い外観に仕上げる⽅法を紹介します。まずは下の動画で⼀連の制作⼯程を確認しましょう。

難易度2/5


⼿順1/6

ファイルを開いて、テキストフレームを作成する

 

InDesignを起動し、ダウンロードした練習⽤サンプルファイル「table.indd」を開きます。

ツールパネルから「横組み⽂字ツール」を選択し、ページ上の「BOWL」の下のスペースをドラッグして、テキストボックスを作成します。

注意:ファイルを開く際に「環境に無いフォント」ダイアログボックスが表⽰されたら、「源ノ⾓ゴシック JP」の全てのフォントにチェックを⼊れ、「アクティベート」をクリックします。

⼿順2/6

Excelシートを読み込む

 

テキストフレーム内にカーソルをおき、「ファイル」→「配置」をクリックします。

「配置」ダイアログボックスが表⽰されるので、練習⽤サンプルファイル「Tableware_List_vw.xlsx」を選択し、[読み込みオプションを表⽰]にチェックを⼊れて「開く」をクリックします。

 

[Microsoft Excel読み込みオプション]ダイアログが表⽰されるので、各項目を下図のように指定して[OK]ボタンをクリックします。

 

ヒント:

Excelで使⽤されたフォーマットをどのように読み込むかを、フォーマット∕テーブルのドロップダウンから選択します。

[フォーマットテーブル] Excel内で使⽤された形式と同じフォーマットを保持する

[アンフォーマットテーブル] Excel内で使⽤された形式と同じフォーマットを保持しない

[アンフォーマットタブ付きテキスト] タブ区切りのテキストとして読み込む

[1回だけフォーマット] Excelで使⽤されているフォーマットと同じフォーマットを初期読み込み時に保持する

テキストフレーム内にExcelの表が読み込まれます。

⼿順3/6

表内のテキストを編集する

 

読み込まれた表は、Excelで設定したフォーマットが保持されているので、他の表と合わせてフォントを変更します。

⽂字ツールを選択したまま、マウスポインタを表の左上の⾓におき、ポインタの形状が⽮印に変化したらクリックします。表の全てのセルが選択されます。

 

「ウィンドウ」→「書式と表」→「⽂字」から⽂字パネルを表⽰します。

フォントのドロップダウンから「源ノ⾓ゴシック JP∕Regular」を選択して、フォントを変更します。他の表と合わせて、商品名と項目はウェイトを「Bold」にします。

⼿順4/6

セルの境界線を設定する

 

表内の編集は、全て⽂字ツールを使⽤しておこないます。

⼀番左の商品の「サイズ」から「価格」までのセルを選択し、右クリックして「セルの属性」→「罫線と塗り」を選択すると、「セルの属性」ダイアログが表⽰されます。

「セルの線」にはどの線がアクティブになっているかをあらわすプレビューが表⽰されます。⻘い線が現在選択されている線です。線をクリックすることで選択/⾮選択を切り替えられます。ここでは外側の線をすべてクリックして、選択を外します。

「種類」のドロップダウンから「点」を選択し、「OK」をクリックします。

同様の操作で他の3つの商品にも罫線を追加します。

ヒント:

プレビューで境界線を設定する際に、外側の境界線のいずれか1つをダブルクリックすると、外側の境界線すべての選択∕⾮選択の切り替えができます。

⼿順5/6

表内に画像を配置する

 

⾏を追加して、それぞれの商品の写真を配置していきます。商品名の⾏の左端にマウスポインタをおき、ポインタの形状が⽮印に変化したらクリックします。⾏が選択されたら、右クリックして「挿⼊」→「⾏」を選択します。

「⾏を挿⼊」ダイアログが表⽰されるので、⾏数を「1」に設定し、「上」にチェックを⼊れて「OK」をクリックします。

⾏が追加されたら、⾏の左端をクリックして選択します。

「ウィンドウ」→「書式と表」→「表」で表パネルを表⽰して、「⾏の⾼さ」のドロップダウンから「最⼩限度」を選択し、右の数値を「32mm」に設定します。

 

⼿持ちの画像を配置してみましょう。4つの画像ファイルをまとめて選択し、InDesign上にドラッグすると画像が1つに重なります。

追加した⾏のセルの上で左から順番にクリックしていくと、それぞれのセル内に画像が配置されます。

 

マウスポインタを画像の上におくと円が表⽰されるので、それをクリックするとセル内の画像が選択され、拡⼤縮⼩、移動、回転などの操作をおこなえます。

⼿順6/6

⾏と列を⼊れ替える

 

最後に、⾏および列の順番を⼊れ替えてみます。⾏を⼊れ替えるには、⾏を選択し(左端をクリック)、上または下⽅向にドラッグすると⾏と⾏の間に線が表⽰されるので、⼊れ替えたい位置でマウスをはなします。

列を⼊れ替えるには、列を選択し(上端をクリック)、左または右⽅向にドラッグすると列と列の間に線が表⽰されるので、⼊れ替えたい位置でマウスをはなします。

 

列を⼊れ替えるには、列を選択し(上端をクリック)、左または右⽅向にドラッグすると列と列の間に線が表⽰されるので、⼊れ替えたい位置でマウスをはなします。

 

InDesignでは、ゼロから表を作成することも、クライアントなどからもらったExcelの表を読み込むことも可能です。表の編集は、テキストを編集するのと同じ感覚で簡単におこなえますので、ぜひ利⽤してみてください。

このページは役に立ちましたか。