この情報は、米国アドビシステムズ社が提供している情報をもとにローカライズし、作成したものです。

 

 

内容 (What's Covered)

 

この文書では、Adobe Acrobat 3D および UNIX プラットフォームで動作する Adobe Acrobat 3D Capture Utility と、サードパーティ製 3D CAD アプリケーションの設定方法について説明します。

 

A. 3D モデルをキャプチャするための 3D CAD アプリケーションの準備

B. Acrobat 3D Version 8 でサポートする 3D CAD アプリケーション

C. プリセットの復元

D. OpenGL 設定の変更

E. よくある質問

 

 A. 3D モデルをキャプチャするための 3D CAD アプリケーションの準備

 

Adobe Acrobat 3D Version 8 を使用して CAD アプリケーションから 3D モデルのキャプチャを行う場合は、以下の設定および確認を行います。

- 3D CAD アプリケーションが OpenGL に対応していることを確認します。一部の 3D CAD アプリケーションでは OpenGL をサポートしていない場合がありますのでご注意ください。

- キャプチャの品質を向上させるために 3D CAD アプリケーションで設定を調整します。例えば、コンパス、製品ツリー、XYZ 座標など、すべてのページ装飾を 3D モデルから削除します。場合によっては、これらのページ装飾がキャプチャされます。また、バックフェイスカリングを無効にして、無地の背景を使用します。この文書では、一般的な 3D CAD アプリケーションのキー設定を紹介しています。

- Acrobat 3D でサポートされていない(弊社で検証を行っていない)CAD アプリケーションについては、Acrobat 3D ヘルプを参照して設定を行ってください。

 

 注意 1 : 3D CAD アプリケーションのバージョンアップなどにより、この文書に記載されている手順および設定が異なる場合があります。

 注意 2 : 以下のセクションで説明する CAD アプリケーションの表示設定等は、CAD アプリケーションの初期設定に基づいた手順です。

 注意 3 : Adobe Acrobat 3D Version 8 を最新のバージョンにアップデートすることをお勧めします。2008 年 3 月現在の最新のアップデートに関する情報は、下記を参照してください。

 文書番号 233353 Acrobat 3D Version 8 アップデートインストール手順

 

 B. Acrobat 3D Version 8 でサポートする 3D CAD アプリケーション

 

Acrobat 3D Version 8 は、以下の CAD アプリケーションをサポートしています(弊社で検証を行っています)。各アプリケーションのバージョンや OpenGL 設定の詳細情報は、「D. OpenGL 設定の変更」セクションを参照してください。

- AutoCAD

- CATIA V4/4D Navigator

- CATIA V5/DMU

- Deep Exploration

- Inventor

- Solidworks/eDrawing

- I-deas

- Teamcenter VisView/VisMockup

- NX

- Pro/Engineer

- Revit

- Rhino 3D

- Solid Edge

- Project Reviewer

- 3ds Max

- Sketchup

 

この文書で説明するその他の CAD アプリケーションも、Acrobat 3D によりキャプチャ候補として認識されます。アプリケーションのキャプチャ設定はあらかじめ定義されていますが、キャプチャ結果を保証するものではありません。

 

 C. プリセットの復元

 

以前に Acrobat 3D 7.0x で 3D モデルのキャプチャを行っていた場合、Acrobat 3D Version 8 で新しいキャプチャ設定を使用するために、旧バージョンで使用したキャプチャ設定を取り除くこともできます。

 

以下の操作を行います。

  1. Acrobat 3D を起動します。
  2. [編集] メニューから [環境設定] を選択します。
  3. [環境設定] ダイアログボックス左側の [分類] リストから [3D Capture] を選択します。
  4. [3D Capture プリセット] セクションのリストから CAD アプリケーションを選択します。
  5. [プリセットを削除] ボタンをクリックします。



     注意 : [プリセットを削除] ボタンをクリックすると、CAD アプリケーションのキャプチャ設定が削除されます。
  6. [OK] をクリックします。
  7. 3D CAD アプリケーションを起動します。
  8. Acrobat 3D で [ファイル] メニューまたはツールバーの [PDF の作成] から [3D Capture] を選択します。
  9. 「<CAD アプリケーション名>は、Acrobat 3D によってキャプチャ可能な CAD アプリケーションとして認識されています。」と表示された場合は [OK] をクリックし、CAD アプリケーションを再起動します。
  10. Acrobat 3D で [設定] ボタンをクリックし、必要に応じてプリセットの設定を変更して [OK] をクリックします。

 

 D. OpenGL 設定の変更

 

Windows で 3D モデルをキャプチャすると、Acrobat 3D は検証されたアプリケーション用の正しい設定でプリセットを作成します。弊社で検証されていない CAD アプリケーションから 3D モデルのキャプチャを行う際に、OpenGL のキャプチャ設定を変更しなければならない場合があります。OpenGL の設定を変更するには、キャプチャ前に表示される [設定] ボタンをクリックして [3D Capture 設定] ダイアログボックスで [OpenGL] タブを選択するか、Acrobat 3D の [3D Capture] 環境設定で [設定を編集] ボタンをクリックします。

同様に、UNIX プラットフォームで 3D モデルのキャプチャを行う際にも、OpenGL キャプチャ設定を変更しなければならない場合があります。キャプチャ設定を変更するには、Acrobat 3D Capture Utility で [ツール] メニューから [オプション] を選択し、CAD アプリケーションを選択して [設定を編集] ボタンをクリックします。

 

CAD アプリケーションで設定の確認、変更を行うには以下の操作を行います。

 

3ds Max/VIZ

  1. [カスタマイズ] メニューから [基本設定] を選択します。
  2. [ビューポート] タブをクリックします。
  3. ディスプレイドライバ下部の [ドライバを選択] をクリックします。
  4. [OpenGL] を選択し、[OK] をクリックします。
  5. 3ds Max を再起動します。

 

 オリジナルの方向やサイズは保持されません。計測は正しく行われない場合があります。

 

※ キャプチャを行う前に、あらかじめフルスクリーンモードにする必要があります。

  1. Print Screen キーを押します。
  2. 3D キャプチャが開始されたことを知らせる警告音の後に、3ds Max のウインドウでモデルを回転するなどして画面をリフレッシュします。



     注意 : ウインドウサイズ変更などの操作でキャプチャを終了することができます。

 

3ds Max 9

  1. 以下の a. ~ f. の操作を行い、OpenGL ディスプレイを有効にします。
  • [カスタマイズ] メニューから [基本設定] をクリックします。
  • [ビューポート] タブをクリックします。
  • [ドライバを選択] をクリックします。
  • [Direct3Dを元に戻す] をクリックします。
  • [OpenGL] を選択して [OK] をクリックします。
  • 3ds Max を再起動します。
  1. キャプチャを行う前に、フルスクリーンモードに切り替えてビューポートを最大化します。
  2. Print Screen キーを押します。
  3. 3D キャプチャが開始されたことを知らせる警告音の後に、3ds Max のウインドウでモデルを回転するなどして画面をリフレッシュします。



     注意 : ウインドウサイズ変更などの操作でキャプチャを終了することができます。

 

 : オリジナルの方向やサイズは保持されません。計測は正しく行われない場合があります。

 

64 bit 版 OS では、以下の操作を行います。

  1. 「A3D_CAPT_AUTOCAPTURE」ユーザ環境変数を 1 に設定します。
  2. 3ds Max を再起動します。
  3. Acrobat 3D を起動します。
  4. [ファイル] メニューから [PDF の作成] - [3D Capture] を選択します。
  5. 3ds Max のウインドウを選択し、画面をリフレッシュします。



     注意 : ウインドウサイズ変更などの操作でキャプチャを終了することができます。

 

4DNAV

設定は必要ありません。

 

ABAQUS/CAE

設定は必要ありません。

 

ARCHITREND Z 2.1(ビルド 12005 以降)

重要 : 管理者権限のないユーザアカウントで ARCHITREND Z を起動してください。管理者権限のあるユーザアカウントで ARCHITREND Z を実行することによりキャプチャ機能が無効となり、3D Capture が動作しないことを示すメッセージが表示されます。詳細については、文書番号 232348 Acrobat 3D Version 8 と ARCHITREND Z が同時に起動しているとキャプチャに失敗するを参照してください。

  1. ARCHITREND Z を起動します。
  2. [設定] メニューから [基本設定] を選択します。
  3. [3D レンダリングエンジン] をクリックします。
  4. [ソフトウェアの選択をオフにする] を選択します。

 

AutoCAD/AutoCAD Mechanical

  1. [ツール] メニューから [オプション] を選択します。
  2. [システム] タブを選択します。
  3. [現在の 3D グラフィック表示] の下の [プロパティ] をクリックします。
  4. [アクセラレーション] の下の [ハードウェアのアクセラレーション] をクリックします。
  5. [ドライバの選択] の下から [wopengl8.hdi] を選択します。
  6. [適用して閉じる] をクリックし、[OK] をクリックします。

 

AutoCAD 2005

  1. [ツール] メニューから [オプション] を選択します。
  2. [システム] タブを選択します。
  3. [現在の 3D グラフィック表示] の下の [プロパティ] をクリックします。
  4. [アクセラレーション] の下の [ハードウェアのアクセラレーション] をクリックします。
  5. [ドライバの選択] の下から [wopengl8.hdi] を選択します。
  6. [適用して閉じる] をクリックし、[OK] をクリックします。

Acrobat 3D で 3D モデルの最適な方向、位置を得るために、キャプチャを行う前に AutoCAD でトップビューに切り替える必要があります。

 

AutoCAD 2007

以下の操作を実行します。

  1. 以下の a. ~ e. の操作を行い、OpenGL ディスプレイを有効にします。
  • [ツール] メニューから [オプション] を選択します。
  • [システム] タブを選択します。
  • [パフォーマンスの設定] を選択します。
  • [ハードウェアアクセラレーションを有効にする] を選択します。
  • AutoCad 2007 を再起動します。
  1. キャプチャを行う前に、リアリ スティック表示に切り替えます。
  2. Print Screen キーを押します。
  3. トップビューに切り替えます。

 

AutoStudio

設定は必要ありません。

※ Alias AutoStudio モデルを Windows でキャプチャする場合には、Acrobat 3D は正しい設定でプリセットを作成します。UNIX のプラットフォームでキャプチャする場合には、[3D キャプチャ設定] ダイアログボックスの [OpenGL] パネルで設定を変更する必要があるかもしれません。フレームバッファモードに「スワップバッファイベント」 を選択し、「表示の変換モード」は「最後のマトリクス」を選択します。

 

CATIA V4

設定は必要ありません。

 

CATIA V5

  1. [ツール] メニューから [オプション] - [全般] - [表示] を選択します。
  2. パフォーマンス下が以下の設定になっていることを確認してください。

    - Occlusion Culling Enabled : [Off]

    - Transparency Quality : [High]

    - Enable Back Face Culling For Faces And Surfaces Only : [Off]

    - Enable OpenGL Local Viewer Lighting : [On]
  3. [視覚化] のチェックをはずし、Z-Buffer 深度を使用してすべてのエレメントを表示します。

 

CATIA 5 でシステムの True Type フォントの使用を無効にすると、PMI テキストのキャプチャで最良の結果を得ることができます。

以下の操作を行います。

  1. [ツール] メニューから [オプション] - [全般] - [表示] を選択します。
  2. [Thickness & Font] タブを選択します。
  3. [CATIA でシステムの TrueType フォントを使用する] の選択を解除します。

 

モデル内で使用されているフォントを変更するには、以下の操作を行います。

  1. 変更するフォントで表示されるテキストを選択します。
  2. 右クリックし、[プロパティ] を選択します。
  3. [フォント] タブを選択します。

 

CATIA V5 r16/r17

  1. [ツール] メニューから [オプション] - [全般] - [表示] を選択します。
  2. パフォーマンス下が以下の設定になっていることを確認してください。

    - [Occlusion Culling Enabled] セクションの [Occlusion Culling Enabled] の選択を解除します。

    - [Transparency Quality] セクションで [High](アルファブレンド)を選択します。

    - [Enable Back Face Culling] セクションで [Standalone Faces] の選択を解除します。

    - [Enable Back Face Culling] セクションで [Faces Belonging To Solids] の選択を解除します。
  3. [深度] セクションで [視覚化] のチェックをはずし、[Z-Buffer 深度を使用してすべてのエレメントを表示] をします。

 

システム TrueType フォントを使用するために CATIVA 5 オプションを変更するには、以下の操作を行います。

  1. [ツール] メニューから [オプション] - [全般] - [表示] を選択します。
  2. [Thickness & Font] タブを選択します。
  3. [CATIA でシステムの TrueType フォントを使用する] の選択を解除します。

 

モデル内で使用されているフォントを変更するには、以下の操作を行います。

  1. 変更するフォントで表示されるテキストを選択します。
  2. 右クリックし、[プロパティ] を選択します。
  3. [フォント] タブを選択します。

 

Deep Exploration

Right Hemisphere 社 Deep Exploration のバージョン 4.0 以前を使用している場合、グラフィックモードを [OpenGL ハードウェア T&L] に設定する必要があります。

グラフィックモードの設定を変更するには、[表示] メニューから [グラフィックモード] - [OpenGL ハードウェア T&L] を選択します。

 

DWF Viewer 6.5

設定は必要ありません。

 

 注意 : キャプチャは、透明オブジェクトがない場合にのみ動作します。

 

Gocad

設定は必要ありません。

 

I-deas

  1. [オプション] メニューから [環境設定] - [表示] を選択します。
  2. 以下の項目の選択を解除します。

    - Viewport Triad

    - Viewport Outline

    - Viewport Label

    - Origin display

    - [Enable Display Reduction] の選択を解除します。

    - [Save Graphic Levels Of Detail Per Entity] の選択を解除します。
  3. [Display Off Screen Entities] を選択します。

 

I-deas 11/12

  1. [ビューコマンド] ウインドウで、表示設定を変更します。



     注意 : [ビューコマンド] ウインドウは、画面下の角に位置し、9 つのアイコンで構成されています。
  • [シェード表示] ボタンをクリックします。
  • [オプション] を選択し、[Shaded-Hardware(ハードウェア シェード)] を選択して [Auto-Display(自動表示)] の選択を解除します。
  • [適用] をクリックします。
  1. [ビューポート] ボタンをクリックし、[One Viewport] を選択します。

    ※ [ビューコマンド] ウインドウ左下の [Front View] ボタンをクリックすると、Acrobat 3D でトップ、フロント、レフトを一致させることができます。

 

ICEM Surf

設定は必要ありません。オリジナルの方向やサイズは保持されません。計測は正しく行われない場合があります。最新の ICEM Surf グラフィックでもカラーの問題が発生する可能性があります。

 

 注意 : [Acrobat 3D キャプチャ設定] ダイアログボックスで [表示の変換モード] セクションの [マトリクスなし] ではなく [最初のマトリクス] を選択することで、オリジナル方向やサイズが保持される場合があります。ただし、この設定を行うことで、3D モデルの配列が誤って生成される場合があります。

 

Inventor

  1. [ツール] メニューから [アプリケーションオプション] を選択します。
  2. [全般] タブをクリックして、[3D インジケータを表示] の選択を解除します。
  3. [表示] タブをクリックします。
  4. [Shaded Display Modes] の [アクティブエッジの表示] の選択を解除します。
  5. [画質] で [スムース] を選択します。

 

Inventor 10

  1. [ツール] メニューから [アプリケーションオプション] を選択します。
  2. [表示] タブをクリックします。
  3. [画質] で [スムース] を選択し、[OK] をクリックします。

 

Inventor 11/Inventor 2008

  1. [ツール] メニューから [アプリケーションオプション] を選択します。
  2. [表示] タブを選択します。
  3. [画質] で [スムース] を選択し、[OK] をクリックします。
  4. [ハードウェア] タブをクリックし、[ハードウェアドライバの種類] で [OpenGL] を選択します。
  5. Inventor を再起動します。

 

JT2Go v6

  1. 3D モデルが表示されるウインドウを右クリックして [プロパティ] - [(1) Part Investigation] を選択します。
  2. 再度ウインドウ上で右クリックして [パフォーマンス] - [編集] を選択します。
  3. [グローバル設定] タブを選択します。
  4. [OpenGL ディスプレイリストを使用] のチェックをはずします。
  5. [OK] をクリックします。

 

Maya

設定は必要ありません。

 

 : オリジナルの方向やサイズは保持されません。計測は正しく行われない場合があります。

 

Mechanical Desktop

Autodesk Mechanical Desktop では、OpenGL を使用する構成に設定する必要があります。

 

MicroStation

  1. [設定] メニューから [レンダリング] - [属性を表示] を選択します。
  2. [グラフィックスのアクセラレーション] を選択します。
  3. [表示] で [Phong] を選択します。
  4. [すべて] を選択します。

 

 : オリジナルの方向やサイズは保持されません。計測は正しく行われない場合があります。

 

Multiphysics

設定は必要ありません。

 

NavisWorks Jetstream v5

  1. [ツール] メニューから [グローバルオプション] をクリックします。
  2. 3D Capture を実行する前に [フレームレートを保証する] の選択を解除します。



     注意 : [Guarantee Frame Rate(フレームレートを保証する)] オプションを無効にすることによって、大きなモデルのレンダリングで最適なパフォーマンスを維持します。モデルサイズが非常に大きい場合、Acrobat 3D でキャプチャに失敗したことを示すメッセージが表示されます。これは、Acrobat 3D でキャプチャを実行するためのメモリが不足している場合に表示されます。いくつかのパーツを非表示にするなどの操作を行い、再度キャプチャを行います。

 

Nx3

設定は必要ありません。

 

PAM-CRASH

設定は必要ありません。

 

Pro/Desktop

設定は必要ありません。

 

Pro/ENGINEER

  1. [表示] メニューから [モデルツリー] の選択をはずすと、モデルツリーがキャプチャされなくなります。
  2. [表示] メニューから [表示設定] - [データ表示] を選択し、すべての設定の選択を解除します。
  3. [表示] メニューから [表示設定] - [システムカラー] を選択し、[ブレンドされた背景] の選択を解除します。



     : オリジナルの方向やサイズは保持されません。計測は正しく行われない場合があります。

 

Pro/ENGINEER wildfire 3

設定は必要ありません。

 

 : オリジナルの方向やサイズは保持されません。計測は正しく行われない場合があります。

  重要 : Acrobat 3D 7.0x を以前にインストールし、キャプチャを行っていた場合は Acrobat 3D Version 8 の環境設定からキャプチャプリセットを削除し、再度追加する必要があります。手順の詳細については、C. プリセットの復元を参照してください。

 

Project Reviewer

  1. [ツール] メニューから [fly mode] - [activate-deactivate] を選択します。
  2. Print Screen を押してキャプチャを実行します。
  3. Acrobat 3D でキャプチャ終了後、[Project Reviewer] の [3D] セクションで右クリックし、メニューから [end fly] を選択します。

 

  重要 : Acrobat 3D 7.0x を以前にインストールし、キャプチャを行っていた場合は Acrobat 3D Version 8 の環境設定からキャプチャプリセットを削除し、再度追加する必要があります。手順の詳細については、C. プリセットの復元を参照してください。

 

Revit 5.1

設定は必要ありません。

 

Revit Building 9/Revit structure 3

  1. [設定] メニューから [オプション] をクリックします。
  2. [グラフィック] タブをクリックします。
  3. [OpenGL ハードウェアアクセラレーションを使用する] を選択します。
  4. Revit を終了し再起動します。

 

キャプチャを実行する前に、以下の操作を行い Revit で [3D ビュー] のセクションボックスオプションが有効になっていることを確認します。

  1. [表示] メニューから [プロパティの表示] を選択します。
  2. [インスタンスパラメータ] セクション内の [範囲] で、[セクションボックス] を選択します。
  3. [Revit グローバル] ウインドウで、[Revit 3D] ウインドウが最大化されていることを確認します。

 

Rhino3D(バージョン 1.0、2.0 および 3.0)

  1. [ツール] メニューから [オプション] を選択します。
  2. [Rhino オプション] メニューから [表示] を選択します。
  3. [ワイヤーフレームのビューポートオプション] で [ワイヤーフレームビューポートの表示] を [OpenGL] に指定します。
  4. [レンダリングするビューポートのオプション] で、すべてのオプションの選択をはずします。
  5. [ドキュメントのプロパティ] から [グリッド] を選択し、グリッドを選択します。
  6. [グリッドのプロパティ] のすべてのオプションの選択をはずします。

 

 Rhino の表示モードには以下の制限があります。

- DOT エンティティはキャプチャされません。

- Text エンティティはキャプチャされません。 (Rhino TextObject エンティティはキャプチャされます。).

- Bump マッピング情報はキャプチャされません。

- 環境マッピングは、静的テクスチャマップとしてキャプチャされます。

- ワイヤフレームラインとエッジはキャプチャされますが、方位は正しくありません。

- 分析モード用で Phino 分析の結果は、表面上の補間色が正しくキャプチャされずに表示されます。(グラデーションの最初の色に設定されます。)

 

eM-Workplace(旧 ROBCAD)

  1. [表示] を選択します。
  2. [表示方法] を選択します。
  3. [グラフィックウィンドウを開く] をクリックします。
  4. [初期設定] をクリックします。

 

 : オリジナルの方向やサイズは保持されません。計測は正しく行われない場合があります。

 

Rockware

設定は必要ありません。

 

  重要 : Acrobat 3D 7.0x を以前にインストールし、Rockware のキャプチャを行っていた場合は、Acrobat 3D Version 8 の環境設定からキャプチャプリセットを削除し、再度追加する必要があります。手順の詳細については、C. プリセットの復元を参照してください。

 

Solid Edge

  1. [ツール] メニューから [オプション] を選択します。
  2. [表示] タブをクリックします。
  3. [アプリケーションの表示] リストから、「搭載しているグラフィックカード」または「保存に戻る」を選択します。
  4. [Culling(選別)] の選択をはずします。
  5. [OK] をクリックします。

 

SolidWorks(バージョン 2007 以前)

設定は必要ありません。

 

  重要 : SolodWorks でキャプチャを行うために Print Screen キーを押したあとは、キャプチャ処理が終了するまで別のウインドウを手前に表示させないようにします。Acrobat 3D のウインドウで表示することができるように、SolidWorks のウインドウを縮小します。SolidWorks でキャプチャが終了すると、Acrobat 3D のウインドウにキャプチャされた 3D モデルが表示されます。

 

Unigraphics

  1. [環境設定] - [視覚化する] を選択します。
  2. [背景を編集する] をクリックします。
  3. [Plain (平板化)] をすべての設定に選択します。
  4. [適用] をクリックして [OK] をクリックします。

 

VisView/VisMockup

  1. [表示] - [環境設定] を選択します。
  2. [全般] パネルから [Backface Culling] の選択をはずします。
  3. [適用] をクリックして、[OK] をクリックします。
  4. [表示] メニューから [パフォーマンス] を選択します。
  5. [Part Investigation] を選択します。

 

 注意 : メニュー項目は、ファイルが読み込まれた場合にのみアクセスすることができます。

 

 E. よくある質問

 

質問 : CAD アプリケーションからキャプチャを実行するために Acrobat 3D の 3D Capture を有効にしてから、CAD アプリケーションでのファイル読み込み時、またはディスプレイのリフレッシュ時にパフォーマンスが著しく低下します。

回答 : CAD アプリケーションのパフォーマンスを向上させるには、以下の操作を行います。

  1. Acrobat 3D を起動します。
  2. [編集] メニューから [環境設定] を選択します。
  3. [分類] リストから [3D Capture] を選択します。
  4. [3D Capture プリセット] セクションで CAD アプリケーションを選択して [設定を編集] ボタンをクリックします。
  5. [このアプリケーションに対して 3D Capture を有効にする] からチェックをはずします。
  6. CAD アプリケーションを再起動します。

 

  重要 : キャプチャを行う際に Acrobat 3D で 3D Capture を有効にし、キャプチャ終了後に再度無効にすることによって CAD アプリケーションのパフォーマンス低下を防ぐことができます。3D Capture を有効、または無効に設定した場合は、CAD アプリケーションの再起動が必要となります。

 

質問 : CAD アプリケーションのアップグレード後に 3D Capture が動作しません。

回答 : Acrobat 3D の 3D Capture エンジンは CAD アプリケーションの各バージョンに対して個別の設定を持っており、CAD アプリケーションの各バージョンがそれぞれ個別のアプリケーションとして認識されます。以前に 3D Capture を有効にした CAD アプリケーションをアップグレードする場合は、新しいバージョン用に 3D Capture を有効にするための操作を行う必要があります。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー