このチュートリアルでは、Adobe Photoshop を使用して、複数の画像からストップモーションアニメーションを作成する方法を紹介します。フレームの順番を入れ替えることで、アニメーションが往復でループするようになります。

難易度2/5


 

本チュートリアル内で使⽤する主な機能

ファイルをレイヤーとして読み込み、タイムライン、レイヤーからフレームを作成、フレームを入れ替え、Web 用に保存(従来)

 

以下が大まかな流れです。 

 

1. フレームを作成

複数の画像をレイヤーとして読み込み、フレームを作成します。

2. フレームを複製して反転

アニメーションをループさせるためにフレームを複製し、順番を逆にします。

3. フレームを調整

アニメーションを見やすくするために最初のフレームのディレイを設定します。

4. アニメーションをレンダリング

作成したループアニメーションを GIF 形式で書き出します。

 

フレームを作成

手順 1/2
練習用ファイルを開く

Photoshop を起動し、「ファイル」-「スクリプト」-「ファイルをレイヤーとして読み込み...」を選択して、「レイヤーを読み込む」ダイアログボックスが開きます。 

 

「参照...」から練習用サンプルファイルをすべて選択して「OK」で開きます。 

 

画像ごとに個別のレイヤーとして読み込まれました。 

 

手順 2/2
フレームを作成

メニューバーの「ウィンドウ」-「タイムライン」を選択して、タイムラインパネルを表示します。

 

タイムラインのパネルメニューから「レイヤーからフレームを作成」を選択します。

レイヤーごとにフレームが作成されました。 

 

Hint

タイムラインパネルは、「ウィンドウ」-「ワークスペース」-「モーション」を選択し、「モーション」ワークスペースに切り替えて表示させることもできます。 

フレームを複製して反転

手順 1/2
フレームを複製

1 フレームから 11 フレームまでを Shift キー+クリックですべて選択し、タイムライン下部の「+」アイコンをクリックします。 

 

選択したフレームが複製されました。 

 

手順 2/2
フレームを入れ替え

アニメーションを往復でループさせるために、複製したフレームの順番を反転させます。

タイムラインのパネルメニューから「フレームを入れ替え」を選択します。

 

複製したフレームの順番が反転しました。 

フレームを調整

手順 1/2
アニメーションをプレビュー

スペースキーでアニメーションを再生し、プレビューします。

スペースキーで再生を停止します。 

 

Hint
Photoshop ではトゥイーンという機能を利用し、中間フレームを自動的に作成することもできます。この機能を利用すると、開始フレームと終了フレームのみでアニメーションを作成することができます。 

 

手順 2/2
ディレイを設定

1 フレームのメニューからディレイを「0.5」に設定します。

開始フレームで 0.5 秒間一時停止するようになりました。 

アニメーションをレンダリング

手順 1/1
アニメーションをレンダリング

作成したアニメーションを GIF 形式で書き出します。

メニューバーの「ファイル」-「書き出し」-「Web 用に保存(従来)...」を選択します。 

 

ダイアログボックスが開きました。

各メニューを以下のように設定し、「完了」をクリックして無限ループするアニメーションを書き出します。

 

最適化ファイル形式:「GIF」

ループオプション:「無限」 

 

以上で今回のチュートリアルは終了です。 

 

 

今回の例では、あらかじめ用意された画像を読み込んで無限ループのフレームアニメーションを作成しました。カメラを定点に構え、料理ができあがる様子やイラストを描き上げる様子などを一定の間隔で撮影しておけば、今回紹介した方法で簡単に無限ループのアニメーションを作成することができます。誰でも簡単にフレームアニメーションが作成できますので、ぜひお試しください。 

このページは役に立ちましたか。