Issue (問題点)

 

作成した画像の背景を透明にすると、Webページなどの前面に、ドキュメントサイズを示す四角形以外のグラフィックオブジェクトを配置できます。ここでは、Webでの作業を目的に、画像の背景を透明にするいくつかの方法をご紹介します。(DTP作業向けの方法としては、下記「Related Records」の「文書番号 211777 Photoshop:クリッピングパスの作成」をご参照ください。)

背景が透明になっている場合、下記のようにグレーと白の格子状の模様が表示されています。

 

 

 

Solutions (解決方法)

 

画像の作成方法は、A ~ D いずれかの操作方法を実行してください。

 A. あらかじめ、背景が透明の画像を作成します。

  1. [ファイル] メニューから [新規] を選択します。

  2. [新規] ダイアログボックスの「内容」で、[透明] にチェックを入れます。

  3. 画像を作成します。

 

 B. レイヤーが「背景」になっている場合、「レイヤー 0」に変更します。

  1. [レイヤー] パレットで「背景」を選択します。

    名前が書いてある部分が反転します。

  2. 「背景」と書いてある部分をダブルクリックします。

    [新規レイヤー] ダイアログボックスが開きます。

  3. [レイヤー名] を「レイヤー0」にします。

  4. ダイアログボックスを閉じます。

  5. 「レイヤー0」上で、以下のいずれかの操作を実行します。

    - 「レイヤー0」上に画像がある場合は、その画像を選択し、[選択範囲] メニューから [選択範囲を反転] を選択します。

    - 「レイヤー0」上に画像がない場合は、[矩形選択ツール] で「レイヤー0」上のすべてを選択します ([選択範囲] メニューから [すべてを選択] )。

  6. Delete キーを押します。  

 

 C. 白または背景色で作成した画像の背景を [マジック消しゴムツール] で消します。[マジック消しゴムツール] は、レイヤー上で、自動的にすべての隣接する近似ピクセルを透明に変更します。

1. ツールボックスの消しゴムのところから、[マジック消しゴムツール] を選択します。

2. 目的に応じて、[ツールバー] のオプションを選択します。詳細は、オンラインヘルプをご覧ください。

3. 透明にしたい部分をクリック (Macintosh の場合) または左クリック (Windows の場合) します。

 

 D. 白または背景色で作成した画像の背景を [背景消しゴムツール] で消します。[背景消しゴムツール] は、レイヤー上でドラッグした部分のピクセルを透明にすることができます。

1. ツールボックスの消しゴムのところから、[マジック消しゴムツール] を選択します。

2. 目的に合わせ、[ツールバー] のオプションを選択します。詳細は、オンラインヘルプをご覧ください。

3. 透明にしたい部分をドラッグします。

 

画像を保存する場合は、透明機能をサポートしている GIF 形式、または PNG 形式で保存します。保存方法は、A 、B いずれかの操作方法を実行してください。

 

 A. [保存] または [別名で保存] を使用します。

1. [ファイル] メニューから [保存] または [別名保存] を選択します。

2. ファイル形式で「CompuServe GIF」または「PNG」を選択します。

「CompuServe GIF」を選択した場合には、[インデックスカラー] ダイアログボックス内で [透明] チェックボックスがオンになっていることを確認します。

 

 B. [Web 用に保存] を使用します。

1. [ファイル] メニューから [Web用に保存] を選択します。

2. 設定の部分でファイル形式などを、[保存オプション] で必要に応じたオプションを選択します。

3. [OK] ボタンをクリックします。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー