注意:

Creative Cloud で Photoshop をご利用の場合は、こちらを参照してください。

この文書では、Adobe Photoshop CS を使用して画像の背景を透明にするさまざまな方法を説明します。

背景を透明にすると、透明部分は以下の画像のように白とグレーの格子状の模様が表示されます。透明を含む画像は Web や DTP などでも多く利用されております。

背景を透明にするには、以下の A. ~ E. のいずれかまたは複数を行います。

透明を保持したまま保存できる Web 用のファイル形式については F. を、透明を保持したまま保存できるファイル形式については G. をご覧ください。

A. 新規ファイル作成時に背景を透明にする

新規ファイルを作成するときに、予め背景を透明に設定することができます。

操作手順は、以下のとおりです。

  1. [ファイル] メニューから [新規] を選択します。
  2. [新規] ダイアログボックスの [カンバスカラー] ポップアップメニューから [透明] を選択します。

  3. [OK] をクリックします。
  4. 背景が透明な画像が新規に作成されます。

B. 背景レイヤーのロックを解除して背景を透明する

背景レイヤーは、ロックされており透明ピクセルを含むことができません。背景を透明にするには、ロックを解除して通常レイヤーに変換する必要があります。

操作手順は、以下のとおりです。

  1. [ウィンドウ] メニューから [レイヤー] を選択し、[レイヤー] パレットを表示します。
  2. [背景] レイヤーをダブルクリックします。

  3. [新規レイヤー] ダイアログボックスでレイヤー名を入力し、[OK] をクリックします。

    背景レイヤーのロックが解除されて通常レイヤーに変換されたため、背景を透明にすることが可能となります。

    例えば、[消しゴムツール] を使用すると背景に透明を表す格子模様が表示されます。操作方法は、以下の C. [消しゴムツール] で背景を透明にする を参照してください。

C. [消しゴムツール] を使用して背景を透明にする

ツールボックスの [消しゴムツール] を使用して背景を透明にすることができます。

操作手順は、以下のとおりです。

  1. 上記の B. 背景レイヤーのロックを解除して背景を透明する を参照し、背景レイヤーを通常レイヤーに変換します。

  2. ツールボックスの [消しゴムツール] を選択します。

  3. 画像をドラッグすると、ドラッグした部分が透明になります。

  4. 消しゴムの大きさを変更するには、画面上 [オプションバー] の左側にある下向き三角をクリックし、マスター直径スライダーをドラッグして調整します。

  5. 間違って消してしまった部分を復元するには、Alt キー(Windows)/Option キー(Macintosh)を押しながらドラッグします。

D. [マジック消しゴムツール] を使用して背景を透明にする

ツールボックスの [マジック消しゴムツール] を使用して背景を透明にすることができます。マジック消しゴムツールは、隣接する同じ色合いの範囲(近似色)を一度にまとめて削除することができます。

操作手順は、以下のとおりです。

  1. ツールボックスの [マジック消しゴムツール] を選択します。

  2. 透明にする部分をクリックすると、クリックした色の近似色が連続して消去されます。

  3. 画像内で、連続しない色の範囲の近似色を消去するには、オプションバーで [隣接] のチェックをはずしてからクリックします。



E. クリッピングパスの作成

Photoshop で作成したクリッピングパスを含む画像を Adobe Illustrator や Adobe InDesign のようなアプリケーションに配置した際、画像の一部分を透明として扱うことが可能です。

詳しい操作方法は、下記の文書を参照してください。

文書番号 223829 クリッピングパスの作成方法(Photoshop CS)

F. Web 用に背景が透明な画像を保存する

Web で多く利用されている画像のファイル形式は、主に JPEG と GIF です。この 2 つのうち、透明を含むことができるのは、GIF 形式です。

JPEG 形式は透明機能をサポートしておりません。
※ JPEG 2000 のみ例外です。また、PNG 形式も透明機能をサポートしていますが、使用頻度が GIF に比べて低いです。詳細は、G. 透明を保持して保存できるファイル形式 をご覧ください。

Photoshop CS で背景の透明を保持して GIF 形式に保存するには、以下の操作を行います。
- [保存] コマンドを行う場合
- [Web 用に保存] コマンドを行う場合

[保存] コマンドを行う場合:

  1. [ファイル] メニューから [保存] または [別名保存] を選択します。
  2. [ファイル形式] (Win)/[フォーマット](Mac)ポップアップメニューから「CompuServe GIF (*.GIF)」を選択します。

  3. [インデックスカラー] ダイアログボックスで「透明」にチェックを入れて [OK] をクリックします。

[Web 用に保存] コマンドを行う場合:

  1. [ファイル] メニューから [Web 用に保存] を選択します。
  2. [Web 用に保存] ウィンドウの画面右上で、ファイル形式が GIF になっていることを確認し、次に「透明部分」にチェックは入っていることを確認します。

  3. [保存] ボタンをクリックし、保存する場所と名前を指定して [OK] をクリックします。

G. 透明を保持して保存できるファイル形式

Photoshop CS で透明を保持したまま画像を保存するには、以下のファイル形式として保存する必要があります。

作業中は Photoshop 形式で保存しておき、最終段階で目的のファイル形式として保存することをお勧めします。

ファイル形式

説明

Photoshop (*.PSD,*.PDD)

Photoshop のオリジナルファイル形式です。透明機能をはじめ、すべての機能を保持して保存することができます。

CompuServe GIF (*.GIF)

256 色までの色数を使用することが出来て、イラストなどに向いており Web での表示に使用されます。

インターレースやアニメーションもサポートしています。

PNG (*.PXR)

PNG 形式は、GIF に代わるものとして開発された形式です。GIF と同様 Web での表示に適しておりグレースケール画像および RGB 画像の透明部分は保持されます。

TIFF (*.TIF,*.TIFF)

アプリケーション間およびコンピュータプラットフォーム間でのファイル交換に使用されます。Photoshop では注釈、透明部分、複数解像度のピラミッドデータも TIFF 形式に保存できます。

 ほとんどのアプリケーションでは、 TIFF の透明機能をサポートしていないため、Photoshop で保存した TIFF を開くと画像は統合されてしまうためご注意ください。

Photoshop PDF (*.PDF,*.PDP)

Photoshop は、汎用 PDF と Photoshop PDF のどちらも読み込むことができますが、保存できるのは Photoshop PDF のみです。Photoshop PDF では画像を 1 つだけ保存することが可能で、透明機能もサポートしています。

JPEG 2000 (*.JPF,*.JPX,*.JP2,*.J2C,*.JPC)

JPEG 2000 は標準の JPEG(JPG)形式よりも多くのオプションと柔軟性を備えたファイル形式です。JPEG 2000 形式は 16 ビットカラーまたはグレースケールファイル、8 ビット透明部分もサポートしており、アルファチャンネルとスポットチャンネルを維持することができます。

Photoshop CS の初期設定では JPEG 2000 は保存できません。詳細は、文書番号 223284 JPEG 2000 形式で保存できない をご覧ください。

アドビコミュニティフォーラムをご利用下さい

この文章はお役に立てましたでしょうか?さらに情報をお探しになる場合には、アドビスタッフがお届けしている解決事例やメンバー同士での活発な意見交換をチェックできるコミュニティフォーラムをご利用下さい。

本作品は Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License によってライセンス許可を受けています。  Twitter™ および Facebook の投稿には、Creative Commons の規約内容は適用されません。

法律上の注意   |   プライバシーポリシー