問題点

ワークスペースのレポートと A4T レポートのデータを比較すると、相違を確認できます。

環境

Target Standard/Premium および Analytics

原因

Target では、アクティビティはページ URL で定義され、対象となる条件(使用されるオーディエンス)に基づいてアクティビティの対象となります。次に、指標訪問者数/訪問回数のデータが、そのアクティビティに含まれているすべての訪問者についてキャプチャされます。

訪問者がアクティビティの Target 内でどのようにキャプチャされるかについて詳しくは、記事「新規訪問者または再訪問者」を参照してください。

訪問回数は、そのアクティビティの一部としてサイトを訪問する単一の訪問者数です。

Target では、ページを読み込んだ場合およびアクティビティで使用されるオーディエンスに該当する場合、指標としてのデータのみが特定されます。

Analytics では、該当する資格条件と訪問者数/訪問回数のデータが、サイトを訪問したすべての訪問者に対してキャプチャされることはありません。

各ツールで記録されたデータには相違があり、次のドキュメントに記載されているこのバリエーションに対しての理由があります。

  1. 予期されるデータの相違の理解(廃止)
  2. データシステム間の相違で処理する間隔を埋めるパーソナライゼーション

Analytics では、訪問指標は常に期間と関連付けられているので、サイトに同じ訪問者が戻った場合に新規の訪問としてカウントするかどうかを判断できます。セッションはユーザーが最初にサイトにアクセスした時点で始まり、次のシナリオのいずれかで終わります。例えば、訪問者が Web サイトにアクセスしてブラウザーを閉じて 5 分後に再度開くと、同じ訪問として引き続きカウントされます。個別訪問者は、指定した期間内に Web サイトを初めて訪問した訪問者です。

これは、Analytics でセグメントを構築している場合と、そのレポートのインスタンス数をアクティビティのインスタンス数と比較する場合に、セグメントで使用されているディメンション/指標がユーザーによって設定された変数の割り当て/有効期限で機能しているときに Analytics セグメントが現在動作しているため、これらが単純に一致する可能性はないからです。

例えば、1 日で、SiteCatalyst は、その日にサイトに入ったすべての訪問者の個別訪問者を表示します。この訪問者は再カウントされません。

ただし、Target は、成功指標の設定方法に応じて 1 日で複数回、訪問者をカウントすることができます。

レポートデータの相違点の基本的な理由は、ページレベルで Target と Analytics が機能する方法によって異なります。Target は、mbox システム(JavaScript 関数を呼び出す特別なクラスを持つ HTML オブジェクト)を使用します。一方、Analytics は、「Image Request」というトラッキングピクセル経由でプッシュされた、ページ上でリンクされている JavaScript を使用します。mbox メソッドにより、Target は Web ページの特定の部分に簡単に提供できます。また、トラッキングピクセルメソッドにより、Analytics は Adobe のデータ収集レイヤーへのリンクを作成できます。ただし、ここでは主に、Target と Analytics は 2 つの同時処理を使用しますが、訪問者と他の指標を記録するために別々のアクションを使用するという点で、そのデータの比較は推奨されません。

Analytics をレポートソースとして使用する場合に、水増しされた訪問と訪問者カウントの影響を最小限に抑える方法について詳しくは、ドキュメント「A4T での水増しされた訪問と訪問者カウントの最小化」を参照してください。

Analytics と Target の指標および計算に使用されるアルゴリズムといった、これらの大きく異なる定義のため、データの相違が発生します。

解決策

ダッシュボード間のデータは比較されません。

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