Fix missing system user ACLs

You have accidentally deleted system ACLs in AEM and it has broken AEM functionality.

Cause

There can be many causes for this, but the most common are:

  • Accidental removal of permissions by users
  • Installation of ACL package with "Overwrite" value set in AC Handling option of the package

Resolution

To solve this issue, you can do the following:

  1. Install a clean AEM author or publish instance locally and set the -r nosamplecontent option during installation (match the instance type with the instance missing the ACLs).  For example: java -Xmx2048m -jar cq-author-p4502.jar -r nosamplecontent
  2. Go to the AEM package manager http://host:port/crx/packmgr/index.jsp and log in as admin
  3. Download and install ACS Commons
  4. Use ACL Packager to package up all the out-of-the-box ACLs.  When configuring the ACL package, set  "/.*" as the only value in Include Patterns. Then set AC Handling option to Merge.
  5. Go to the package manager and build the ACL package.
  6. Download the package
  7. Once you obtain that hotfix then install it to the broken environment by dropping it in the crx-quickstart/install folder
  8. After the hotfix is fully installed (validate via the error.log) then restart AEM
  9. Then drop the ACL package in the crx-quickstart/install folder on the broken instance
  10. After that package is installed then restart AEM one more time

Now the original out of the box ACLs have been restored.

 Adobe

쉽고 빠르게 지원 받기

신규 사용자이신가요?