일련의 사진과 프레임 애니메이션을 사용하여 애니메이션 GIF를 만드는 방법을 살펴보세요.
산을 배경으로 물가에 바위가 있는 해안선

Photoshop에서 일련의 사진을 반복 재생되는 애니메이션 GIF로 변환하는 방법을 살펴보세요.

이 기법은 DSLR 카메라 또는 모바일 디바이스로 촬영한 일련의 사진을 사용하여 타임랩스 애니메이션을 만드는 데 유용합니다. 이 예제의 경우 iPhone의 연속 촬영 모드로 촬영한 일련의 사진을 사용합니다. 위의 샘플 에셋을 다운로드하여 압축을 풀거나 보유하고 있는 일련의 사진들을 사용하십시오.

팁: 또한 이 기법을 사용하여 짧은 비디오에서 애니메이션 GIF를 만들 수도 있습니다. 1단계(선택 사항)로 스크롤하여 비디오 파일을 사용하는 방법을 살펴보십시오.

일련의 사진 가져오기

Photoshop을 열고 파일 > 스크립트 > 스택으로 파일 불러오기를 선택합니다.

찾아보기를 클릭하고 사용할 사진을 찾습니다. Shift 키를 누른 상태에서 모든 파일을 선택하고 열기를 클릭합니다.

확인을 클릭하여 사진들을 레이어로 구성된 하나의 파일로 가져옵니다.

파일 > 스크립트 > 스택으로 파일 불러오기 선택

작업 영역의 오른쪽에 있는 레이어 패널에 여러 개의 새 레이어가 생성됩니다.

개별 레이어는 애니메이션 GIF의 프레임이 됩니다.

레이어 패널에서 새로운 레이어가 애니메이션의 프레임이 됨

선택 사항: 비디오 가져오기

짧은 비디오를 사용하려면 먼저 해당 비디오의 프레임을 개별 레이어로 변환해야 합니다. 파일 > 가져오기 > 비디오 프레임을 레이어로...를 선택합니다.

사용할 비디오 파일을 검색하여 선택한 다음 열기를 클릭합니다.

확인을 클릭하여 비디오 프레임을 레이어로 구성된 하나의 파일로 변환합니다.

참고: Photoshop에서 너무 긴 비디오는 가져오지 못할 수도 있습니다. 가져오기 창의 옵션을 사용하여 가져올 프레임 수를 제한합니다. 전체 비디오를 가져오거나 비디오의 한 범위만 선택할 수 있습니다. 또한 가져올 프레임 수를 2개 프레임 간격과 같이 일정한 간격으로 제한할 수 있습니다.

파일 > 가져오기 > 비디오 프레임을 레이어로... 선택

타임라인 열기

창 > 타임라인을 선택하여 타임라인 패널을 엽니다.

패널 가운데에 있는 버튼의 화살표를 클릭하고 프레임 애니메이션 만들기를 선택한 다음 이 버튼을 클릭하여 새 프레임 애니메이션을 만듭니다.

창 > 타임라인 선택

애니메이션 프레임으로 레이어 변환

타임라인 패널의 오른쪽 상단에 있는 메뉴 아이콘을 클릭하고 레이어에서 프레임 만들기를 클릭합니다.

그러면 레이어 패널에 있는 모든 레이어가 애니메이션의 개별 프레임으로 변환됩니다.

레이어에서 프레임 만들기 선택

타임라인 패널 하단에 있는 재생 버튼을 클릭하거나 키보드의 스페이스바를 눌러 애니메이션을 미리 봅니다.

참고: 애니메이션이 반대로 재생되면 타임라인의 메뉴 아이콘을 다시 클릭한 다음 프레임 반전을 선택합니다.

타임라인의 메뉴 아이콘 클릭 후 프레임 반전 선택

애니메이션 반복 설정

타임라인 패널 하단에 있는 반복 메뉴를 클릭하고 계속을 선택하면 애니메이션이 계속 반복됩니다.

반복 메뉴에서 계속 선택

타임라인 패널 하단에 있는 재생 버튼을 클릭하거나 키보드의 스페이스바를 눌러 애니메이션을 미리 봅니다.

GIF로 애니메이션 내보내기

파일 > 내보내기 > 웹용으로 저장(레거시)...를 선택합니다.

  1. 사전 설정 메뉴에서 GIF 128 디더를 선택합니다.
  2. 색상 메뉴에서 256을 선택합니다.
  3. 온라인에서 이 GIF를 사용하거나 애니메이션 파일 크기를 줄이려면 이미지 크기 옵션에서 폭과 높이 필드를 변경합니다.
  4. 루핑 옵션 메뉴에서 계속을 선택합니다.

내보내기 창의 왼쪽 하단에 있는 미리 보기... 버튼을 클릭하여 웹 브라우저에서 GIF를 미리 봅니다.

저장...을 클릭하고 애니메이션 GIF 파일의 저장 위치를 선택합니다.

파일 > 내보내기 > 웹용으로 저장(레거시)... 선택

이상입니다. 지금까지 애니메이션 GIF를 만들어 보았습니다. 직접 만든 애니메이션 GIF를 온라인에 게시해 보십시오.

또한 레이어로 구성된 Photoshop 파일이라면 이 기법을 사용할 수 있습니다.

10/03/2020
이 페이지가 도움이 되었습니까?