참고:

모양 도구를 사용하면 단추, 탐색 모음, 웹 페이지에 사용되는 기타 항목을 쉽게 만들 수 있습니다. Photoshop의 모든 그리기 기능에 대한 개요는 그리기 정보를 참조하십시오.

참조 페이지:

illustrator/using에 연결

creative cloud/kb/heading에 연결

mobile apps/how-to에 연결

Photoshop에서 모양 그리기

Photoshop에서 모양 그리기
Julieanne Kost

모양 레이어에 모양 만들기

  1. 모양 도구 또는 [펜 도구]를 선택합니다. 옵션 막대 메뉴에서 모양이 선택되었는지 확인합니다.

  2. 모양의 색상을 선택하려면 옵션 막대에서 색상 견본을 클릭한 다음 [색상 피커]에서 색상을 선택합니다.
  3. (옵션) 옵션 막대에서 도구 옵션을 선택합니다. 모양 단추 옆의 거꾸로 된 화살표를 클릭하면 각 도구의 추가 옵션을 볼 수 있습니다. 모양 도구 옵션을 참조하십시오.

  4. (옵션) 모양에 스타일을 적용하려면 옵션 막대에 있는 [스타일] 팝업 메뉴에서 사전 설정 스타일을 선택합니다. 자세한 내용은 사전 설정 스타일 적용을 참조하십시오.

  5. 다음과 같이 이미지에서 드래그하여 모양을 그립니다.
    • 사각형이나 모서리가 둥근 직사각형은 정사각형으로, 타원은 원으로, 선 각도는 45도의 배수로 제한하려면 Shift 키를 누른 채 드래그합니다.
    • 중심부터 그리려면 모양의 중심이 될 위치에 포인터를 놓고 Alt 키(Windows) 또는 Option 키(Mac OS)를 누른 상태에서 원하는 크기의 모양이 되도록 모퉁이 또는 가장자리까지 대각선 방향으로 드래그합니다.
    모퉁이부터 그리기(왼쪽)와 중심부터 그리기(오른쪽)
    모퉁이부터 그리기(왼쪽)와 중심부터 그리기(오른쪽)

    참고:

    중심부터 그리기는 [별모양 도구](Illustrator)와 [다각형 도구](Illustrator와 Photoshop)의 기본 동작입니다.

비디오 | 만들기, 편집 및 작업

Photoshop 팀 구성원 Jeanne Rubbo가 모양 레이어를 만들고, 편집하고, 작업하는 방법을 정보용 비디오 시리즈로 보여줍니다. 방법 알아보기:

자세한 내용은 그리기 및 입력 도구 갤러리를 참조하십시오.

하나의 레이어에 여러 개의 모양 그리기

하나의 레이어에 여러 개의 모양을 그리거나 [추가], [빼기], [교차] 또는 [제외] 옵션을 사용하여 레이어에 있는 현재 모양을 수정할 수 있습니다.

  1. 모양을 추가할 레이어를 선택합니다.
  2. 그리기 도구를 선택하고 도구별 옵션을 설정합니다. 자세한 내용은 모양 도구 옵션을 참조하십시오.

  3. 옵션 막대에서 다음 중 하나를 선택합니다.

    모양 영역에 추가

    기존 모양이나 패스에 새 영역을 추가합니다.

    모양 영역에서 빼기

    기존 모양이나 패스에서 겹치는 영역을 제거합니다.

    모양 영역 교차

    영역을 기존 모양과 새 영역의 교차 부분 또는 기존 패스와 새 영역의 교차 부분으로 제한합니다.

    모양 영역 겹침 제외

    병합된 새 영역과 기존 영역에서 겹치는 영역을 제외합니다.

  4. 이미지에 모양을 그립니다. 옵션 막대에서 도구 단추를 클릭하여 그리기 도구 간에 쉽게 전환할 수 있습니다.

휠 모양 그리기

기존 모양 내에서 모양을 오려내서 밑에 있는 레이어가 오려낸 곳을 통해 보이게 합니다. 이 절차는 도넛 모양을 만드는 방법이지만 사용자 정의 모양을 비롯하여 모양 도구를 다양한 방식으로 조합하여 새 모양을 만들 때도 이 기법을 그대로 적용할 수 있습니다.

  1. 도구 상자에서 [타원 도구] 를 선택합니다. 이 도구는 다른 모양 도구나 [선 도구] 에 가려져 있을 수도 있습니다.

  2. 옵션 막대 메뉴에서 모양이 선택되었는지 확인합니다.

  3. 문서 창에서 드래그하여 모양을 그립니다. Shift 키를 누른 상태에서 드래그하면 타원이 원으로 제한됩니다.
  4. 옵션 막대에서 [모양 영역에서 빼기] 단추 를 선택합니다.

  5. 새 모양 내에서 드래그하여 오려내기 모양을 만듭니다. 마우스를 놓으면 새 모양 아래에 있는 이미지가 오려낸 영역을 통해 보입니다.
  6. 두 모양 중 한 모양의 위치를 다시 지정하려면 도구 상자에서 [패스 선택 도구] 를 클릭하고 지정할 패스를 선택합니다. [패스 선택 도구]는 [직접 선택 도구] 에 가려져 있을 수 있습니다. 위치를 옮길 모양을 새 위치로 드래그하거나 키보드의 화살표 키를 사용하여 한 번에 한 픽셀씩 이동합니다.

    참고:

    Shift 키를 누른 채 클릭하면 두 개 이상의 패스를 선택할 수 있습니다.

사용자 정의 모양 그리기

[사용자 정의 모양] 팝업 패널의 모양을 사용하여 사용자 정의 모양을 그리거나 사용자 정의 모양으로 사용할 모양 또는 패스를 저장할 수 있습니다.

  1. [사용자 정의 모양] 도구 를 선택합니다. (도구가 표시되지 않을 경우 도구 상자의 아래쪽에 있는 [사각형] 도구를 누른 상태로 있습니다.)

  2. 옵션 막대의 [사용자 정의 모양] 팝업 패널에서 모양을 선택합니다.

    패널에 원하는 모양이 없으면 패널의 오른쪽 위 모퉁이에 있는 화살표를 클릭하여 다른 모양 범주를 선택합니다. 현재 모양을 대체할 것인지 묻는 대화 상자가 나타나면 [확인]을 클릭하여 새 범주에 속한 모양만 표시하거나 [첨부]를 클릭하여 이미 표시된 모양에 추가합니다.

  3. 이미지에서 드래그하여 모양을 그립니다.

사용자 정의 모양으로 모양 또는 패스 저장

  1. [패스] 패널에서 패스(모양 레이어의 벡터 마스크, 작업 패스 또는 저장된 패스 중 하나)를 선택합니다.
  2. [편집] > [사용자 정의 모양 정의]를 선택하고 [모양 이름] 대화 상자에 새 사용자 정의 모양의 이름을 입력합니다. 새 모양이 옵션 막대의 [모양] 팝업 패널에 나타납니다.
  3. 새 사용자 정의 모양을 새 라이브러리의 일부로 저장하려면 팝업 패널 메뉴에서 [모양 저장]을 선택합니다.

자세한 내용은 사전 설정 관리자 사용을 참조하십시오.

래스터화된 모양 만들기

래스터화된 모양을 만들 때는 모양을 그리고 래스터화한 후 전경색으로 모양을 채우는 것입니다. 래스터화된 모양은 벡터 개체로 편집할 수 없습니다. 래스터 모양은 현재 전경색을 사용하여 만들어집니다.

  1. 레이어를 선택합니다. 문자 레이어와 같은 벡터 기반 레이어에는 래스터화된 모양을 만들 수 없습니다.
  2. 모양 도구를 선택하고 옵션 막대에서 [픽셀 칠] 단추 를 클릭합니다.
  3. 옵션 막대에서 다음 옵션을 설정합니다.

    모드

    모양이 기존 이미지 픽셀에 영향을 미치는 방법을 조정합니다. (혼합 모드를 참조하십시오.)

    불투명도

    모양이 밑에 있는 픽셀을 가리거나 나타내는 정도를 지정합니다. 불투명도가 1%인 모양은 거의 투명하게 보이고, 불투명도가 100%인 모양은 완전히 불투명하게 보입니다.

    앤티 앨리어스

    모양의 가장자리 픽셀을 매끄럽게 만들고 주변 픽셀과 혼합합니다.

  4. 도구별 옵션을 추가로 설정합니다. 자세한 내용은 모양 도구 옵션을 참조하십시오.

  5. 모양을 그립니다.

모양 도구 옵션

각 모양 도구는 아래 옵션의 고유한 하위 세트를 제공합니다. 이러한 옵션을 사용하려면 옵션 막대에서 모양 단추 행의 오른쪽에 있는 화살표를 클릭합니다.

옵션 막대에서 모양 도구 옵션에 액세스(선 옵션이 표시되어 있음)
옵션 막대에서 모양 도구 옵션에 액세스(선 옵션이 표시되어 있음)

화살촉의 시작과 끝

선에 화살표를 추가합니다. [선 도구]를 선택한 다음 [시작]을 선택하면 선의 시작 부분에 화살촉이 추가되고 [끝]을 선택하면 선의 끝 부분에 화살촉이 추가됩니다. 두 옵션을 모두 선택하면 양쪽 끝에 모두 화살촉이 추가됩니다. 모양 옵션이 팝업 대화 상자에 나타납니다. [너비]와 [길이]에 값을 입력하여 화살촉의 비율을 선 너비의 백분율로 지정합니다. [너비]에는 10%부터 1000%까지, [길이]에는 10%부터 5000%까지의 값을 입력합니다. 화살촉의 오목한 정도를 나타내는 값(-50%에서 +50까지)을 입력합니다. 오목한 정도를 나타내는 값은 화살촉이 선과 만나는 곳인 화살촉의 가장 넓은 부분의 곡률(굴곡 정도)을 정의합니다.

참고:

벡터 선택 도구와 그리기 도구를 사용하여 화살촉을 직접 편집할 수도 있습니다.

원형

타원을 원으로 제한합니다.

정의된 비율

사용자 정의 모양을 만들어진 비율을 기반으로 렌더링합니다.

정의된 크기

사용자 정의 모양을 만들어진 크기를 기반으로 렌더링합니다.

크기 고정

[너비]와 [높이] 텍스트 상자에 입력한 값을 기반으로 사각형, 모서리가 둥근 직사각형, 타원, 사용자 정의 모양을 고정된 모양으로 렌더링합니다.

중앙부터

사각형, 모서리가 둥근 직사각형, 타원, 사용자 정의 모양을 중앙에서부터 렌더링합니다.

측면 들여쓰기 기준

다각형을 별 모양으로 렌더링합니다. 텍스트 상자에 백분율을 입력하여 별의 반경 중 돌출부가 차지하는 부분을 지정합니다. 50%로 설정하면 별 전체 반경의 절반이 되는 위치에 돌출부를 만듭니다. 이 값이 클수록 뾰족하고 가는 돌출부가 만들어지고 값이 작을수록 부푼 모양의 돌출부가 만들어집니다.

비례

사각형, 모서리가 둥근 직사각형, 타원을 [너비]와 [높이] 텍스트 상자에 입력한 값을 기반으로 너비와 높이 비례가 유지되는 모양으로 렌더링합니다.

반경

모서리가 둥근 직사각형의 경우에는 모퉁이 반경을 지정하고, 다각형의 경우에는 다각형의 중심에서 바깥쪽 점까지의 거리를 지정합니다.

측면

다각형의 변의 개수를 지정합니다.

모퉁이 매끄럽게 또는 가장자리 매끄럽게

다각형을 렌더링할 때 모퉁이나 움푹 팬 곳을 매끄럽게 렌더링합니다.

픽셀에 스냅

사각형이나 모서리가 둥근 직사각형의 가장자리를 픽셀 경계에 스냅합니다.

정사각형

사각형이나 모서리가 둥근 직사각형을 정사각형으로 제한합니다.

제한 없음

사각형, 모서리가 둥근 직사각형, 타원 또는 사용자 정의 모양의 너비와 높이를 드래그하여 설정할 수 있습니다.

두께

선 도구에 대한 너비를 픽셀로 지정합니다.

참고:

다른 모양 도구에 대한 획 너비를 변경하려면 레이어 > 레이어 스타일 > 획을 선택합니다. (사용자 정의 레이어 스타일 적용 또는 편집을 참조하십시오.)

모양 편집

모양은 벡터 마스크에 연결된 칠 레이어입니다. 모양의 칠 레이어를 편집하여 칠을 다른 색상, 그레이디언트 또는 패턴으로 쉽게 변경할 수 있습니다. 모양의 벡터 마스크를 편집하여 모양의 윤곽선을 수정하거나 레이어에 스타일을 적용할 수도 있습니다.

  • 모양의 색상을 변경하려면 [레이어] 패널에서 해당 모양 레이어의 축소판을 두 번 클릭하고 색상 피커를 사용하여 다른 색상을 선택합니다.
  • 모양을 패턴이나 그레이디언트로 칠하려면 [레이어] 패널에서 모양 레이어를 선택하고 레이어 > 레이어 스타일 > 그레이디언트 오버레이를 선택합니다.
  • 획 너비를 변경하려면 [레이어] 패널에서 모양 레이어를 선택하고 레이어 > 레이어 스타일 > 획을 선택합니다.
  • 모양의 윤곽선을 수정하려면 [레이어] 패널이나 [패스] 패널에서 모양 레이어의 벡터 마스크 축소판을 클릭합니다. 그런 다음 직접 선택 및 펜 도구를 사용하여 모양을 변경합니다.
  • 크기나 비율의 변화없이 모양을 이동하려면 [이동] 도구를 사용합니다.

자세한 내용은 패스 구성 요소 조정자유 변형을 참조하십시오.

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책