1) HtmltoPDF (webkit route) NO funciona en AIX para AEM 6.2.
2) HtmltoPDF (webkit route) es obsoleto en AIX, AEM 6.2 en adelante.
3) HtmltoPDF (webkit route) en Linux y Solaris tiene una doble dependencia de openssl-0.9.x y openssl-1.0.x. Este es un problema conocido que se solucionará con un parche formal pero, por el momento, se puede hacer que funcione con una solución que requiera algunas configuraciones adicionales, como se indica a continuación.

RHEL 6.x y 7.x
Necesitamos las siguientes liberaciones adicionales de 32 bits (es decir, i686) en el sistema:
a. /usr/lib/lib/libcurl.so.3
b. /usr/lib/libssl.so.0.9.6
c. /usr/lib/libcrypto.so.0.9.6
d. /usr/lib/libssl.so.1.0.0
e. /usr/lib/lib/libcrypto.so.1.0.0 Los

archivos [a,b,c] los proporciona compat-libcurl3, que si se instalan a través de yum, arrastra una dependencia transitiva en openssl-0.9.6 Los
archivos [d,e] los proporciona openssl-1.0.x. Si no se instalan en /usr/lib, cree enlaces simbólicos con estos nombres que apunten a las bibliotecas reales.

Asegúrese de que las librerías de 32 bits estén disponibles (libicudata.so.42) para la conversión HtmlToPdf basada en Webkit y libicudata.so.42 para la conversión HtmlToPdf basada en PhantomJS.

La existencia de /usr/lib/X11/fonts es obligatoria. En distribuciones recientes de RHEL, el directorio /usr/lib/X11 ha sido eliminado, por lo tanto necesitamos crearlo manualmente.
  a) Cree un vínculo simbólico /usr/lib/X11/fonts -> /usr/share/X11/fonts
  b) Disponibilidad de fuentes de mensajería IBM type1. Descomprímalos en /usr/share/X11/fonts (dentro de la carpeta 'font-ibm-type1-1.0.3')
  c) /usr/share/fonts tiene que estar presente
  d) Cree un enlace simbólico /usr/share/fonts/X11_fonts que apunte a /usr/share/X11/fonts

Solaris 11
Necesitamos las siguientes librerías adicionales de 32 bits (i686) en el sistema:
a. /usr/lib/lib/libssl.so.0.9.6
b. /usr/lib/libcrypto.so.0.9.6

Si éstos no están presentes en /usr/lib, cree enlaces simbólicos con estos nombres apuntando a las librerías reales, a saber
libssl.so.0.9.6 -> libssl.so.1.0.0
libcrypto.so.0.9.6 -> libcrypto.so.1.0.0

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea