Problema

Al instalar una versión de Communiqué anterior a la 4.2.1 en un servidor Linux de 64 bits con JDK 1.5.0, se obtiene un error similar al siguiente:

CLASSPATH:/tmp/install.dir.30430/InstallerData:/tmp/install.dir.30430/InstallerData/installer.zip: grep: error al cargar bibliotecas compartidas: libc.so.6: no puede abrir el archivo de objeto compartido: No existe tal archivo o directorio ========= Forking JAVA ============================================= /opt/jdk1.5.0_12/bin/java: error al cargar bibliotecas compartidas: libpthread.so.0: no se puede abrir el archivo de objeto compartido: no existe tal archivo o directorio

Solución

Deshabilite LD_ASSUME_KERNEL en el script del instalador:

cat cq4-2-0-20070327-db.sh | sed "s/export LD_ASSUME_KERNEL/#xport LD_ASSUME_KERNEL/" > cq4-inst.sh

Información adicional

Este error es el resultado de un problema en el instalador de Communiqué. El problema se ha solucionado en la versión 4.2.1.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea