Síntomas

Al crear un usuario (con CQ o LDAP), este no puede acceder a su bandeja de entrada de notificaciones a menos que sea miembro de un grupo de usuarios administradores (o administradores de privilegios). ¿Qué permiso se le tiene que conceder al usuario para que vea su propia bandeja de entrada de notificaciones sin concederle privilegios de administración de usuarios?

Además, el error de seguimiento se lanza en el registro cuando el usuario intenta acceder a la bandeja de entrada de notificaciones:

26.10.2009 15:42:41.833 *ERROR* [127.0.0.1 [1256586161833] GET /bin/wcm/notification/inbox/messages.json HTTP/1.1] com.day.cq.wcm.notification.inbox.impl.InboxServlet No se puede consultar la bandeja de entrada para el usuario xxxxxx javax.jcr.AccessDeniedException: xxxxxx sin acceso a UserManager

Causa

De forma predeterminada, un usuario tiene todos los permisos para acceder a su carpeta de inicio en el espacio de trabajo crx.default. Los usuarios estándar no tienen acceso al espacio de trabajo de crx.system. Cuando se accede a la bandeja de entrada de notificaciones, hay una marca adicional en el código, que lanza una AccessDeniedException si el usuario no tiene acceso al espacio de trabajo de crx.system.

Por lo tanto, solo los usuarios que sean miembros de (1) administradores, (2) administradores de privilegios o (2) grupos de usuarios administradores no podrán cambiar su bandeja de entrada de notificaciones.

Resolución

La solución alternativa actual es crear un nuevo grupo y concederle acceso a crx.system al espacio de trabajo. El usuario se debe añadir a este grupo.

  1. Acceda al espacio de trabajo crx.system con la cuenta de administrador.
  2. Abra el Explorador de contenido.
  3. Vaya a /rep:workspaces/crx.system.
  4. Utilice el botón Seguridad para permitir que el nuevo grupo acceda a este repositorio.

Se aplica a

CQ 5.2.1

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