Problema

Algunas configuraciones y paquetes de OSGi subidos a /apps en una carpeta de instalación o una carpeta de configuración no se aplican.

Entorno

AEM 6.x

Causa

Las siguientes causas son las responsables del problema.

  1. La carpeta de instalación o configuración está en un nivel más profundo que cuatro niveles de profundidad en el árbol de carpetas. Los archivos con un nivel más profundo no se instalan.
  2. La configuración o el paquete tiene una estructura incorrecta o está dañado.
  3. La carpeta de instalación o configuración tiene un modo de ejecución en el nombre que no se aplica a la instancia. Por ejemplo, config.publishqa o install.publishstage.

El instalador de OSGi está en estado inconsistente.

Resolución

  1. Si la carpeta de instalación o configuración está a un nivel de profundidad superior a cuatro. Por ejemplo, /apps/sites/siteA/jars/install/foo-1.0.0.jar no se instala, sin embargo /apps/siteA/install/foo-1.0.0.jar sí.
  2. Para ver si hay errores y para validar que su configuración o paquete no tenga una estructura incorrecta, revise el archivo error.log.
  3. Si hay un modo de ejecución en el nombre de la carpeta, vaya a http://host:port/system/console/status-slingsettings en la instancia AEM y valide que se aplica el modo de ejecución correcto.
  4. Si sospecha que el instalador de OSGi está funcionando mal, consulte este artículo para ver los pasos necesarios para solucionar el problema.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea