Última actualización el
3 may. 2021
Causa
Puede haber múltiples causas para este problema. En este artículo, nos centramos en una causa conocida, en la que se eliminan las ACL del usuario del servicio sling-i18n. Esto suele ocurrir cuando se instala un paquete ACL desde otro entorno.
Resolución
Compruebe si el usuario de servicio sling-i18n tiene acceso de lectura en el nodo /
- Vaya a http://host:port/crx/explorer/index.jsp
- Iniciar sesión como administrador
- Abrir el Explorador de contenido
- Haga clic en el nodo raíz - /
- En la parte superior del navegador, seleccione Seguridad => Editor de control de acceso (el botón Seguridad es la imagen de una caja fuerte)
- Comprobar si el usuario de la sling-i18n tiene garantizado el acceso de lectura. Si no es así, seguir los pasos que se indican a continuación.
Arreglar las ACL de los usuarios del servicio:
- Instale ACS Commons si aún no está instalado. Necesitará usar el ACS Commons ACL Packager.
- Utilizar el ACL Packager para crear un paquete de copia de seguridad de todos los ACL de un entorno dañado. Antes de crear el paquete, editar su configuración, vaya al modo Avanzado pestaña y ajuste Uso de CA en Combinar.
- Instale una nueva instancia de AEM con los mismos parches (service packs, hotfixes, etc.).
- Cree un paquete con el modo de fusión de las ACL desde la instancia nueva.
- Construya el paquete con el modo de fusión también.
- Descargar el paquete
- Instale el paquete de ACL en un entorno environment.Reinstall dañado desde el paso 1.
- La reinstalación del paquete reordena las ACL personalizadas hasta el final de la lista, lo que garantiza que las ACL personalizadas no se sustituyan por otras nuevas.
Una vez que el ACL ha sido resuelto, se requiere un paso final.
- Vaya a /system/console/bundles, y reinicie el paquete "Apache Sling Internationalization Support"