Valide las versiones de los paquetes OSGi después de las actualizaciones, service pack, feature pack o instalaciones de fix pack.
La siguiente herramienta le ayuda a validar que las versiones de los paquetes OSGi instalados en su instancia AEM coinciden con las versiones esperadas para su versión AEM y sus parches.  Esto es útil para validar actualizaciones de AEM e instalaciones de Service Pack con éxito.
 
Instrucciones:
  1. Copiar/pegar el JSON de http://aemhost1:port/system/console/bundles.json al campo de texto JSON.
  2. Seleccione Versión de producto y versión menor en los dos menús desplegables para rellenar automáticamente el campo JSON esperado o copie/pegue JSON de otra instancia de AEM en el campo JSON esperado (también desde http://aemhost2:port/system/console/bundles.json).
  3. Haga clic en Comparar para ver la diferencia.
  4. Los paquetes similares se muestran en blanco, las diferentes versiones de paquetes se muestran en amarillo, los paquetes recién añadidos se muestran en verde agua y los paquetes borrados se muestran en rojo claro.
  5. Filtre los datos utilizando el cuadro Filtro.
Versión del producto:  Cargando...
JSON de /system/console/bundles.json

Resultados de la comparación
Filtro:
Nombre simbólico Nombre del paquete Número de versión esperado Número de versión real

 

 

* Gracias a Sham Sundar Hassan Chikkegowda por proporcionar el código fuente original para esta herramienta.  Su sitio personal puede ser visitado aquí.