Info zu Flash-Dateien

Flash Professional kann zur Arbeit mit einer Vielzahl von Dateitypen verwendet werden, und jeder Typ hat einen anderen Zweck:

  • FLA-Dateien sind die primären Dateien, mit denen Sie in Flash Professional arbeiten; sie enthalten die grundlegenden Medien-, Zeitleisten- und Skriptinformationen für ein Flash Professional-Dokument. Bei Medienobjekten handelt es sich um Grafik-, Text-, Sound- und Videoobjekte, aus denen sich der Inhalt eines Flash Professional-Dokuments zusammensetzt. In der Zeitleiste teilen Sie Flash Professional mit, wann bestimmte Medienobjekte auf der Bühne angezeigt werden sollen. Mit ActionScript®-Code legen Sie fest, wie Flash Professional-Dokumente auf Benutzerinteraktionen reagieren sollen. Außerdem können Sie damit das Verhalten Ihrer Flash-Dokumente genauer steuern.

  • Unkomprimierte XFL-Dateien ähneln FLA-Dateien. Eine XFL-Datei und die zugehörigen Dateien im selben Ordner sind einfach die unkomprimierte Variante einer FLA-Datei. Dieses Format erleichtert es Benutzergruppen, gleichzeitig an verschiedenen Elementen eines Flash-Projekts zu arbeiten. Weitere Informationen finden Sie unter Arbeiten mit nicht komprimierten XFL-Dateien.

  • Bei SWF-Dateien, den kompilierten Versionen von FLA-Dateien, handelt es sich um die Dateien, die auf einer Webseite angezeigt werden. Bei der Veröffentlichung einer FLA-Datei wird von Flash Professional eine SWF-Datei erstellt.

    Das Flash Professional-SWF-Dateiformat ist ein offener Standard und wird auch von anderen Anwendungen unterstützt. Weitere Informationen zu den Dateiformaten von Flash Professional finden Sie unter www.adobe.com/go/flashplayer.

  • AS-Dateien sind ActionScript-Dateien. Sie können diese Dateien verwenden, wenn Sie Ihren ActionScript-Code teilweise oder vollständig außerhalb der FLA-Dateien speichern möchten. Dies kann bei der Codeorganisation und bei Projekten, bei denen mehrere Personen an unterschiedlichen Teilen des Flash Professional-Inhalts arbeiten müssen, hilfreich sein.

  • SWC-Dateien enthalten die Flash Professional-Komponenten, die wiederverwendet werden können. Jede SWC-Datei enthält einen kompilierten Movieclip, ActionScript-Code und weitere für die Komponente erforderliche Elemente.

    Hinweis: (Nur Flash Professional CC) SWC-Dateien können nicht in Flash Pro importiert werden.

  • ASC-Dateien enthalten ActionScript-Code, der auf einem Computer mit Flash Media Server ausgeführt wird. Diese Dateien bieten die Möglichkeit, serverseitige Logik zu implementieren, die zusammen mit ActionScript in einer SWF-Datei eingesetzt wird.

    Hinweis: ASC-Dateien werden von Flash Professional CC nicht unterstützt.

  • JSFL-Dateien sind JavaScript-Dateien, mit denen Sie dem Flash Professional-Authoring-Tool neue Funktionen hinzufügen können.

Adobe empfiehlt

Adobe empfiehlt
< a href =" http://goo.gl/1iL8L" > Introducing Flash Professional < /a >
Todd Perkins

Die folgenden zusätzlichen Videos und Tutorials demonstrieren die Arbeit mit Flash Professional. Einige Videos zeigen Flash Professional CS3 oder CS4, gelten aber auch für Flash Professional CS5.

Arbeiten mit anderen Adobe-Anwendungen

Flash wurde für eine Zusammenarbeit mit anderen Adobe®-Anwendungen konzipiert, um eine breite Palette von kreativen Arbeitsabläufen zu ermöglichen. Sie können Illustrator®- und Photoshop®-Dateien direkt in Flash importieren. Sie können auch Videodateien in Flash erstellen und in Adobe® Premiere® Pro oder After Effects® bearbeiten; umgekehrt ist es auch möglich, Videodateien aus diesen Anwendungen in Flash zu importieren. Beim Veröffentlichen der SWF-Dateien können Sie den Inhalt mithilfe von Dreamweaver® in Ihren Webseiten einbetten. Außerdem können Sie Flash direkt aus Dreamweaver heraus starten, um den Inhalt zu bearbeiten.

Öffnen von XFL-Dateien

Ab Flash Professional CS5 ist XFL das interne Format der FLA-Dateien, die Sie erstellen. Wenn Sie eine Datei in Flash speichern, ist das Standardformat FLA, das interne Format der Datei ist jedoch XFL.

Andere Adobe®-Anwendungen, wie beispielsweise After Effects®, können Dateien im XFL-Format exportieren. Diese Dateien weisen die XFL-Dateierweiterung anstelle der FLA-Erweiterung auf. InDesign® kann direkt im FLA-Format exportieren, das intern XFL ist. So können Sie zunächst in After Effects oder InDesign an einem Projekt arbeiten und es dann in Flash fertig stellen.

Das Öffnen von XFL-Dateien und das Arbeiten damit erfolgt in Flash genau wie bei FLA-Dateien. Wenn Sie eine XFL-Datei in Flash Professional öffnen, können Sie sie als FLA-Datei oder als nicht komprimierte XFL-Datei speichern.

In den folgenden Videotutorials wird gezeigt, wie Sie XFL-Dateien aus InDesign und AfterEffects über XFL und FLA nach Flash exportieren:

So öffnen Sie eine XFL-Datei in Flash:

  1. Exportieren Sie Ihre Arbeit in einer anderen Adobe®-Anwendung, wie InDesign oder After Effects, als XFL-Datei.

    Die Anwendung behält alle Ebenen und Objekte der ursprünglichen Datei in der XFL-Datei bei.

  2. Wählen Sie in Flash Professional „Datei“ > „Öffnen“ und navigieren Sie zu der XFL-Datei. Klicken Sie auf „Öffnen“.

    Die XFL-Datei wird in Flash genau wie eine FLA-Datei geöffnet. Alle Ebenen der Originaldatei erscheinen in der Zeitleiste und die Originalobjekte werden im Bedienfeld „Bibliothek“ angezeigt.

    Sie können jetzt wie gewohnt mit der Datei arbeiten.

  3. Um die Datei zu speichern, wählen Sie „Datei“ > „Speichern“.

    Flash Professional fordert Sie im Dialogfeld „Speichern unter“ auf, einen Namen für die neue FLA-Datei einzugeben.

  4. Geben Sie einen Namen ein und speichern Sie die FLA-Datei.

Arbeiten mit nicht komprimierten XFL-Dateien

Ab Flash Professional CS5 können Sie wahlweise mit Ihren Flash-Dateien im nicht komprimierten XFL-Format arbeiten. In diesem Format können Sie alle separaten Teile oder Unterdateien sehen, aus denen sich die Flash-Datei zusammensetzt. Dazu gehören:

  • Eine XML-Datei, die die Flash-Datei als Ganzes beschreibt.

  • Separate XML-Dateien, um die einzelnen Bibliothekssymbole zu beschreiben.

  • Zusätzliche XML-Dateien, die Veröffentlichungseinstellungen, Einstellungen für mobile Gerät und andere Elemente enthalten.

  • Ordner mit externen Beständen, zum Beispiel Bitmapdateien, die von der Flash-Datei verwendet werden.

Indem Sie das nicht komprimierte XFL-Format verwenden, ist es möglich, dass verschiedene Personen separat an einzelnen Teilen der Flash-Datei arbeiten. Sie können auch ein Quellensteuerungssystem verwenden, um die Änderungen an den einzelnen Teildateien innerhalb der nicht komprimierten XFL-Datei zu verwalten. Zusammengenommen erleichtern diese Funktionen die Zusammenarbeit mehrerer Designer und Entwickler an größeren Projekten erheblich.

Verwenden von Live-Updates mit XFL-Dateien

Mithilfe der Liveaktualisierung von bearbeitbaren Beständen für nicht komprimierte XFL-Dokumente können Sie beliebige Bibliotheksbestände aus einem nicht komprimierten XFL-Dokument bearbeiten, während das Dokument in Flash geöffnet ist. Die Änderungen an den Beständen werden in Flash übernommen, wenn Sie die Bearbeitung des Materials in einer anderen Anwendung beenden.

So bearbeiten Sie Bestände aus einem nicht komprimierten XLF-Dokument in einer anderen Anwendung:

  1. Speichern Sie ein Flash-Dokument als nicht komprimierte XFL-Datei.

  2. Öffnen Sie das zu bearbeitende Element aus dem Ordner BIBLIOTHEK des nicht komprimierten XFL-Dokuments in einem geeigneten Editor wie zum Beispiel Photoshop.

  3. Bearbeiten Sie das Element und speichern Sie die Änderungen.

  4. Kehren Sie zu Flash Pro zurück.

    Die Aktualisierung des Elements ist sofort in Flash zu sehen.

Bearbeiten von SWF-Dateien aus Dreamweaver in Flash

Wenn Sie sowohl Flash als auch Dreamweaver installiert haben, können Sie eine SWF-Datei in einem Dreamweaver-Dokument auswählen und sie mit Flash bearbeiten. Flash bearbeitet die SWF-Datei nicht direkt; es bearbeitet vielmehr das Quelldokument (FLA-Datei) und exportiert dann die SWF-Datei erneut.

  1. Öffnen Sie in Dreamweaver den Eigenschafteninspektor („Fenster“ > „Eigenschaften“).
  2. Führen Sie im Dreamweaver-Dokument einen der folgenden Schritte aus:
    • Klicken Sie auf den Platzhalter für die SWF-Datei und anschließend im Eigenschafteninspektor auf „Bearbeiten“.

    • Klicken Sie mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Mac OS) auf den Platzhalter für die SWF-Datei und wählen Sie aus dem Kontextmenü die Option „Bearbeiten mit Flash“ aus.

      Dreamweaver wechselt zu Flash und Flash versucht, die Flash-Authoringdatei (.FLA) für die ausgewählte SWF-Datei zu finden. Wenn Flash die Flash-Authoringdatei nicht finden kann, werden Sie aufgefordert, sie manuell zu suchen.

      Hinweis: Wenn die FLA- oder SWF-Datei gesperrt ist, checken Sie die Datei in Dreamweaver aus.

  3. Bearbeiten Sie die FLA-Datei in Flash. Im Flash-Dokumentfenster wird angezeigt, dass Sie gerade eine Datei aus Dreamweaver bearbeiten.
  4. Klicken Sie auf „Fertig“, wenn Sie alle gewünschten Änderungen vorgenommen haben.

    Flash aktualisiert die FLA-Datei und exportiert sie dann erneut als SWF-Datei. Anschließend wird Flash geschlossen und die Anwendung wechselt wieder zum Dreamweaver-Dokument zurück.

    Hinweis:

    Wenn Sie die SWF-Datei aktualisieren möchten und Flash geöffnet bleiben soll, wählen Sie in Flash „Datei“ > „Aktualisieren für Dreamweaver“.

  5. Sie können die aktualisierte Datei im Dokument anzeigen, indem Sie im Dreamweaver-Eigenschafteninspektor auf „Abspielen“ klicken. Wenn Sie eine Vorschau der Seite in einem Browserfenster anzeigen möchten, drücken Sie die Taste F12.
  1. Starten Sie Flash.
  2. Wählen Sie im Hauptbildschirm von Flash „Neu erstellen“ > „Flash-Datei (Mobil)“.
  3. Wählen Sie in Device Central eine Player-Version und eine ActionScript-Version aus.
  4. Wählen Sie einen Inhaltstyp.
  5. Wählen Sie in der Liste „Verfügbare Geräte“ eines oder mehrere Zielgeräte aus (oder wählen Sie ein einzelnes Gerät oder eine Gerätegruppe in der Liste „Gerätegruppen“ aus).
  6. Klicken Sie auf „Erstellen“.
  7. Fügen Sie dem neuen Flash-Dokument Inhalt hinzu.
  8. Wählen Sie zum Testen des Dokuments „Steuerung“ > „Testen“.

Erstellen neuer Dokumente

Sie können ein neues Dokument erstellen oder ein zuvor gespeichertes Dokument in Flash Professional öffnen, und Sie können bei der Arbeit ein neues Fenster öffnen. Sie haben auch die Möglichkeit, Eigenschaften für neue oder vorhandene Dokumente festzulegen.

Erstellen neuer Dokumente

  1. Wählen Sie „Datei“ > „Neu“.
  2. Klicken Sie auf der Registerkarte „Allgemein“ auf den Flash-Dokument-Typ, den Sie erstellen wollen.
  3. Führen Sie einen der folgenden Schritte aus:

Erstellen von neuen Dokumenten aus Vorlagen

  1. Wählen Sie „Datei“ > „Neu“.
  2. Klicken Sie auf die Registerkarte „Vorlagen“.
  3. Wählen Sie in der Liste „Kategorie“ eine Kategorie und in der Liste „Kategorieelemente“ ein Dokument aus. Klicken Sie anschließend auf „OK“. Zu diesem Zweck ist im Lieferumfang der Flash Professional-Anwendung eine Auswahl verschiedener Standardvorlagen enthalten, die um eigene Vorlagen erweitert werden kann.

Öffnen von vorhandenen Dokumenten

  1. Wählen Sie „Datei“ > „Öffnen“.
  2. Wechseln Sie im Dialogfeld „Öffnen“ zu der Datei oder geben Sie den Pfad zur Datei im Feld „Gehe zu“ ein.
  3. Klicken Sie auf „Öffnen“.

Anzeigen eines Dokuments, wenn mehrere Dokumente geöffnet sind

Wenn Sie mehrere Dokumente öffnen, werden die offenen Dokumente durch Registerkarten oben im Dokumentfenster identifiziert, damit Sie leichter zwischen den Dokumenten wechseln können. Registerkarten werden nur angezeigt, wenn Dokumente im Dokumentfenster maximiert sind.

  1. Klicken Sie auf die Registerkarte des Dokuments, das Sie einsehen möchten.

    Registerkarten werden standardmäßig in der Reihenfolge angezeigt, in der die Dokumente erstellt wurden. Die Reihenfolge der Registerkarte lässt sich durch Ziehen ändern.

Öffnen eines neuen Fensters für das aktuelle Dokument

  1. Wählen Sie „Fenster“ > „Fenster duplizieren“.

Festlegen von Eigenschaften für neue oder vorhandene Dokumente

  1. Wählen Sie, während das Dokument geöffnet ist, „Modifizieren“ > „Dokument“.

    Das Dialogfeld „Dokumenteinstellungen“ wird angezeigt.

  2. Um die Abmessungen auf der Bühne festzulegen, führen Sie einen der folgenden Schritte aus:
    • Tragen Sie in die Felder „Breite“ und „Höhe“ die gewünschten Werte ein, um die Abmessungen der Bühne in Pixel anzugeben. Die Mindestgröße beträgt 1 x 1 und die maximal zulässige Größe 2880 x 2880 Pixel.

    • Klicken Sie neben „Anpassen an“ auf die Option „Inhalt“, um die Bühnenabmessungen genau an den Umfang ihres Inhalts anzupassen.

    • Klicken Sie neben „Anpassen an“ auf die Option „Drucker“, um die Bühnenabmessungen so zu wählen, dass ihr Inhalt den gesamten Druckbereich einer Seite ausfüllt. Die Größe des Druckbereichs entspricht der Papiergröße abzüglich der im Dialogfeld „Seite einrichten“ (Windows) bzw. „Druckränder“ (Macintosh) unter „Ränder“ eingestellten Randbreite.

    • Klicken Sie auf „Standard“, um die Bühnenabmessungen auf den Standardwert 550 x 400 Pixel einzustellen.

  3. Um die Position und Ausrichtung von 3-D-Objekten auf der Bühne so anzupassen, dass sie relativ zu den Bühnenrändern angezeigt werden, aktivieren Sie die Option „3D-Perspektive anpassen, um die aktuelle Bühnenprojektion beizubehalten“.

    Diese Option ist nur verfügbar, wenn Sie die Abmessungen der Bühne ändern.

  4. (Nur in CS5.5.) Um die Größe des Bühneninhalts an die geänderte Bühnengröße anzupassen, aktivieren Sie die Option „Inhalt mit Bühne skalieren“.

    Diese Option ist nur verfügbar, wenn Sie die Abmessungen der Bühne ändern. In den Voreinstellungen können Sie festlegen, ob Inhalte in gesperrten und ausgeblendeten Ebenen skaliert werden sollen. Weitere Informationen finden Sie unter Festlegen von allgemeinen Voreinstellungen.

  5. Um die Maßeinheit für Lineale festzulegen, die im Arbeitsbereich angezeigt werden, wählen Sie im Popupmenü „Linealeinheit“ eine Option aus. (Mit dieser Einstellung geben Sie zugleich an, welche Einheiten im Bedienfeld „Info“ verwendet werden.)
  6. Klicken Sie auf das Farbfeld „Hintergrundfarbe“ und wählen Sie in der Farbpalette eine Hintergrundfarbe für das Dokument aus.
  7. Geben Sie unter „Bildrate“ die Anzahl der Einzelbilder an, die bei der Wiedergabe der Animation pro Sekunde angezeigt werden sollen.

    In den meisten Fällen ist für die Wiedergabe einer Animation auf dem Computer ein Wert von 8 bis 15 BpS (Bilder pro Sekunde) ausreichend, insbesondere dann, wenn die Animation von einer Website geladen wird. Wenn Sie die Bildrate ändern, wird die neue Bildrate zur Standardeinstellung für neue Dokumente.

  8. (Nur in CS5.5.) Um das Dokument automatisch in regelmäßigen Abständen zu speichern, aktivieren Sie die Option „Automatisch speichern“ und geben die Anzahl an Minuten zwischen den einzelnen Speicherintervallen an.
  9. Führen Sie einen der folgenden Schritte aus:
    • Um die neuen Einstellungen auf das aktuelle Dokument anzuwenden, klicken Sie auf „OK“.

    • Klicken Sie auf „Als Standard“, um die neuen Einstellungen als Standardeigenschaften für alle neuen Dokumente zu übernehmen.

Ändern der Dokumenteigenschaften mit dem Eigenschafteninspektor

  1. Klicken Sie im Arbeitsbereich auf eine Stelle außerhalb der Bühne, damit auf der Bühne kein Objekt ausgewählt ist. Im Eigenschafteninspektor werden die Dokumenteigenschaften angezeigt. (Sollte der Eigenschafteninspektor nicht geöffnet sein, wählen Sie „Fenster“ > „Eigenschaften“.)
  2. (Nur in CS5.5.) Wählen Sie im Abschnitt „Veröffentlichen“ eine Flash Player- und eine ActionScript-Version für Ihr Dokument aus. Um·weitere·Veröffentlichungseinstellungen·anzuzeigen,·klicken·Sie·auf·die·Schaltfläche·„Veröffentlichungseinstellungen“. Weitere Informationen finden Sie unter Veröffentlichungseinstellungen.

  3. Geben Sie im Abschnitt „Eigenschaften“ als BpS-Wert (Bild pro Sekunde) an, wie viele Animationsbilder in jeder Sekunde abgespielt werden sollen.
  4. Um die Größe der Bühne zu ändern, geben Sie Werte für die Breite und Höhe der Bühne an.
  5. Um eine Hintergrundfarbe für die Bühne auszuwählen, klicken Sie neben der Eigenschaft „Bühne“ auf das Farbfeld und wählen eine Farbe aus der Palette aus.
  6. Um weitere Dokumenteigenschaften zu ändern, klicken Sie neben der Eigenschaft „Größe“ auf die Schaltfläche „Dokumenteigenschaften bearbeiten“. Weitere Informationen zu allen Dokumenteigenschaften finden Sie unter Festlegen von Eigenschaften für neue oder vorhandene Dokumente.

Hinzufügen von XMP-Metadaten zu Dokumenten

Sie können XMP-Daten (Extensible Metadata Platform), zum Beispiel Titel, Autor, Beschreibung, Copyright-Hinweise, in Ihre FLA-Dateien einschließen. XMP ist ein Metadatenformat, das auch von bestimmten anderen Adobe®-Anwendungen interpretiert werden kann. Die Metadaten können in Flash Professional und in Adobe® Bridge angezeigt werden. Weitere Informationen zu XMP-Metadaten finden Sie unter Metadaten und Schlüsselwörter in der Bridge-Hilfe.

Hinweis: 32-Bit Bridge wird von Adobe Flash Professional CC nicht unterstützt.

Durch das Einbetten von Metadaten können Internet-Suchmaschinen besser nach Flash Professional -Inhalten suchen. Die Suchmetadaten basieren auf den XMP-Spezifikationen (Extensible Metadata Platform) und werden in der FLA-Datei in einem W3C-kompatiblen Format gespeichert.

Die Metadaten einer Datei enthalten Informationen über den Inhalt, den Copyright-Status, den Ursprung und die Geschichte der Datei. Im Dialogfeld „Dateiinformationen“ können Sie die Metadaten für die aktuelle Datei anzeigen und bearbeiten.

Je nach Art der ausgewählten Datei können die folgenden Metadatentypen angezeigt werden:

Beschreibung

Enthält u. a. Informationen zum Autor, zum Titel und zum Copyright.

IPTC

Zeigt bearbeitbare Metadaten an. Sie können Ihren Dateien Beschreibungen oder Copyright-Informationen hinzufügen. IPTC Core ist eine Spezifikation, die im Oktober 2004 vom IPTC (International Press Telecommunications Council) genehmigt wurde. Sie unterscheidet sich insofern vom älteren IPTC (IIM, Legacy), dass neue Eigenschaften hinzugefügt, einige Eigenschaftennamen geändert und einige Eigenschaften gelöscht wurden.

Kameradaten (Exif)

Zeigt Informationen an, die von Digitalkameras bereitgestellt werden, darunter die Kameraeinstellungen, die bei der Aufnahme verwendet wurden.

Videodaten

Zeigt Metadaten zu Videodateien an, darunter Pixel-Seitenverhältnis, Szene und Aufnahme.

Audiodaten

Zeigt Metadaten zu Audiodateien an, darunter Interpret, Album, Spurnummer und Genre.

Mobile SWF

Führt Informationen zu SWF-Dateien auf, darunter Titel, Autor, Beschreibung und Copyright.

Protokoll

Führt ein Protokoll der Änderungen, die mit Photoshop an Bildern vorgenommen wurden.

Hinweis: Damit das Protokoll mit den Metadaten der Datei gespeichert wird, muss die Voreinstellung „Verlaufsprotokoll“ in Photoshop aktiviert sein.

Version Cue

Führt alle Informationen zur Version-Cue-Dateiversion auf.

DICOM

Zeigt Information über Bilder an, die im Format Digital Imaging and Communications in Medicine (DICOM) gespeichert wurden.

So fügen Sie Metadaten hinzu:

  1. Wählen Sie „Datei“ > „Datei-Informationen“.
  2. Geben Sie im Dialogfeld „Datei-Informationen“ die Metadaten ein, die Sie hinzufügen möchten. Sie können der FLA-Datei jederzeit Metadaten hinzufügen bzw. diese entfernen.

Speichern von Flash-Dokumenten

Sie können ein Flash Professional-Dokument (FLA-Datei) wahlweise unter seinem aktuellen Namen im aktuellen Verzeichnis speichern oder ihm einen anderen Dateinamen und Speicherort zuweisen.

Bei einem Dokument, das Änderungen enthält, die noch nicht gespeichert wurden, wird in der Dokumenttitelleiste, in der Anwendungstitelleiste und auf der Dokumentregisterkarte ein Stern (*) hinter dem Dokumentnamen angezeigt. Wenn Sie das Dokument speichern, wird der Stern nicht mehr angezeigt.

Speichern von Flash-Dokumenten im FLA-Standardformat

  1. Führen Sie einen der folgenden Schritte aus:
    • Wählen Sie „Datei“ > „Speichern“, um die auf der Festplatte gespeicherte Version der Datei zu aktualisieren.

    • Wählen Sie „Datei“ > „Speichern unter“, um das Dokument an einem anderen Ort und/oder unter einem anderen Namen zu speichern oder um das Dokument zu komprimieren.

  2. Wenn Sie den Befehl „Speichern unter“ auswählen oder das Dokument zum ersten Mal speichern, legen Sie den Namen und den Speicherort der Datei fest.
  3. Klicken Sie auf „Speichern“.

Speichern von Dokumenten im nicht komprimierten XFL-Format

  1. Wählen Sie „Datei“ > „Speichern unter“.
  2. Wählen Sie im Menü „Dateityp“ den Eintrag „Flash CS5.5 nicht komprimiertes Dokument (*xfl)“.
  3. Wählen Sie einen Namen und Speicherort für die Datei und klicken Sie auf „Speichern“.

Wiederherstellen der zuletzt gespeicherten Version eines Dokuments

  1. Wählen Sie „Datei“ > „Wiederherstellen“.

Speichern eines Dokuments als Vorlage

  1. Wählen Sie „Datei“ > „Als Vorlage speichern“.
  2. Geben Sie in das Feld „Name“ des Dialogfelds „Als Vorlage speichern“ einen Namen für die Vorlage ein.
  3. Wählen Sie im Popupmenü „Kategorie“ eine Kategorie aus oder geben Sie einen Namen ein, um eine neue Kategorie zu erstellen.
  4. Tragen Sie in das Feld „Beschreibung“ eine Beschreibung der neuen Vorlage ein. Diese Beschreibung kann bis zu 255 Textzeichen umfassen. Klicken Sie anschließend auf „OK“.

    Die Beschreibung wird angezeigt, wenn die Vorlage im Dialogfeld „Neues Dokument“ ausgewählt wird.

    Um eine gespeicherte Vorlage zu löschen, öffnen Sie einen der folgenden Ordner und löschen die the FLA-Datei der Vorlage aus dem entsprechenden Kategorienordner.

    • Windows XP – C:\Dokumente und Einstellungen\<Benutzername>\Lokale Einstellungen\Anwendungsdaten\Adobe\Flash CS5\<Sprache>\Configuration\Templates\

    • Windows Vista und 7 – C:\Benutzer\<Benutzername>\AppData\Local\Adobe\Flash CS5\<Sprache>\Configuration\Templates\

    • Mac OS - <Festplatte>/Users/<Benutzername>/Library/Application Support/Adobe/Flash CS5/<Sprache>/Configuration/Templates/

Speichern eines Dokuments als Flash CS4-Dokument

  1. Wählen Sie „Datei“ > „Speichern unter“.
  2. Geben Sie den gewünschten Dateinamen und Speicherort ein.
  3. Wählen Sie im Popupmenü „Format“ die Option „Flash CS4-Dokument“ aus und klicken Sie auf „Speichern“.

    Hinweis:

    Unter Umständen werden Sie in einer Warnmeldung darauf hingewiesen, dass beim Speichern im Flash CS 4-Format Inhalte verloren gehen können. Klicken Sie in diesem Fall auf „Als Flash CSX 4 speichern“, wenn Sie die Datei trotzdem speichern möchten. Dies kann vorkommen, wenn das Dokument Merkmale enthält, die nur in Flash CS5 verfügbar sind. Diese Merkmale bleiben in Flash Professional nicht erhalten, wenn Sie das Dokument im Flash MX 4-Format speichern.

Speichern von Dokumenten beim Beenden von Flash

  1. Wählen Sie „Datei“ > „Beenden“ (Windows) bzw. „Flash“ > „Flash beenden“ (Macintosh).
  2. Wenn Sie Dokumente mit noch nicht gespeicherten Änderungen geöffnet haben, werden Sie von Flash Professional aufgefordert, die Änderungen zu speichern oder zu verwerfen.
    • Klicken Sie auf „Ja“, um die Änderungen zu speichern und das Dokument zu schließen.

    • Klicken Sie auf „Nein“, um die Dokumente zu schließen, ohne die Änderungen zu speichern.

Drucken von Flash-Dokumenten

Sie können Dokumente in einer Vorschau anzeigen und drucken, Bilder in Flash Professional-Dokumenten drucken oder auch Bilder bestimmen, die für jeden späteren Betrachter Ihres Flash-Dokuments druckbar sein sollen.

Wenn Sie Bilder in einem Flash Professional-Dokument drucken, können Sie im Dialogfeld „Drucken“ angeben, welche Szenen oder Bilder ausgegeben werden sollen und wie viele Exemplare Sie jeweils benötigen. Unter Windows haben Sie im Dialogfeld „Seite einrichten“ die Möglichkeit, das Papierformat, die Ausrichtung sowie verschiedene weitere Druckoptionen einzustellen, unter anderem die Seitenränder und ob alle auf den einzelnen Seiten enthaltenen Bilder gedruckt werden sollen. Auf dem Macintosh finden Sie die entsprechenden Optionen in den Dialogfeldern „Seite einrichten“ und „Druckränder“.

Die Dialogfelder „Drucken“ und „Seite einrichten“ werden vom jeweiligen Betriebssystem bereitgestellt; ihr Erscheinungsbild und die verfügbaren Optionen hängen vom ausgewählten Druckertreiber ab.

  1. Wählen Sie „Datei“ > „Seite einrichten“ (Windows) oder „Datei“ > „Druckränder“ (Macintosh).
  2. Stellen Sie die Seitenränder ein. Wählen Sie unter „Zentriert“ beide Optionen, um das Bild in der Mitte der Seite auszudrucken.
  3. Wählen Sie im Menü „Bilder“, ob alle Bilder im Dokument oder nur das erste Bild jeder Szene gedruckt werden sollen.
  4. Wählen Sie im Menü „Layout“ die folgenden Optionen:

    Originalgröße

    Das Bild wird in voller Größe ausgedruckt. Tragen Sie in das Feld „Skalieren“ einen Wert ein, um das Bild verkleinert oder vergrößert auszudrucken.

    An Seite anpassen

    Die einzelnen Bilder werden so verkleinert oder vergrößert, dass sie den gesamten Druckbereich der Seite ausfüllen.

    Storyboard

    Mehrere Piktogramme werden auf einer Seite ausgedruckt. Wählen Sie „Felder“, „Raster“ oder „Leer“. Geben Sie im Feld „Bilder“ die Anzahl der Piktogramme pro Seite an. Geben Sie im Feld „Bildrand“ den Abstand zwischen den einzelnen Piktogrammen an, und wählen Sie „Bilder beschriften“, um die Bildbezeichnung als Miniatur auszudrucken.

  5. Wählen Sie „Datei“ > „Drucken“, um Bilder zu drucken.

Verwenden der Bildbezeichnung zum Deaktivieren von Druckvorgängen

Wenn keine Bilder in der Hauptzeitleiste gedruckt werden sollen, weisen Sie einem Bild diese Bezeichnung zu: „!#p“. Durch die Kennzeichnung mit !#p wird die gesamte SWF-Datei nicht druckbar und der Befehl „Drucken“ im Kontextmenü des Flash Players wird deaktiviert. Sie können außerdem das Kontextmenü des Flash Players entfernen.

Selbst wenn Sie den Druck von Flash Player aus deaktivieren, können Bilder nach wie vor über den Browserbefehl „Drucken“ gedruckt werden. Da dieser Befehl eine Browserfunktion ist, kann er von Flash Professional aus nicht gesteuert oder deaktiviert werden.

Deaktivieren des Drucks über das Flash Player-Kontextmenü

  1. Öffnen oder aktivieren Sie das zu veröffentlichende Flash Professional-Dokument (FLA-Datei).
  2. Wählen Sie das erste Schlüsselbild in der Hauptzeitleiste aus.
  3. Wählen Sie „Fenster“ > „Eigenschaften“, um den Eigenschafteninspektor einzublenden.
  4. Geben Sie im Eigenschafteninspektor den Wert !#p in das Bezeichnungsfeld ein, um das Bild als nicht druckbar zu kennzeichnen.

    Sie müssen die Bezeichnung !#p nur ein Mal eingeben, um den Befehl „Drucken“ im Kontextmenü zu deaktivieren.

    Hinweis:

    Alternativ dazu können Sie ein leeres Bild auswählen (anstatt eines Schlüsselbilds) und ihm die folgende Bezeichnung zuweisen: #p.

Deaktivieren des Drucks durch Entfernen des Kontextmenüs im Flash Player

  1. Öffnen oder aktivieren Sie das zu veröffentlichende Flash Professional-Dokument (FLA-Datei).
  2. Wählen Sie „Datei“ > „Einstellungen für Veröffentlichungen“.
  3. Klicken Sie auf die Registerkarte „HTML“, deaktivieren Sie „Menü anzeigen“, und klicken Sie auf „OK“.

Angeben eines Druckbereichs beim Drucken von Bildern

  1. Öffnen Sie das Flash Professional-Dokument (FLA-Datei) mit den zu druckenden Bildern.
  2. Wählen Sie ein Bild aus, das Sie nicht durch Eingabe der Bildbezeichnung #p als druckbar definiert haben und das sich auf derselben Ebene befindet wie eines mit der Bezeichnung #p.

    Zur besseren Übersicht können Sie das nächste Bild nach dem Bild mit der Bezeichnung #p auswählen.

  3. Erstellen Sie auf der Bühne eine Form in der Größe des gewünschten Druckbereichs. Sie können auch ein Bild mit einem Objekt in der entsprechenden Druckbereichsgröße auswählen, um die Begrenzungsbox dieses Bilds zu verwenden.
  4. Wählen Sie das Bild in der Zeitleiste aus, das die gewünschte Form für die Begrenzungsbox enthält.
  5. Geben Sie im Eigenschafteninspektor („Fenster“ > „Eigenschaften“) als Bildbezeichnung den Wert #b ein, um die ausgewählte Form als Begrenzungsbox für den Druckbereich zu kennzeichnen.

    Sie können die Bildbezeichnung #b pro Zeitleiste nur einmal eingeben. Diese Option entspricht der Option „Film“ im Popupmenü „Begrenzungsbox“ für die Print-Aktion.

Ändern der gedruckten Hintergrundfarbe

Sie können die im Dialogfeld „Eigenschaften“ ausgewählte Hintergrundfarbe drucken. Sie können die Hintergrundfarbe ausschließlich für die zu druckenden Bilder ändern; stellen Sie hierzu ein farbiges Objekt auf die unterste Ebene der zu druckenden Zeitleiste.

  1. Stellen Sie eine gefüllte Form, die die Bühne abdeckt, auf die unterste Ebene der zu druckenden Zeitleiste.
  2. Wählen Sie die Form aus, und wählen Sie „Modifizieren“ > „Dokument“. Wählen Sie eine Farbe für den zu druckenden Hintergrund.

    Dadurch wird die Hintergrundfarbe des gesamten Dokuments geändert, auch für Movieclips und geladene SWF-Dateien.

  3. Führen Sie einen der folgenden Schritte aus:
    • Wenn diese Farbe als Dokumenthintergrund gedruckt werden soll, muss das Bild, in das Sie die Form gestellt haben, zum Drucken markiert sein.

    • Wenn für nicht zu druckende Bilder eine andere Hintergrundfarbe verwendet werden soll, wiederholen Sie Schritt 2 und 3. Stellen Sie dann in allen Bildern, die nicht gedruckt werden sollen, die Form auf die unterste Ebene der Zeitleiste.

Mit dem Befehl „Drucken“ im Flash Player-Kontextmenü können Sie Bilder aus jeder Flash Professional-SWF-Datei drucken.

Mit dem Druckbefehl im Kontextmenü können keine Transparenz- und Farbeffekte oder Bilder aus anderen Movieclips gedruckt werden. Diese erweiterten Druckfunktionen sind nur über das PrintJob-Objekt und die Funktion print() verfügbar.

  1. Öffnen Sie das Dokument.

    Mit dem Befehl „Drucken“ werden die Bilder mit der Bezeichnung #p gedruckt. Der Druckbereich ist die Bühne bzw. die angegebene Begrenzungsbox.

    Wenn Sie keine bestimmten Bilder zum Drucken markiert haben, werden alle Bilder in der Hauptzeitleiste des Dokuments gedruckt.

  2. Wählen Sie „Datei“ > „Vorschau für Veröffentlichungen“ > „Standard“, oder drücken Sie die Taste F12, um den Flash Professional-Inhalt in einem Browser anzuzeigen.
  3. Klicken Sie im Flash Professional-Inhalt innerhalb des Browserfensters mit der rechten Maustaste (Windows) bzw. bei gedrückter Ctrl-Taste (Macintosh), um das Flash Player-Kontextmenü anzuzeigen.
  4. Wählen Sie im Flash Player-Kontextmenü den Befehl „Drucken“, um das gleichnamige Dialogfeld anzuzeigen.
  5. Windows: Wählen Sie den gewünschten Druckbereich, um festzulegen, welche Bilder gedruckt werden sollen.
  6. Macintosh: Wählen Sie im Dialogfenster „Drucken“ die gewünschten Seiten aus.
  7. Wählen Sie alle anderen gewünschten Druckoptionen aus. Welche Optionen jeweils zur Verfügung stehen, hängt vom jeweiligen Drucker ab.
  8. Klicken Sie auf „OK“ (Windows) bzw. „Drucken“ (Macintosh).

Hinweis:

Zwischen Druckaufträgen, die über das Kontextmenü aktiviert werden, und solchen, die durch Aufruf des PrintJob-Objekts aktiviert werden, findet keine Interaktion statt.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie