Es gibt verschiedene Fälle, in denen Arbeitsabläufe innerhalb der Kampagne nicht starten, wenn auf die Schaltfläche zum Starten geklickt wird. Statt zu starten wechseln die Arbeitsabläufe innerhalb einer Kampagne zum Status „So bald wie möglich starten“.

Umgebung

Alle Campaign V6.0, V6.1.0 und V6.1.1.
Alle Betriebssysteme, z.B. Windows, Linux, Debian.

Ursache

Es kann zwei Ursachen für diesen Fehler geben:

1> Die Grenze für gleichzeitig ablaufende Arbeitsabläufe in einer Kampagne wird erreicht und es können keine neuen Arbeitsabläufe gestartet werden. Dies kann bestätigt werden, indem Sie die Anzahl der in einer Kampagne ausgeführten Workflows überprüfen und den Wert von „NmsOperation_LimitConcurrency“ unter „Plattform“ -> „Optionen“ überprüfen.

Hinweis:

Wenn dieser Grenzwert erreicht ist, bleibt der Arbeitsablauf im Status „so schnell wie möglich starten“, solange die Anzahl der ausgeführten Arbeitsabläufe über dem Grenzwert liegt. Wenn die Zahl unter den Grenzwert fällt, wird der Arbeitsablauf begonnen. Der Status „so schnell wie möglich starten“ ist also nicht von Dauer.

2> Der häufigste Grund dafür, dass Arbeitsabläufe innerhalb einer Kampagne nicht gestartet werden können, ist der Fehler des Kampagnenjobs (Operationmgt)-Arbeitsablaufs. Dies ist ein technischer Arbeitsauflauf im Ordner Kampagnenprozess unter dem Knoten „Administration“ -> „Produktion“ -> „Technische Arbeitsabläufe“. Dieser Arbeitsablauf verwaltet Aufträge oder Workflows in einer Kampagne und führt dazu, dass Arbeitsabläufe nicht gestartet werden bzw. nicht beendet werden.

Sie können diesen Arbeitsablauf neu starten, wenn das Ausführen der Kampagnen-Arbeitsabläufe fehlgeschlagen ist.

Lösung

Für den ersten Fehler können wir Folgendes tun:

>> Erhöhen Sie das Limit für den gemeinsamen Zugriff, wenn es sich um einen geschäftlichen Bedarf handelt; oder wir können erklären, dass der Workflow gestartet wird, sobald der Grenzwert für den gemeinsamen Zugriff wiederhergestellt wird.

Für den zweiten Fehler können wir Folgendes tun:

>> Starten Sie den Arbeitsablauf der „Kampagnenjobs (Operationmgt)“ neu, wenn er fehlgeschlagen ist. Sobald Sie die Anwendung neu gestartet haben, müssen wir sicherstellen, dass wir im Terminplaner „die ausstehenden Aufgaben ausführen“, um zu prüfen, ob sie erneut bei einer der Aktivitäten fehlschlägt.

  • Wenn der Arbeitsablauf angehalten wurde, setzen Sie ihn fort und führen Sie einen Neustart durch, wenn er nach dem Fortsetzen fehlschlägt.
  • Wenn der Arbeitsablauf beendet wurde, starten Sie ihn.
  • Wenn er erneut fehlschlägt, müssen wir das „audit-log“ auf spezifische Fehler prüfen und die entsprechende Fehlerbehebung durchführen.


Beispiel: Sie erhalten möglicherweise einen Fehler wie:

Kampagnenjob-Workflow (operationmgt) ist mit folgendem Fehler fehlgeschlagen:
25/08/2016 17:34: 25 Scheduler JavaScript: Fehler beim Auswerten von Skript „operationMgt/Scheduler“.
25/08/2016 17:34:25 Terminplaner. Es wurde kein Zugriffstoken gefunden, um ein Benutzer-Update durchzuführen.
25/08/2016 17:34:25 Terminplaner. Starten von Ziel-Workflow „xyz_wkf_engage_4“ für Kampagne „01 – Kampagne aktivieren (xyz_engage_campaign)“

Das bedeutet, dass er versucht, den Arbeitsablauf „xyz_wkf_engage_4“ zu starten, aber dazu nicht in der Lage ist. In den meisten Fällen würde dieser Workflow auf einen fertigen Status verweisen und nicht gestartet werden können. Dazu können wir einen bedingungslosen Stopp für den Arbeitsablauf „xyz_wkf_engage_4“ durchführen und dann Kampagnenjobs neu starten (operation mgt).

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