Keine Analytics-Daten aus iOS-Versionen von AEM-Apps
In der Benutzeroberfläche von Adobe Mobile Services sind keine Analytics-Daten in einer AEM-App für iOS sichtbar.

Umgebung

AMS-Anwendungen für iOS-Mobilgeräte

Ursache

Ihre App wurde so eingerichtet, dass HTTPS-Aufrufe zugelassen werden, aber Ihre Adobe Mobile Services ist auf die Verwendung von HTTP für Analytics eingestellt.

Lösung

Analytics für die Verwendung von HTTP einstellen

  1. Melden Sie sich bei http://mobilemarketing.adobe.com an (achten Sie darauf, auf die Option zur Verwendung des Analytics-Kontos zu klicken).
  2. Klicken Sie auf „Apps verwalten“.
  3. Klicken Sie auf den Namen Ihrer App.
  4. Scrollen Sie zu den SDK-Analytics-Optionen.
  5. Aktivieren Sie die Option zur Verwendung von HTTPS.
  6. Scrollen Sie nach unten und klicken Sie auf „Speichern“.
  7. Erstellen Sie Ihre App mit dem AEM Mobile On-demand-Portal neu und stellen Sie diese Aktualisierung Ihren Endbenutzern zur Verfügung.

Weitere Informationen

Wenn Sie das AEM Mobile On-demand-Portal zum Erstellen einer iOS-App verwenden, ist eine der Optionen „Nur HTTPS-Verbindungen zulassen“.

In der Benutzeroberfläche befindet sich über dieser Option folgende Warnung:
„Stellen Sie sicher, dass Ihre Mobile Marketing SDK-Analytics-Optionen auf die Verwendung von HTTPS eingestellt sind, bevor Sie das Häkchen setzen.“ Weitere Informationen". „Weitere Informationen“ ist eine Verknüpfung zu folgender Seite:
https://helpx.adobe.com/de/digital-publishing-solution/help/building-ios-apps.html

Auf dieser Seite steht unter der Abschnittsüberschrift „HTTPS-Verbindung“:
„Wenn Sie nur zugelassene HTTPS-Verbindungen auswählen, erstellen Sie eine Entwicklerversion Ihrer App und testen Sie diese eingehend. Stellen Sie sicher, dass Hyperlinks, dynamische Banner und Anmeldefunktionen ordnungsgemäß funktionieren. Navigieren Sie außerdem zum Adobe Mobile Services Dashboard und konfigurieren Sie Ihre App-Einstellungen für die Verwendung von HTTPS, um sicherzustellen, dass Analytics-Daten ordnungsgemäß bereitgestellt werden. (Siehe Analytics für AEM-Mobilanwendungen: Konfigurieren der Einstellungen für Mobile-Marketing-App.)“

„Konfigurieren der Einstellungen für Mobile-Marketing-App“ ist eine Verknüpfung, die zu dieser Seite und Verankerung führt:
https://helpx.adobe.com/de/digital-publishing-solution/help/analytics.html#configure-mobile-marketing

Auf dieser Seite werden die Schritte und die Reihenfolge aufgeführt, um HTTPS für die Analytics-Dienste, die Ihre App nutzt, zu aktiveren:
„Konfigurieren der Einstellungen für Mobile-Marketing-App
Verwenden Sie das Mobile Marketing Dashboard, um die Analytics-Einstellungen für Ihr Projekt zu konfigurieren. Wenn Sie beispielsweise eine App erstellen, die HTTPS-Domänen statt HTTP erfordert, können Sie die Einstellungen bearbeiten.“

  1. Gehen Sie zu https://mobilemarketing.adobe.com und melden Sie sich an.
  2. Wählen Sie „Apps verwalten“ > „Alle Applikationen“.
  3. Erstellen Sie eine App oder wählen Sie eine App aus.
  4. Ändern Sie nach Wunsch die Einstellungen. Wählen Sie beispielsweise „HTTPS verwenden“, um sicherzustellen, dass Analytics-Aufrufe HTTPS-konform sind.
  5. Nachdem Sie Ihre Einstellungen gespeichert haben, erstellen Sie die App neu. Es ist erforderlich, Ihre App neu zu erstellen, um alle im Mobile Marketing Dashboard getätigten Konfigurationsänderungen zu übernehmen.