Inhalt kann in AEM Mobile iOS-Appversion 2017.9.4 oder 2017.9.5 nicht herunterladen oder aktualisieren

Problem

Nach dem Aktualisieren einer App auf Version 2017.9.4 oder 2017.9.5, können Inhalte nicht heruntergeladen oder angezeigt werden oder es werden veraltete Inhalte angezeigt.

Umgebung

AEM Mobile iOS Appversion 2017.9.4 oder 2017.9.5

Ursache

Der Viewer erwartet den Ablauf des vom Server erhaltenen authToken nach 24 Stunden. Das Token läuft jedoch nach einer Stunde ab. Nach einer Stunde sendet der Viewer weiterhin das abgelaufene Token, das der Server ablehnt.

Lösung

Ein Fix wurde im Rahmen von Hot Fix 2017.11.4 [1] bereitgestellt.
Diesen Fix in das AEM Mobile Preflight im iOS App Store zu bekommen dauert einige Zeit, da er bei Apple durch den Reviewprozess muss. In der Zwischenzeit können Sie testen, indem Sie eine eigene App mit aktiviertem, testbereitem Preflight erstellen. Mehr hierzu bei "Erstellen einer App mit aktiviertem 'Preflight ermöglichen" [2].

[1] https://helpx.adobe.com/digital-publishing-solution/release-note/bug-fix-release-notes.html
[2] https://helpx.adobe.com/digital-publishing-solution/help/preview-content.html

Adobe-Logo

Bei Ihrem Konto anmelden