Campaign-Synchronisation erhält nicht den korrekten HTML-Code von AEM

Nachdem Sie den Workflow „In Adobe Campaign veröffentlichen“ ausgeführt und in Adobe Campaign synchronisiert haben, sehen Sie nicht den richtigen HTML-Code, der in Campaign aufgenommen wird.

Umgebung

AEM 6.x

Ursache

Es kann viele Ursachen für die falsche Bereitstellung des HTML-Codes an Campaign geben.

  • Eine öffentliche URL ist in der AEM Campaign Integration-Konfiguration eingerichtet, welche auf die Seite per CDN, Load Balancer oder Dispatcher kommt.  Wenn in jeder Ebene des architektonischen Stapels etwas fehlerhaft sein könnte, dann ist es ein CDN Cache-Fehler, der Load Balancer weist auf falsche Dispatcher, der Dispatcher ist nicht richtig konfiguriert oder schlägt fehl, oder AEM Publish-Instanzen schlagen mit Fehlermeldungen oder falschem Code fehl.
  • Wenn der Inhalt direkt von einer Veröffentlichungsinstanz bereitgestellt wird, kann dies daran liegen, dass die Veröffentlichungsinstanz falsch konfiguriert ist und Fehler treten auf oder der falsche Code ist installiert usw.

Lösung

  1.  Aktivieren / Veröffentlichen Sie die Newsletterseite in AEM, bevor Sie in Campaign veröffentlichen.

  2. Überprüfen Sie die Öffentliche URL der OSGi-Konfiguration [1] im AEM Campaign-Integration-Dialogfeld, die Öffentliche URL ist diejenige, die der Workflow nutzt, um den HTML-Code abzurufen, der zu Adobe Campaign gesendet wird.  Wenn dieses Feld ausgefüllt ist, kopieren Sie die URL in die Zwischenablage:

    [1] http://host:port/system/console/configMgr/com.day.cq.mcm.campaign.impl.IntegrationConfigImpl

  3. Wenn Öffentliche URL in dieser Konfiguration leer ist, dann wechselt das System über in die URL für Veröffentlichen in der Externalizer-Konfiguration [2] (Failover).  Kopieren Sie diese Veröffentlichen-URL in die Zwischenablage:

    [2] http://host:port/system/console/configMgr/com.day.cq.commons.impl.ExternalizerImpl

  4. Nehmen Sie die URL, die Sie aus den vorherigen Schritten erhalten haben, und rufen Sie die Newsletterseite auf, mit /path/to/newsletter.publish.html der Veröffentlichen-Instanz. 

    Zum Beispiel: /content/site/en/newsletters/test.publish.html

  5. In den meisten Fällen werden Sie feststellen, dass HTML auf die gleiche Weise wie in Campaign nicht korrekt angezeigt wird.  Dies ist die URL, die vom Workflow abgerufen und an Adobe Campaign gesendet wird.  Das Anzeigen dieser URL ermöglicht es Ihnen Fehler zu beheben, wenn das Problem ein Fehler beim CDN-Caching, Belastungsausgleich, Dispatcher-Caching oder in einer AEM Publish-Instanz oder Codeausgabe besteht (d. h. falscher Code wurde in der Veröffentlichungsinstanz eingesetzt).

Adobe-Logo

Bei Ihrem Konto anmelden