Zuletzt aktualisiert am
30. April 2021
Problem
Wenn Indizes mit type = „ordered“ installiert werden, bleibt der asynchrone Indexer hängen.
Wenn ein Upgrade von AEM 6.0, 6.1 oder 6.2 auf 6.3 mit einem Index vom Typ „ordered“ durchgeführt wird, schlägt das Upgrade fehl.
Umgebung
AEM 6.3.
Ursache
In AEM 6.3 wurde die Unterstützung des Indextyps „ordered“ aus dem Oak-Repository entfernt.
Lösung
Löschen Sie Eigenschaftsindizes vom Typ = „ordered“ und ersetzen Sie sie durch äquivalente Lucene-Eigenschaftsindizes.
Siehe diese Dokumentation für Details zu diesem Thema.