Überprüfen Sie die OSGi-Bundle.-Versionen nach Installationen von Upgrades, Service Packs, Feature Packs oder Fix Packs
Mit dem folgenden Tool können Sie überprüfen, ob die Versionen der in Ihrer AEM-Instanz installierten OSGi-Bundles mit den erwarteten Versionen für Ihre AEM-Version und Patches übereinstimmen.  Dies ist hilfreich bei der Validierung erfolgreicher AEM-Upgrades und Service Packs.
 
Anweisungen:
  1. Kopieren / Einfügen des JSON von http://aemhost1:port/system/console/bundles.json in das Textfeld JSON tatsächlich.
  2. Wählen Sie Produktversion und untergeordnete Version aus den beiden Dropdown-Menüs, um das Erwartete JSON Feld automatisch auszufüllen oder kopieren / einfügen JSON aus einer anderen AEM Instanz in das Erwartete JSON Feld (auch von http://aemhost2:port/system/console/bundles.json).
  3. Klicken Sie auf Vergleichen, um die Unterschiede anzuzeigen.
  4. Ähnliche Bundles werden in Weiß dargestellt, unterschiedliche Bundle-Versionen werden in Gelb angezeigt, neu hinzugefügte Bundles werden in Aqua angezeigt und gelöschte Bundles in Hellrot.
  5. Filtern Sie die Daten über das Feld Filter.
Produktversion: Laden...
JSON von /system/console/bundles.json

Ergebnisse des Vergleichs
Filtern:
Symbolischer Name Name des Bundles Erwartete Versionsnummer Aktuelle Versionsnummer

 

 

* Vielen Dank an Sham Sundar Hassan Chikkegowda für die Bereitstellung des Original- Quellcodes für dieses Tool.  Seine persönliche Website kann hier besucht werden.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie