Erfahren Sie, wie Sie Scrolling-Effekte und Deckkraft-Bildlaufeffekte für Seitenelemente in Adobe Muse anwenden können.

Hinweis:

Adobe Muse wird nicht mehr um neue Funktionen ergänzt und der Support wird am 26. März 2020 eingestellt. Detaillierte Informationen und Unterstützung erhalten Sie auf der Seite zum Ende der Produktlebensdauer von Adobe Muse.

Anwenden von Bildlaufeffekten auf Seitenelemente

Das Bildlaufeffekte-Bedienfeld enthält vier verschiedene Registerkarten, über die Sie die Bewegung, die Deckkraft, die Diashow-Widgets und den Adobe Edge Animate-Inhalt steuern können, basierend darauf, wie der Seitenbildlauf durchgeführt wird. Wenn Bildlaufeffekte miteinander angewendet werden und wenn einige Elemente darüber hinaus auch verankert sind, auf 100 % Breite gesetzt sind und/oder im Ebenenbedienfeld über- und hintereinander angeordnet sind, können Sie eine Vielfalt von überzeugenden Effekten erstellen.

Anwenden von Bewegungsbildlaufeffekten über das Bildlaufeffekte-Bedienfeld

Die Benutzeroberfläche des Bildlaufeffekte-Bedienfelds ähnelt dem Bildlaufeffekte-Bedienfeld für Browser-Füllung und Hintergrundfüllung. Führen Sie folgende Schritte aus, um Bildlaufeffekte auf ein Seitenelement mithilfe der Registerkarte „Bewegung“ des Bildlaufeffekte-Bedienfelds anzuwenden:

  1. Wechseln Sie in Muse zur Entwurfsansicht und wählen Sie Seite > Seiteneigenschaften
  2. Legen Sie den Wert für die Mindesthöhe auf ein Minimum von 2000 Pixel fest, um sicherzustellen, dass die Seite für einen Bildlauf lang genug ist. 
  3. Klicken Sie auf „OK“, um Ihre Änderungen zu speichern und um das Dialogfeld „Seiteneigenschaften“ zu schließen.
  4. Zeichnen Sie in der Entwurfsansicht ein Rechteck oder einen Textrahmen auf der Seite.
  5. Verwenden Sie die Registerkarte „Fläche“ des Menüs „Fläche“, um ein gekacheltes oder ein nicht gekacheltes Hintergrundbild hinzuzufügen. Oder wählen Sie eine homogene Flächenfarbe oder eine Verlaufsflächenfarbe aus.
  6. Wählen Sie „Fenster“ > „Bildlaufeffekte“, um das Bildlaufeffekte-Bedienfeld zu öffnen.
Öffnen Sie das Bildlaufeffekte-Bedienfeld, um auf die Bildlaufeffekt-Einstellungen zuzugreifen.
Öffnen Sie das Bildlaufeffekte-Bedienfeld, um auf die Bildlaufeffekt-Einstellungen zuzugreifen.

  1. Aktivieren von Bildlaufeffekten: Im Bildlaufeffekte-Bedienfeld wird die Registerkarte „Bewegung“ (ganz links) angezeigt. Aktivieren Sie bei ausgewähltem Element auf der Seite das Kontrollkästchen „Bewegung“.

    TIPP: Beachten Sie, dass die Aktivierung des Kontrollkästchens „Bewegung“ dem Element einen T-förmigen Griff (Quergriff) hinzufügt, der von der oberen Kante hervorragt. Der Quergriff gibt die Ankerposition für den Bildlaufeffekt im Element an. Der Bildlaufeffekt beginnt, wenn ein Besucher beim Blättern die Ankerposition erreicht.

    Der Quergriff wird standardmäßig über dem Element angezeigt. Sie können aber auch durch Klicken und Ziehen den Griff weiter nach oben ausdehnen, ihn nach unten ziehen, damit er an der oberen Kante des Elements ausgerichtet ist, oder den Griff nach unten unter das Element ziehen.

  2. Den Quergriff positionieren, um die Ankerposition festzulegen: Ziehen Sie den Quergriff, um die Ankerposition festzulegen. Dies ermöglicht es Ihnen, die Bewegung einzurichten, die auftritt, bevor und nachdem die Seite beim Bildlauf die obere Kante des Quergriffes erreicht.

    Alternativ können Sie einen numerischen Wert in das Feld „Ankerposition“ in der Mitte des Bildlaufeffekte-Bedienfelds eingeben, während die Registerkarte „Bewegung“ aktiv ist. Im Bild oben wird die Ankerposition auf 200 Pixel festgelegt. 

    Die Position des T-förmigen Griffs stellt die Ankerposition des Elements dar. Wenn ein vertikaler Bildlauf der Seite durchgeführt wird, werden die Einstellungen im Bereich „Erste Bewegung“ angewendet, sodass die Position des Elements der eigentlichen Position entspricht wie in der Entwurfsansicht gezeigt.

    Wenn der Besucher einen Bildlauf der Seite durchführt oder auf eine Ankerverknüpfung klickt, um hinter die Ankerposition des Elements zu springen, werden die Einstellungen im Abschnitt „Letzte Bewegung“ angewendet.

    Der Abschnitt „Erste Bewegung“ enthält mehrere Pfeile für die vertikale und horizontale Richtung sowie Geschwindigkeitsoptionen.

  3. Vertikale Richtung für die „Erste Bewegung“ einrichten: Wählen Sie eine vertikale Richtung (nach oben oder unten), indem Sie auf eine der Vertikal-Schaltflächen klicken. Geben Sie einen Geschwindigkeitswert im Feld neben den Pfeilen für die vertikale Richtung ein, um die Geschwindigkeit festzulegen, mit der die Bewegung in Bezug auf die Seitenbildlaufgeschwindigkeit erfolgt. Wenn Sie den Wert „0“ eingeben, wird das Element nicht vertikal bewegt. Sie können auch einen Prozentwert eingeben, indem Sie einen Dezimalwert verwenden. Wenn Sie beispielsweise „0,5“ eingeben, wird das Element vertikal in halber Bildlaufgeschwindigkeit bewegt.

  4. Horizontale Richtung für die „Erste Bewegung“ einrichten: Legen Sie die horizontale Richtung (nach links oder rechts) des Bildlaufs für das Element fest, indem Sie auf den Links- oder Rechtspfeil klicken, um die Richtung festzulegen, in der das Element bewegt wird, bevor es die Ankerposition erreicht. Im Feld rechts neben den Horizontal-Pfeilen stellen Sie den Geschwindigkeitswert für die horizontale Richtung ein. Wenn Sie das Element nicht in eine horizontale Richtung bewegen möchten, setzen Sie den Wert für die anfängliche horizontale Geschwindigkeit auf 0.

  5. Wiederholen Sie die Schritte 7 und 8, um die Richtung und die Geschwindigkeit der Bewegung für den Abschnitt „Letzte Bewegung“ festzulegen.

Im folgenden Beispiel unten ist die Ankerposition auf 500 Pixel festgelegt. Wenn der Browser mit dem Bildlauf beginnt, bewegt sich das Element mit 1-facher Geschwindigkeit nach unten an die Position, d. h. mit der gleichen Geschwindigkeit wie der Seitenbildlauf. Das Element erreicht die Position, während auf der Seite ein Bildlauf an die Ankerposition durchgeführt wird. Sobald die Seite über die Ankerposition hinaus läuft, bewegt sich das Element im Vergleich zum Seitenbildlauf in 2-facher Geschwindigkeit nach rechts.

Wenden Sie die Bewegungseinstellungen an, um den Bildlaufeffekt in Adobe Muse festzulegen.
Wenden Sie die Bewegungseinstellungen an, um den Bildlaufeffekt festzulegen.

  1. Klicken Sie auf „Vorschau“ oder „Datei“ > „Seitenvorschau in Browser“, um die Bildlaufeffekte zu testen. Führen Sie einen Bildlauf der Seite nach unten und wieder nach oben durch, um die Bewegung des Elements zu sehen.
  2. Kehren Sie zu Muse zurück oder klicken Sie auf die Schaltfläche „Entwurf“, wenn Sie mit der Prüfung fertig sind, um mit der Bearbeitung der Seite fortzufahren.

Anwenden von Deckkraft-Bildlaufeffekten über das Bildlaufeffekte-Bedienfeld

In diesem Abschnitt lernen Sie, wie Sie Transformationen auf die Sichtbarkeit anwenden können, mit denen die Anzeige eines Elements basierend auf den Bildlaufinteraktionen des Besuchers geändert wird. Dies ist ein nützlicher Weg, um Inhalte anzuzeigen und auszublenden, indem Sie Elemente ein- oder ausblenden, während der Benutzer einen Bildlauf nach unten in einen neuen Bereich der Seite durchführt. Führen Sie die folgenden Schritte aus, um mithilfe der Registerkarte „Deckkraft“ des Bildlaufeffekte-Bedienfelds Bildlaufeffekte anzuwenden, die sich auf die Transparenz eines Seitenelements auswirken:

  1. Stellen Sie während der Bearbeitung einer Seite in der Entwurfsansicht sicher, dass in den Seiteneigenschaften unter der Mindesthöhe ein Pixelwert eingestellt ist, der größer ist als die durchschnittliche Höhe der meisten Monitore, wie etwa 2000 Pixel . Alternativ können Sie der Seite Inhalt hinzufügen, um sicherzustellen, dass sie für einen Bildlauf lang genug ist.
  2. Zeichnen Sie in der Entwurfsansicht ein Rechteck oder einen Textrahmen auf der Seite.
  3. Verwenden Sie die Registerkarte „Fläche“ des Menüs „Fläche“ (oder verwenden Sie das Flächenbedienfeld), um dem ausgewählten Seitenelement ein gekacheltes oder nicht gekacheltes Hintergrundbild hinzuzufügen oder um eine homogene Flächenfarbe oder einen Farbverlauf festzulegen. (Fügen Sie anderenfalls, falls gewünscht, ein Diashow-Widget hinzu oder platzieren Sie eine Adobe Edge Animate OAM-Datei auf der Seite.)
  4. Während das Element ausgewählt ist, klicken Sie auf die Registerkarte „Deckkraft“ (zweite Registerkarte von links) auf dem Bildlaufeffekte-Bedienfeld und aktivieren Sie dann das Kontrollkästchen „Deckkraft“.
Aktivieren Sie das Kontrollkästchen „Deckkraft“, um die Deckkraft-Bildlaufeffekte für das ausgewählte Element zu aktivieren.
Aktivieren Sie das Kontrollkästchen „Deckkraft“, um die Deckkraft-Bildlaufeffekte für das ausgewählte Element zu aktivieren.

Durch Aktivieren der Option „Deckkraft“ wird eine andere Art Griff auf dem Element angezeigt. Genau wie der Quergriff, der verwendet wird, um die Ankerposition in der Registerkarte „Bewegung“ festzulegen, können Sie auf den Griff klicken und ihn ziehen, damit er über dem Element angezeigt wird. Ziehen Sie ihn nach unten, damit er an der oberen Kante (oder über jedem beliebigen Teil des Elements) liegt, oder ziehen Sie ihn nach unten unter das Element. Der Deckkraft-Griff hat drei unterschiedliche Teile, die unabhängig voneinander gezogen werden können, um die Ankerposition sowie die Verblassen-Position 1 und 2 festzulegen.

  1. Klicken und ziehen Sie das mittlere quadratische Teil des Griffs, um die Ankerposition festzulegen. Im Beispiel unten ist die Ankerposition auf 150 Pixel festgelegt.
Legen Sie die Ankerposition fest, indem Sie den mittleren quadratischen Griff vertikal ziehen.
Legen Sie die Ankerposition fest, indem Sie den mittleren quadratischen Griff vertikal ziehen.

  1. Klicken und ziehen Sie den oberen runden Teil des Griffes, um ihn an der gewünschten Position zu platzieren. Im Beispiel unten wird die Verblassen-Position 1 auf 100 Pixel festgelegt.
Festlegen der Verblassen-Position 1 des Deckkraft-Griffs
Klicken und ziehen Sie die obere, linke Seite des Rundgriffs, um die erste Position festzulegen, die sich auf die Transparenz des Elements auswirkt.

  1. Klicken und ziehen Sie den unteren runden Teil des Griffes, um ihn an der gewünschten Position zu platzieren. Im Beispiel unten wird die Verblassen-Position 2 auf 200 Pixel festgelegt.
Festlegen der Verblassen-Position 2 des Deckkraft-Griffs
Klicken und ziehen Sie die obere, rechte Seite des Rundgriffs, um die zweite Position einzustellen, die sich auf die Transparenz des Elements auswirkt.

Hinweis:

Falls erwünscht, kann die Ankerposition neben den Verblassen-Positionsgriffen gezogen werden, um sie auf denselben Wert zu setzen. Anstatt die Griffe zu ziehen, können Sie auch numerische Werte für jedes dieser Felder im Bildlaufeffekte-Bedienfeld eingeben.

In diesem Beispiel ist das Element zu Beginn vollständig transparent und wird immer undurchsichtiger, bis es vollständig deckend ist (der Deckkraftwert für die Ankerposition ist derzeit auf 100 % festgelegt), sobald die Seite die Ankerposition erreicht. Sobald der Bildlauf der Seite über die Ankerposition hinaus geht, wird das Element schrittweise wieder transparenter, um vollständig ausgeblendet zu werden, wenn die Seite über die 200-Pixel-Marke hinaus läuft.

Festlegen des Prozentwerts der Deckkraft für Bildlaufeffekte
Legen Sie auf der Registerkarte „Deckkraft“ des Bildlaufeffekte-Bedienfelds den Prozentwert der Deckkraft fest (wobei 0 % vollständig transparent ist).

  1. Klicken Sie auf „Vorschau“ oder „Datei“ > „Seitenvorschau in Browser“, um die Bildlaufeffekte zu testen. Führen Sie einen Bildlauf der Seite nach unten und wieder nach oben durch, um sich anzusehen, wie sich die Deckkraft des Elements im Verlauf des Seitenbildlaufs ändert.
  2. Kehren Sie zu Muse zurück oder klicken Sie auf die Schaltfläche „Entwurf“, wenn Sie mit der Prüfung fertig sind, um die Seitenbearbeitung fortzusetzen.

Arbeiten mit der Registerkarte „Diashow“ des Bildlaufeffekte-Bedienfelds

Ein anderer häufiger Einsatzbereich für Bildlaufbewegungen besteht darin, die Bildlaufinteraktion mit der Anzeige von Bildern in einer Diashow zu kombinieren. Sie können der Seite ein Diashow-Widget hinzufügen und dann die Registerkarte „Diashow“ des Bildlaufeffekte-Bedienfelds verwenden, um Bildlaufeffekte anzuwenden, z. B. die automatische Anzeige eines neuen Bilds in der Diashow, wenn ein Seitenbildlauf an eine bestimmte Position durchgeführt wird.

Klicken Sie auf die Registerkarte „Diashow“ (dritte Registerkarte von links), um die Einstellungen für diesen Abschnitt zu überprüfen.

Allgemein wird dieser Teil der Bildlaufbewegungsschnittstelle zur Verankerung eines Diashow-Widgets auf der Seite verwendet. Im Allgemeinen wird das Diashow-Widget (unter Verwendung des Menüs „Optionen“) konfiguriert, um nur den größeren Diashow-Container anzuzeigen, während Sie die Miniaturen sowie die Schaltflächen „Weiter“ und „Zurück“ ausblenden.

Mit diesem Effekt lässt sich besonders gut eine Diashow im Vollbildmodus einrichten, obwohl die Art des Diashow-Widgets, das Sie hinzufügen möchten, letztendlich vom Design der Site abhängig ist.

Führen Sie folgende Schritte aus, um Bildlaufeffekte auf ein Diashow-Widget anzuwenden:

  1. Aktualisieren Sie den Wert für die Mindesthöhe im Dialogfeld „Seiteneigenschaften“, um die Seite lang genug für einen Bildlauf zu machen. Alternativ können Sie Inhalte hinzufügen, um eine längere Seite zu erstellen.
  2. Ziehen Sie ein Diashow-Widget aus der Widgets-Bibliothek auf die Seite. Verwenden Sie das Menü „Optionen“, um die Diashow-Optionen zu konfigurieren. (Wenn Sie Bildlaufeffekte auf Diashow-Widgets anwenden, sind die Optionen „Weiter“, „Zurück“ und „Miniaturen“ normalerweise deaktiviert.)
  3. Fügen Sie dem Diashow-Widget Bilder hinzu, indem Sie im Menü „Optionen“ neben dem Abschnitt „Bilder“ auf den Ordner klicken. Navigieren Sie, um die Bilder auszuwählen, die Sie von Ihrem Computer hinzufügen möchten, um die Bildergalerie zu füllen.
  4. Verwenden Sie die Verankerungsschnittstelle im Steuerungsbedienfeld, um die Diashow an der aktuellen Position im Browserfenster zu verankern. Klicken Sie bei ausgewählter Diashow auf eine der sechs Ankerpositionen.
Anwenden von Bildlaufeffekten auf Diashow-Widgets
Verankern Sie das Diashow-Widget an einer bestimmten Position, damit es bei einem Bildlauf im Browserfenster an dieser Position bleibt.

Nachdem Sie die Diashow hinzugefügt und konfiguriert haben, können Sie Bildlaufeffekte hinzufügen.

Aktivieren Sie in der Registerkarte „Diashow“ des Bildlaufeffekte-Bedienfelds das Kontrollkästchen „Diashow“, während das Diashow-Widget ausgewählt ist.

Aktivieren Sie die Option „Diashow“ im Bildlaufeffekte-Bedienfeld.
Wählen Sie das Diashow-Widget aus und aktivieren Sie die Option „Diashow“ im Bildlaufeffekte-Bedienfeld.

Beachten Sie, dass der Diashow der Griff für die Ankerposition in der Entwurfsansicht hinzugefügt wird, sobald die Option „Diashow“ aktiviert ist. Wenn Sie die Werte für die Bildlaufankerpositionen aktualisieren möchten, können Sie die linke und die rechte Seite des Griffes ziehen oder numerische Werte in das Feld „Ankerpositionen für Bildlaufbewegung“ eingeben. Sie können im Bildlaufeffekte-Bedienfeld auch auf die Nach-oben- und Nach-unten-Pfeile klicken, um den numerischen Wert zu erhöhen oder zu verringern.

Die Registerkarte „Diashow“ im Bildlaufeffekte-Bedienfeld enthält zwei Schaltflächen für zwei verschiedene Arten, wie Sie die Wiedergabe der Diashowbilder steuern können. Sie können die Diashow so einrichten, dass sie automatisch abgespielt wird oder dass sie die Bilder schrittweise gemäß dem Bildlauf durchlaufen wird.

Die erste Möglichkeit besteht darin, die gewünschte Ankerposition festzulegen und dann das Kontrollkästchen „Automatisch abspielen“ zu aktivieren.

Wenn auf der Seite ein Bildlauf über die Ankerposition hinaus durchgeführt wird (oder wenn der Besucher auf einen Link zu einem Anker-Tag klickt und somit zu einer Stelle auf der Seite unterhalb der Ankerposition wechselt), wird die Diashow abgespielt. Die Funktion zum automatischen Abspielen zeigt weiterhin die Bilder an und durchläuft sie so lange, bis wieder ein Seitenbildlauf an eine Stelle oberhalb der Ankerposition durchgeführt wird oder bis der Besucher die Seite verlässt.

In dem Beispiel im Bild oben wird die Diashow abgespielt, sobald beim Seitenbildlauf die 100-Pixel-Marke (oder eine beliebige Stelle unter dieser Ankerposition) erreicht wird. Wenn der Besucher wieder einen Seitenbildlauf nach oben durchführt, wird die Diashow angehalten, wenn beim Seitenbildlauf an eine Position über der Ankerposition gelangt (99 Pixel oder weniger).

Die zweite Möglichkeit, das Diashow-Widget zu steuern, besteht darin, die Ankerposition festzulegen und dann das Optionsfeld „Wechseln der Folien jede“ zu aktivieren. In diesem Workflow legen Sie auch die Anzahl der Pixel im Feld unter dem Optionsfeld fest, um anzugeben, wie häufig die Bilder in der Diashow durchlaufen werden, basierend darauf, wie weit die Seite nach unten verschoben wird.

Beispielsweise können Sie ein Diashow-Widget auf einer längeren Seite verankern, damit es an einer festen Position bleibt, während die anderen Seiteninhalte sich beim Bildlauf bewegen. Wenn Sie einen numerischen Wert für die Option „Wechseln der Folien jede“ festlegen, können Sie die Diashow so einrichten, dass sie jedes Mal, wenn ein Bildlauf nach unten an die angegebene Pixelmarke durchgeführt wird, zum nächsten Bild im Satz wechselt.

Im Bild oben wird die Ankerposition auf 200 festgelegt. Nachdem für die Seite ein Bildlauf an eine Stelle unter der 200-Pixel-Marke von der oberen Kante durchgeführt wird, wird das nächste Bild in der Serie in der Diashow jedes Mal angezeigt, wenn die Seite um weitere 30 Pixel verschoben wird.

Festlegen von Bildlaufeffekten für Diashows in Adobe Muse
Legen Sie die Diashow so fest, dass sie jedes Mal zum nächsten Bild wechselt, wenn ein Seitenbildlauf um eine bestimmte Pixelanzahl durchgeführt wird.

Arbeiten mit der Registerkarte „Adobe Edge Animate“ des Bildlaufeffekte-Bedienfelds

Adobe Edge Animate ist ein intuitives Designwerkzeug, mit dem Sie HTML5-basierte Webanimationen erstellen können. Mithilfe der Benutzeroberfläche von Edge Animate können Sie Kompositionen erstellen, die in Schleife geschaltete bewegte Grafiken und Symbole enthalten. Die Animationen, die Sie mit Adobe Edge Animate erstellen, können als OAM-Dateien exportiert und anschließend in den Seiten Ihrer Muse-Site platziert werden. Mit Edge Animate erstellte Animationen werden in einem Browser abgespielt, ohne dass ein Zusatzmodul erforderlich ist.

Wenn Sie Animationen in Adobe Edge Animate erstellen, ziehen Sie Elemente auf die Bühne und ändern Sie deren Bewegungen mittels einer Zeitleiste. Sie können Elemente direkt der Hauptzeitleiste hinzufügen und darüber hinaus auch verschachtelte Elemente mit Unterelementen erstellen, die anhand ihrer eigenen internen Zeitleisten wiedergegeben werden. Weitere Informationen zum Arbeiten mit Adobe Edge Animate finden Sie auf der Adobe Edge Animate-Produktseite. Schauen Sie sich auch die Adobe Edge Animate-Videotutorials auf Adobe TV an.

Um mit der Adobe Edge Animate-Bildlaufbewegungsfunktion zu arbeiten, besteht der erste Schritt darin, speziell für diesen Zweck eine Komposition zu entwickeln. Bildlaufeffekte können auf OAM-Dateien angewendet werden, um sich auf die Animationen auszuwirken, die auf der Hauptzeitleiste platziert werden. Durch strategisches Entwerfen der Animationen, sodass sich nur die Elemente, die sich bei einem Bildlauf bewegen sollen, auf der Hauptzeitleiste befinden (während alles andere in der Animation in den Zeitleisten des verschachtelten Symbols platziert wird), können Sie interaktive Animationen erstellen. Beim Durchführen des Bildlaufs steuern die Bildlaufeffekt-Einstellungen nur die Wiedergabe der animierten Elemente auf der Hauptzeitleiste.

Weitere Informationen zur Erstellung von Animationen, insbesondere für Adobe Muse-Sites, finden Sie unter Hinzufügen von Adobe Edge Animate-Inhalten.

Führen Sie folgende Schritte aus, um mit der Registerkarte „Diashow“ im Bildlaufeffekte-Bedienfeld zu arbeiten:

  1. Exportieren Sie die OAM-Datei aus Adobe Edge Animate und speichern Sie sie in Ihrem Site-Ordner.
  2. Starten Sie Muse und doppelklicken Sie auf eine Seite, um sie in der Entwurfsansicht zu öffnen. Stellen Sie sicher, dass die Seite lang genug ist, um einen Bildlauf durchzuführen, indem Sie die Einstellungen für die Mindesthöhe im Dialogfeld „Seiteneigenschaften“ aktualisieren oder indem Sie Seiteninhalt hinzufügen, um eine längere Seite zu erstellen.
  3. Wählen Sie „Datei“ > „Platzieren“ und navigieren Sie zur OAM-Datei im Site-Ordner.
  4. Öffnen Sie das Bildlaufeffekte-Bedienfeld. Klicken Sie auf die Registerkarte „Adobe Edge Animate“ (vierte Registerkarte von links), um die Einstellungen für diesen Abschnitt zu überprüfen.
  5. Aktivieren Sie bei ausgewählter OAM-Datei das Kontrollkästchen „Edge Animate“.
Festlegen von Bildlaufeffekten für Animationen in Adobe Muse
Legen Sie die Edge Animate-Animation so fest, dass sie abgespielt wird, wenn ein Seitenbildlauf zu einer bestimmten Position durchgeführt wird, oder richten Sie sie so ein, dass der Frame bei jedem Seitenbildlauf um eine bestimmte Pixelanzahl wechselt.

Im Bild oben wird die Ankerposition auf 50 Pixel festgelegt. Sie können den Quergriff ziehen oder einen anderen Wert in das Feld „Ankerposition“ eingeben, um sie anzupassen.

Nach dem Einstellen der Ankerposition können Sie die Wiedergabe der Animation mithilfe von zwei Optionen steuern:

  • Automatisch abspielen: Wenn diese Option aktiviert ist, wird die Animation in der Hauptzeitleiste abgespielt, sobald im Browser ein Bildlauf an die Ankerposition durchgeführt wird, unabhängig von der Anzahl der Frames in der Hauptzeitleiste. Die Animation wird so lange weiter abgespielt, bis ein Seitenbildlauf an eine Position über der Ankerposition durchgeführt wird.
  • Anzeige wechseln alle: Wenn diese Option ausgewählt ist, wechselt die Hauptzeitleistenanimation 1 Frame weiter, sobald ein Seitenbildlauf an eine Stelle hinter einer bestimmten Anzahl Pixel durchgeführt wird. Wenn Sie beispielsweise eine Seite mit einer Höhe von 3000 Pixel erstellen und den Wert 10 eingeben, wird die Hauptzeitleistenanimation beim Seitenbildlauf mit einer Geschwindigkeit von 1 Frame alle 10 Pixel abgespielt. Wenn der Besucher den Seitenbildlauf schneller durchführt, erhöht sich die Animationsrate.

Hinweis:

Alle animierten Objekte, die von der Hauptzeitleiste in der Adobe Edge Animate-Komposition verknüpft oder eingebettet sind, werden von den Bildlaufbewegungseffekteinstellungen nicht beeinflusst. Daher können Sie sich entweder für einen statischen Hintergrund entscheiden oder verschachtelte Elemente in einer kontinuierlichen Schleife schalten, die sich konsistent bewegen, unabhängig vom Eingriff des Benutzers, der den Seitenbildlauf durchführt.

  1. Nachdem Sie die Einstellungen in der Registerkarte „Edge Animate“ des Bildlaufeffekte-Bedienfelds ausgewählt haben, wählen Sie „Datei“ > „Seitenvorschau in Browser“ (oder klicken Sie auf die Schaltfläche „Vorschau“). Testen Sie die Seite, indem Sie einen Bildlauf nach oben und nach unten durchführen, um die Wiedergabe des Inhalts der Edge Animate-Animation (die der Hauptzeitleiste hinzugefügt wurde) anzuzeigen.
  2. Wenn Sie Änderungen vornehmen müssen, kehren Sie zu Muse zurück (oder klicken Sie auf die Schaltfläche „Entwurf“) und aktualisieren Sie die Einstellungen im Bildlaufeffekte-Bedienfeld.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie