Search assets

  1. Adobe Premiere Pro User Guide
  2. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Release Notes | Premiere Pro
    4. Premiere Pro system requirements
    5. Keyboard shortcuts in Premiere Pro
    6. Accessibility in Premiere Pro
  3. Creating projects
    1. Creating projects
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  4. Workspaces and workflows
    1. Workspaces
    2. Working with Panels
    3. Windows touch and gesture controls
  5. Capturing and importing
    1. Capturing
      1. Capturing and digitizing footage
      2. Capturing HD, DV, or HDV video
      3. Batch capturing and recapturing
      4. Setting up your system for HD, DV, or HDV capture
    2. Importing
      1. Transferring and importing files
      2. Importing still images
      3. Importing digital audio
    3. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    4. Supported file formats
    5. Digitizing analog video
    6. Working with timecode
  6. Editing
    1. Sequences
      1. Create and change sequences
      2. Add clips to sequences
      3. Rearrange clips in a sequence
      4. Find, select, and group clips in a sequence
      5. Edit from sequences loaded into the Source Monitor
      6. Rendering and previewing sequences
      7. Working with markers
      8. Scene edit detection
    2. Video
      1. Create and play clips
      2. Trimming clips
      3. Synchronizing audio and video with Merge Clips
      4. Render and replace media
      5. Undo, history, and events
      6. Freeze and hold frames
      7. Working with aspect ratios
    3. Audio
      1. Overview of audio in Premiere Pro
      2. Audio Track Mixer
      3. Adjusting volume levels
      4. Editing, repairing, and improving audio using Essential Sound panel
      5. Monitor clip volume and pan using Audio Clip Mixer
      6. Audio balancing and panning
      7. Advanced Audio - Submixes, downmixing, and routing
      8. Audio effects and transitions
      9. Working with audio transitions
      10. Apply effects to audio
      11. Measure audio using the Loudness Radar effect
      12. Recording audio mixes
      13. Editing audio in the timeline
      14. Audio channel mapping in Premiere Pro
      15. Use Adobe Stock audio in Premiere Pro
    4. Advanced editing
      1. Multi-camera editing workflow
      2. Editing workflows for feature films
      3. Set up and use Head Mounted Display for immersive video in Premiere Pro
      4. Editing VR
    5. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
  7. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Automatically reframe video for different social media channels
      5. Color correction effects
      6. Change duration and speed of clips
      7. Adjustment Layers
      8. Stablilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  8. Graphics, Titles, and Animation
    1. Graphics and titles
      1. Create titles and motion graphics
      2. Applying text gradients in Premiere Pro
      3. Using Motion Graphics templates for titles
      4. Replace images or videos in Motion Graphics templates
      5. Use data-driven Motion Graphics templates
      6. Best Practices: Faster graphics workflows
      7. Add Responsive Design features to your graphics
      8. Working with captions
      9. Speech to Text
      10. Speech to Text in Premiere Pro | FAQ
      11. Upgrade Legacy titles to Source Graphics
    2. Animation and Keyframing
      1. Adding, navigating, and setting keyframes
      2. Animating effects
      3. Use Motion effect to edit and animate clips
      4. Optimize keyframe automation
      5. Moving and copying keyframes
      6. Viewing and adjusting effects and keyframes
  9. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  10. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Get creative with color using Lumetri looks
    3. Adjust color using RBG and Hue Saturation Curves
    4. Correct and match colors between shots
    5. Using HSL Secondary controls in the Lumetri Color panel
    6. Create vignettes
    7. Lumetri scopes
    8. Display Color Management
    9. HDR for broadcasters
    10. Enable DirectX HDR support
  11. Exporting media
    1. Workflow and overview for exporting
    2. Quick export
    3. Exporting for the Web and mobile devices
    4. Export a still image
    5. Exporting projects for other applications
    6. Exporting OMF files for Pro Tools
    7. Export to Panasonic P2 format
    8. Exporting to DVD or Blu-ray Disc
    9. Best Practices: Export faster
  12. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  13. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Using Productions
    8. How clips work across projects in a Production
    9. Consolidate, transcode, and archive projects
    10. Managing metadata
    11. Best Practices
      1. Best Practices: Working with Productions
      2. Best Practices: Learning from broadcast production
      3. Best Practices: Working with native formats
  14. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset preferences
    3. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    4. Check if your system is compatible with Premiere Pro
    5. Premiere Pro for Apple silicon
    6. Eliminate flicker
    7. Interlacing and field order
    8. Smart rendering
    9. Control surface support
    10. Best Practices: Working with native formats
    11. Knowledge Base
      1. Green and pink video in Premiere Pro or Premiere Rush
      2. How do I manage the Media Cache in Premiere Pro?
      3. Fix errors when rendering or exporting
      4. Troubleshoot issues related to playback and performance in Premiere Pro
  15. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline media

Manage media easily in Premiere Pro, even in complex projects! Use powerful search options like metadata-based Search Bins and the handy Timeline Search.

An important post-production task is locating and managing your media clips and assets.

Premiere Pro provides several search options to help find you media files easily even in complex projects, making you spend less time on searching and more time on editing.

Search options in Premiere Pro

Find dialog

You can use the Find dialog in Premiere Pro to search for items in a project. You can specify the search criteria to be a single property or a combination of properties.

You cannot, however, save the searches that you perform using the Find dialog. That is, once you clear the search criteria, you lose the search results.

Search Bins

Premiere Pro provides Search Bins that offer powerful metadata searching capabilities. When you search for items in the Project Panel, you can associate a Search Bin with your search query. The search results stay up to date with items that meet the search criteria.

Search in Timeline

Timeline Search is an invaluable time saver that lets you manage complex Timelines more easily. You can find and select clips within a sequence based on specific search criteria.

Find assets using the Find dialog

The FInd dialog lets you perform both simple and detailed searches. You can locate any assets in your project that meet criteria you specify. For example, you can search for a video clip that has a certain word in its Name column and a phrase in its Comment column.

  1. Do one of the following:
    • Click the Find icon (magnifying glass) at the bottom of the Project panel.
    • Select the Project panel, and press Ctrl + F (Windows), or Command + F (Mac OS).
  2. In the Find dialog box, select the name of the columns to search from the menus under Column.
  3. Select the appropriate operators from the menus under Operator.
  4. Type in the characters you want to find in the specified columns in their respective Find What fields.
  5. If you’re searching for two criteria simultaneously, do one of the following:
    • To find assets that match both criteria, select All from the Match menu.
    • To find assets that match either criteria, select Any from the Match menu.
    Note:

    Select the Case Sensitive check box to perform a case-sensitive search.

  6. Click Find.

Find assets using Search Bins

You can create a Search Bin that displays a collection of project items matching your search criteria. Search Bins are updated automatically when importing assets, deleting assets, or modifying asset metadata.

Search Bins appear in the Project panel like other regular bins, and are denoted by the Search Bin icon .

Note:

Search Bins display aliases of the original project items and not copied media, so no media duplication occurs.

Create a Search Bin

  1. Do one of the following:

    • Select New Search Bin from the Project panel's pop-up menu or context menu.
    • Select File > New > Search Bin.
  2. In the Search Bin dialog, enter the search criteria in the Find field.

  3. In the Search Bin dialog, you can search across all the metadata used in your project or restrict your search to specific metadata properties.

Important notes about Search Bins

  • If a project item appearing in a Search Bin is deleted from the project. Or, if metadata is changed that causes an item to no longer match the Search Bin's search criteria, the item is removed from the Search Bin.
  • When you specify a single metadata property, the search is restricted only to clip metadata. When you select the following metadata properties, you can search across both clip and file metadata.
    • Name
    • Tape Name
    • Description
    • Comment
    • Log Note
    • Scene
    • Shot
    • Client

Save a search query as a Search Bin

To create a Search Bin from a search query, follow these steps.

  1. Enter your search query in the Search field of the project panel.

    Note:

    As you type each new letter in the search query, the search results update dynamically.

  2. Click the Search Bin icon next to the Search field.

The name of the Search Bin that is created matches the entered search query.

A. Type search query B. Click to create Search Bin from query C. Search Bin displaying assets matching search criteria 

Rename a Search Bin

To rename a Search Bin, right-click (Win) or Ctrl-click (Mac) the Search Bin, and select Rename. The new name that you enter does not change the search criteria of the Search Bin.

Revise the contents of a Search Bin

You cannot modify the contents of a Search Bin like other regular bins in the Project panel. You need to revise the search criteria of a Search Bin to change its contents.

  1. In the Project panel, select Edit Search Bin from the context menu of the Search Bin.
  2. In the Edit Search Bin dialog, revise the search criteria as required.
  3. Click OK after specifying the revised search criteria.

Delete a Search Bin

To delete a Search Bin, select the Search Bin to delete, and select Clear from the context menu. You can drag the Search Bin to the Trash icon , or simply press Delete on your keyboard.

Note:

Deleting a Search Bin deletes only the aliases of the project items and not the original project items.

Find assets using Timeline Search

Timeline Search provides you advanced search options that let you easily find and manage clips in complex Timelines.

With a Timeline panel active, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).

The Find dialog that appears is similar to the Project panel's Find dialog. You can find and select clips within a sequence based on a a single property, like clip name, marker name, or use a combination of properties.

  1. In the Find dialog box, select the name of the columns to search from and the appropriate operators.

  2. Type in the characters you want to find in the specified columns in their respective Find fields.

    Note:

    Select the Case Sensitive check box to perform a case-sensitive search.

  3. Click Find or press Enter on the keyboard. Premiere Pro selects and moves the playhead to the clip on the Timeline and closes the Find dialog.

  4. To find the next instance of clip matching the search criteria, select Edit > Find Next. The playhead moves to next clip in the Timeline matching the search criteria and selects it.

Find and select all clips in a sequence matching search criteria

  1. With the Timeline panel active for a selected sequence, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).
  2. Enter the search criteria.
  3. Press Find All.

Premiere Pro closes the Find Dialog, moves the playhead to the first matching clip, and selects all matching clips.

Find a sequence marker with text matching search criteria

  1. With the Timeline panel active for a selected sequence, select Edit > Find. Or use the keyboard shortcut Ctrl+F (Windows), or Command+F (Mac).
  2. Select Markers from the Search pop-up menu, and enter the search criteria in the Find field.
  3. Click Find or press Enter on the keyboard. Premiere Pro closes the Find dialog and moves the playhead to the first marker matching the search criteria.
  4. Select Edit > Find Next to move the playhead to the next marker matching the search criteria.
Adobe logo

Sign in to your account