User Guide Cancel

Ingest and Proxy Workflow in Adobe Premiere Pro

  1. Adobe Premiere Pro User Guide
  2. Beta releases
    1. Beta Program Overview
    2. Premiere Pro Beta Home
    3. Beta features
      1. New Spectrum UI
      2. Free stock audio from Adobe Stock 
  3. Getting started
    1. Get started with Adobe Premiere Pro
    2. What's new in Premiere Pro
    3. Best practices for updating Premiere Pro
    4. Keyboard shortcuts in Premiere Pro
    5. Accessibility in Premiere Pro
    6. Frequently asked questions
    7. Release notes
  4. Hardware and operating system requirements
    1. Hardware recommendations
    2. System requirements
    3. GPU and GPU Driver requirements
    4. GPU Accelerated Rendering & Hardware Encoding/Decoding
  5. Creating projects
    1. Start a new project
    2. Open projects
    3. Move and delete projects
    4. Work with multiple open projects
    5. Work with Project Shortcuts
    6. Backward compatibility of Premiere Pro projects
    7. Open and edit Premiere Rush projects in Premiere Pro
    8. Best Practices: Create your own project templates
  6. Workspaces and workflows
    1. Workspaces
    2. Import and export FAQs
    3. Working with Panels
    4. Windows touch and gesture controls
    5. Use Premiere Pro in a dual-monitor setup
  7. Frame.io
    1. Install and activate Frame.io
    2. Use Frame.io with Premiere Pro and After Effects
    3. Integrate Adobe Workfront and Frame.io
    4. Share for review with Frame.io
    5. Invite collaborators to co-edit a project
    6. Frequently asked questions
  8. Import media
    1. Importing
      1. Transfer files
      2. Importing still images
      3. Importing digital audio
    2. Importing from Avid or Final Cut
      1. Importing AAF project files from Avid Media Composer
      2. Importing XML project files from Final Cut Pro 7 and Final Cut Pro X
    3. File formats
      1. Supported file formats
      2. Support for Blackmagic RAW
    4. Working with timecode
  9. Editing
    1. Edit video
    2. Sequences
      1. Create and change sequences
      2. Set In and Out points in the Source Monitor
      3. Add clips to sequences
      4. Rearrange and move clips
      5. Find, select, and group clips in a sequence
      6. Remove clips from a sequence
      7. Change sequence settings
      8. Edit from sequences loaded into the Source Monitor
      9. Simplify sequences
      10. Rendering and previewing sequences
      11. Working with markers
      12. Source patching and track targeting
      13. Scene edit detection
    3. Cut and trim clips
      1. Split or cut clips
      2. Trim clips
      3. Edit in Trim mode
      4. Perform J cuts and L cuts
      5. Create and play clips
      6. Adjust Trimming and Playback preferences
    4. Video
      1. Synchronizing audio and video with Merge Clips
      2. Render and replace media
      3. Undo, history, and events
      4. Freeze and hold frames
      5. Working with aspect ratios
    5. Audio
      1. Overview of audio in Premiere Pro
      2. Edit audio clips in the Source Monitor
      3. Audio Track Mixer
      4. Adjusting volume levels
      5. Edit, repair, and improve audio using Essential Sound panel
      6. Enhance Speech
      7. Enhance Speech FAQs
      8. Audio Category Tagging
      9. Automatically duck audio
      10. Remix audio
      11. Monitor clip volume and pan using Audio Clip Mixer
      12. Audio balancing and panning
      13. Advanced Audio - Submixes, downmixing, and routing
      14. Audio effects and transitions
      15. Working with audio transitions
      16. Apply effects to audio
      17. Measure audio using the Loudness Radar effect
      18. Recording audio mixes
      19. Editing audio in the timeline
      20. Audio channel mapping in Premiere Pro
      21. Use Adobe Stock audio in Premiere Pro
    6. Text-Based Editing
      1. Text-Based Editing
      2. Text-Based Editing FAQs
    7. Advanced editing
      1. Multi-camera editing workflow
      2. Editing VR
    8. Best Practices
      1. Best Practices: Mix audio faster
      2. Best Practices: Editing efficiently
      3. Editing workflows for feature films
  10. Video Effects and Transitions
    1. Overview of video effects and transitions
    2. Effects
      1. Types of effects in Premiere Pro
      2. Apply and remove effects
      3. Effect presets
      4. Metadata effect in Premiere Pro
      5. Automatically reframe video for different social media channels
      6. Color correction effects
      7. Effects Manager
      8. Change duration and speed of clips
      9. Adjustment Layers
      10. Stabilize footage
    3. Transitions
      1. Applying transitions in Premiere Pro
      2. Modifying and customizing transitions
      3. Morph Cut
  11. Titles, Graphics, and Captions    
    1. Overview of the Essential Graphics panel
    2. Graphics and Titles
      1. Create a title
      2. Linked and Track Styles
      3. Working with style browser
    3. Graphics
      1. Create a shape
      2. Draw with the Pen tool
      3. Align and distribute objects
      4. Change the appearance of text and shapes
      5. Apply gradients
      6. Add Responsive Design features to your graphics
      7. Install and use Motion Graphics templates
      8. Replace images or videos in Motion Graphics templates
      9. Use data-driven Motion Graphics templates
    4. Captions
      1. Speech to Text
      2. Download language packs for transcription
      3. Working with captions
      4. Check spelling and Find and Replace
      5. Export text
      6. Speech to Text FAQs
    5. Best Practices: Faster graphics workflows
    6. Retiring the Legacy Titler FAQs
    7. Upgrade Legacy titles to Source Graphics
  12. Fonts and emojis
    1. Color fonts
    2. Emojis
  13. Animation and Keyframing
    1. Adding, navigating, and setting keyframes
    2. Animating effects
    3. Use Motion effect to edit and animate clips
    4. Optimize keyframe automation
    5. Moving and copying keyframes
    6. Viewing and adjusting effects and keyframes
  14. Compositing
    1. Compositing, alpha channels, and adjusting clip opacity
    2. Masking and tracking
    3. Blending modes
  15. Color Correction and Grading
    1. Overview: Color workflows in Premiere Pro
    2. Color Settings
    3. Auto Color
    4. Get creative with color using Lumetri looks
    5. Adjust color using RGB and Hue Saturation Curves
    6. Correct and match colors between shots
    7. Using HSL Secondary controls in the Lumetri Color panel
    8. Create vignettes
    9. Looks and LUTs
    10. Lumetri scopes
    11. Display Color Management
    12. Timeline tone mapping
    13. HDR for broadcasters
    14. Enable DirectX HDR support
  16. Exporting media
    1. Export video
    2. Export Preset Manager
    3. Workflow and overview for exporting
    4. Quick export
    5. Exporting for the Web and mobile devices
    6. Export a still image
    7. Exporting projects for other applications
    8. Exporting OMF files for Pro Tools
    9. Export to Panasonic P2 format
    10. Export settings
      1. Export settings reference
      2. Basic Video Settings
      3. Encoding Settings
    11. Best Practices: Export faster
  17. Collaborative editing
    1. Collaboration in Premiere Pro
    2. Get started with collaborative video editing
    3. Create Team Projects
    4. Add and manage media in Team Projects
    5. Invite and manage collaborators
    6. Share and manage changes with collaborators
    7. View auto saves and versions of Team Projects
    8. Manage Team Projects
    9. Linked Team Projects
    10. Frequently asked questions
  18. Long form and Episodic workflows
    1. Long Form and Episodic Workflow Guide
    2. Using Productions
    3. How clips work across projects in a Production
    4. Best Practices: Working with Productions
  19. Working with other Adobe applications
    1. After Effects and Photoshop
    2. Dynamic Link
    3. Audition
    4. Prelude
  20. Organizing and Managing Assets
    1. Working in the Project panel
    2. Organize assets in the Project panel
    3. Playing assets
    4. Search assets
    5. Creative Cloud Libraries
    6. Sync Settings in Premiere Pro
    7. Consolidate, transcode, and archive projects
    8. Managing metadata
    9. Best Practices
      1. Best Practices: Learning from broadcast production
      2. Best Practices: Working with native formats
  21. Improving Performance and Troubleshooting
    1. Set preferences
    2. Reset and restore preferences
    3. Recovery Mode
    4. Working with Proxies
      1. Proxy overview
      2. Ingest and Proxy Workflow
    5. Check if your system is compatible with Premiere Pro
    6. Premiere Pro for Apple silicon
    7. Eliminate flicker
    8. Interlacing and field order
    9. Smart rendering
    10. Control surface support
    11. Best Practices: Working with native formats
    12. Knowledge Base
      1. Known issues
      2. Fixed issues
      3. Fix Premiere Pro crash issues
      4. Unable to migrate settings after updating Premiere Pro
      5. Green and pink video in Premiere Pro or Premiere Rush
      6. How do I manage the Media Cache in Premiere Pro?
      7. Fix errors when rendering or exporting
      8. Troubleshoot issues related to playback and performance in Premiere Pro
  22. Extensions and plugins
    1. Installing plugins and extensions in Premiere Pro
    2. Latest plugins from third-party developers
  23. Video and audio streaming
    1. Secure Reliable Transport (SRT)
  24. Monitoring Assets and Offline Media
    1. Monitoring assets
      1. Using the Source Monitor and Program Monitor
      2. Using the Reference Monitor
    2. Offline media
      1. Working with offline clips
      2. Creating clips for offline editing
      3. Relinking offline media

Learn how the ingest and proxy workflow works in Premiere Pro, and how to create custom presets for ingest and proxy.

Note:

Starting December 11, 2023, new users and organizations will not be entitled to Creative Cloud Synced files. Starting February 1, 2024, Creative Cloud Synced files will be discontinued for personal accounts that existed before December 11, 2023 (learn more here). Starting October 1, 2024, Creative Cloud Synced files will be discontinued for business accounts associated with organizations that existed before December 11, 2023 (learn more here).

New Media Management features in both Premiere Pro and Adobe Media Encoder give you much greater control over the handling of your files during the ingest process, and allow more flexibility when working with large media files.

You can set Premiere Pro to copy media to a specific location on your machine as it imports and even begin editing immediately while your media copies in the background. If your workflow requires a transcode, you can easily set Premiere Pro or Adobe Media Encoder to handle that step.

Premiere Pro also supports more native formats than ever, including 6K and 8K files from the RED Weapon camera. This is useful when the media you work with is more demanding on your computer system than it can manage. For example, when you want to work on a lightweight, portable device, you can generate proxies on ingest, automatically associating them with the native full-resolution media. A single click lets you toggle between full-res and proxy clips.

Ingest Settings & Media Browser

The Premiere Pro Media Browser panel allows you to ingest media automatically in the background while you begin editing. 

An ingest check box in the Media Browser panel toggles on/off the automatic ingest behavior. A settings button next to it opens the Project Settings dialog box, where you can adjust the ingest settings. A similar ingest check box in the Project Settings dialog box is in sync with the Media Browser panel’s setting. When toggled on, you can choose one of four operations to begin automatically when files are imported into the project. You can continue to edit while the ingest process is complete in the background.

Copy 

You can copy the media as it is to a new location. For example, this option is typically used to transfer camera footage from removable media onto your local hard drive. The Primary Destination option in Ingest Settings specifies the transfer path. After the media is copied, the clips in the project point to these copies of the files.

Transcode 

You can transcode the media to a new format in a new location. For example, this option is typically used to transcode original camera footage to a specific format used within a post-production facility. The file path is specified by the Primary Destination option in Settings, and the format is specified by the chosen preset and frame size. After the media has been transcoded, the clips in the project point to these transcoded copies of the files. 

Create Proxies 

Use this option to create and attach proxies to the media. For example, this option is used to create lower-resolution clips for increased performance during editing, which can be switched back to the original full resolution files for final output. The file path where the proxies are generated is specified by the Proxy Destination option in the settings, and the format is specified by the chosen preset and frame size. After proxies have been generated, they are automatically attached to the clips in the project.

Copy and Create Proxies 

This option copies media and creates proxies for them as well, as specified above. 

Import preset support

All four options come with a set of default presets, which have the file destinations set to 'Same as Project'. Alternatively, you can also choose a custom destination or your Creative Cloud Files folder, which syncs the files automatically to the cloud. You can also create your own 'Ingest' presets using Adobe Media Encoder.

Summary info

The summary gives detailed information on destination path, preset used, and preset details.

Specific tips & workflow

Premiere Pro 24.2 no longer includes Low, Medium, and High-resolution proxy presets.

If you want to create proxies at the  resolutions from those presets, specify the following custom proxy dimensions:

  • Low: 1024x540
  • Medium: 1280x720
  • High: 1536x790
  • When creating an ingest preset in Adobe Media Encoder, marking the frame size and frame rate as Match Source is categorized as a Transcode preset. If the frame size or rate isn't marked as Match Source, then the preset is categorized as a Proxy preset for generating proxies. Premiere Pro will override the specified frame size of proxy ingest presets with the fractional resolution specified in Premiere Pro. You can populate the custom width and height fields in the Premiere Pro dialog if you want proxies to be created at a specific frame size.
  • Ensure that source camera folder structures are placed inside a uniquely named parent folder when copying these sources using ingest settings. If ingesting (copying) directly from a camera card that does not permit having a uniquely named parent folder, designate a unique destination folder for each camera card. Failing to follow these guidelines results in conflicts while copying camera folder structure media to the destination, causing ingest failures or overwriting files (resulting in data loss).
  • During a Copy and Create Proxies operation, the proxy files are generated from the source high-res media (not the copied media); therefore, monitor the progress panel for completion of both the copy and the proxy jobs before disconnecting the source media from the system. All ingest operations are paused during playing back.
  • If the selected resolution creates a proxy file with an illegal dimension for the selected format, AME will round that value to the nearest legal value. For example, non-decimal dimensions or (for some formats) dimensions that are odd or not divisible by 16.
  • For HDR media only: If the selected resolution creates a proxy file with a height of 576 or less, the proxy is created with a height of 720, with the width calculated accordingly based on the source aspect ratio. This ensures the proxies remain compatible with the color management workflow in Premiere Pro. 

Create an Ingest Preset

You can create and use custom preset for Ingest and Proxy workflow. Ingest and Proxy works only with Ingest presets created in Adobe Media Encoder.

How to create a new Ingest preset

1.  Launch Adobe Media Encoder and create a new Adobe Media Encoder preset with the desired output settings, such as video codec and frame size.  This step is optional and is used if you have a specific format and output settings that are not covered in the built-in Adobe Media Encoder presets.  Audio settings in Adobe Media Encoder presets are ignored when transcoding or creating proxies via ingest.

2.  In the Preset Browser in Adobe Media Encoder, click the plus sign (+) and select Create Ingest Preset, or select Preset > Create Ingest Preset.  This step opens the Ingest Preset Settings dialog box.

3. Under Preset Name, name your preset. Under Comments, add any other information you desire.

4. To copy ingested footage to a new location on disk (or move a file from external media to the local hard disk), enable the Transfer option.  Then, select a location for new files to be placed under the Destination drop-down menu.  You can choose to verify the copied file by enabling Verify and selecting the verification type in the verify dropdown menu.

NOTE:  If Copy is enabled in the ingest preset, the preset becomes available in Premiere Pro’s Ingest Settings dialog under the Copy and Copy and Create Proxies options, it is not available in the Transcode and Create Proxies options.

5. To transcode or create proxies when ingesting footage into a Premiere Pro project, enable the Transcode files to Destination option.  Then, select a location for new files to be placed under the Destination drop-down menu. You can then select the output type under the Format drop-down menu.  The list of available encoding presets appears under the Preset drop-down menu, including any custom encoder presets you have created.

NOTE:  If Transcode files to Destination is enabled in the ingest preset, the preset becomes available in Premiere Pro’s Ingest Settings dialog box under the Transcode and Create Proxies options, it is not available in the Copy and Copy and Create Proxies options.

6. When you are finished with all sections of the Ingest Presets dialog box, press OK to save it in Adobe Media Encoder.

7.  To use your newly created Ingest Preset in Premiere Pro’s Ingest Setting or Create Proxies dialog box, export the preset from Adobe Media Encoder to disk.  To do this, right click (WIN) or Ctrl-click (Mac OS) the desired preset in the Adobe Media Encoder Preset Browser, and select Export Preset. Select a location on disk for the .epr file.  You can also select a preset in the Adobe Media Encoder Preset Browser and select Preset > Export.

To use File Metadata and File Rename

You can add file metadata to files that are being transcoded or to new proxies, and you can rename files on ingest when copying or transcoding (the filename of proxies is always inherited from the source file). Rename does not work with camera format files (for example, P2 folder structures).

Adding File Metadata

1. When creating an ingest preset, enable the Add File Metadata by clicking the check box.  In the drop-down menu on the right, select New Preset. 

2. Click the + sign, and Metadata key and value pairs.  You can add more key and value pairs by clicking the plus sign (+).

3. When you are finished entering the pairs, press Save button to save the metadata preset.  A dialog box appears asking for a preset name. Enter the name and save.

The Add File Rename action

1. When creating an ingest preset, enable “Add File Rename” by clicking the check box.  In the drop-down menu on the right, select New Preset. 

2. Click the + sign, and select the type of rename action you would like to add.  You can add additional rename actions by clicking the plus (+) sign.

3. After adding rename actions, press save button to save the Raname preset.  A dialog box appears asking for a preset name, enter the name and save.

NOTE: File Metadata and File Rename are stored as presets on disk.  When moving an ingest preset to a new computer, the metadata and rename presets must be moved also. If the File Metadata and File Rename presets are not moved to the new computer, the ingest preset does not function correctly.  To do this:

a. Select the desired metadata or rename preset from the dropdown, then select the second dropdown to the right of the selection dropdown.

b. Choose the Save As command and save the File Metadata or File Rename preset to a new location on disk.

c. On the new, secondary computer, open the Ingest Preset Setting dialog, and select the File Metadata or File Rename drop-down menu and select Import Preset.

Create Proxies

You can create proxies directly from items in the project panel. 

  1. Choose Create Proxies from the Project panel context menu to open the Create Proxies dialog.

    The menu item is enabled when one or more items in the panel are selected that can be proxied. Premiere Pro can create proxies for master clip project items if they have video, have no captions, and are not growing files. The media must also be online.

  2. In the Create Proxies dialog, use the default frame size of Half and set the preset to the default ProRes QuickTime Proxy, or choose any other frame size and preset.

    You can also add presets created in Adobe Media Encoder by clicking the Add Ingest Preset button. You can also create proxies in a Proxies directory next to the original media or a custom location.

  3. To easily identify proxy files in the Program monitor, select Add Watermark.

  4. You can also select the Choose a file option from the Watermark dropdown to personalize your proxies with custom watermarks.

    You can upload any image of choice, which you can then see in your media in the Source panel after it is rendered by the Adobe Media Encoder.

    UI shows the Create Proxies dialog box with the option to Choose a file highlighted
    Choose custom watermarks for clear identification of proxy-enabled media, minimizing confusion during the editing process.

  5. Select OK.

    Premiere Pro presents a progress dialog box while it prepares proxy creation jobs to send to Adobe Media Encoder.

    A proxy job is then created in Adobe Media Encoder for each of the project items chosen that can be proxied, and an offline proxy is attached to each project item. You can monitor the progress of these jobs in the Premiere Pro Progress panel, or in Adobe Media Encoder.

  6. While the jobs are processed, continue to work with the corresponding high-resolution project items in Premiere Pro. When the proxy jobs are complete, Premiere Pro automatically switches to displaying the proxy video in the timeline if Enable Proxies is enabled in the Media preferences panel.

Note:

Premiere Pro does not need to remain open while proxy jobs are processed in Adobe Media Encoder. If you quit Premiere Pro before all jobs are complete, any proxies created while Premiere Pro is not running are attached when Premiere Pro is launched and the document is reopened.

How do I identify proxy files in my project?

There are a number of ways you can tell whether you are working with proxies or your original files.

  The Toggle Proxies button on the Program monitor allows you to toggle proxies. But it also indicates if you are working with proxies. If this button is blue, it means proxies are enabled, if it's grey, they are not.

There are also badges in the sequence - both on the timeline and the Project panel indicating the status. 

If this icon is red, it indicates that the proxy files are offline. Premiere Pro is unable to find them because they have been moved or deleted.

If you add a Watermark while creating proxies, Premiere Pro displays a watermark on the lower left of the Program Monitor.

Progress panel & dialog

Ingest and Create Proxies

When transcoding or creating proxies, the renders in Adobe Media Encoder are displayed in the progress panel.  To see the dialog, choose Window > Progress…”  You see separate entries for Proxy job status and for Ingest job status. Status can be Waiting..., Complete, In Progress (or a progress bar), Canceled, and an error message if the job failed.

When creating proxies from existing files in the Project Panel, you can cancel the entire operation while the “Creating Proxy Jobs” dialog is open.

NOTE:  When transcoding or creating proxies in Adobe Media Encoder, you can pause and restart the render queue, without canceling the connection to Premiere Pro, allowing automatic attachment of proxies to continue to occur between Premiere Pro and Adobe Media Encoder.  If you stop the render queue in Adobe Media Encoder, any connection between proxies and original files are lost, and no automatic proxy attachment takes place.  If the queue in Adobe Media Encoder is stopped, you must recreate all transcode or proxy jobs.

Attach Proxies, Reconnect Full Resolution Media & Toggle/Enable Proxies

These two options are used for manual attachment of Proxy or Full Res media. These options are useful if you create proxy media outside of the Create Proxies workflow (for example, media created via third party software, hardware, or a combination of both) or you want to reattach Proxy or Full Res media to Offline clips. The supported workflow allows attachment of Proxies with other frame sizes & PAR (pixel aspect ratio) combinations that are divisible by the Full Res clip (for example, 1920x1080 1.0 PAR Full Res and 960x540 1.0 PAR Proxy or 1440x1080 1.33 PAR Proxy), but other parameters such as fielding, frame rate, duration, and audio channels must match. Mismatched audio channels results in warning dialogs and are not allowed, but other mismatched video parameters are not blocked and results in issues.

Media support: Attach Proxies and Full Resolution Media options are available for video-only, A/V, and Offline clips in the Project panel. Other file types (for example, audio-only, stills, image sequences) are not supported. Right-click (WIN) or Ctrl-click (Mac OS) your clips in the Project panel and choose Proxy > Attach Proxies or Reconnect Full Resolution Media. You can also assign shortcuts for each option in the Keyboard Shortcuts dialog box.

  • Attach Proxies launches the Attach Proxies dialog box that is similar to the Link Media dialog box. You can choose between Media Browser or OS dialog boxes to attach your Proxy clip to your Full Res clips in the Project panel. Attach Proxies also has an Undo command.
  • Reconnect Full Resolution Media launches the Reconnect Full Resolution Media dialog box, which is identical to the Attach Proxies dialog, except that it attaches Full Res clips. When using this option, the selected clip moves into the Proxy position and the clip you select in the Reconnect Full Resolution dialog becomes the new Full Res clip. If a Proxy was already attached to your clip, then it keeps the Proxy clip and only the Full Res portion is replaced. Reconnect Full Resolution cannot be undone, but you can use Reconnect Full Resolution Media to attach another clip.

Note: Attach Proxies and Reconnect Full Res Media options is always be enabled for supported clips. If you decide you want to change the Full Res or Proxy of a clip, you can choose either option again and attach a different clip.

Enable/Toggle Proxies: To view Proxy or Full Res, simply use the Toggle Proxies button in the Source Monitor or Program Monitor. This button is available in the Button Editor (the plus sign (+) in the lower right of either Monitor), that you can add in the transport controls area. This setting is a global machine Preference, so it can also be set via Preferences > Media > Enable proxies. These buttons and Preference are linked, so setting it one place sets it in the others. The Toggle/Enable Proxies preference applies to all Projects created on that system. If you move the Project to another system, the preference is determined by what was set on that system, not the Project. When set, the button turns blue which indicates that you are viewing Proxy in the Source and Program Monitors. You can also set a shortcut for Toggle Proxies in Keyboard Shortcuts.

Note: Other panels do not automatically update thumbnails based upon the Toggle/Enable Proxies state. This can result in thumbnails not following the Toggle/Enable Proxies setting, but that does alleviate certain performance issues.

Proxy column: In the Project and Metadata Panels, there is an option in Metadata Display > Premiere Pro Project Metadata for Proxy column. Click the check box and a Proxy column is added to the panel in List View. The column is blank if no Proxy is attached, it lists as Attached if a Proxy is attached to a clip, and it lists as Offline for an attached Proxy that is missing or Offline.

Note: The Metadata panel and Project panel columns only reports information for the Full Res clip. There are two places where you can view information of the Proxy clip: Properties and Info Panel.

Properties: When you get Properties on a clip with Proxy attached, the top portion contains information for the Full Res clip and below that lists information for the Proxy clip.

Info Panel: When Proxy is attached to an A/V clip, the Info panel lists the basic video and audio information below the Full Res clip info. The info panel does not report Proxy information for video only clips, though.

Note: All other areas of Premiere Pro only reports Full Res information.

Offline and relink/reattach: The Link Media dialog has not been updated to restrict functionality for Proxy. In the Link Media dialog, make sure to only relink to same files and avoid unsupported formats, and so on (the Attach dialog box restricts your choices to only supported formats). Depending on if Full Res or Proxy are Offline, you have slightly different options to relink or reattach.

  • Full Res: (clips went Offline while Project was closed) In process of opening the Project, you automatically receive the Link Media dialog which you use for relinking to Full Res clips. If you prefer to use the Reconnect Full Resolution Media dialog or keep Full Res Offline, you may click Offline All or Cancel. Once the Project is opened, you have options for Link Media and Reconnect Full Resolution Media in the context menu. If the Full Res clip goes offline while you are working in a Project, you are presented with the Link Media dialog box.
  • Proxy: (clips went Offline while Project was closed) In process of opening the Project, you automatically receive the Link Media dialog which you can use to relink your Proxy clips. If you prefer to use the Attach Proxies dialog or keep Proxies Offline, click Offline All or Cancel. If you want the option to Link Media upon opening the Project again, use the Cancel button. This is important because if you choose Offline or Offline All and Save your Project, the Link Media dialog box does not appear upon closing and reopening the Project. Once the Project is opened, you have an option for Attach Proxies only in a context menu (Link Media is dimmed for clips with only Proxies Offline). If a Proxy clip goes Offline while you are working in a Project, you are Link Media dialog box does not open. If you close and then reopen the Project, the Link Media dialog box launches. Note that the Link Media dialog box only presents the File Name and File Path column information for Proxies.

Note: If Proxies and Full Res are both Offline, when you are presented with the automatic Link Media dialog in process of opening a Project and you want to only relink certain clips, you can Shift or Command/Control click the desired clips in the Link Media dialog.

1) Toggle Proxies button

2) Info Panel with Proxy video and audio information for the selected clip

3) Status column for Full Res status

4) Proxy column for Proxy status

Note:

If you intend to use proxies for clips with an interpreted framerate, be sure to interpret the framerate before you create your proxies.

Detach proxies

You can detach a proxy if you want to recreate a new proxy or if you don't need proxies any longer.

To detach proxies from your clips, right-click the clip in the Project panel and select Proxy > Detach Proxy.

Note:

When you detach a proxy, Premiere Pro does not delete the proxy files on disk - to avoid deleting files or proxies that could be referenced in another project. You can decide to keep or delete the proxy files.

Detach proxies
Detach proxies

 Assign a keyboard shortcut to quickly detach proxies. Go to Edit > Keyboard Shortcuts (Win) or Premiere Pro > Keyboard Shortcuts (macOS), search for Detach Proxies and assign a shortcut.

Export with proxies

Premiere Pro uses full resolution media while exporting, even if you have enabled proxies in Preferences > Media Preferences, or by using the Toggle Proxies button in the Program Monitor.

If your export doesn't require the full resolution media, and if you want to export quickly, select the Use Proxies checkbox in the Export Settings dialog box.

Enabling proxies in Export mode
Enabling proxies in Export mode

 If you select Use Previews in conjuction with Use Proxies in Export mode, Premiere Pro uses the rendered previews if a section of the timeline has both a rendered preview and proxy media. This further speeds up the export process.

Relationship between source footage and proxy dimensions

Source footage dimensions and their expected proxy dimensions

Source dimensions

Full

Half

Quarter

1920x1080 (HD)

1920x1080

960x540*

480x270*

3840x2160 (4K UHD)

3840x2160

1920x1080

960x540*

4096x2160 (4K)

4096x2160

2048x1080

1024x540*

6144x3456 (6K)

6144x3456

3072x1728

1536x864

7680x4320 (8K UHD)

7680x4320

3840x2160

1920x1080

8192x4608 (8K)

8192x4608

4096x2304

2048x1152

2160x3840 (Vertical 4K UHD)

2160x3840

1080x1920

540x960

1080x1920 (Vertical HD)

1080x1920

540x960

270x480*

* Proxies of HDR footage set to these sizes will be created with a height of 720 and the width calculated accordingly based on the source aspect ratio.

Tips and Tricks

To easily monitor the Offline/Online status of clips, set the Project panel to List View and enable the Proxy column, moving it next to the existing Status column (reports status of Full Res). See screenshot below for an example.

• When you render Previews, Export Media or use certain Analysis effects (Warp Stabilizer, Rolling Shutter Repair, Morph Cut), Premiere Pro always uses and displays Full Res, regardless of the Toggle/Enable Proxies setting. The only exception is when you have Offline Full Res, but Proxy is Online, then Proxy is used. To force Premiere Pro to use proxies on export, check the Use Proxies checkbox in Export mode.

• Note: Certain combinations of resolutions and codecs may be of good enough quality to make it difficult to discern any visual differences between Proxy and Full Res clips. To avoid this issue, select Add Watermark when you create a proxy.

• If you encounter any issues with Toggle/Enable Proxies not working or tool tips do not work, quit Premiere Pro and delete Preferences. You can also delete Preferences by pressing Shift + Option/Alt keys while launching Premiere Pro.

• The recommended Proxy workflow includes appending "_Proxy" to the name of your Proxy clips (for example, scene01_Proxy.mxf) and placing Proxy clips (on disk) in a folder named "Proxies" that is placed right next to the Full Res clips. This helps with reattachment of clips. The Create Proxies dialog's default destination setting takes care of both of these conditions. If you happen to set a custom destination, then you should add the Proxies folder to the destination. By default, any Create Proxies action automatically appends _Proxy to the clip name. 

• Full Res or Proxy clips with the same name (for example, C0001.mxf, C0001.mxf, C0001.mxf) or multiple versions of same name with appended number (for example, MyClip_Proxy.mxf, MyClip_1_Proxy.mxf, MyClip_2_Proxy.mxf) can cause some confusion with the Attach and Link Media dialogs when they are set to Relink others automatically. This can result in automatic attach or relink to the wrong clips. To avoid issues, you can deselect this option and attach or relink the affected clips one by one.

Unsupported features

  • The Proxy workflow is not supported for interchange options such as Project Manager, Render and Replace, AAF, Final Cut Pro XML, EDL, OMF, and so on. You lose Proxy attachment for these functions. After Effects and Audition interoperability functions are also not currently supported with the Proxy workflow.
  • Modify > Audio Channels and Modify > Timecode are also not supported for Proxy workflow.
  • Formats with Source Clip Effects Source Settings (for example, R3D, ARRI, DPX, and so on) are supported for Full Res clips. Source Clip Effects Source Settings formats are not supported to be used as Proxy clips, however. for example: R3D Full Res and H.264 Proxy is supported. R3D Full Res and DPX Proxy is not supported.

Talk to us

If you have questions about proxies, reach out to us in our Premiere Pro community. We would love to help.

 Adobe

Get help faster and easier

New user?

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX 2024

Adobe MAX
The Creativity Conference

Oct 14–16 Miami Beach and online

Adobe MAX

The Creativity Conference

Oct 14–16 Miami Beach and online