Lorsque vous diffusez un formulaire, Acrobat crée automatiquement un porte-documents PDF afin de recueillir les données envoyées par les utilisateurs. Par défaut, ce fichier est enregistré dans le même dossier que le formulaire d’origine et est nommé de la façon suivante : nom du fichier_responses. Vous pouvez vous servir de ce fichier pour compiler les formulaires renvoyés.

Adobe recommends

Adobe recommends
<a href="https://tv.adobe.com/watch/acrobat-x/managing-form-data/">Didacticiel vidéo : Gestion des données de formulaire</a>
Timothy Plumer, Jr.

Collecte des données utilisateur

  1. Lorsqu’un utilisateur vous renvoie un formulaire, ouvrez le formulaire en question.
  2. Dans la boîte de dialogue Ajouter le formulaire rempli à un fichier réponse, sélectionnez l’une des options suivantes :

    Ajouter à un fichier réponse existant

    Permet de compiler les données du fichier réponse créé dans l’assistant de diffusion de formulaires lors de l’envoi du formulaire. (Le cas échéant, cliquez sur Parcourir et accédez au fichier réponse.)

    Créer un fichier réponse

    Permet de créer un fichier réponse qui porte le nom saisi et se trouve à l’emplacement choisi.

Le fichier réponse s’ouvre dès que vous cliquez sur OK. Chaque formulaire renvoyé ajouté au fichier réponse s’affiche sous la forme d’un fichier composant dans un porte-documents PDF.

Compilation des données de formulaire

  1. Dans Acrobat, choisissez Outils > Formulaires > Autres options de formulaire > Compiler les formulaires renvoyés.
  2. Dans la boîte de dialogue Compiler les données, effectuez l’une des opérations suivantes pour sélectionner un fichier réponse PDF :
    • Cliquez sur Parcourir, accédez au fichier réponse, puis sélectionnez-le.

    • Saisissez le chemin d’accès au fichier réponse.

  3. Cliquez sur Ajouter un fichier, puis accédez au formulaire renvoyé.
  4. Recommencez l’étape précédente aussi souvent que nécessaire pour ajouter d’autres formulaires renvoyés.

Une fois que vous avez cliqué sur OK, les données des formulaires sélectionnées sont ajoutées au fichier réponse. Chaque formulaire renvoyé s’affiche sous la forme d’un fichier composant dans un porte-documents PDF.

Ajout des données utilisateur à un fichier réponse existant

  1. Dans Acrobat, ouvrez le fichier réponse.
  2. Dans le panneau de navigation de gauche, cliquez sur Ajouter.
  3. Dans la boîte de dialogue Ajouter les formulaires renvoyés, cliquez sur Ajouter un fichier. Accédez aux formulaires renvoyés et sélectionnez-les, puis cliquez sur Ouvrir.
  4. Recommencez l’étape précédente pour ajouter tout autre formulaire renvoyé dans d’autres dossiers. Cliquez ensuite sur OK.

Lorsque vous avez terminé, chaque formulaire PDF ajouté s’affiche sous la forme d’un fichier composant dans le porte-documents PDF.

Exportation des données utilisateur à partir d’un fichier réponse

Procédez de cette façon pour enregistrer toutes les entrées du fichier réponse d’un porte-documents PDF dans une feuille de calcul ou un fichier XML.

  1. Dans Acrobat, ouvrez le fichier de réponse et sélectionnez les données à exporter.
  2. Dans le panneau de navigation de gauche, cliquez sur Exporter.
  3. Dans la boîte de dialogue Sélectionner le dossier d’enregistrement du fichier, spécifiez les nom, emplacement et format de fichier (CSV ou XML) pour les données de formulaire, puis cliquez sur Enregistrer.

Gestion des fichiers de données de formulaire

Vous pouvez convertir les réponses sur un formulaire PDF vers d’autres formats de fichier (et vice-versa). Ces formats permettent de conserver toutes les données et sont nettement moins volumineux que le format PDF.

Importation de données de formulaire

Il peut arriver que certaines personnes renvoient des formulaires remplis sous la forme de fichiers données uniquement, plutôt que de fichiers PDF complets. Ces fichiers ne sont pas au format PDF mais dans d’autres formats, notamment FDF ou XML. Vous pouvez afficher les données renvoyées par une personne dans le contexte du document PDF en ouvrant le fichier d’origine et en important les informations du fichier de données.

  1. Dans Acrobat, ouvrez le formulaire PDF dans lequel vous souhaitez importer les données.
  2. Choisissez Outils > Formulaires > Effacer le formulaire.

    Remarque :

    lorsque vous importez les données à partir d’un autre fichier dans un formulaire PDF, les données importées remplace toutes les informations qui s’affichaient préalablement dans les champs de formulaire individuels. Toutefois, si le fichier de données importé contient un ou plusieurs champs non remplis, l’importation ne permettra pas d’effacer les données d’origine.

  3. Choisissez Outils > Formulaires > Autres options de formulaire > Gérer les données de formulaire > Importer des données.
  4. Dans la boîte de dialogue de sélection du fichier contenant les données de formulaire, choisissez un format dans le menu Type de fichier correspondant au fichier de données à importer. Localisez et sélectionnez ce fichier, puis cliquez sur Ouvrir.

    Remarque :

    certains formats sont disponibles uniquement pour des types spécifiques de formulaires PDF, selon l’application utilisée pour créer le formulaire, par exemple Acrobat ou Designer ES2. Les données importées d’un fichier texte (.txt) doivent être placées dans des rangées délimitées par tabulation afin de créer des colonnes.

Exportation de fichier de données

Vous pouvez enregistrer les informations dans un formulaire PDF rempli sous la forme d’un fichier de données dans un autre format de fichier. Vous pouvez par la suite réutiliser les données pour remplir à nouveau le formulaire ou un autre formulaire doté des mêmes champs et des mêmes noms de champs.

  1. Dans Acrobat, ouvrez le formulaire rempli.
  2. Choisissez Outils > Formulaires > Autres options de formulaire > Gérer les données de formulaire > Exporter des données.
  3. Dans la boîte de dialogue Exporter les données du formulaire, sélectionnez le formulaire dans lequel vous voulez enregistrer les données (FDF, XFDF, XML ou TXT). Sélectionnez ensuite un emplacement, saisissez le nom du fichier et cliquez sur Enregistrer.

    Remarque :

    certains formats sont disponibles uniquement pour des types spécifiques de formulaires PDF, selon la méthode de création du formulaire.

Fusion des fichiers de données exportés vers une feuille de calcul

Si vous voulez compiler les données de formulaires qui ne se trouvent pas encore dans un jeu de données, procédez comme suit :

  1. Choisissez Outils > Formulaires > Autres options de formulaire > Gérer les données de formulaire > Fusionner les fichiers de données dans une feuille de calcul.
  2. Dans la boîte de dialogue Exporter les données provenant de plusieurs formulaires, cliquez sur Ajouter des fichiers.
  3. Dans la boîte de dialogue de sélection du fichier contenant les données de formulaire, choisissez un format dans le menu Type de fichier (Acrobat FDF (Form Data Format) ou Tous les fichiers). Accédez ensuite aux formulaires à fusionner dans la feuille de calcul, sélectionnez-les, puis cliquez sur Ouvrir.
  4. Le cas échéant, recommencez l’opération pour ajouter des fichiers de données de formulaire placés ailleurs.
  5. Cliquez sur Exporter. Sélectionnez ensuite un dossier et saisissez le nom du fichier pour la feuille de calcul, puis cliquez sur Enregistrer.
  6. Dans la boîte de dialogue Progression de l’exportation, cliquez sur Afficher le fichier maintenant pour ouvrir le fichier de feuille de calcul ou cliquez sur Fermer la boîte de dialogue pour revenir à Acrobat.

Remarque :

Lorsque les formulaires renvoyés se trouvent dans un fichier réponse, la méthode la plus efficace pour exporter les informations vers une feuille de calcul consiste à utiliser le bouton Exporter les données dans le panneau de navigation de gauche pour le fichier réponse du porte-documents PDF.

Suivi des formulaires

Utilisez la fonction de suivi pour gérer les formulaires que vous avez diffusés ou reçus. Le dispositif de suivi permet d’afficher et de modifier l’emplacement du fichier réponse, d’identifier les destinataires ayant répondu, d’ajouter d’autres destinataires, d’envoyer un message à tous les destinataires et d’examiner les réponses à un formulaire.

Suivi des formulaires

  1. Dans Acrobat, sélectionnez Edition > Options de formulaire > Suivi ou Visualiser > Dispositif de suivi.

  2. Dans le panneau de navigation de gauche, développez l’élément Formulaires.

  3. Sélectionnez un formulaire, puis effectuez l’une des opérations suivantes :

    • Pour afficher toutes les réponses au formulaire, cliquez sur Afficher les réponses.

    • Pour modifier l’emplacement d’un fichier réponse, cliquez sur Modifier l’emplacement du fichier dans la zone Emplacement du fichier réponse.

    • Pour afficher le formulaire d’origine, cliquez sur Ouvrir le formulaire d’origine.

    • Pour envoyer le formulaire à d’autres destinataires, cliquez sur Ajouter des destinataires.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne