Remarque :

Cet article vous concerne si vous effectuez une mise à niveau d’AEM Forms sur OSGi. Pour plus d’informations à propos de l’installation d’AEM Forms sur JEE, voir la documentation de la section Installation, mise à niveau et mise en grappe d’AEM Forms on JEE dans AEM Forms 6.1 - Aide et didacticiels.

Avant la mise à niveau

Avant la mise à niveau d’AEM Forms 6.0 vers AEM Forms 6.1 :

  • Installez les derniers Service Pack et correctifs pour AEM Forms 6.0. Pour télécharger et installer les derniers Service Packs, voir la documentation AEM 6.0.
  • Préparez l’instance de source pour la mise à niveau. Pour obtenir des instructions détaillées, reportez-vous à l’article Mise à niveau vers AEM 6.1.

Mettre à niveau

Suivez les étapes ci-après pour réaliser la mise à niveau d’AEM Forms 6.0 vers AEM Forms 6.1 Feature Pack 1 :

  1. Téléchargez AEM 6.1 QuickStart.

  2. (Installations Unix/Linux uniquement) Si vous utilisez UNIX ou Linux en tant que système d’exploitation sous-jacent, ouvrez la fenêtre de terminal, accédez au dossier contenant crx-quickstart et exécutez la commande suivante :

    chmod -R 755 ../crx-quickstart

  3. Remplacez AEM 6.0 QuickStart par AEM 6.1 QuickStart, puis démarrez l’instance d’auteur.

    Le démarrage d’AEM 6.1 Quickstart met à niveau le référentiel crx-repository existant vers AEM 6.1, migre automatiquement le contenu de la version antérieure vers la version plus récente et crée un dossier nommé versions archivées.  

  4. Une fois le serveur en marche, redémarrez l’instance AEM. Avant de redémarrer l’instance AEM, vérifiez que tous les lots sont à l’état actif. Les lots sont répertoriés à l’adresse http://[serveur]:[port]/system/console/. Si tous les lots ne sont pas actifs, patientez, puis vérifiez leur statut après quelques minutes. Une fois que tous les lots sont à l’état actif, redémarrez le serveur AEM.   

  5. Ouvrez le dossier de versions archivées et copiez tous les dossiers contenus dans le dossier de référentiel [AEM_racine]\crx-. Redémarrez l’instance AEM 6.1. Avant de redémarrer l’instance AEM, vérifiez que tous les lots sont à l’état actif. Les lots sont répertoriés à l’adresse http://[serveur]:[port]/system/console/. Si tous les lots ne sont pas actifs, patientez, puis vérifiez leur statut après quelques minutes. Une fois que tous les lots sont à l’état actif, redémarrez le serveur AEM.  

  6. Connectez-vous à AEM en tant qu’administrateur, puis ouvrez le partage de package. Connectez-vous au partage de package à l’aide d’un ID Adobe. Une liste des dossiers et des packages s’affiche.   

    Remarque :

    L’URL par défaut du partage de package est : http:[serveur]/host/crx/packageshare/login.html.

    Remarque :

    Avant d’installer les packages de modules complémentaires AEM Forms, vérifiez que le chemin d’installation d’AEM Quickstart ne contient aucune espace.

  7. Dans le partage de package, recherchez les packages de modules complémentaires d’AEM Forms, cliquez sur le package correspondant à votre système d’exploitation, puis sur Télécharger. Lisez et acceptez l’accord de licence, puis cliquez sur OK. Une fois le téléchargement effectué, le mot Téléchargé apparaît en regard du package.

    Vous pouvez également utiliser les liens de téléchargement direct répertoriés dans la section Package de module complémentaire d’AEM Forms pour télécharger un package manuellement.

    Remarque :

    AEM Forms 6.1 Feature Pack 1 est le dernier package de module complémentaire d’AEM Forms. Il s’agit d’un package cumulatif. En plus des améliorations et des correctifs pour les différents composants d’AEM Forms 6.1, le package comprend également toutes ses fonctions. Pour obtenir la liste détaillée des améliorations et correctifs, consultez la section Nouveautés d’AEM Forms 6.1 Feature Pack 1.

  8. Ouvrez le gestionnaire de packages, localisez le package téléchargé, puis cliquez sur Installer. L’URL par défaut est http://[serveur]:[port]/crx/packmgr/index.jsp. Une fois le package installé sur votre environnement, le mot Partager s’affiche en regard du package dans Package Manager.

    Remarque :

    Si le correctif 6717 est installé et que vous installez le package de module complémentaire AEM Forms Feature Pack 1, le message d’erreur « Impossible d’installer le package » peut s’afficher dans la fenêtre de Package Manager. Vous pouvez ignorer ce message d’erreur.

  9. (Facultatif) Indépendamment du package AEM Forms 6.1, le partage de package contient des packages pour les services Central Migration Bridge et Send to printer, et des packages de modules complémentaires pour les sites de référence Geometrixx Finance et Geometrixx.gov. Vous pouvez également installer ces packages si besoin.

    Vous pouvez utiliser le partage de package AEM pour télécharger et installer ces packages. La section Package de module complémentaire AEM Form répertorie également les liens de téléchargement direct pour télécharger les packages manuellement.

  10. (En option) Configurez le service DocAssurance

    Le service DocAssurance n’est pas disponible hors de la zone. Il nécessite que les bibliothèques RSA et BouncyCastle soient installées avec le module AEM Forms. Suivez la procédure ci-après pour déléguer le démarrage des bibliothèques : 

    1. Arrêtez le serveur AEM.

    2. Ouvrez le fichier sling.properties dans [installation AEM]\crx-quickstart\conf\ en vue de sa modification.

      Remarque :

      Si vous utilisez [racine_AEM]\crx-quickstart\bin\start.bat pour démarrer AEM, modifiez le fichier sling.properties dans [racine_AEM]\crx-quickstart\

    3. Ajoutez les propriétés suivantes au fichier sling.properties :

      sling.bootdelegation.class.com.rsa.jsafe.provider.JsafeJCE=com.rsa.*
      sling.bootdelegation.class.org.bouncycastle.jce.provider.BouncyCastleProvider=org.bouncycastle.* 
    4. Enregistrez le fichier, puis fermez-le. Redémarrez le serveur AEM.

  11. Une fois le package installé, ne redémarrez pas immédiatement le serveur. Avant de redémarrer l’instance AEM, vérifiez que tous les lots (à l’exception des lots Signatures) sont à l’état actif. Les lots sont répertoriés à l’adresse http://[serveur]:[port]/system/console/. Si tous les lots ne sont pas actifs, patientez quelques minutes puis vérifiez leur statut.

    Une fois que tous les lots sont à l’état actif, redémarrez le serveur AEM.  

Package de module complémentaire AEM Forms

Package de module complémentaire AEM Forms pour AEM 6.1

Après avoir installé AEM 6.1 QuickStart, téléchargez et installez les packages de modules complémentaires requis.

Package de module complémentaire AEM Forms 6.1
Lien de téléchargement
Package de module complémentaire AEM Forms pour AIX adobe-aemfd-aix-pkg
Package de module complémentaire AEM Forms pour Linux adobe-aemfd-linux-pkg
Package de module complémentaire AEM Forms pour Solaris
adobe-aemfd-solaris-pkg
Package de module complémentaire AEM Forms pour Windows adobe-aemfd-win-pkg
Services Central Migration Bridge et Send to printer adobe-aemfd-cmb-pkg
Package de module complémentaire pour exemple de site Geometrixx Gov cq-geometrixx-gov-all-pkg
Package de module complémentaire pour exemple de site Geometrixx Finance cq-geometrixx-finance-pkg

Package de module complémentaire AEM Forms pour le correctif 6717

Après avoir installé AEM 6.1 QuickStart, téléchargez et installez les packages de modules complémentaires requis.

Package de module complémentaire AEM Forms 6.1
Lien de téléchargement
Package de module complémentaire AEM Forms pour AIX adobe-aemfd-aix-pkg
Package de module complémentaire AEM Forms pour Linux adobe-aemfd-linux-pkg
Package de module complémentaire AEM Forms pour Solaris
adobe-aemfd-solaris-pkg
Package de module complémentaire AEM Forms pour Windows adobe-aemfd-win-pkg
Package de module complémentaire AEM Forms pour Mac OS X adobe-aemfd-osx-pkg

Remarque :

Le correctif 6717 d’AEM Forms 6.1 est un package cumulatif. Outre les améliorations et correctifs pour les différents composants d’AEM Forms 6.1, le package comprend également toutes les fonctions d’AEM Forms 6.1. Pour obtenir la liste détaillée des améliorations et correctifs, voir les Notes de mise à jour.

Remarque :

Le package du correctif 6717 d’AEM Forms 6.1 pour Mac OS X n’est pas pris en charge dans l’environnement de production et doit être utilisé uniquement à des fins de démonstration.

Package de module complémentaire AEM Forms pour AEM 6.1 Feature Pack 1 (dernière version)

Après avoir installé AEM 6.1 QuickStart, téléchargez et installez les packages de modules complémentaires requis.

Package de module complémentaire AEM Forms 6.1
Lien de téléchargement
Package de module complémentaire AEM Forms pour AIX AEM-Forms-6.1-FP1-AIX
Package de module complémentaire AEM Forms pour Linux AEM-Forms-6.1-FP1-LX
Package de module complémentaire AEM Forms pour Solaris
AEM-Forms-6.1-FP1-SOL
Package de module complémentaire AEM Forms pour Windows AEM-Forms-6.1-FP1-WIN
Package de module complémentaire AEM Forms pour Mac OS X AEM-Forms-6.1-FP1-OSX
Central Migration Bridge AEM-Forms-6.1-FP1-CMB
Utilitaire de migration de Correspondence Management AEM-Forms-6.1-FP1-CM-MIGRATION-PKG
Package de module complémentaire pour exemple de site Geometrixx Gov AEM-Forms-6.1-FP1-GOV-REF-SITE
Package de module complémentaire pour exemple de site Geometrixx Finance AEM-Forms-6.1-FP1-FSI-REF-SITE

Remarque :

AEM Forms 6.1 Feature Pack 1 est le dernier package de module complémentaire d’AEM Forms. Il s’agit d’un package cumulatif. En plus des améliorations et des correctifs pour les différents composants d’AEM Forms 6.1, le package comprend également toutes ses fonctions. Pour obtenir la liste détaillée des améliorations et des correctifs, voir Nouveautés des notes de mise à jour d’AEM Forms 6.1..

Remarque :

Lors de l’installation du package de module complémentaire AEM Forms Feature Pack 1, vous pouvez rencontrer le message d’erreur « Impossible d’installer le package ». Il est plus sûr d’ignorer le message d’erreur.    

Remarque :

Le package de module complémentaire AEM Forms pour Mac OS X n’est pas pris en charge dans l’environnement de production et doit être utilisé uniquement à des fins de démonstration.

Vérifier l’instance mise à niveau

  1. Ouvrez la console Bundles Web et vérifiez que tous les lots à l’adresse /system/console/bundle sont actifs. L’adresse par défaut des Web Bundles est http://localhost:4502/system/console/bundles.

  2. Recherchez le lot afml (afml). Si vous rencontrez plusieurs versions du lot afml, supprimez le lot avec la version 1.460868.0 et redémarrez le serveur AEM.

  3. Ouvrez le gestionnaire de package et assurez-vous qu’un package cq-content avec la version 6.1 existe.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne