Nous avons plusieurs cas où les flux de production à l’intérieur de la campagne ne commencent pas en cliquant sur le bouton de démarrage Au lieu de démarrer, les flux de production à l’intérieur d’une campagne vont à « Démarrer dès que possible ».

Environnement

Toutes les campagnes V6.0, V6.1.0 et V6.1.1
Tous les systèmes d’exploitation comme Windows, Linux, Debian.

Cause

Il peut y avoir deux causes à ce problème :

1> La limite de simultanéité pour les flux de production dans une campagne est atteinte et aucun nouveau flux de production ne peut être démarré. Ceci peut être confirmé en vérifiant le nombre de flux de production exécutés lors du processus et en vérifiant la valeur de NmsOperation_LimitConcurrency sous Platform>Options.

Remarque :

Lorsque cette limite est atteinte, le flux de production ne conserve que le statut « Démarrer dès que possible » tant que le nombre de flux de production en cours d’exécution est supérieur à la limite de concomitance. Chaque fois que le nombre passe sous la limite, le flux de production est désactivé. Par conséquent le statut « Démarrer dès que possible » n’est pas permanent.

2> La raison la plus fréquente pour laquelle les flux de production ne démarrent pas dans le cadre d’une campagne est l’échec des travaux de campagne (gestion de l'opération) flux de production. Il s’agit d’un flux de production technique qui se trouve dans le dossier Processus de campagne dossier sous Administration>Production>Nœud de flux de production technique. Ce flux de production gère les tâches ou les flux de production à l’intérieur d’une campagne et les flux de production ne peuvent pas démarrer / arrêter.

Vous pouvez redémarrer ce flux s’il ne parvient pas à reprendre le fonctionnement des flux de campagne.

Résolution

Pour le premier échec, nous pouvons :

>> Augmenter la limite de concomitance si c’est un besoin commercial ou nous pouvons expliquer que le flux de production commence dès que le seuil de concomitance est rétabli.

Pour le deuxième échec, il est possible de :

>> Redémarrer le flux de production de la campagne (gestion de l'opération) en cas d’échec. Après le redémarrage, nous nous assurons que nous « exécutons les tâches en attente » sur le planificateur pour vérifier s’il échoue à nouveau sur l’une des activités.

  • Si le flux de production est en pause, reprenez-le, puis tentez un redémarrage s’il échoue après la reprise.
  • Si le flux de production est arrêté, démarrez-le.
  • S’il échoue à nouveau, nous devons vérifier le journal de contrôle pour détecter les erreurs spécifiques et résoudre les problèmes en conséquence.


Exemple : vous pourriez avoir un échec comme :

Le flux de production des travaux de campagne (gestion de l'opération) a échoué avec erreur :
25/08/2016 17:34:25 scheduler JavaScript : erreur lors de l’évaluation du script « operationMgt/scheduler ».
25/08/2016 17:34:25 Planificateur, aucun jeton d’accès trouvé pour effectuer la mise à jour de l'utilisateur.
25/08/2016 17:34:25 Planificateur, démarrage du ciblage du flux de production « xyz_wkf_engage_4 » pour la campagne « 01 - lancer la campagne (xyz_engage_campaign) ».

Cela signifie qu’il essaie de démarrer le flux de production xyz_wkf_engage_4 mais n’est pas capable de le faire. Dans la plupart des cas, ce flux de production pointe vers un état fini et ne peut pas démarrer. Pour cela, nous pouvons faire un arrêt inconditionnel pour le flux de production xyz_wkf_engage_4 et ensuite redémarrer les travaux de la campagne (gestion de l’opération).

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