L’instance AEM se bloque avec OutOfMemoryError en raison de sessions Jetty

Problème

AEM se bloque avec ou sans OutOfMemoryError. Le rapport de brêche suspectée à partir de Eclipse Memory Analyzer Tool (MAT) montre org.eclipse.jetty.server.session.HashedSession consommant la majeure partie du tas.

Exemple de sortie d’Eclipse MAT :

1 650 055 instances de « org.eclipse.jetty.server.session.HashedSession », chargées par "org.apache.felix.framework.BundleWiringImpl$BundleClassLoaderJava5 @ 0x6c279ad00", occupent 2 292 147 984 octets (51,04 %). Ces instances sont référencées à partir d'une instance de "java.util.concurrent.ConcurrentHashMap$Node[]", chargées par ""

Motd-clés
java.util.concurrent.ConcurrentHashMap$Node[]
org.eclipse.jetty.server.session.HashedSession
org.apache.felix.framework.BundleWiringImpl$BundleClassLoaderJava5 @ 0x6c279ad00

Environnement

AEM 6.0, 6.1

Cause

Il s'agit d'un problème connu fixé dans AEM6.2.  Les sessions Jetty n’avaient pas de délai d'expiration par défaut configuré dans AEM6.0 et 6.1.

Résolution

  1. Accédez à http://host:port/system/console/configMgr/org.apache.felix.http

  2. Définissez une valeur raisonnable Délai d'attente de session

  3. Enregistrer

Logo Adobe

Accéder à votre compte