Problème

Après la mise à jour d'une instance de création CQ5.2.1 vers 5.3, les membres du groupe utilisateur-administrateurs ne peuvent plus gérer les utilisateurs et les groupes.

Cause

La configuration par défaut des ACL pour la section /home où sont stockés les utilisateurs et les groupes a été simplifiée avec CQ5.3. Le mécanisme de mise à niveau de CQ5.2.1 vers CQ5.3 n'en tient pas compte, laissant une configuration ACL incohérente qui rend pratiquement inefficaces les capacités d'administration des utilisateurs du groupe utilisateur-administrateurs.

Résolution

Joint à cet article est un paquet de contenu CQ5 contenant un script qui restaure la capacité de gérer les utilisateurs/groupes pour les membres du groupe par défaut utilisateur-administrateurs.

Assurez-vous d’avoir une copie de sauvegarde de l’instance mise à niveau avant d’appliquer les étapes suivantes :

  • Après une mise à niveau réussie, tous les utilisateurs/groupes sont conservés dans des dossiers de sauvegarde.
    • /home/users-xxxxxx
    • /home/groups-yyyyyy
  • Via l'explorateur de contenu CRX, supprimez ces 2 dossiers de sauvegarde et enregistrez.
  • Téléchargez et installez le paquet joint en utilisant le gestionnaire de paquets CQ5.
  • Sous Outils, double-cliquez sur Fix /home ACL setup ou demandez manuellement http://<host>:<port>/etc/fix_home_setup.html
  • Démarrez la procédure.

S’applique à

Mise à niveau CQ5.3

Telechargement

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne