Problème

Lors de la migration de contenu des versions de AEM 6.0, 6.1 ou 6.2 vers AEM 6.3 à l'aide du programme utilitaire de CRX2Oak, l'erreur suivante est observée :

22.08.2017 11:25:16.256 ERROR c.a.g.c.c.MigrationSpecGenerator: I/O error during processing migration specification: org.apache.jackrabbit.oak.segment.file.InvalidFileStoreVersionException: Using oak-segment-tar, but oak-segment should be used

Environnement

CRX2Oak-1.6.x est utilisé pour migrer AEM6.0-6.2 vers 6,3 ou une version ultérieure.

Cause

Paramètre manquant dans la commande CRX2Oak.

Résolution

Ajouter « segment-old » : avant le chemin source dans la commande CRX2Oak comme suit (voir le texte en surbrillance ci-dessous) :

java -Xmx1g -jar crx2oak-1.6.8-all-in-one.jar --include-paths=/content/geometrixx segment-old:/opt/old-aem/repository /opt/aem63/crx-quickstart/repository

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne