Problème

Certaines configurations et lots OSGi chargés vers /apps sous un dossier d’installation ou un dossier de configuration ne sont pas appliqués.

Environnement

AEM 6.x

Cause

Certaines causes ci-dessous sont à l'origine du problème.

  1. Le dossier d’installation ou de configuration est à plus de quatre niveaux de profondeur dans l’arborescence des dossiers. Les fichiers situés à un niveau de profondeur supérieur à ce niveau ne sont pas installés.
  2. La configuration ou le lot sont mal formés ou corrompus.
  3. Le dossier d’installation ou de configuration possède un mode d'exécution dans le nom qui ne s’applique pas à l’instance. Par exemple, config.publishqa ou install.publishstage.

Le programme d’installation OSGi ne fonctionne pas correctement.

Résolution

  1. Si le dossier d’installation ou de configuration se trouve à un niveau de profondeur supérieur à quatre. Par exemple /apps/sites/siteA/jars/install/foo-1.0.0.jar ne sera pas installé, mais /apps/siteA/install/foo-1.0.0.jar sera installé.
  2. Consultez le journal error.log pour savoir s’il existe des erreurs et pour vérifier si votre configuration ou votre lot n’est pas mal formé.
  3. S’il existe un mode d'exécution dans le nom de dossier, aller à http://host:port/system/console/status-slingsettings sur l’instance AEM et vérifier que le bon mode d'exécution est appliqué.
  4. Si vous pensez que le programme d'installation d'OSGi fonctionne mal, consultez cet article pour connaître les étapes à suivre afin de corriger le problème.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne