Fichiers JavaScript et CSS manquants sur les pages AEM

Problème

Certains fichiers JS et CSS sont absents des pages AEM ou de l'interface utilisateur AEM. 

Cause

Une ou plusieurs des raisons suivantes sont responsables de ce problème.
  • La requête xpath [1] utilisée par le gestionnaire de bibliothèque AEM Client (HTMLLibraryManager) utilise un index autre que l'index /oak: index/nodetype.
  • L'index du type de nœud ne parvient pas à être mis à jour ou est corrompu.
  • Les permissions de l'utilisateur clientlibs-service sont manquantes.
/jcr: root//element(*, cq :ClientlibraryFolder)

Résolution

I. Vérifiez les autorisations des utilisateurs de services.

Consultez cet article en cas d’absence des droits d’utilisateur clientlibs-service.

II. Vérifiez que la requête récupère les résultats corrects.

  1. Allez à http://aem-host:porl/crx/de/index.jsp et connectez-vous en tant qu'administrateur.

  2. Allez à Outils > Requête

  3. Dans la zone Requête du bas, entrez la requête suivante :
    /jcr: root//element(*, cq: ClientlibraryFolder)

  4. Vérifiez si votre bibliothèque cliente manquante se trouve dans les résultats. Si elle y apparaît, contactez AEM Customer Care pour obtenir de l’aide pour des recherches plus approfondies. Sinon, passez à l’étape suivante.

  5. Si vous trouvez que les résultats ont exclu la bibliothèque client manquante, accédez à http://aem-host:port/libs/granite/operalions/content/diagnosis/tool.html/granite:queryperformance.

     

  6. Entrez à nouveau la requête et cliquez sur Explain.

  7. La sortie vous indique quel index est utilisé pour exécuter la requête. Si l'index répertorié n'est pas l'index du type de nœud, alors quelque chose ne va pas.

     

  8. Vous pouvez déboguer ce qui fait qu'un index différent renvoie une estimation moins coûteuse pour la requête. Reportez-vous à cet article pour savoir comment activer la journalisation du débogage pour l’analyse des requêtes.

  9. Si l'index correct est sélectionné mais ne parvient pas à renvoyer le résultat correct, il est corrompu. Dans ce cas, vous pouvez réindexer l'index du type de nœud.

  10. Pour réindexer l'index de manière asynchrone, suivez les étapes de cet article.

    Attention :

    Notez que pendant la réindexation, certaines recherches peuvent afficher des résultats obsolètes et le système peut être moins réactif.  Il est recommandé d'interrompre la réindexation ou d'effectuer cette tâche lorsque la quantité minimale d'utilisateurs est sur le système.

 Adobe

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