Comment les masques sont-ils associés à des couches alpha dans Photoshop

Lorsque vous sélectionnez une portion d’image, le reste de l’image est masqué, c’est-à-dire protégé contre les modifications. Lorsque vous créez un masque, vous isolez les zones d’une image en applicant des modifications de couleur, des filtres ou d’autres effets au reste de l’image. Vous pouvez également utiliser des masques pour des opérations d’édition complexes sur des images, par exemple l’application progressive d’une couleur ou d’effets de filtre.

Vous pouvez ajouter un masque à un calque et l’utiliser pour masquer des parties du calque et faire apparaître les calques en dessous. Par défaut, le masque de fusion est lié au calque auquel il est attaché.

Pour enregistrer une sélection de façon plus permanente, vous pouvez l’enregistrer en tant que couche alpha. La couche alpha stocke la sélection comme un masque de niveaux de gris modifiable dans le panneau Couches. Une fois enregistrée en tant que couche alpha, vous pouvez récupérer la sélection à tout moment ou même la charger dans une autre image. Les masques sont stockés dans les couches alpha. Les masques et les couches sont des images en niveaux de gris, ce qui permet de les modifier comme toute autre image avec les outils de peinture et de retouche ainsi que les filtres. Les zones peintes en noir sur un masque sont protégées tandis que les zones peintes en blanc peuvent être modifiées.

Si vous souhaitez modifier directement la transparence du calque, créez un masque pour ces données.

  1. Dans le panneau Calques, sélectionnez le calque.
  2. Choisissez Calque > Masque de calque > De la transparence.

Vous pouvez cliquer sur la vignette tout en maintenant la touche Maj enfoncée pour la désactiver et rendre l’image et ses canaux opaques.

Photoshop convertit la transparence en une couleur opaque, masquée par le nouveau masque. La couleur opaque varie considérablement selon les filtres et tout autre traitement précédemment appliqués au calque.

Canaux Photoshop

Les couches sont des images en niveaux de gris qui renferment différents types d’informations :

  • Les couches d’informations chromatiques sont créées automatiquement à l’ouverture d’une nouvelle image. Leur nombre est fonction du mode colorimétrique de l’image. Une image RVB, par exemple, comporte une couche pour chaque couleur (le rouge, le vert et le bleu) et une couche composite utilisée pour l’édition de l’image.
  • Les couches alpha stockent les sélections sous forme d’images en niveaux de gris. En ajoutant des couches alpha, vous pouvez créer et stocker des masques permettant de manipuler et de protéger des portions d’une image. (Voir la section A propos des masques et des couches alpha.)
  • Les couches de tons directs servent à spécifier d’autres plaques d’impression pour les encres correspondantes. (Voir la section A propos des tons directs).

Une image peut compter jusqu’à 56 couches. Toutes les nouvelles couches ont les mêmes dimensions et le même nombre de pixels que l’image d’origine. Avec une image RVB dotée de trois canaux de couleur (rouge, vert et bleu) et d'un canal composite (RVB), vous pouvez ajouter jusqu'à 20 canaux alpha supplémentaires.

La taille de fichier requise pour une couche varie selon les informations des pixels de celle-ci. Certains formats de fichier, notamment les formats TIFF et Photoshop, compressent les informations des couches et permettent ainsi d’économiser de l’espace. La taille d'un fichier non compressé, y compris les couches alpha et les calques, apparaît comme la valeur la plus à droite dans la barre d'état au bas de la fenêtre lorsque vous choisissez Taille du document dans le menu contextuel.

Remarque :tant que vous enregistrez un fichier dans un format prenant en charge le mode couleur de l'image, les canaux de couleur sont préservés. Les couches alpha ne sont conservées que si vous enregistrez le fichier au format Photoshop, PDF, TIFF, PSB ou Brut. Le format DCS 2.0 ne conserve que les couches de tons directs. L'enregistrement dans d'autres formats peut ignorer les informations sur les canaux.

Transparence et canaux alpha et png

Le format PNG ne prend pas en charge les canaux alpha arbitraires comme les autres formats tels que le format TIFF. PNG spécifie que le quatrième canal d'un fichier est la transparence et uniquement la transparence. Lorsque vous ouvrez un fichier PNG avec transparence dans Photoshop, cette image est considérée comme une seule couche. Il ne s’agit pas d’une image d’arrière-plan plate. Les canaux alpha peuvent contenir n'importe quoi, tandis que la transparence est une relation de canal spécifique. Vous pouvez avoir plusieurs canaux alpha par document, mais un seul canal de transparence. Photoshop gère la transparence et les canaux alpha séparément. La transparence d'un fichier PNG existant peut être modifiée dans Photoshop en créant un masque de calque à partir des données de transparence (voir les étapes ci-dessous).

Si vous souhaitez voir l'opacité d'un point donné dans un fichier image, procédez comme suit :

  1. Ouvrez la palette infos.
  2. Cliquez sur l’option de palette dans le coin supérieur droit et sélectionnez Options de panneau.
  3. Lorsqu’il indique « Readout Color Readout », choisissez Mode : Opacité.
  4. Cliquez sur OK.
  5. La palette infos fournit le niveau d’opacité à l’emplacement de la souris.
  6. Si vous souhaitez modifier directement la transparence du calque, il est possible de créer un masque de fusion en fonction de la transparence du calque.
  7. Dans le panneau Calques, sélectionnez le calque.
  8. Sélectionnez Calque > Masque de calque > Depuis la transparence.
  9. Une vignette de masque de calque est visible pour le calque d’origine. Vous pouvez faire un MAJ-clic sur la vignette pour la désactiver et rendre l’image et ses couches opaque. Cliquez à nouveau sur la vignette pour la réactiver.

Les masques sont stockés dans les couches alpha. Dans le panneau des canaux, vous devriez voir un masque de couche 0. Masquer les canaux de couleur et rendre le masque de calque 0 visible en cliquant sur l'icône de l'œil pour voir le masque. Les masques et les couches sont des images en niveaux de gris, ce qui permet de les modifier comme toute autre image avec les outils de peinture et de retouche ainsi que les filtres. Les zones peintes en noir sur un masque sont protégées tandis que les zones peintes en blanc peuvent être modifiées.

Si vous enregistrez le fichier en tant que fichier PNG, puis rouvrez le fichier PNG dans Photoshop, la transparence est implicite. Vous ne voyez pas de vignette de masque de couche ni de masque stocké dans un canal alpha.

Sélectionnez les zones non transparentes une couche dans Photoshop

Vous pouvez sélectionner toutes les zones non transparentes d’un calque, ou, dans le cas d’un masque de fusion, toutes les zones non masquées. La sélection de ces zones est utile lorsque vous souhaitez sélectionner un contenu d'image entouré ou contenant des zones transparentes ou pour créer une sélection excluant les zones masquées d'un calque.

1. Procédez de l’une des manières suivantes :

  • Pour sélectionner uniquement les zones non transparentes d'un calque non masqué, cliquez tout en maintenant la touche Ctrl (Windows) ou Commande (Mac OS X) enfoncée sur la vignette du calque dans le panneau Calques.
  • Pour sélectionner les zones non masquées d'un calque comportant un masque de calque, cliquez tout en maintenant la touche Ctrl (Windows) ou Commande (Mac OS X) enfoncée sur la vignette du masque de calque dans le panneau Calques.
  • 2. Si une sélection existe, vous pouvez effectuer l'une des opérations suivantes :
  • Pour ajouter les pixels à une sélection existante, appuyez sur Ctrl + Maj (Windows) ou Commande + Maj (Mac OS), puis cliquez sur la vignette du calque ou sur la vignette du masque de calque dans le panneau Calques.
  • Pour soustraire les pixels d'une sélection existante, appuyez sur Ctrl + Alt (Windows) ou Commande + Option (Mac OS), puis cliquez sur la vignette du calque ou sur la vignette du masque de calque dans le panneau Calques.
  • Pour charger l'intersection des pixels et d'une sélection existante, appuyez sur Ctrl + Alt + Maj (Windows) ou Commande + Option + Maj (Mac OS), puis cliquez sur la vignette du calque ou la vignette du masque dans le panneau Calques.

Créer un canal alpha à partir d'une sélection

  1. Sélectionnez la ou les zones de l’image à isoler à l’aide d’un outil de sélection.
  2. Choisissez la commande Sélection > Mémoriser la sélection.
  3. Dans la boîte de dialogue Mémoriser la sélection, spécifiez les éléments suivants, puis cliquez sur OK :
    1. Document
      Choisit une image de destination pour la sélection. Par défaut, la sélection est placée sur une couche de l’image active. Vous pouvez cependant la mémoriser dans une couche d’une autre image ouverte ayant les mêmes dimensions en pixels ou dans une nouvelle image.
    2. Canal
      Choisit un canal de destination pour la sélection. Par défaut, celle-ci est mémorisée dans une nouvelle couche. Vous pouvez cependant la mémoriser dans n’importe quelle couche existante de l’image sélectionnée ou dans un masque de fusion si l’image contient des calques.
  4. Si vous mémorisez la sélection comme une nouvelle couche, entrez le nom de celle-ci dans la zone de texte Nom.
  5. Si vous mémorisez la sélection dans une couche existante, indiquez comment combiner les sélections :
    1. Remplacer le canal
      : remplace la sélection en cours dans le canal.
    2. Ajouter au canal
      : ajoute la sélection au contenu du canal actuel.
    3. Soustraire du canal
      : supprime la sélection du contenu du canal.
    4. Intersection avec le canal
      : conserve les zones de la nouvelle sélection qui recoupent le contenu du canal.

Vous pouvez sélectionner la couche dans le panneau Couches pour voir la sélection mémorisée affichée en niveaux de gris.

Déterminer si un canal est un canal alpha dans Photoshop

Si vous double-cliquez sur le canal, la fenêtre de dialogue des options du canal apparaît. La fenêtre de dialogue indique si la couleur indique "zones masquées", "zones sélectionnées" ou "couleur d'accompagnement".

Créer un canal alpha à partir d'une sélection

  1. Sélectionnez la ou les zones de l’image à isoler à l’aide d’un outil de sélection.
  2. Choisissez Sélection > Enregistrer la sélection.
  3. Spécifiez les éléments suivants dans la boîte de dialogue Enregistrer la sélection, puis cliquez sur OK :
    1. Document
      Choisit une image de destination pour la sélection. Par défaut, la sélection est placée sur une couche de l’image active. Vous pouvez cependant la mémoriser dans une couche d’une autre image ouverte ayant les mêmes dimensions en pixels ou dans une nouvelle image.
    2. Canal
      Choisit un canal de destination pour la sélection. Par défaut, celle-ci est mémorisée dans une nouvelle couche. Vous pouvez cependant la mémoriser dans n’importe quelle couche existante de l’image sélectionnée ou dans un masque de fusion si l’image contient des calques.
  4. Si vous mémorisez la sélection comme une nouvelle couche, entrez le nom de celle-ci dans la zone de texte Nom.
  5. Si vous mémorisez la sélection dans une couche existante, indiquez comment combiner les sélections :
    1. Canal de remplacement
      Remplace la sélection en cours dans le canal.
    2. Ajouter au canal
      : ajoute la sélection au contenu du canal actuel.
    3. Soustraire du canal
      : supprime la sélection du contenu du canal.
    4. Intersection avec le canal
      : conserve les zones de la nouvelle sélection qui recoupent le contenu du canal.
  6. Vous pouvez sélectionner la couche dans le panneau Couches pour voir la sélection mémorisée affichée en niveaux de gris.

Comment Photoshop affiche les propriétés de transparence des images

Si une image contient un tracé de détourage, le chemin de détourage est affiché dans la fenêtre "Chemins" de Photoshop, son nom étant affiché en gras.

Si une image contient un canal alpha ou masque, le canal supplémentaire est affiché dans la fenêtre "Canaux". Chaque canal de la fenêtre "Canaux" comporte une icône de l'image en cours. Si vous double-cliquez sur cette icône, rien ne se produit pour les couleurs de processus, mais une fenêtre "Options de canal" s'ouvre pour les canaux masqués, alpha et ponctuels. Cette fenêtre "Channel Options" affiche les propriétés des canaux supplémentaires.

Si une image contient un canal de transparence, elle n’est pas affichée dans la fenêtre « canaux ». En revanche, la fenêtre « Calques » contient une entrée de calque (affichée dans la police non-italic) et sans aucune entrée de calque en arrière-plan.

Si une image contient plusieurs calques, la fenêtre « Calques » contient plusieurs entrées de calque.

Techniques utilisées pour créer des transparences dans les trames d'images.

Il existe plusieurs techniques de création de transparence dans les trames d'images :

  • Masques
  • Canaux alpha et de masque
  • Canaux de transparence
  • Calques multiples

Masques

Le moyen le plus courant de créer de la transparence dans la production prépresse utilise les chemins de détourage. Les chemins de détourage isolent les objets de premier plan et rendent leur arrière-plan transparent. Les chemins de détourage sont des structures de lignes vectorielles qui créent des bords durs entre les objets de premier plan et l'arrière-plan transparent.

Canaux alpha et masque

Certains formats d'image prennent en charge les canaux alpha ou masqués.

Dans toutes les images raster, chaque pixel est représenté par un ensemble de valeurs numériques pour tous les colorants de l'image, en fonction de son espace colorimétrique. Si une image contient un canal alpha, chaque pixel de l'image est représenté en plus par une valeur numérique qui spécifie l'opacité de ce pixel. Dans les canaux alpha, 100% spécifie un pixel opaque et 0% spécifie un pixel transparent. Les canaux de masque sont exactement comme les canaux alpha, sauf pour leur polarité. Dans les canaux de masque, 100% spécifie un pixel transparent et 0% spécifie un pixel opaque. Les canaux alpha et masques offrent une transparence à plusieurs niveaux pour les ombres portées et les contours souples des objets, également appelés effets de plume. Si un format d'image prend en charge les canaux alpha et masqués, toute image de ce format peut contenir zéro, un ou plusieurs canaux alpha ou masquer. Les canaux supplémentaires peuvent être identifiés par leurs noms uniques. Si une image contient un ou plusieurs canaux alpha ou masqués, l'utilisateur a la possibilité d'appliquer aucun des canaux supplémentaires ou exactement l'un d'entre eux.

Canaux de transparence

Les couches de transparence ressemblent beaucoup à celles des couches alpha. Les formats d’image Raster prenant en charge les couches de transparence peuvent contenir une ou plusieurs couches de transparence. L’utilisateur ne dispose généralement pas du choix nécessaire pour appliquer le canal de transparence ou non. L’application d’un canal de transparence est obligatoire. Chaque pixel d'image est représenté par un ensemble de valeurs numériques pour les colorants visibles et une valeur numérique supplémentaire contenant les informations d'opacité. 100% indique un pixel opaque et 0% indique un pixel transparent. Les canaux de transparence offrent également une transparence multiniveau. Un exemple bien connu de format d'image avec des canaux de transparence est le format PNG avec la couleur RVBA.

Calques multiples

La méthode la plus complexe pour créer la transparence consiste à combiner plusieurs calques dans Adobe Photoshop. Seuls les documents natifs TIFF et Photoshop prennent en charge plusieurs calques. Les images TIFF contiennent toujours une image principale qui est une combinaison de tous les calques Photoshop. Cependant, les images Photoshop natives contiennent une image principale qui n’est pas nécessairement une combinaison de tous les calques Photoshop.

Glossaire

Masque de fusion

Un masque de calque est un masque de transparence attaché au calque. Il apparaît uniquement dans le canal alpha si le calque est actif.

Canal alpha non associé

Les images RVB avec transparence alpha peuvent être stockées de deux manières différentes. L’une consiste à stocker les valeurs RVB brutes et les valeurs alpha comme des couches distinctes ; il s’agit d'« alpha non-associé ». Le format normalisé PNG sur l'alpha « non-associé » (« non prémultipé ») pour stocker des images avec des masques de transparence distincts. La plupart des programmes de traitement d'image stockent des images avec un alpha non associé, afin de pouvoir manipuler RVB et alpha indépendamment les uns des autres, sans perdre de données RVB lors de la mise à zéro de l'alpha.

Canal alpha pré-multiplié

Une autre méthode consiste à stocker les valeurs RVB non brutes, mais premultipliées par la valeur alpha correspondante, qui est ensuite appelée « alpha associé ».
Si un canal alpha est utilisé dans une image, il est courant de multiplier la couleur par la valeur alpha. On parle généralement d'alpha premultiplié. « L'alpha premultiplié » enregistre les valeurs de pixel premultipliées par la fraction alpha. L'information alpha d'un pixel n'est pas seulement stockée dans le canal alpha lui-même, mais elle est déjà "multipliée" dans les canaux rouge, vert et bleu. Le logiciel de rendu qui fait référence à l’alpha associé, étant donné que les valeurs RVB déjà multipliées par alpha, ne fonctionnent plus en temps réel lorsqu’il effectue une fusion alpha. Le format TIFF prend en charge les deux types d'alpha, mais ils sont souvent mal étiquetés.

 

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne