Mises à jour de sécurité disponibles pour ColdFusion | APSB18-14
Référence du bulletin Date de publication Priorité 
APSB18-14 10 avril 2018 2

Récapitulatif

Adobe a publié des mises à jour de sécurité pour ColdFusion versions 11 et 2016. Ces mises à jour corrigent une vulnérabilité importante de type « chargement de bibliothèque non sécurisé » (CVE -2018-4938), une vulnérabilité importante de type « cross-site scripting, XSS » susceptible de faciliter l’injection de code (CVE-2018-4940) et une vulnérabilité importante de type « cross-site scripting, XSS » susceptible d’entraîner la divulgation d’informations (CVE-2018-4941). Ces mises à jour permettent également de contrer une vulnérabilité critique de désérialisation non sécurisée de Java (CVE-2018-4939), ainsi qu’une vulnérabilité critique d’analyse XML non sécurisée (CVE-2018-4942).

Versions concernées

Produit Versions concernées Plate-forme
ColdFusion (version 2016) Mise à jour 5 et versions antérieures Toutes
ColdFusion 11 Mise à jour 13 et versions antérieures Toutes

Solution

Adobe attribue à ce correctif la priorité suivante et recommande aux utilisateurs concernés de mettre à jour leurs installations avec les dernières versions des logiciels :

Produit Version mise à jour Plate-forme Priorité Disponibilité
ColdFusion (version 2016) Mise à jour 6 Toutes 2 Note technique
ColdFusion 11 Mise à jour 14 Toutes
2 Note technique

Remarque :

Les mises à jour de sécurité figurant dans les notes techniques ci-dessus nécessitent le JDK 8u121 ou une version supérieure (pour ColdFusion 2016), et le JDK 7u131 ou JDK 8u121 (pour ColdFusion 11). Adobe recommande d’installer la dernière version du JDK/JRE pour ColdFusion. L’installation de la mise à jour de ColdFusion sans utiliser la mise à jour du JDK correspondante NE permettra PAS de sécuriser le serveur. Voir les notes techniques dédiées pour plus de détails.

Les utilisateurs doivent également appliquer les paramètres de sécurité décrits sur la page de sécurité de ColdFusion et consulter les guides de verrouillage de sécurité dédiés.

Détails concernant la vulnérabilité

Catégorie de la vulnérabilité Impact de la vulnérabilité Gravité Références CVE
Chargement non sécurisé de la bibliothèque Réaffectation de privilèges en local Important CVE-2018-4938
Désérialisation de données non approuvées Exécution de code à distance Critique CVE-2018-4939
Cross-site scripting, XSS Divulgation d’informations Important CVE-2018-4940
Cross-site scripting, XSS Divulgation d’informations Important CVE-2018-4941
Traitement non sécurisé d’entités externes XML Divulgation d’informations Critique CVE-2018-4942

Remerciements

Adobe tient à remercier les personnes et sociétés suivantes pour avoir signalé ces problèmes et joint leurs efforts aux nôtres pour assurer la sécurité de nos clients :

  • Nitesh Shilpkar (CVE-2018-4938)
  • Nick Bloor du NCC Group (CVE-2018-4939)
  • Jaaziel Sam Carlos (CVE-2018-4940)
  • William Eatman et Michael S. O’Dell de l’USRA (CVE-2018-4941)
  • Matthias Kaiser de Code White GmbH (CVE-2018-4942)

Configuration requise pour le JDK de ColdFusion

COLDFUSION 2016 HF6

Cette mise à jour de sécurité nécessite d’avoir le JDK 8u121 ou une version ultérieure pour ColdFusion. Adobe recommande d’installer la dernière version du JDK/JRE pour ColdFusion. L’installation de la mise à jour de ColdFusion sans utiliser la mise à jour du JDK correspondante NE permettra PAS de sécuriser le serveur.

Pour les serveurs d’applications

De plus, lors des installations de JEE, définissez l’indicateur JVM suivant : « -Djdk.serialFilter= !org.mozilla.**;!com.sun.syndication.** », dans le fichier de démarrage respectif en fonction du type de serveur d’applications utilisé.

Exemple :

Sur le serveur d’applications Apache Tomcat, modifiez JAVA_OPTS dans le fichier « Catalina.bat/sh ».

Sur le serveur d’applications WebLogic, modifiez JAVA_OPTIONS dans le fichier « startWeblogic.cmd ».

Sur un serveur d’application WildFly/EAP, modifiez JAVA_OPTS dans le fichier « standalone.conf ».

Définissez les indicateurs JVM sur une installation de JEE pour ColdFusion, et non sur une configuration autonome.

COLDFUSION 11 HF14

Cette mise à jour de sécurité nécessite d’avoir les JDK 7u131 ou 8u121, ou une version ultérieure pour ColdFusion.

Adobe recommande d’installer la dernière version du JDK/JRE pour ColdFusion. L'installation de la mise à jour de ColdFusion sans utiliser la mise à jour JDK correspondante NE permettra PAS de sécuriser le serveur.

Pour les serveurs d’applications

De plus, sur les installations de J2EE, définissez l’indicateur JVM suivant, « -Djdk.serialFilter= !org.mozilla.**;!com.sun.syndication.** », dans le fichier de démarrage respectif en fonction du type de serveur d'applications utilisé.

Exemple :

Sur le serveur d'applications Apache Tomcat, modifiez JAVA_OPTS dans le fichier « Catalina.bat/sh ».

Sur le serveur d'applications WebLogic, modifiez JAVA_OPTIONS dans le fichier « startWeblogic.cmd ».

Sur un serveur d'application WildFly/EAP, modifiez JAVA_OPTS dans le fichier « standalone.conf ».

Définissez les indicateurs JVM sur une installation JEE de ColdFusion, et non sur une configuration autonome.

Clause limitative de responsabilité Adobe

Contrat de licence

En utilisant un logiciel d'Adobe Systems Incorporated ou de ses filiales ("Adobe"), vous acceptez les présentes clauses. À défaut, il vous est interdit d'utiliser ce logiciel. Les dispositions du Contrat de licence de l'utilisateur final accompagnant un fichier donné au moment de l'installation ou du téléchargement d'un logiciel prévaudront sur les dispositions ci-après.

L'exportation et la réexportation de logiciels Adobe sont régies par les EAR (Export Administration Regulations) américaines et il est interdit d'exporter ou de réexporter lesdits logiciels vers la Corée du Nord, Cuba, l'Iran, l'Irak, la Libye, le Soudan, la Syrie ou vers tout autre pays soumis à l'embargo des États-Unis. En outre, il est interdit de distribuer des logiciels Adobe à toute personne fichée sur les listes suivantes : Table of Denial Orders, Entity List ou List of Specially Designated Nationals.

En téléchargeant ou en utilisant un logiciel Adobe, vous certifiez ne pas être ressortissant de Corée du Nord, de Cuba, d'Iran, d'Irak, de Libye, du Soudan, de Syrie ou de tout autre pays soumis à l'embargo des États-Unis, ni être fiché sur les listes suivantes : Table of Denial Orders, Entity List ou List of Specially Designated Nationals. Si le logiciel est destiné à être utilisé avec une application ("application hôte") publiée par Adobe, Adobe vous concède une licence non exclusive d'utilisation dudit logiciel avec l'application hôte uniquement, sous réserve que vous possédiez une licence valide émanant d'Adobe pour l'application hôte. Sauf disposition contraire prévue plus haut, ledit logiciel vous est concédé sous licence dans le respect des conditions générales du Contrat de licence de l'utilisateur final régissant votre utilisation de l'application hôte.

DÉNI DE GARANTIE : VOUS RECONNAISSEZ QU'ADOBE NE VOUS A CONSENTI AUCUNE GARANTIE EXPRESSE CONCERNANT LE LOGICIEL ET QUE CE LOGICIEL VOUS EST FOURNI "EN L'ÉTAT" SANS GARANTIE D'AUCUNE SORTE. ADOBE REJETTE TOUTE GARANTIE, EXPRESSE OU TACITE, EN RAPPORT AVEC LE LOGICIEL, Y COMPRIS, NON LIMITATIVEMENT, TOUTE GARANTIE TACITE D'APTITUDE À UN USAGE PARTICULIER, DE NÉGOCIABILITÉ, DE QUALITÉ MARCHANDE OU DE NON-CONTREFAÇON DES DROITS D'UN TIERS. Certains États/juridictions interdisant l’exclusion de garanties tacites, il est possible que les limitations ci-avant ne s’appliquent pas à vous.

LIMITATION DE RESPONSABILITÉ : LA RESPONSABILITÉ D'ADOBE NE POURRA AUCUNEMENT ÊTRE ENGAGÉE À VOTRE ÉGARD EN CAS DE PERTE D'USAGE, D'INTERRUPTION D'ACTIVITÉ, OU DE TOUT TYPE DE DOMMAGE DIRECT, INDIRECT, ACCESSOIRE OU CONSÉCUTIF (MANQUE À GAGNER INCLUS), QUELLE QUE SOIT LA FORME D'ACTION MENÉE — POUR DÉFAUT D'EXÉCUTION DE CONTRAT, EN RESPONSABILITÉ CIVILE (Y COMPRIS POUR FAUTE), STRICTE RESPONSABILITÉ DU PRODUIT OU AUTRE — QUAND BIEN MÊME L'ÉVENTUALITÉ DE TELS DOMMAGES AURAIT ÉTÉ PORTÉE À LA CONNAISSANCE D'ADOBE. Certains États/juridictions interdisant l’exclusion ou la limitation de dommages accessoires ou consécutifs, il est possible que les limitations ci-avant ne s’appliquent pas à vous.