The AEM Mobile Signing Tool shows the following in its iOS panel and iOS apps cannot be signed: "iOS apps cannot be signed because of the following issues: Xcode 8 or greater could not be found on your system. Xcode 8 is required for signing and submitting to the App Store.”

Environment

Mac OS

Cause

The Mac OS has the "active developer directory" set to  '/Library/Developer/CommandLineTools'. It is fine when using only the Xcode command line tools but the AEM Mobile Signing Tool needs the Xcode app. So it must be installed and, if necessary, it has "active developer directory" set to the app.

Resolution

If you have not already done so, install Xcode from the Mac OS App Store application. Attempt to use the AEM Mobile Signing Tool.

If it still shows the error, do the following:

  1. In the finder go to /Applications/Utilities and launch the Terminal app.
  2. Type the following, then press Return:

sudo xcode-select -s /Applications/Xcode.app/Contents/Developer

Now launch the AEM Mobile Signing Tool.

Šis darbs ir licencēts saskaņā ar Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported licenci  Uz portālā Twitter™ un Facebook izvietotajiem ziņojumiem neattiecas Creative Commons sistēmas noteikumi.

Juridisks paziņojums   |   Tiešsaistes konfidencialitātes politika