عندما تقوم بتوزيع نموذج، يقوم Acrobat ألياً بإنشاء حزمة PDF لتجميع البينات المسلمة من قبل المستخدمين. بشكل افتراضي، يتم حفظ هذا الملف في نفس المجلد مثل النموذج الأصلي ويسمى اسم الملف_ردود. يمكنك استخدام هذا الملف لترجمة النماذج المرتجعة.

Adobe recommends

Adobe recommends
<a href="https://tv.adobe.com/watch/acrobat-x/managing-form-data/">برامج تعليمية عبر الفيديو: إدارة بيانات النموذج</a>
Timothy Plumer, Jr.

تجميع بيانات المستخدم

  1. بعد أن يقوم مستخدم بتسليم نموذج ما، قم بفتح النموذج المرتجع.
  2. في مربع الحوار Add Completed Form To Responses File، حدد أحد الخيارات التالية:

    Add To An Existing Responses File

    يجمع البيانات في ملف الردود الذي تم إنشاؤه عند استخدام المعالج Distribute Form لإرسال النموذج. (إن كان ضرورياً، انقر فوق Browse وحدد مكان ملف الردود.)

    Create A New Responses File

    إنشاء ملف ردود، باستخدام اسم ومكان تقوم بتعيينه.

يفتح ملف الردود بعد أن تنقر OK. يظهر كل نموذج مرتجع تتم إضافته إلى ملف الردود كملف مكون لـ نموذج PDF.

تجميع بيانات النموذج

  1. في Acrobat، اختر Tools >‏ Forms >‏ More Form Options >‏ Compile Returned Forms.
  2. في شاشة Compile Data، قم بأحد الإجراءات التالية لتحديد ملف ردود PDF:
    • انقر فوق Browse، ثم حدد مكان وحدد ملف الردود.

    • اكتب المسار في ملف الاستجابة.

  3. انقر فوق Add File وانتقل إلى النموذج المرتجع.
  4. قم بتكرار الخطوة السابقة حسب الحاجة لإضافة المزيد من النماذج المرتجعة.

بعد أن تنقر OK، تتم إضافة البيانات من النماذج المحددة إلى ملف الردود. يظهر كل نموذج مرتجع كملف مكون من حزمة PDF.

إضافة بيانات مستتخدم إلى ملف استجابة حالي

  1. في Acrobat، افتح ملف الردود.
  2. في لوحة التصفح الموجودة على اليسار، انقر فوق Add.
  3. في الشاشة Add Returned Forms، انقر فوق Add File. ثم حدد مكان وحدد النماذج المرتجعة، وانقر فوق Open.
  4. كرر الخطوة التالية لإضافة أي نماذج مرتجعة في المجلدات الأخرى. عند الانتهاء انقر فوق OK.

عند الانتهاء، يظهر كل نموذج PDF تتم إضافته كملف مكون من حزمة PDF.

تصدير بيانات المستخدم من ملف استجابة

استخدم هذه العملية لحفظ كل المدخلات في ملف استجابة PDF Portfolio في جدول بيانات أو ملف XML.

  1. في Acrobat، افتح ملف الردود وحدد البيانات المطلوب تصديرها.
  2. في لوحة التصفح الموجودة على اليسار، انقر فوق Export.
  3. في شاشة Select Folder To Save File، قم بتعيين اسم ومكان وتنسيق ملف (CSV أو XML) لبيانات النموذج، وانقر فوق Save.

إدارة ملفات بيانات النموذج

يمكنك نقل الإجابات على نموذج PDF إلى ومن تنسيقات ملفات أخرى تحتفظ بالبيانات في مساحة أقل من PDF كامل.

استيراد بيانات نموذج

في بعض سيناريوهات سير العمل، يقوم الأفراد بتسليم نماذج معبئة على هيئة ملفات بيانات فقط بدلاً من هيئة ملفات PDF كاملة. تلك الملفات ليست ملفات PDF، لكنها تستخدم تنسيق ملفات آخر، مثل FDF أو XML. يمكنك عرض البيانات المسلمة من قبل متلقين منفردين في سياق PDF بفتح الملف الأصلي وإدراج المعلومات في ملف البيانات.

  1. في Acrobat، افتح نموذج PDF المطلوب استيراد بيانات إليه.
  2. اختر Tools >‏ Forms >‏ Clear Form.

    ملاحظة:

    عندما تقوم بإدراج بيانات من ملف آخر في نموذج PDF، تستبدل البيانات المدرجة أي معلومات التي ظهرت سابقاً في حقول النموذج المنفردة. على أي حال، إذا احتوى ملف البيانات المدرجة على حقل نموذج فارغ أو أكثر، فإن الإدراج لن يمسح البيانات الأصلية.

  3. اختر Tools >‏ Forms >‏ More Form Options >‏ Manage Form Data >‏ Import Data.
  4. في شاشة تSelect File Containing Form Data، حدد تنسيق فيFile Of Type المرادف لملف البيانات الذي تريد إدراجه. ثم عيِّن مكان ملف FDF وحدده، وانقر فوق Open.

    ملاحظة:

    بعض التنسيقات متوفرة فقط لأنواع معينة من نماذج PDF، حسب التطبيق المستخدم لإنشاء النموذج، مثل Acrobat أو Designer ES2. البيانات التي تقوم بإدراجها من ملف نص (.txt) يجب أن يتم تنسيقه على هيئة صفوف مفصولة بحروف جدولة التي تكون الأعمدة.

تصدير بيانات الملف

يمكنك حفظ المعلومات في نموذج PDF مكتمل مثل ملف بيانات في تنسيق ملف مختلف. لاحقًا، يمكنك إعادة استخدام البيانات لتعبئة النموذج مرة أخرى أو نموذج آخر بنفس الحقول وأسماء الحقول.

  1. في Acrobat، افتح ملف النموذج المكتمل.
  2. اختر Tools >‏ Forms >‏ More Form Options >‏ Manage Form Data >‏ Export Data.
  3. في شاشة Export Form Data As، حدد التنسيق الذي تريد حفظ بيانات النموذج به (FDF، XFDF، XML، أو TXT). ثم حدد مكان، واكتب اسم الملف، وانقر فوق Save.

    ملاحظة:

    بعض تنسيقات الملف متاحة فقط لأنواع معينة من نماذج PDF، حسب كيفية إنشاء النموذج.

دمج ملفات البيانات المصدرة إلى جدول بيانات

إذا كنت تريد ترجمة بيانات من نماذج ليست في مجموعة بيانات بالفعل، فاستخدم العملية التالية.

  1. اختر Tools >‏ Forms >‏ More Form Options >‏ Manage Form Data >‏ Merge Data Files Into Spreadsheet.
  2. في الشاشة Export Data From Multiple Forms، انقر فوق Add Files.
  3. في الشاشة Select file Containing Form Data، حدد خيار تنسيق ملف في الخيار File Of Type (Acrobat Form Data Files أو All Files). ثم عيِّن مكان ملفات النموذج التي تريد دمجها في الجدول، وحددها، وبعد ذلك انقر فوق Open.
  4. كرر الخطوة السابقة لإضافة ملفات بيانات النموذج الموجودة في أماكن أخرى، حسب الحاجة.
  5. انقر فوق Export. ثم حدد مجلد واسم الملف للجدول الإلكتروني، وانقر فوق Save.
  6. في شاشة Export Progress، انقر فوق إما View File Now لفتح ملف الجدول الإلكتروني أو Close Dialog للرجوع إلى Acrobat.

ملاحظة:

عندما تكون النماذج المرتجعة في ملف الردود، فإن أكثر الطرق كفاءة لتصدير المعلومات إلى جدول بيانات هي استخدام الزر Export Data في لوحة التصفح اليسرى لملف ردود حزمة PDF.

لمحة حول Forms Tracker‏

استخدم المتتبع Tracker لإدارة النماذج التي قمت بتوزيعها أو استلامها. يتيح لك Tracker عرض وتحرير مكان ملف الردود، وتتبع أي من المتلقين قام بالرد، وإضافة المزيد من المتلقين، وإرسال بريد إلكتروني لكل المتلقين، وعرض الردود على نموذج ما.

تتبع النماذج

  1. في Acrobat، اختر Edit > Form Options > Track or View > Tracker.

  2. في لوحة التنقل على اليسار، قم بتمديد Forms.

  3. حدد نموذج، ثم قم بتنفيذ أحد الأمور التالية:

    • لعرض جميع الردود من نموذج، انقر View Responses.

    • لتعديل مكان ملف الردود، في Responses File Location انقر فوق Edit File Location.

    • لعرض النموذج الأصلي، انقر Open Original Form.

    • لإرسال النموذج لأكثر من متلقي، انقر Add Recipients.

تم ترخيص هذا العمل بموجب الترخيص العام غير المعدل الخاص بالإسناد وعدم التجارة والمشاركة الإصدار 3.0 ‏من ‏‏Creative Commons‏‏  إن بنود Creative Commons لا تشمل منشورات Twitter™‎ وFacebook.

إشعارات قانونية   |   سياسة الخصوصية على الإنترنت