Creative_Cloud_mnemonic_RGB_48px

Update to Illustrator CS6 available

For more information, see the New features summary.


HiDPI support

To take advantage of advancements in high-resolution display technologies, Illustrator includes native support for high-resolution displays. This feature is currently available for the Mac OS (for example, the MacBook Pro with Retina display). You can work with a sharper and clearer user interface on devices with high-resolution displays. Thumbnails in panels are also much clearer.

Text and complex artwork also display in greater clarity, and in colors and hues that appear more vibrant than before.

With HiDPI support, artwork appears crisper on a high-resolution display
With HiDPI support, artwork appears crisper on a high-resolution display

A. Illustrator with HiDPI support B. Illustrator without HiDPI support 

Adobe Creative Cloud only

Package files

Gather all the files used, including linked graphics and fonts, into a single folder for quick hand-off. Choose File > Package to collect all assets in a single location. See Package Files.

Unembed images

Replace embedded images with links to their extracted PSD or TIFF files. Select an embedded image and choose Unembed from the Links panel menu, or click Unembed in the Control panel. See Unembed images.

Links panel improvements

View and track additional information about placed artwork directly in the Links panel. See Links Information

Adobe Mercury Performance System

The Adobe Mercury Performance system is a combination of solutions that makes Illustrator faster, more responsive, and able to handle larger files.

64-bit native support

Makes general processing faster on 64-bit Macintosh and Windows operating systems. Illustrator can now take advantage of RAM beyond 3 GB.

Handle larger files

Concurrent handling of large files is less likely to cause errors, like out-of-memory exceptions. Complex tasks, such as creating package designs, large-format graphics, or cartography, are better handled.

Improved memory handling

Reduces out-of-memory errors for operations such as rasterization, export, and working on several large files simultaneously.

For more information, view the video on the Mercury Performance System, by Lynda.com.

Improved user interface

The user interface is more efficient, streamlined, and more configurable, to make working in Illustrator a more pleasing experience.

Example of a user interface enhancement: Configurable brightness levels and corresponding canvas colors
Example of a user interface enhancement: Configurable brightness levels and corresponding canvas colors

Simplified Workflows

Patterns

Pattern creation and editing tasks have been simplified, so you can save hours of repetitive and tedious work. The new Pattern Options panel provides you with an easy set of options to experiment and modify your design until you get the pattern of your choice.

For details on the Pattern Options panel and workflow, see Create and edit patterns.

For more information, view the video on pattern creation and editing, by Lynda.com.

Create or edit a pattern with the new Pattern panel
Pattern creation

Gradient on a stroke

The gradient on a stroke feature provides you with three types of gradients to apply to a stroke. You no longer have to expand a stroke to fill it, and then apply a gradient to it. Apply a gradient to a stroke using the Gradient panel (Window > Gradient):

Within: Behaves as if the stroke has been expanded to a filled object with a gradient

Along: The gradient is applied along the length of the stroke.

Across: The gradient is applied across the width of the stroke.

For more information, view the video on applying gradients to a stroke, by Lynda.com.

Apply a gradient to a stroke
Apply a gradient to a stroke

Image Trace

The workflow to vectorize a raster image now produces much cleaner tracings. The output has fewer paths and anchor points, and better color recognition than the Live Trace feature in previous versions. 

For more information on the new Image Trace workflow, read this article, or watch this video by Lynda.com.

Gaussian Blur

The new Gaussian Blur effect (Effect > Blur > Gaussian Blur) is speedy and efficient. Select the Preview checkbox to view the Gaussian Blur applied to your artwork, in real time.

New or improved profiles and components

Use the improved profiles and additional component libraries to get a quick start on your art projects:

  • A new profile named Devices has been introduced in the New Document dialog box (File > New). The new profile contains presets for the iPad, iPhone, Xoom, Fire, Nook, and Galaxy devices.
  • The Web profile has a new default size (960px x 560px).
  • New Pattern and new Pantone Plus™ color libraries have been added.

For more information, view the video on enhanced startup profiles and other changes, by Lynda.com

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy