User Guide Cancel

Mask layers

  1. Photoshop User Guide
  2. Introduction to Photoshop
    1. Dream it. Make it.
    2. What's new in Photoshop
    3. Edit your first photo
    4. Create documents
    5. Photoshop | Common Questions
    6. Photoshop system requirements
    7. Get to know Photoshop
  3. Photoshop and other Adobe products and services
    1. Work with Illustrator artwork in Photoshop
    2. Work with Photoshop files in InDesign
    3. Substance 3D Materials for Photoshop
    4. Use the Capture in-app extension in Photoshop
  4. Photoshop on the iPad (not available in mainland China)
    1. Photoshop on the iPad | Common questions
    2. Get to know the workspace
    3. System requirements | Photoshop on the iPad
    4. Create, open, and export documents
    5. Add photos
    6. Work with layers
    7. Draw and paint with brushes
    8. Make selections and add masks
    9. Retouch your composites
    10. Work with adjustment layers
    11. Adjust the tonality of your composite with Curves
    12. Apply transform operations
    13. Crop and rotate your composites
    14. Rotate, pan, zoom, and reset the canvas
    15. Work with Type layers
    16. Work with Photoshop and Lightroom
    17. Get missing fonts in Photoshop on the iPad
    18. Japanese Text in Photoshop on the iPad
    19. Manage app settings
    20. Touch shortcuts and gestures
    21. Keyboard shortcuts
    22. Edit your image size
    23. Livestream as you create in Photoshop on the iPad
    24. Correct imperfections with the Healing Brush
    25. Create brushes in Capture and use them in Photoshop on the iPad
    26. Work with Camera Raw files
    27. Create and work with Smart Objects
    28. Adjust exposure in your images with Dodge and Burn
    29. Auto adjustment commands in Photoshop on the iPad
    30. Smudge areas in your images with Photoshop on the iPad
    31. Saturate or desaturate your images using Sponge tool
    32. Content aware fill for iPad
  5. Photoshop on the web (not available in mainland China)
    1. Common questions
    2. System requirements
    3. Keyboard shortcuts
    4. Supported file types
    5. Introduction to the workspace
    6. Open and work with cloud documents
    7. Generative AI features
    8. Basic concepts of editing
    9. Quick Actions
    10. Work with layers
    11. Retouch images and remove imperfections
    12. Make quick selections
    13. Image improvements with Adjustment Layers
    14. Move, transform, and crop images
    15. Draw and paint
    16. Work with Type layers
    17. Work with anyone on the web
    18. Manage app settings
    19. Generate Image
    20. Generate Background
    21. Reference Image
  6. Photoshop (beta) (not available in mainland China)
    1. Get started with Creative Cloud Beta apps
    2. Photoshop (beta) on the desktop
    3. Generate image with descriptive text prompts
    4. Generate background with descriptive text prompts
  7. Generative AI (not available in mainland China) 
    1. Common questions on generative AI in Photoshop
    2. Generative Fill in Photoshop on the desktop
    3. Generative Expand in Photoshop on the desktop
    4. Generative Fill in Photoshop on the iPad
    5. Generative Expand in Photoshop on the iPad
    6. Generative AI features in Photoshop on the web
  8. Content authenticity (not available in mainland China)
    1. Content credentials in Photoshop
    2. Identity and provenance for NFTs
    3. Connect accounts for creative attribution
  9. Cloud documents (not available in mainland China)
    1. Photoshop cloud documents | Common questions
    2. Photoshop cloud documents | Workflow questions
    3. Manage and work with cloud documents in Photoshop
    4. Upgrade cloud storage for Photoshop
    5. Unable to create or save a cloud document
    6. Solve Photoshop cloud document errors
    7. Collect cloud document sync logs
    8. Invite others to edit your cloud documents
    9. Share files and comment in-app
  10. Workspace
    1. Workspace basics
    2. Preferences
    3. Learn faster with the Photoshop Discover Panel
    4. Create documents
    5. Place files
    6. Default keyboard shortcuts
    7. Customize keyboard shortcuts
    8. Tool galleries
    9. Performance preferences
    10. Use tools
    11. Presets
    12. Grid and guides
    13. Touch gestures
    14. Use the Touch Bar with Photoshop
    15. Touch capabilities and customizable workspaces
    16. Technology previews
    17. Metadata and notes
    18. Touch capabilities and customizable workspaces
    19. Place Photoshop images in other applications
    20. Rulers
    21. Show or hide non-printing Extras
    22. Specify columns for an image
    23. Undo and history
    24. Panels and menus
    25. Position elements with snapping
    26. Position with the Ruler tool
  11. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  12. Image and color basics
    1. How to resize images
    2. Work with raster and vector images
    3. Image size and resolution
    4. Acquire images from cameras and scanners
    5. Create, open, and import images
    6. View images
    7. Invalid JPEG Marker error | Opening images
    8. Viewing multiple images
    9. Customize color pickers and swatches
    10. High dynamic range images
    11. Match colors in your image
    12. Convert between color modes
    13. Color modes
    14. Erase parts of an image
    15. Blending modes
    16. Choose colors
    17. Customize indexed color tables
    18. Image information
    19. Distort filters are unavailable
    20. About color
    21. Color and monochrome adjustments using channels
    22. Choose colors in the Color and Swatches panels
    23. Sample
    24. Color mode or Image mode
    25. Color cast
    26. Add a conditional mode change to an action
    27. Add swatches from HTML CSS and SVG
    28. Bit depth and preferences
  13. Layers
    1. Layer basics
    2. Nondestructive editing
    3. Create and manage layers and groups
    4. Select, group, and link layers
    5. Place images into frames
    6. Layer opacity and blending
    7. Mask layers
    8. Apply Smart Filters
    9. Layer comps
    10. Move, stack, and lock layers
    11. Mask layers with vector masks
    12. Manage layers and groups
    13. Layer effects and styles
    14. Edit layer masks
    15. Extract assets
    16. Reveal layers with clipping masks
    17. Generate image assets from layers
    18. Work with Smart Objects
    19. Blending modes
    20. Combine multiple images into a group portrait
    21. Combine images with Auto-Blend Layers
    22. Align and distribute layers
    23. Copy CSS from layers
    24. Load selections from a layer or layer mask's boundaries
    25. Knockout to reveal content from other layers
  14. Selections
    1. Get started with selections
    2. Make selections in your composite
    3. Select and Mask workspace
    4. Select with the marquee tools
    5. Select with the lasso tools
    6. Adjust pixel selections
    7. Move, copy, and delete selected pixels
    8. Create a temporary quick mask
    9. Select a color range in an image
    10. Convert between paths and selection borders
    11. Channel basics
    12. Save selections and alpha channel masks
    13. Select the image areas in focus
    14. Duplicate, split, and merge channels
    15. Channel calculations
  15. Image adjustments
    1. Replace object colors
    2. Perspective warp
    3. Reduce camera shake blurring
    4. Healing brush examples
    5. Export color lookup tables
    6. Adjust image sharpness and blur
    7. Understand color adjustments
    8. Apply a Brightness/Contrast adjustment
    9. Adjust shadow and highlight detail
    10. Levels adjustment
    11. Adjust hue and saturation
    12. Adjust vibrance
    13. Adjust color saturation in image areas
    14. Make quick tonal adjustments
    15. Apply special color effects to images
    16. Enhance your image with color balance adjustments
    17. High dynamic range images
    18. View histograms and pixel values
    19. Match colors in your image
    20. Crop and straighten photos
    21. Convert a color image to black and white
    22. Adjustment and fill layers
    23. Curves adjustment
    24. Blending modes
    25. Target images for press
    26. Adjust color and tone with Levels and Curves eyedroppers
    27. Adjust HDR exposure and toning
    28. Dodge or burn image areas
    29. Make selective color adjustments
  16. Adobe Camera Raw
    1. Camera Raw system requirements
    2. What's new in Camera Raw
    3. Introduction to Camera Raw
    4. Create panoramas
    5. Supported lenses
    6. Vignette, grain, and dehaze effects in Camera Raw
    7. Default keyboard shortcuts
    8. Automatic perspective correction in Camera Raw
    9. Radial Filter in Camera Raw
    10. Manage Camera Raw settings
    11. Open, process, and save images in Camera Raw
    12. Repair images with the Enhanced Spot Removal tool in Camera Raw
    13. Rotate, crop, and adjust images
    14. Adjust color rendering in Camera Raw
    15. Process versions in Camera Raw
    16. Make local adjustments in Camera Raw
  17. Image repair and restoration
    1. Remove objects from your photos with Content-Aware Fill
    2. Content-Aware Patch and Move
    3. Retouch and repair photos
    4. Correct image distortion and noise
    5. Basic troubleshooting steps to fix most issues
  18. Image enhancement and transformation
    1. Replace sky in your images
    2. Transform objects
    3. Adjust crop, rotation, and canvas size
    4. How to crop and straighten photos
    5. Create and edit panoramic images
    6. Warp images, shapes, and paths
    7. Vanishing Point
    8. Content-aware scaling
    9. Transform images, shapes, and paths
  19. Drawing and painting
    1. Paint symmetrical patterns
    2. Draw rectangles and modify stroke options
    3. About drawing
    4. Draw and edit shapes
    5. Painting tools
    6. Create and modify brushes
    7. Blending modes
    8. Add color to paths
    9. Edit paths
    10. Paint with the Mixer Brush
    11. Brush presets
    12. Gradients
    13. Gradient interpolation
    14. Fill and stroke selections, layers, and paths
    15. Draw with the Pen tools
    16. Create patterns
    17. Generate a pattern using the Pattern Maker
    18. Manage paths
    19. Manage pattern libraries and presets
    20. Draw or paint with a graphics tablet
    21. Create textured brushes
    22. Add dynamic elements to brushes
    23. Gradient
    24. Paint stylized strokes with the Art History Brush
    25. Paint with a pattern
    26. Sync presets on multiple devices
    27. Migrate presets, actions, and settings
  20. Text
    1. Add and edit the text
    2. Unified Text Engine
    3. Work with OpenType SVG fonts
    4. Format characters
    5. Format paragraphs
    6. How to create type effects
    7. Edit text
    8. Line and character spacing
    9. Arabic and Hebrew type
    10. Fonts
    11. Troubleshoot fonts
    12. Asian type
    13. Create type
  21. Filters and effects
    1. Use the Blur Gallery
    2. Filter basics
    3. Filter effects reference
    4. Add Lighting Effects
    5. Use the Adaptive Wide Angle filter
    6. Use the Oil Paint filter
    7. Use the Liquify filter
    8. Layer effects and styles
    9. Apply specific filters
    10. Smudge image areas
  22. Saving and exporting
    1. Save your files in Photoshop
    2. Export your files in Photoshop
    3. Supported file formats
    4. Save files in graphics formats
    5. Move designs between Photoshop and Illustrator
    6. Save and export video and animations
    7. Save PDF files
    8. Digimarc copyright protection
  23. Color Management
    1. Understanding color management
    2. Keeping colors consistent
    3. Color settings
    4. Duotones
    5. Work with color profiles
    6. Color-managing documents for online viewing
    7. Color-managing documents when printing
    8. Color-managing imported images
    9. Proofing colors
  24. Web, screen, and app design
    1. Photoshop for design
    2. Artboards
    3. Device Preview
    4. Copy CSS from layers
    5. Slice web pages
    6. HTML options for slices
    7. Modify slice layout
    8. Work with web graphics
    9. Create web photo galleries
  25. Video and animation
    1. Video editing in Photoshop
    2. Edit video and animation layers
    3. Video and animation overview
    4. Preview video and animations
    5. Paint frames in video layers
    6. Import video files and image sequences
    7. Create frame animations
    8. Creative Cloud 3D Animation (Preview)
    9. Create timeline animations
    10. Create images for video
  26. Printing
    1. Print 3D objects
    2. Print from Photoshop
    3. Print with color management
    4. Contact Sheets and PDF Presentations
    5. Print photos in a picture package layout
    6. Print spot colors
    7. Print images to a commercial printing press
    8. Improve color prints from Photoshop
    9. Troubleshoot printing problems | Photoshop
  27. Automation
    1. Creating actions
    2. Create data-driven graphics
    3. Scripting
    4. Process a batch of files
    5. Play and manage actions
    6. Add conditional actions
    7. About actions and the Actions panel
    8. Record tools in actions
    9. Add a conditional mode change to an action
    10. Photoshop UI toolkit for plug-ins and scripts
  28. Troubleshooting
    1. Fixed issues 
    2. Known issues
    3. Optimize Photoshop performance
    4. Basic troubleshooting
    5. Troubleshoot crash or freeze
    6. Troubleshoot program errors
    7. Troubleshoot scratch disk full errors
    8. Troubleshoot GPU and graphics driver issues
    9. Find missing tools
    10. Photoshop 3D | Common questions around discontinued features

  Discontinuation of 3D features in Photoshop

Photoshop’s 3D features will be removed in future updates. Users working with 3D are encouraged to explore Adobe’s new Substance 3D collection, which represents the next generation of 3D tools from Adobe. Additional details on the discontinuation of Photoshop’s 3D features can be found here: Photoshop 3D | Common questions on discontinued 3D features.

Learn how to mask layers to hide and reveal parts of your composite

Topics in this article:

Add a mask to a layer and use the mask to hide portions of the layer and reveal the layers underneath.

Masking layers come in handy when combining multiple photos into a single image or when removing a person or an object from a photo.

Create layer and vector masks

You can create two types of masks:

  1. Layer masks are resolution-dependent bitmap images that are edited with the painting or selection tools.
  2. Vector masks are resolution independent and are created with a pen or shape tool.

Both layer and vector masks are nondestructive, which means you can go back and re‑edit the masks later without losing the pixels they hide.

In the Layers panel, both the layer and vector masks appear as an additional thumbnail to the right of the layer thumbnail.

For the layer mask, this thumbnail represents the grayscale channel that is created when you add the layer mask. The vector mask thumbnail represents a path that clips out the contents of the layer.

Follow these steps to create a layer or vector mask over the Background layer.

  1. Convert your Background layer into a regular layer by navigating to Layer > New > Layer from Background.

  2. Use the Add layer mask icon at the end of the Layers panel to add a Layer Mask.    

    Layer mask and vector mask thumbnails in the Layers panel in Photoshop
    View the Layer mask and Vector mask thumbnails in the Layers panel

  3. Use the Density and Feather sliders to make adjustments to your composite.  

    Layer Mask in Properties panel

    Vector Mask in Properties panel

You can edit a layer mask to add or subtract from the masked region. A layer mask is a grayscale image. The areas you paint in black are hidden, the areas you paint in white are visible, and the areas you paint in shades of gray appear in various levels of transparency.

The areas in black are hidden and the areas in white are visible, and the areas in shades of gray appear in various levels of transparency.

A vector mask creates a sharp-edged shape on a layer and is useful anytime you want to add a design element with clean and defined edges. After you create a layer with a vector mask, you can apply one or more layer styles to it, edit them if needed, and instantly have a usable button, panel, or other web-design element.

The Properties panel provides additional controls to adjust a mask. You can change the opacity of a mask to let more or less of the masked content show through, invert the mask, or refine the mask borders, as with a selection area.

Add layer masks

When you add a layer mask, you can hide or show all of the layer, or base the mask on a selection or transparency. Later, you’ll paint on the mask to precisely hide portions of the layer, revealing the layers beneath.

Add a mask that shows or hides the entire layer

  1. Make sure that no part of your image is selected. Choose Select > Deselect.
  2. In the Layers panel, select the layer or group.
  3. Do one of the following:
    • To create a mask that reveals the entire layer, click the Add Layer Mask  button in the Layers panel, or choose Layer > Layer Mask > Reveal All.

    • To create a mask that hides the entire layer, Alt-click (Win) or Option-click (Mac) the Add Layer Mask button, or choose Layer > Layer Mask > Hide All.

Add a layer mask that hides part of a layer

  1. In the Layers panel, select the layer or group.
  2. Select the area in the image, and do one of the following:
    • Click the New Layer Mask button  in the Layers panel to create a mask that reveals the selection.
    • Alt-click (Win) or Option-click (Mac) the Add Layer Mask button in the Layers panel to create a mask that hides the selection.
    • Choose Layer > Layer Mask > Reveal Selection or Hide Selection.

To directly edit layer transparency, do the following and create a mask:

  1. In the Layers panel, select the layer.
  2. Choose Layer > Layer Mask > From Transparency.

Photoshop converts transparency into an opaque color, hidden by the newly created mask. The opaque color varies greatly, depending upon the filters and other processing previously applied to the layer. This technique is helpful for video and 3D workflows.

Apply a layer mask from another layer

Do one of the following:

  • To move the mask to another layer, drag the mask to the other layer.
  • To duplicate the mask, Alt-drag (Win) or Option-drag (Mac) the mask to the other layer.

Create layer masks for all detected objects in a layer

Layer masking is a nondestructive way to hide parts of an image or layer without erasing them. They're great for making image composites, modifying background colors, removing or cutting out objects, and targeting your edits so they affect only certain areas, rather than the entire layer.

Mask All Objects is a quick and easy way to create layer masks for all detected objects in a layer. It will auto-generate mask layer groups, on separate layers, for every object detected on the selected layer with one command.

Mask All Objects is great for creating selections from the auto-generated masks, targeting the layer, then applying edits such as Generative Fill, adjustments, or filters. For example, if you have six people in an image, each person will be masked on their own separate layer group, as well as one mask for the entire group of people.

Follow these steps to learn how to use Mask All Objects in the Layers tab in Photoshop:

  1. Mask all objects

    Select a single layer, either go to Layer > Mask All Objects, right-click on the layer in the Layers panel, or go to the Layers panel flyout menu and select Mask All Objects.

    Progress bar in Photoshop can be viewed while masks are generated for layers that include many objects
    Generating masks may take a few minutes for layers that include many objects.

  2. Add an Adjustment to the Masked Layer

    In the Layers panel, find the mask associated with the object you would like to adjust.

    Select a layer mask group - you can now add any adjustment or filter you want to the masked object.

    Add an adjustment to a masked layer in Photoshop
    A hue saturation adjustment has been applied to one of the lemons to make it look like a lime.

    Select Adjustment > Hue Saturation at the end of the Layers panel and move the color slider until the selection is green. The adjustment is applied to the layer mask group.

    Tip:
    • To view on canvas what is being masked, CMD + click on the layer mask to select with marching ants,
    • Select Move tool and turn on Show Transform Controls in the Move tool options bar + select the layer mask to view the masked object. 
    • Turn on smart guides, select a layer, hold down the CMD key and the mask will be highlighted on canvas with smart guides.
  3. After your masking work is complete, go to File > Scripts > Delete All Empty Layers to remove groups or layers that contain no or empty data.

    Remove groups or layers that contain no or empty data
    After your masking work is complete, remove groups or layers that contain no or empty data.

Unlink layers and masks

By default, a layer or group is linked to its layer mask or vector mask, as indicated by the link icon  between the thumbnails in the Layers panel. The layer and its mask move together in the image when you move either one with the Move tool . Unlinking them lets you move them independently and shift the mask’s boundaries separately from the layer.

  • To unlink a layer from its mask, click the link icon in the Layers panel.

  • To reestablish the link between a layer and its mask, click between the layer and mask path thumbnails in the Layers panel.

Disable or enable a layer mask

Do one of the following:

  • Select the layer containing the layer mask you want to disable or enable, and click the Disable/Enable Mask button  in the Properties panel.

  • Shift-click the layer mask thumbnail in the Layers panel.

  • Select the layer containing the layer mask you want to disable or enable, and choose Layer > Layer Mask > Disable/Enable.

A red X appears over the mask thumbnail in the Layers panel when the mask is disabled, and the layer’s content appears without masking effects.

Apply or delete a layer mask

You can apply a layer mask to permanently delete the hidden portions of a layer [*]. Layer masks are stored as alpha channels, so applying and deleting layer masks can help reduce file size. You can also delete a layer mask without applying the changes.

Note:

[*] Pixels are hidden, not deleted when applying layer masks with discontiguous areas.

  1. In the Layers panel, select the layer containing the layer mask.
  2. Do one of the following:
    • To remove the layer mask after applying it permanently to the layer, click the Apply Mask icon  at the bottom of the Properties panel.
    • To remove the layer mask without applying it to the layer, click the Delete button at the bottom of the Properties panel, and then click Delete.

    You can also apply or delete layer masks using the Layer menu.

    Note:

    You cannot apply a layer mask permanently to a Smart Object layer when deleting the layer mask.

Select and display the layer mask channel

For easier editing of a layer mask, you can display the grayscale mask by itself or as a rubylith overlay on the layer.

  1. In the Layers panel, do one of the following:

    • Alt-click (Win) or Option-click (Mac) the layer mask thumbnail to view only the grayscale mask. To redisplay the layers, Alt-click or Option-click the layer mask thumbnail. Alternatively, click the eye icon  in the Properties panel.
    • Hold down Alt+Shift (Win) or Option+Shift (Mac), and click the layer mask thumbnail to view the mask on top of the layer in a Rubylith masking color. Hold down Alt+Shift or Option+Shift, and click the thumbnail again to turn off the color display.

Change the layer mask color or opacity

  1. Double-click the layer mask channel in the Channels panel.

  2. To choose a new mask color, in the Layer Mask Display Options dialog box, click the color swatch and choose a new color.
  3. To change the opacity, enter a value between 0% and 100%.

    Both the color and opacity settings affect only the appearance of the mask and have no effect on how underlying areas are protected. For example, you may want to change these settings to make the mask more easily visible against the colors in the image.

  4. Click OK.

Adjust mask opacity and edges

Use the Properties panel to adjust the opacity of a selected layer or vector mask. The Density slider controls mask opacity. Feather lets you soften mask edges.

Other options are specific to layer masks. The Invert option reverses masked and unmasked areas. The Mask Edge option gives you various controls to modify the mask edges, such as Smooth and Contract/Expand. For information on the Color Range option, see Create and confine adjustment and fill layers.

Change mask density

  1. In the Layers panel, select the layer containing the mask you want to edit.
  2. In the Layers panel, click the Mask thumbnail. A border appears around the thumbnail.

  3. In the Properties panel, drag the Density slider to adjust the mask opacity.

    At 100% density, the mask is opaque and blocks out any underlying area of the layer. As you lower the density, more of the area under the mask becomes visible.

Feather mask edges

  1. In the Layers panel, select the layer containing the mask you want to edit.
  2. In the Layers panel, click the Mask thumbnail. A border appears around the thumbnail.

  3. Drag the Feather slider to apply feathering to the mask edges.

    Feathering blurs the edges of the mask to create a softer transition between the masked and unmasked areas. Feathering is applied from the edges of the mask outward, within the range of pixels you set with the slider.

Refine mask edges

  1. In the Layers panel, select the layer containing the mask you want to edit.
  2. In the Layers panel, click the Mask thumbnail. A border appears around the thumbnail.

  3. Click Select and Mask in the options bar. You can modify mask edges with the options in the Select and Mask workspace and view the mask against different backgrounds. 

  4. Click OK in the Select and Mask workspace to apply your changes to the layer mask.


 Adobe

Get help faster and easier

New user?