Refining a recorded performance

Learn everything you need to know about refining a recorded performance of your puppets including the functionalities of the timeline work area.

Adjust time and reorder scene contents

You can change the timing and order of puppets, recorded takes, and audio to fine-tune your work. Puppets and audio appear as track items (larger bars), and recorded takes appear as shorter bars under puppet track items. You can also zoom in or out in time for easier access to track bars or a temporal overview of the scene.

When zoomed into the duration of a frame of time in the Timeline panel, the horizontal center of the frame is denoted with a dashed line to indicate the exact time that the track item or take is being sampled.

Drag the Zoom Timeline slider or click the Zoom Timeline In, Zoom Timeline Out, or Zoom Timeline to Fit Entire Scene buttons in the lower-right corner of the Timeline panel. The buttons have keyboard shortcuts (–, =, and \).

Scroll through time when zoomed in

Use the horizontal scrollbar below the scrollable region of the Timeline panel or swipe horizontally on the trackpad.

Scroll through the stack of puppet and audio tracks

Use the vertical scrollbar or swipe vertically on the trackpad.

Select or deselect track items

  • Click the track’s name (for a puppet) or the track item’s bar to select it. 
    Select a track item for a puppet to modify the behavior parameter values for the puppet’s instance in the scene, overriding the values in the source (primary definition) of the puppet. 
  • Selecting a puppet track automatically arm the puppet for recording.
  • To toggle the selection of a puppet, Shift-click or Command/Ctrl-click the puppet’s track item or the track’s name (track header on the left side of the panel). Toggle selection allows you to select multiple puppets at the same time.
  • To deselect all contents click away from any track item bar.

Hierarchical selection

Selected track items appear solid blue in the Timeline panel. When a take or projection bar for a puppet is selected (either directly selected or after recording takes), the bar becomes solid blue. The puppet track gets outlined in blue to indicate that something in the puppet’s hierarchy is selected. This hierarchical selection also allows the puppet’s behavior parameters to be visible in the Properties panel and modified immediately after adjusting takes.

Select or deselect takes

  • Click a take to select it and other takes captured during the same recording pass. These takes are linked by default, and can be dragged and trimmed in unison.
  • Shift-click or Command/Ctrl-click a take to toggle the selection of linked takes.
When multiple parameters are recorded at the same time, the takes are linked. By default, selecting one take doesn't select or affect its linked takes, but you can manage all linked takes at the same time by clicking the Linked Selection command from the Timeline menu. When a take is selected, the corresponding section of the summary bar (along with the bottom of a puppet track item) appears highlighted in blue, which is informative when the track item is collapsed and you can’t see the take bars.

Split track items and takes

Shorten a puppet or an audio track item or take by splitting it at the playhead (current time). This operation essentially duplicates the selection, and trims the original and the new bars.

To split track items or takes:

  1. Select the items and place the playhead at the split time.
  2. Choose Edit > Split (Shift+Command/Ctrl+D).

Duplicate track items and takes

Create a copy of a track item or takes to use later.

To duplicate track item or takes:

  1. Select the items or takes.
  2. Choose Edit > Duplicate (Command/Ctrl+D).

Adjust timing of a track item or take

Extending a take bar from either end holds the take's recorded values before the original In point and after the original Out point of the take.

  • To shift it in time, drag the middle part of the bar horizontally.
  • To trim its start or end time, drag the left or right end of the bar.
Note:

If you split a take, extending from the split point just reveals the trimmed part.

Override snapping to edges and for finer control

Hold down the Command/Ctrl key while dragging a track item or take bar.

Move selection to the playhead

Shift the selected tracks, takes, trigger/viseme bars, or keyframes in time to align to the playhead, by using the Timeline > Move Selection In to Playhead ([) or Timeline > Move Selection Out to Playhead (]) commands.

Reorder a track

To reorder a track, for example, to change the rendering order of puppet, select the track, then choose Timeline > Arrange > Move Up or Move Down, or press Command+Up/Down Arrow or Ctrl+Up/Down Arrow.

Rearrange selected tracks or takes

To rearrange selected tracks or takes to the top or bottom of the stack, choose Timeline > Arrange > Move to Top or Move to Bottom menu commands. 

Delete a track item

Select a track item, then choose Edit > Delete or press Delete or Backspace. Deleting an audio track item does not remove its track.

Move takes

Move selected takes for the same parameter up or down via Timeline > Move Up or Move Down commands. The commands can still be used for selected tracks.

Merge takes

Combine multiple selected Lip Sync or Triggers takes into a single take bar of viseme or trigger bars to consolidate separate lip sync or triggered recordings so that they don’t occupy as much vertical space in your timeline. To merge, choose Timeline > Merge Takes menu command.

Sequence takes

To arrange selected takes for a parameter sequentially in the timeline, choose the Timeline > Sequence Takes menu command. In the Sequence Takes dialog box, do one of the following:

  • To arrange the takes end to end, leave the Overlap option unselected.
  • To overlap takes, select Overlap, and enter a Frames value to set the overlap position.

Collapse or expand all takes or keyframes on a track

Collapsing all takes or keyframes for a track allows you to see more of your timeline’s tracks and rows of takes and keyframes at one time, reducing the need to scroll vertically. Command-click (macOS) / Ctrl-click (Windows) a disclosure triangle for a behavior’s parameter in the timeline to expand or collapse all takes or all keyframes on that track. 

Shy and Hide Shy buttons

Quickly hide or show individual rows in the timeline by selecting the Shy button for them and then toggling the Hide Shy button next to the search filter text field. Command-click (macOS) / Ctrl-click (Windows) a Shy button to change the shy state for all rows.

Shy and Hide Shy buttons

Delete a take

Select the take bar and press Delete or choose Edit > Delete.

  • To delete a puppet’s takes, select all the takes and press Delete.
  • To delete the puppet track, press Delete after the takes are deleted and the selection is at the puppet track.

Blend performances together

You can blend performances at the beginning and the end of a take to smoothly transition between a puppet’s default appearance and its recorded performances. You can also customize blend durations or quickly set a default duration.

Blending a behavior’s parameter’s take

1. Expand the puppet and projection bar that contains a blendable take. 

You can blend the following takes:

  • Numeric parameters like Dangle’s Wind Strength or Transform’s Scale
  • Angle parameters like Transform’s Rotation
  • Face’s Camera Input parameter
  • Dragger’s Mouse & Touch Input parameter

2. Do one of the following:

  • To use a custom blend duration, drag the small square at either top corner of the take bar inward; the cursor changes to a finger with arrows on either side when above the square. The farther you drag from the edge of the bar, the more gradually you can ease into or out from the recorded performance.
  • To use a default (half-second) blend duration, select the projection or take bar, then choose Timeline > Blend Take submenu. You can blend only the incoming (Blend In), outgoing (Blend Out), or both sides (Blend In and Out) of the take. You can further customize the duration by dragging the small squares.
  • To cycle through available default blend durations, choose Timeline > Blend Take > Next Blend (Command/Ctrl+B) or Previous Blend (Shift+Command/Ctrl+B).

When you trim a take, in (left side) and out (right side) blend durations do not change unless the take bar duration becomes shorter than the blend durations.

Note:

The Timeline > Blend Take commands set a default duration for the incoming and outgoing blends, but don’t set the ease to a specific type of curve. The default is Ease In & Out.

To set the blend easing curve:

1. Right-click above the incoming blend and then choose Blend In Curve, above the outgoing blend and then choose Blend Out Curve, or in the middle of the take bar and then choose Blend.

2. Choose an easing type from the submenu: No Easing (linear curve), Ease In (ease into the blend), Ease Out (ease out from the blend), or Ease In & Out (ease both ends of the blend).

Removing blending of a take

Do one of the following:

  • Choose Timeline > Blend Take > Remove Blend.
  • Drag the small square toward the edges of the take bar.

Show or hide recorded takes for a puppet

To show or hide the puppet’s recordings, click the disclosure triangle next to a puppet’s name in the track header in the Timeline panel. Each recorded behavior parameter appears as a separate projection bar that summarizes the takes within it. If you don’t see any projection bars under a puppet’s track item, check that you armed at least one behavior parameter for recording and that the track was selected/armed before recording.

You can modify all takes for a parameter from its projection bar, or make finer adjustments to specific takes by clicking the disclosure triangle for the projection bar.

Note:

If more than one take was recorded for a parameter, the topmost take bar at any given time is used, and any information from take bars below it is ignored (and shown without color as if in a shadow). Transition points between takes for a parameter are indicated by a vertical line on the parameter’s projection bar.

To start at the beginning of the scene

Click the Go to Start button or press Home.

Collapse view of a parameter’s takes

Collapsed view of takes
Collapsed view of takes

When collapsed into a single lane, you can click different parts to select the individual take bars. When selected, information about the take is displayed on its bar, blend curves are visible, and blend handles are adjustable.

Record behavior in take groups

Take groups enable multiple performances for a specific handle compose together, without affecting performances for other handles you drag. The Dragger behavior records each Draggable handle that you move as a separate take group. By grouping Dragger takes by dragged handles, you don’t have to use multiple Dragger behaviors to capture multiple dragged handles. The Timeline panel shows each Dragger takes grouped by handle name as “Handle (handle-name)”.

Timeline: work area navigation and operations

A scene’s timeline has a work area that you can enable to isolate operations to a range of frames in a scene. You can enable the work area when needed, and disable it when not needed.

To enable or disable the work area, follow these steps:

  • Either click the work area bar at the top of the time ruler or toggle the Enable Work Area command in the Timeline menu or Context menu above the work area bar. 
  • Dragging any part of a disabled work area bar enables it.
A) Work are disabled B) Work area enabled
A) Work are disabled B) Work area enabled

When enabled, the work area is a lighter-gray bar and its range of time is highlighted in the track area. When disabled, the work area bar is a subtle darker-gray color.

Setting the work area

To change the start or end time for the work area, do either of the following:

Set Work Area Start to Playhead places the start of the work area at the beginning (left side) of the frame the playhead is in, if the playhead isn’t aligned to a frame boundary.

Set Work Area End to Playhead places the end of the work area at the end (right side) of the frame the playhead is in, if the playhead isn’t aligned to a frame boundary.

• Place the playhead at the specific frame in time and then choose Set Work Area Start to Playhead (Option/Alt+I) or Set Work Area End to Playhead (Option/Alt+O) from either the Timeline menu or the context menu for the work area bar.

Note: You cannot set the start time after the end of the work area, or vice versa.

To set the work area to match the selected tracks or take bars:

Choose Set Work Area to Selection (Option/Alt+/) from either the Timeline menu or the context menu above the work area bar. The work area will span the earliest and latest times in the selection.

To shift the work area in time, do the following:

Drag the middle of the work area bar horizontally. Dragging the edges or middle of the work area bar will snap the start or end of the work area bar to the edges of puppet track bars, take bars, and markers. Similarly, dragging the edges of puppet track bars or take bars or markers, will snap them to the start or end of the work area bar.

Set Work Area Selection

Places the start and end of the work area at the nearest frame boundaries that enclose the selection.

Go to Work Area End

Places the playhead at the beginning of the last frame in the work area, instead of at the end of the last frame.

Trim Out to Playhead

Trims the track or take to the end of the frame the playhead is in. That way, the content of the track or take is still visible at the playhead.

Also, playback will start at the frame the playhead is in. So, if the playhead is at the right edge of the work area, playback won’t loop around to the start of the work area.

Jumping to the start or end of the work area

To jump to the start or end of the work area, do the following:

  • Right-click above the work area bar, then choose Go to Work Area Start or Go to Work Area End from the context menu.
  • Use the keyboard shortcut Option/Alt+Left Arrow and Option/Alt+Right Arrow.

Editing selected takes using the work area

When the work area is enabled, you can perform the following edits:

  • To delete the segment of selected takes within the work area, either choose Timeline > Clear to leave a gap (no recordings in the work area) or Timeline > Ripple Delete to close the gap by shifting the selected takes originally after the work area to the start of the work area.
A) Before  B) Clear  C) Ripple delete
A) Before B) Clear C) Ripple delete

  • To insert a gap in time the duration of the work area for the selected takes, choose Timeline > Insert Time.
A) Before  B) Insert time
A) Before B) Insert time

The Clear, Ripple Delete, and Insert Time commands are also available in the context menu above the work area bar.

Looping playback within the work area

When the work area is enabled, playback of the scene will automatically loop within the work area. Playback starts at the current time , and will loop when the playhead reaches the end of the work area. If the playhead is after the work area, playback will not loop.

Recording takes using the work area

When the work area is enabled, the Timeline > Record Take for Work Area command (Command/Ctrl+3) creates a new take. The new take covers the duration of the work area for the armed behavior parameters.

Exporting the work area

When the work area is enabled, the scene export commands (File > Export > Video via Adobe Media Encoder and File > Export > PNG Sequence and WAV) only use the segment of time within the work area.

Note: Scenes with puppets that use Physics simulations (Dangle, Collide, Particles) will still require frames before the start of the work area to be rendered (that is, a run-up) to export the intended results for the frames in the work area.

When the work area is disabled, those commands export the full duration of the scene.

Note: The work area is ignored when dragging a scene into After Effects or Premiere Pro. The scene’s duration is used in these Dynamic Link workflows

Trimming the scene to the work area

When the work area is enabled, you can trim the scene to just the segment of time within the work area by choosing Timeline > Trim Scene to Work Area or the same command in the context menu above the work area bar.

Zooming and scrolling through time using gestures

Zooming and scrolling in the Timeline panel is now also possible via two-finger gestures on a trackpad or touchscreen.

To zoom time via gestures, do any of the following: 

  • With the mouse pointer above a specific time in the Timeline panel, do a pinch-to-zoom gesture on a trackpad. Alternatively, hold down Option (macOS) or Alt or Ctrl (Windows) as you spin the mouse wheel or swipe using two fingers vertically on a trackpad. 
  • Do a pinch-to-zoom gesture above a specific time in the Timeline panel on a touchscreen.

To scroll across time or tracks via gestures, do either of the following: 

  • With the mouse pointer above the Timeline panel, swipe using two fingers either horizontally or vertically across a trackpad. Alternatively, to scroll across time, hold down Shift as you spin the mouse wheel or swipe using two fingers vertically on a trackpad.
  • Swipe using two fingers either horizontally or vertically across the Timeline panel on a touchscreen.

Snapping to frame boundaries while moving and trimming content

Moving a track, take, trigger, or viseme bar, or a marker automatically snaps its left edge to frame boundaries and to the left or right edges of other tracks, takes, markers, and work area. Trimming a track, take, trigger, or viseme bar does similar for the dragged edge of the bar, snapping to frame boundaries and the left or right edges of other tracks, takes, markers, and work area.

To position these bars or markers off of a frame boundary, do the following:

  • Hold down the Command (macOS) or Ctrl (Windows) key while dragging. 

Note: Pressing the Up/Down Arrow keys for a selected trigger or viseme bar still offsets the bar in time by the duration of a frame.

Take reuse between puppets and projects

All types of takes can be cut, copied, and pasted between puppets and projects. To reuse takes, follow these steps:

  1. Select the takes to reuse.

    • To remove them from the puppet, choose Edit > Cut (Command/Ctrl+X). 
    • To retain the original takes and duplicate them, choose Edit > Copy (Command/Ctrl+C).
  2. Select a different puppet track item in the Timeline, in either the current or another project. Reposition the playhead to where you want the take to start and choose Edit > Paste (Command/Ctrl+V).

The selected take is pasted relative to the playhead . Any behavior associated with the copied takes are applied to the target puppet if it doesn’t have those behaviors. If the puppet has multiple behaviors (for the take), each of them gets a copy of the take. You can also copy multiple takes. They are pasted in the order they were selected.

For more information about taking Character Animator  visemes  into After Effects for use on different characters, see Lip Sync: Take export for After Effects.

Note:
  • Pasting a behavior that is hidden by default but isn’t hidden while being copied (Cycle Layers) pastes the new instance as hidden.
  • Pasted behaviors are always added at the top level of the puppet, even if the copied take was for a behavior lower in the puppet structure.
  • Pasted behaviors do not retain any custom behavior names.
  • Copied takes for multiple instances of the same behavior (two instances of Face at different places in the puppet structure) gets pasted into a single instance of the behavior.

Reuse (cut, copy, and paste) viseme and trigger bars

Instead of copying the entire Audio Input take of visemes or Trigger take of triggers, you can selectively cut, copy, and paste viseme and trigger bars to reuse just the recordings you need.

Note:

Visemes and triggers can be pasted on a different puppet track. However, to reuse triggers, be sure the target puppet has equivalent triggers in the Triggers panel for those being pasted. Copying a puppet’s triggers from the Triggers panel and pasting them into the target puppet’s Triggers panel ensures this compatibility.

To reuse viseme or trigger bars, follow these steps:

  1. Select the specific viseme or trigger bars from a single take.

    Note:

    Selecting viseme or trigger bars from multiple takes will use the takes themselves, not the individual bars selected.

  2. Choose Edit > Cut or Edit > Copy.

  3. Move the playhead to a different time. Or, if you want to paste the bars onto a different puppet, select the puppet track’s Lip Sync > Audio Input or Triggers take bar .

  4. Choose Edit > Paste.

The selected viseme or take bars are either moved or copied relative to the playhead’s time.

The selected viseme or take bars are either moved or copied relative to the playhead’s time.

By default, multiple recordings for a parameter creates take bars on separate rows in the Timeline panel, but you can collapse them into a single lane to reduce vertical scrolling and still have access to them individually. 

Click the twirl arrow to collapse or expand a parameter’s takes. The twirl arrow only appears if a parameter has multiple takes. 

Renaming tracks

Tracks (puppets, audio, scenes) in a scene’s timeline are named after their source item in the Project panel. You can give tracks custom names to help identify the purpose or use of a track. Custom track names aren’t affected by changes you might make to the source item’s name.

To rename a track, do either of the following: 

  • Select a track, then press Return (macOS) / Enter (Windows). 
  • Right-click above the header (left-side) part of a track, then choose Rename.

Markers

Markers let you mark up specific changes (for example, when a character is looking to the left) in a scene’s timeline. Stop markers allow playback to stop when they are reached. You can switch between a regular informational marker and a stop marker at any time.

Working with markers

Learn how to work with markers

Create a marker

To create a marker, move the playhead to the intended time, then do either of the following:

  • For a regular marker, choose Timeline > Add Marker (Ctrl+8 on Mac, Numpad * on Windows).
  • For a stop marker, choose Timeline > Add Stop Marker (Ctrl+Shift+8 on Mac, Shift+Numpad * on Windows). The icon for a stop marker shows a small square sign.

Note: You can switch a regular marker to a stop marker, or conversely. To switch, right-click the marker, and enable or disable the Stop Playback at Marker option.

Rename a marker

  • To rename a marker, double-click/ Enter, and then enter a new name.

Move a marker

  • To move a marker to a different time, drag it horizontally. Markers can snap to other items in the timeline, and conversely.

Delete a marker

  • To delete a marker, select it (Shift-click to select multiple), and then choose Edit > Delete.

Markers in a Character Animator scene appear in other applications using Dynamic Link. For example, when you drag a scene from Character Animator’s Project panel into After Effects’s Project panel, those scene’s markers appear as composition markers in After Effects.

Tip: If you make changes to the scene’s markers in Character Animator, refresh the markers in After Effects by right-clicking above a composition marker and then choosing Update Markers From Source.

Markers via Dynamic Link

Audio waveform and audio track resize

The audio track shows the waveform of the audio file helping you adjust the timing of puppets, takes, and visemes to the audio. Audio tracks appear twice as tall as other tracks by default, and can be resized as needed by dragging the bottom edge of the track header vertically.

Resize audio track
Resize audio track

Audio track volume control

When you record a scene, each audio track in a scene’s timeline has its own Volume setting (specified in decibels, dB) to control that track’s volume level independently. Use the slider to adjust the values.

Audio track volume control

Adobe logo

Sign in to your account