Información general

Character Animator es una aplicación de animación de personajes que permite dar vida a personajes expresivos con sus propias ilustraciones.

Adobe Character Animator le permite importar ilustraciones de Adobe Photoshop o Adobe Illustrator y darles vida. Para ello, primero capture su actuación con una cámara y un micrófono. Mientras el usuario actúa, Character Animator imita sus expresiones faciales, sincroniza los movimientos de la boca con su voz y proporciona un control completo sobre todos los aspectos de movimiento de un personaje.

Puede animar un personaje que haya adquirido de otra persona o generar sus propios personajes a partir sus ilustraciones de Photoshop o Illustrator. Puede incluso escribir sus propios comportamientos o utilizar comportamientos existentes de otros.

Adobe

Instalación de Adobe Character Animator

Adobe Character Animator se instala junto con After Effects CC 2015. Sin embargo, es una aplicación independiente y puede iniciarse por separado fuera de After Effects.

Para obtener más información sobre la versión más reciente de After Effects, consulte el Resumen de nuevas funciones.

Creación de ilustración de varias capas para un personaje

Con Photoshop o Illustrator, cree un documento de varias capas que represente las partes estructurales (cabeza, ojos, boca, brazos, piernas, etc.) de un personaje. Si ya ha creado un personaje, vaya al siguiente apartado para obtener información sobre la importación de ilustraciones en Character Animator.

Creación de una marioneta

En Character Animator, elija File > Import para buscar y seleccionar el archivo de ilustración.

La ilustración seleccionada se importa y aparece una representación en forma de marioneta, creada a partir de las capas, en el panel Proyecto. La estructura de las ilustraciones en un documento de Photoshop o Illustrator determina la estructura de la marioneta en Character Animator. Algunas funciones de la marioneta se pueden intercambiar entre distintas variaciones o sustituciones (por ejemplo, varias expresiones de la boca de un personaje pueden ser capas separadas en el documento). En Character Animator, puede crear una estructura de generación de marioneta personalizada que incluya las sustituciones. No hace falta modificar las ilustraciones originales.

Posicionamiento de la marioneta en una escena

Con la marioneta seleccionada en el panel Proyecto, haga clic en el botón Add to New Scene para colocarla en una nueva escena. La escena se abre automáticamente en el panel Escena y la marioneta que acaba de añadir estará seleccionada en el panel Línea de tiempo. 

Las escenas contienen marionetas. Cuando se abre una escena en el panel Escena, se puede fijar la posición inicial de las marionetas en la escena y animarlas en el tiempo.

Control de la marioneta

Observe el personaje en el panel Escena, coloque su cara a una distancia cómoda de la cámara web (pero bastante grande dentro del círculo mostrado en el panel Camera & Microphone), adopte una expresión facial neutra y haga clic en Set Rest Pose. Aparecerán puntos de seguimiento rojos en su cara.

Si la marioneta tiene caras con nombres específicos (por ejemplo, Cabeza, Ojo izquierdo, Boca, etc.), se pueden controlar con varias expresiones faciales delante de la cámara web. Si los pies de la marioneta tienen guías con nombres específicos, se pueden arrastrar con el ratón.

Una marioneta tiene comportamientos, funciones que permiten controlar sus movimientos, su deformación, aspecto y otros atributos.Algunos comportamientos utilizan controles externos, como la cámara web o el audio o el ratón. Dichos comportamientos permiten el control expresivo de sus ilustraciones estáticas.

Ajuste de los parámetros de comportamiento

Si no desea que la cabeza del personaje cambie de tamaño o gire, reduzca los valores de los parámetros de posición Head Position Strength y escala Head Scale Strength del comportamiento de la cara en el panel Propiedades. Intente desplazar el personaje más cerca del centro de la escena. Para ello, aumente el valor de parámetro Position X para el comportamiento Transformación. Mantenga presionada la tecla Mayús mientras desplaza el valor para conseguir cambios más grandes.

La mayoría de los comportamientos tienen parámetros que permiten personalizar los resultados. El origen (la definición maestra de una) marioneta aparece en el panel Proyecto, con instancias de la marioneta en una escena. Los valores de los parámetros de la marioneta de origen son los valores predeterminados para todas las instancias, pero puede anular esos valores para cada instancia.

Grabación de una actuación

  1. En el panel Propiedades, haga clic en el botón Arm for Record (pequeño círculo rojo) junto a los nombres de comportamiento Mouse Tracker and Keyboard Triggers para desactivarlos.
  2. Deje los comportamientos de Face y Lip Sync activados para que se capturen los cambios en los comportamientos durante la grabación.
  3. Haga clic el botón Record rojo en la parte inferior del panel Escena, y comience su actuación (mueva la cabeza, mire a su alrededor, parpadee, hable, etc.).
  4. Haga clic en Stop para detener la grabación.

Los comportamientos activados se identifican con un pequeño círculo rojo y texto en color rojo. La pista de la marioneta seleccionada también se activa para la grabación (el fondo del nombre de la marioneta en el encabezado de pista en el lado izquierdo del panel Línea de tiempo es rojo), lo que indica que se capturarán los comportamientos activados en dicha marioneta. Al seleccionar un marioneta y activarla a nivel de pista, puede capturar una actuación en la escena.

La actuación se captura como tomas para los comportamientos de Face y Lip Sync. De forma predeterminada, la pista de una marioneta aparece contraída, pero puede identificarse cuando se ha capturado una actuación porque aparecerá una barra de color claro a lo largo de la parte inferior de la barra del elemento de pista de la marioneta. Si hace clic en el triángulo desplegable para ampliar la pista de la marioneta, verá las tomas grabadas individualmente para los comportamientos activados. Si también se ha habilitado Microphone Input durante la grabación, el audio detectado también se captura como archivo WAV y aparece como pista de audio en la línea de tiempo.

Previsualización y revisión

  1. Haga clic en Play o presione la barra espaciadora para previsualizar la grabación.
  2. Haga clic en Stop (o presione la barra espaciadora de nuevo) y, a continuación, en Go to Start cuando haya terminado.

Puede ver tomas grabadas durante la reproducción. El indicador de tiempo actual se mueve a través de tiempo durante la reproducción, pero no se puede mover manualmente.Después de la segunda grabación, aparece una barra de tomas Mouse Tracker (si se ha ampliado la pista de la marioneta), pero no aparece ningún elemento de pista de audio adicional. Si se reproduce la línea de tiempo de la escena, verá la combinación de las dos grabaciones.

Exportación de la grabación de la actuación de la marioneta

  1. Seleccione la escena en el panel Proyecto y, a continuación, ajuste la duración de la escena a 10 segundos (o a la duración de las dos tomas grabadas) en el panel Propiedades.
  2. Elija Archivo > Exportar > Escena y, a continuación, especifique una ubicación y un nombre en el disco para la actuación.

La duración de la escena aparece como una sección resaltada en el panel Línea de tiempo y controla el número de fotogramas que se van a exportar.Las tomas grabadas se exportan como una secuencia PNG (con canal alfa para la composición) y un archivo WAV para el audio grabado. La duración del contenido exportado se determina mediante el parámetro Duración de la escena en el panel Propiedades.

Importación de la grabación en After Effects

Acción
  1. En After Effects, seleccione Archivo > Secuencias de comandos
  2. Seleccione Archivo > Secuencias de comandos y, a continuación, seleccione Nueva comp. a partir de Character Animator Recording.jsx.
  3. Seleccione el primer archivo PNG en la carpeta de la grabación exportada.
  4. Previsualice la composición para ver el resultado.

Si necesita realizar un cambio en la marioneta, puede volver a editarla en Character Animator y cambiar las ilustraciones en Photoshop o Illustrator. Los cambios pueden volver a transferirse a After Effects.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea