Get a new perspective on a photograph by separating foreground from background in Adobe Photoshop and adding parallax with a 3D camera in Adobe After Effects.
Student looks at a library computer monitor displaying an old photograph of a group of people

Qué necesita

This sample file is an Adobe Stock asset you can use to practice what you learn in this tutorial. If you want to use the sample file beyond this tutorial, you can purchase a license on Adobe Stock. Check out the ReadMe file in the folder for the terms that apply to your use of this sample file.

To create a convincing third dimension in a normal photograph, start with a high-resolution image that contains discrete elements that you can easily separate into foreground and background layers in Photoshop. For example, use the Select and Mask workspace (Select > Select and Mask) to isolate figures in the foreground, remove objects with Content-Aware Fill, and retouch photos with selective uses of the Patch tool, Clone Stamp tool, or Healing Brush tool. The goal is to isolate objects in the foreground and provide sufficient elements — from one or more photographs — to create a convincing background. In our example, we brought in another photo to supply the missing details in the building.

Adobe Photoshop shows a group of people isolated from the background within the Select and Mask workspace

Switching over to After Effects, import the layered Photoshop file as a Composition and accept the default Editable Layer Styles option in the Import Kind dialog box. Press Command/Control+N to open the Composition Settings dialog box. Set the dimensions smaller than the photograph. Drag all layers from the imported PSD file into the new composition so that the background layer is on the bottom. With the layers selected in the Timeline panel, press S to scale them in unison until they fit as you wish in the viewable area of the Composition panel. (If necessary, press P to reposition them too.) Finally, click the 3D Layer switch to make them all 3D layers.

Adobe After Effects shows foreground and background layers imported into a new composition and the 3D switch set

Parallax animation relies on an adequate distance between the 3D layers in z space. Starting with the top layer, press P and position it closer to you in z space (z < 0), then press S and scale it back down to normal size. Position the background layer farther away in z space (z > 0) and then scale it up. Any middle layers can stay where they are or move slightly forward or backward, depending on the scene. The final image should look almost the same as before except that now there’s distance between the layers. 

Timeline panel shows z-space Position and Scale adjustments made to foreground and background layers

The z-space positioning you choose for each layer depends on the relative distance between these objects in the original scene when the photo was taken. To replicate that shot, create a Camera layer (Layer > New > Camera). In the Camera Settings dialog box, set Type to One-Node Camera and use a Preset focal length that suits the photo.

Camera Settings dialog box shows Type set to One-Node Camera and Preset set to 35mm

Position the new Camera layer at the top of the Timeline panel. To get a better perspective on the layers’ relative positions and understand how the camera’s movements affect the final parallax animation, open the View Layout menu at the bottom of the Composition panel and choose 2 Views. Set one view to Custom View 1 and keep the other at Active Camera.

Composition panel shows Custom View 1 and Active Camera views side by side

To create the parallax effect, simply animate the camera around 3D space. Twirl down the Transform properties for the Camera layer and keyframe Position and Orientation — and whatever other transform controls you want to change over time. 

Timeline panel shows camera movement keyframes and Composition panel shows path of camera movement in 3D space

As you experiment, you may have to press Command/Control+Z repeatedly to undo an unsuccessful camera move. When you like what you see, add easing to the keyframes. Command/Control-clicking a keyframe uses Auto Bézier (circle), which can help smooth the rate of change.

With Adobe Stock, you have access to more than 100 million high-quality, royalty-free images including photos, graphics, videos, and templates to jump-start your creative projects. Try Adobe Stock and get 10 free images.

09/02/2020

Adobe Stock contributors: blantiag, maho, Rawpixel.com

¿Le ha servido de ayuda esta página?