Vaya a http://aem-host:port/crx/de/index.jsp e inicie sesión como administrador.
Problema
Faltan algunos archivos.js y.css de sus páginas AEM o de la interfaz de usuario de AEM.
Causa
Esto podría ser causado por algunas cosas:
- La consulta xpath[1] utilizada por el AEM Client Library Manager (HTMLLibraryManager) utiliza un índice distinto al /oak:index/nodetype.
- El índice nodetype no se actualiza o está dañado.
- Faltan los permisos del usuario del servicio clientlibservice.
[1]
/jcr:root//element(*, cq:ClientLibraryFolder)
Resolución
I. Comprobar los permisos de los usuarios del servicio
Revise este artículo en caso de que falten los permisos de usuario del servicio clientlibs.
II. Comprobar que la consulta está obteniendo resultados correctos
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Vaya a Herramientas => Consulta.
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En el cuadro de consulta inferior, introduzca esta consulta:
/jcr:root//element(*, cq:ClientLibraryFolder)
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Valide si su biblioteca de cliente que falta está o no en los resultados. Si está allí, póngase en contacto con Atención al cliente de AEM para obtener ayuda con una investigación adicional. De lo contrario, vaya al paso siguiente.
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Si encuentra que los resultados excluyen la biblioteca del cliente que falta, vaya a http://aem-host:port/libs/granite/operations/content/diagnosis/tool.html/granite:queryperformance
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Vuelva a introducir la consulta y haga clic en "Explicar".
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El resultado muestra el índice que se utiliza para ejecutar la consulta. Si el índice listado no es el índice "nodetype", entonces algo está mal.
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Necesitaría depurar lo que está causando que un índice diferente devuelva una estimación de costo menor para la consulta. Consulte este artículo para saber cómo habilitar el registro de depuración para el análisis de consultas.
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Si se selecciona el índice correcto pero no devuelve el resultado correcto, entonces se corrompe. Tendrá que volver a indexar el índice de nodos.
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Siga los pasos de este artículo para reindexar el índice asincrónicamente.